Navigation in Domino Designer

HCL Domino® Designer is installed as Eclipse perspectives arranged into easy-to-access views, palettes, and editors. You can perform tasks using the main menu, right-click menus, and icons in the view, palette, and editor title bars.

The Domino Designer perspectives are as follows:
  • Domino Designer shows all design elements in the Applications Navigator and is the default perspective.
  • XPages excludes design elements not needed for XPages development.
  • Forms/Views excludes design elements only needed for XPages development.

To change perspectives, click Window > Open Perspective.

To adjust the content of the perspectives, go to File > Preferences > Domino Designer > Applications Navigator.

Because the Domino Designer perspectives are defined by Eclipse conventions, you can move, resize, close, and open views. To save your new arrangement as a new perspective with a name you choose, select Window > Save Perspective As in the menu bar.

You can also navigate through views using the default Eclipse keyboard shortcut Ctrl+F7 or by clicking Window > Navigation in the Eclipse main menu.

To see any view that is hidden, click Window > Show Eclipse Views in the main Eclipse menu, and select the hidden view from the list.