Setting Domino Designer XPages user preferences

You can modify XPages settings in Domino® Designer so that you can use this unique design element in custom ways in your application development.

Accessing the XPages Preferences panel(s)

To access the XPages Preferences panel, choose File >Preferences >Domino Designer >XPages. From this panel, you can access and change settings in these XPages areas:

  • XPages settings (overall settings)
  • Extension Library (sub-panel)
  • Palette (sub-panel)

XPages settings

To access this Preferences panel, choose File >Preferences >Domino Designer >XPages. You can change the following XPages settings from the XPages Preferences panel.

  • XPages Editor
    • Always open source tab - Lets you choose which tab to open when the XPages editor opens. The choices are Source, Design, and last used tab.
    • Show script snippet for labels instead of {controlID} in labels - If enabled, lets you show control script snippet for labels instead of the control ID in labels.
    • Number of characters of script to show (10-100) - This becomes enabled if you enable "Show script snippet..." and lets you specify the number of characters of the scrip snippet you wish to be visible.
    • Show line breaks in editor - Enabled by default. Deselect this setting to shut off the display of line breaks in the editor.
    • Show bubble help on Data panels - Enabled by default. Deselect this setting to shut off the display of bubble help on Data panels.
    • Enable content assist on tag names of in source editor - Enabled by default. Deselect this setting to shut off content assist on tag names of in source editor.
    • Show hover help in Properties view - Enabled by default. Deselect this setting to shut off the display of hover help in Properties view.
    • Time delay (milliseconds) - Specifies in milliseconds much time elapses before hover help is displayed
    • Show hover help on tag names in Source editor - Enabled by default. Deselect this setting to shut off the display of hover help on tag names in Source editor.
    • Time delay (milliseconds) - Specifies in milliseconds much time elapses before the hover help is displayed
    • Prevent loading of Style Sheet (CSS) resources for the Design tab - Stops the loading of CSS resource files for the Design tab. This stops the editor from slowing down if large CSS resource files are included on an XPage.
  • Automatic Recompile (settings used when a custom control is modified)
    • Automatically recompile dependent XPages - Enabled by default. Deselect this setting to disable automatic recompilation of dependent XPages.
    • Manually recompile XPages - Enabled by default. Deselect this setting to disable the ability to manually recompile XPages. A manual recompile is recommended for team development environments. Use Project >Clean to manually recompile the entire application.

Extension Library settings

This panel lets you set the Extension Library settings. To access the Extension Library preferences panel, choose File >Preferences >Domino Designer >XPages >Extension Library. You can change the following setting(s) from this panel.

  • Show warning when dropping the application layout control on an XPage rather than a custom control- Enabled by default. Deselect this setting to shut off the display of the warning.

Palette settings

Palettes let you work with controls in an organized way. This preferences panel lets you control how you want your control palette to display the controls you are working.

To access the Palette preferences panel, choose File >Preferences >Domino Designer >XPages >Palette. You can do the following with this panel:

Note: An XPage must be in focus in the Editor for this panel to display.
  • By default, an initial profile named Profile1 is created. This is the profile which contains the current state of the palette when Designer is first launched. If you have modified the palette using the old Designer Palette Preferences page, those changes will be reflected in Profile1. You can rename and delete Profile1 from within the palette profiles user interface.
  • The user interface has a list of profiles and a tree showing the control drawers and controls in those drawers. The tree shows the layout of the palette for the selected profile in the list of profiles. You can check the controls/drawers that you want to see in the palette and uncheck those that you do not wish to see. You can also move individual controls within their parent drawer but you cannot move controls between drawers.
  • You can also reorder the drawers. The reordering of drawers of controls, however, is not supported by the Controls palette for this release. Custom Controls will never be shown in the tree, and will always be present in the controls palette.
  • You also can sort palette draw content alphabetically. As some palette drawers are not sorted (Core Controls, for example), enabling this preference will correct this.
  • When you click New to create a new profile, the new profiles palette layout will be based on the currently selected profile in the list of profiles. By default the active profile will be selected in the list of profiles. To switch profiles, simply select the profile you wish to activate and click Apply or OK.
  • To restore the selected file to the default profile, click Restore Defaults. Restoring the default profile does not delete profiles that create.
  • If you delete all the profiles in the list of profiles, Profile1 is recreated, with a palette layout matching the default layout.

For more detail on all of the settings mentioned in this topic, refer to the Designing XPages applications section of this guide.