Apple profile displayed as unverified

Read this section to troubleshoot if the Apple mobile displays the deployed Apple profile as “Unverified.”

Problem

  • When an Apple MDM enrollment or MDM policy profile is installed or deployed, the device shows the profile status as "Unverified".
  • An Apple profile (Enrollment or Policy Profile) that was verified previously suddenly show as "Unverified" on the device.

Cause

  • If you use Digicert certificates, you might encounter this issue when you renew TLS certificate.

  • If a TLS certificate is renewed and the Trusted CA has actually replaced/renewed the intermediate certificates (which is not a usual scenario), then it could cause new enrollment and policy profiles to appear as “Unverified” as the signing certificate is signed by an intermediate certificate that is currently unknown to the endpoint.

Solution

  • If you have Apple Devices in your MCM deployment, ensure that you run the Update Apple Enrollment Certificate before expiration Fixlet as a policy action. The devices due for their device identity certificate renewal within 45 days are displayed on the main MCM Dashboard in a tile showing Expiring Certificates. With this you can proactively avoid the certificate expiry.
  • Re-deploy the Policy in question to a device through WebUI, if you need to correct an Unverified profile".
  • If any devices still have “Unverified” enrollment or MDM profiles after these steps complete, contact HCL support for further assistance.