Policy is deployed, but is not effective on the device

This page provides information to troubleshoot the issue if a policy is deployed but is not effective on the device.

Problem

A policy has been deployed successfully through WebUI without error, but the expected policy is not applied to the target device.

Cause

This can be due to various reasons depending on the OS, the policy type such as custom uploaded policy or policy created through WebUI and so on. Some of the reasons are as follows:
  • Profile is valid looking but it is missing something or has incorrect values somewhere, so OS says success but does not have the effect expected.
  • Profile is valid, but not supported by the version of the OS on the target machine.

    For example, in macOS, Restriction policy for screen sharing (where the users cannot enable screen sharing) is supported only in version 10.14.4 and later. See https://support.apple.com/en-in/guide/mdm/mdmba790e53/1/web/1.0. To find if the policy is supported on a specific version of the OS, refer the official documentation of the respective OS.

  • Device is offline.

Solution

  • Ensure you upload policy with appropriate extension for the intended target device.
  • Ensure the expected policy is available for the intended target’s OS version.
  • Ensure the device is online. Deployed policy is applied only when the device becomes online.