Cannot connect to transaction manager

A connection attempt fails, a message says that the application cannot connect to the transaction manager.

Possible cause

This message is generated when the MTS installation does not have the latest update of the component DLLs. The interface, IDtcToXaHelperSinglePipe that the Informix® OLE DB Provider uses to communicate with MS DTC might not be available in the installation (part of MSDTCPRX.DLL).

Resolution

This problem occurs due to incorrect setup. You must ensure that the msdtcprx DLL is version 1999 or higher. The MTS component files get updated by installing Windows NT™ Service Pack 6. Install the Windows NT Service Pack 6 or higher after the MTS installation.