Class not registered

When you attempt to connect to the HCL Informix® data source, the message Class not registered opens.

Possible cause

The Informix OLE DB Provider DLL might not be loaded.

Resolution

Check that the Informix OLE DB Provider DLL is in the location recorded in the registry entry, which points to bin\ifxoledbc.dll in your Informix Connect or Informix Client Software Development Kit installation. If that is not the case, reregister Informix OLE DB Provider. See the registry entries topics in the Microsoft™ OLE DB documentation for more information.

Also, make sure that INFORMIXDIR\bin is in the system path.