Notes のアクセシビリティ機能

ユーザー補助機能は、動作が制限されている方、視力の限られた方など、身体に障害を持つ方々に IT 製品をご使用いただけるように支援する機能です。

アクセシビリティー機能

HCL Notes® のアクセシビリティ機能は、運動障害や視覚障害など、身体に障害を持つユーザーが情報技術製品を快適に使用できるようにサポートする機能です。Notes が提供する主なユーザー補助機能には、次のようなものがあります。

  • アクセラレータキーとコマンドキーを使用して Notes を操作できます。

    画面上で下線の付いた文字がアクセラレータです。例えば、[ファイル] メニューのアクセラレータは「F」です。Microsoft® Windows® の場合、[Alt] キーを押しながらアクセラレータキーを押すと、アクションを実行できます。例えば、[Alt] + [F] キーを押すと、[ファイル] メニューが表示されます。有効になっていれば、拡張アクセラレータを使用することもできます。

    コマンドキーを使用すれば、アクションを直接実行できます。通常は [Ctrl] キー (Windows) または [Command] キー (Macintosh) を使用します。例えば印刷を行う場合は、[Ctrl] + [P] キー (Macintosh の場合は [Command] + [P] キー) を押します。

  • Notes は Microsoft Active Accessibility (MSAA) を採用しています。視覚障害のあるユーザーの場合は、デジタルスピーチシンセサイザとスクリーンリーダーソフトウェアを使用して、画面の表示内容を音声で聞くことができます。
  • Notes は、カラースキーム、フォントサイズ、ハイコントラスト表示などのシステムの表示設定をサポートしています。以下のセクション 低視力の方のための Notes の設定 を参照してください。

Notes ユーザーのニーズにあわせてカスタマイズするための数多くの機能が用意されています。次のいずれかのセクションを参照してください。

  • 基本プリファレンスでカスタマイズできる設定
  • メールプリファレンスでカスタマイズできる設定
  • ロケーションプリファレンスでカスタマイズできる設定
  • 追加の Notes 設定
  • 低視力の方のための Notes の設定
  • ヒント

キーボードショートカット

Notes で使用可能なショートカットキーの詳細については、「ショートカットキー」または「Macintosh のショートカットキー」を参照してください。

本製品では、アプリケーション固有のキーに加えて、Microsoft Windows の標準ナビゲーションキーを使用します。

インターフェース情報

基本プリファレンスでカスタマイズできる設定

[ファイル] > [プリファレンス] (Notes Basic 版クライアントユーザーの場合: [ファイル] > [プリファレンス] > [ユーザープリファレンス]Mac OS X ユーザーの場合: [Notes] > [プリファレンス]) をクリックし、[Notes クライアントの基本設定] をクリックして次の動作を実行します。

デフォルトのフォントを変更する

異なるフォントを選択できます。

[表示][デフォルトフォント] をクリックし、デフォルトフォントを選択して [OK] をクリックします。

[拡張アクセラレータ表示を有効にする] オプションを選択または選択解除する

拡張アクセラレータを使用すると、キーボードからブックマークバーやウィンドウのタブを操作できます。拡張アクセラレータを有効にしてから [Alt] キーを押したままにすると、各ブックマークとウィンドウタブの追加のアクセラレータが表示されます。画面に表示されている拡張アクセラレータを確認してから、移動したい Notes の領域に対応する文字または数値を押します。

[追加のオプション][拡張アクセラレータ表示を有効にする] を選択または選択解除します。

[3D ワークスペース] または [右ボタンのダブルクリックでウィンドウを閉じる] オプションを選択または選択解除する

[3D ワークスペース] の選択を解除すると、画面がより鮮明になり、スクリーンリーダーにアクセスしやすくなります。[右ボタンのダブルクリックでウィンドウを閉じる] オプションを選択すると、Notes では別の方法でウィンドウを閉じることができます。

[追加のオプション] で、これらのオプションのいずれかまたは両方を選択または選択解除します。

[Java™ アプレット]、[JavaScript™]、[JavaScript から Java へのアクセスを有効にする]、[JavaScript エラーダイアログ]、[Notes ブラウザでプラグインを有効にする]、[Notes ブラウザで ActiveX を有効にする] を有効または無効にする

Notes は、Java アプレット、JavaScript、Plugins、ActiveX テクノロジーをサポートしています。これらのテクノロジーの中には現在利用できないものもあります。どのテクノロジーを利用しているかによって、これらの機能を無効に設定します。

[追加のオプション] で、これらのオプションを有効または無効にします。

[読み込み専用の文書でタブを移動に使用する] オプションを選択または選択解除する

[Tab] キーは、最後の未読文書が選択されるまで次の未読文書に移動します。その後、次のフレームにある選択可能な次のオブジェクトに移動します。文書が読み込みモードで開いているときに [Tab] キーを使用すると、URL、アプリケーションリンク、添付ファイルなどの埋め込みオブジェクトに移動します。

[追加のオプション] で、[読み込み専用の文書でタブを移動に使用する] を選択または選択解除します。

[アクセシビリティキーボードナビゲーションを使用] オプションを選択または選択解除する

方向矢印を無効にして [Tab] キーを有効にすると、編集モードで文書内のフィールドからフィールドに移動できます。

[追加のオプション] で、[アクセシビリティキーボードナビゲーションを使用する] を選択または選択解除します。

Notes Basic 版クライアントユーザーの場合: メニューバーの [ウィンドウ] メニューを表示すると、開いている文書とアプリケーション間を移動できます。[ウィンドウ] メニューのオプションが有効の場合、ウィンドウタブの拡張アクセラレータが無効となり、代わりに [ウィンドウ] メニューが有効になります。[追加のオプション][ウィンドウ メニューを表示] を選択または選択解除します。Windows のハイコントラスト色のスキームを指定した場合 (ハイコントラスト色のスキームを有効にする方法の詳細については、Windows のヘルプを参照してください) は、ユーザーインターフェース、ビュー、文書に同じ色を使用するように Notes を設定できます。
注: ハイコントラストのオプションは、デフォルトで 5 分のタイムアウトが設定されています。システムが 5 分間アイドル状態になると、ハイコントラストの設定からデフォルトの設定に戻ることがあります。
[追加のオプション][システムカラーを使用する] を選択または選択解除します。

メールプリファレンスでカスタマイズできる設定

[ファイル] > [プリファレンス] (Notes Basic 版クライアントユーザーの場合: [ファイル] > [プリファレンス] > [ユーザープリファレンス]Mac OS X ユーザーの場合: [Notes] > [プリファレンス]) をクリックし、[メール] > [送信と受信] をクリックして次の動作を実行します。

受信メールを音声または表示で通知するように設定する

新規メールメッセージを受信した場合、Notes は音声または表示により新着メッセージを通知します。

[新規メール到着時の処理] で、[通知音][ポップアップの表示][スライドイン要約] をクリックします。

特定のワードプロセッサを選択する

Notes の編集機能を使用して文書を編集するように設計されていますが、Notes 以外のワードプロセッサを使用して文書を編集することもできます。

[代替メッセージエディタ] で、[Microsoft Word] または [Word Pro] を選択します。

インターネットメール形式またはインターネットニュース形式を設定する

HTML またはプレーンテキスト形式を選択できます。

[メール] から [インターネット] をクリックします。次に、インターネットメールの場合は [インターネットメール形式] から形式を選択し、インターネットニュースの場合は [インターネットニュース形式] から形式を選択します。

ロケーションプリファレンスでカスタマイズできる設定

Notes で画像をロードするかどうかを選択する

スクリーンリーダーを使用している場合は、画像のロードには適しません。画像をロードしないように設定すると、パフォーマンスが向上します。

[ファイル] > [プリファレンス] (Notes Basic 版クライアントユーザーの場合: [ファイル] > [プリファレンス] > [ロケーションプリファレンス]Mac OS X ユーザーの場合: [Notes] > [プリファレンス]) をクリックし、[ロケーション] をクリックして編集するロケーションをクリックし、[編集] をクリックします。

次に、[詳細] タブをクリックしてから [基本] タブをクリックします。[イメージの読み込み] フィールドで [要求時] をクリックします。

Notes 以外のブラウザを選択する Notes

Notes をインターネットブラウザとして使用できます。または、テキストだけが表示されるような他のブラウザも使用できます。システムに使用したいブラウザをインストールしておきます。

[ファイル] > [プリファレンス] (Notes Basic 版クライアントユーザーの場合: [ファイル] > [プリファレンス] > [ロケーション]Macintosh OS X ユーザーの場合: [Notes] > [プリファレンス]) をクリックして [Web ブラウザ] をクリックし、[このオペレーティングシステムのデフォルトとして設定しているブラウザを使用する] を選択して [適用] をクリックします。

追加の Notes 設定

次のような追加設定ができます。

ワークスペースをホームページとして設定する

より簡単にアクセスできるように、 Notes の起動時に Notes のホームページではなく Notes ワークスペースが表示されるように設定することができます。ワークスペースとホームページには MSAA からアクセスできます。ブックマークで、[アプリケーション] フォルダを開き、ワークスペースのブックマークを右クリック (Macintosh の場合は [Ctrl] キーを押しながらクリック) して、[ブックマークをホームページに設定] をクリックします。

Notes.ini ファイルでフォント設定を変更する

Notes.ini 設定ファイルは、Notes ディレクトリに格納されています。このファイルには、各ユーザーの Notes インストールに関する情報が保存されています。拡大フォントや小さなフォントが必要な場合は、Notes を終了して Notes.ini ファイルをテキストエディタで開き、ファイル内の任意の場所で新しい行として次の設定を追加します。

Display_font_adjustment=n

n は、デフォルトのサイズに追加するポイントの数で、-1 から 25 までの数値です。例えば、フォントサイズを 3 ポイント大きくする場合は、次のように入力します。

Display_font_adjustment=3
注意: 4 以上の値を使用すると、フォーマットの問題が発生することがあります。こうした拡大フォントが必要な場合、Windows の表示フォントを変更することをお勧めします。この方法を使用すると、Notes を含めたコンピュータ上のすべてのプログラムに反映されます。低視力の方のための Notes の設定 セクションを参照してください。

新しいフォントの行を追加してから Notes.ini ファイルを保存し、Notes を再度開きます。

別の方法として、[ファイル] > [プリファレンス] > [フォントと色] をクリックし、[拡大フォント] または [特大フォント] を選択することもできます。

ブックマークリストのキーボードナビゲーションを有効にする

[Alt] + [B] キーを押して [開く] メニューを表示すれば、キーボードを使ってブックマークリストにアクセスしナビゲーションできます。Notes Basic 版クライアントユーザーの場合: 基本プリファレンスで [拡張アクセラレータ表示を有効にする] が使用可能になっている場合は、ブックマークリストでキーボードナビゲーションを使用することができます。[Alt] + [B] キーを押して、ブックマークリストにフォーカスを移動します。ナビゲーションには、上矢印、下矢印、[Home]、[End]、[Page Up]、[Page Down] の各キーを使用できます。ブックマークを選択するには、[Enter] キーを押します。ブックマークリストからフォーカスを解除するには、[Esc] キーを押します。

カレンダーで概要を有効にする

カレンダービューのデフォルトでは、日付は水平方向に表示され、タイムスロットは通常垂直に表示されます。ナビゲーションを容易にするため、これらのビューで概要を使用して、タイムスロットを表示せずにビューを完全に垂直方向に表示することができます。これにより、エントリ間を直接移動できるようになります。このように設定するには、カレンダーを開いて [表示] > [表示] > [要約] をクリックします。

カレンダーの日付ヘッダー情報を表示する

カレンダーのサイズによって、日付のヘッダー情報が全部表示されない場合、キーボードをお使いであれば [Alt] + [-] (マイナス) キーを使ってペインの境界線用の [サイズ] メニューを開いて使用できます。メニューを使って移動させる境界線を選択し、矢印キーを使って選択した境界線を移動させます。[Alt] + スペースバーを使って、Notes のウィンドウ全体のサイズを指定するメニューを開くこともできます。

プリビューペインを使用する

Notes の使い方によっては、メールの受信ボックスのようにプリビューペインのオン/オフを切り替えたい場合があります。

スクリーンリーダーのユーザーはプリビューペインをオフにする必要があります。オフにするには、[Alt] + [V] キーを押して [ビュー] メニューを開き、[P] を押して [プリビューペイン] メニューを開き、再び [P] を押して [プリビューの表示] オプションの選択を解除します。

キーボードのユーザーとハイコントラストのユーザーは、選択した文書 (例えば、カレンダーエントリ) のビューからは利用できない情報を入手できるので、プリビューペインを開いたままにしておきたいと思う場合があります。

メールとカレンダーのプリファレンスにアクセスする

スクリーンリーダーを使用していて、メールとカレンダーのプリファレンスの読み取りに支障がある場合は、[ファイル] > [プリファレンス] コマンドではなく、[アクション] > [詳細] > [プリファレンス] コマンドを使用してメールとカレンダーのプリファレンスにアクセスしてみてください。

ウィジェットを XPage ベースのウィジェットカタログからインストールする

Notes からインストールするには、ウィジェット文書を開き、[Alt] + [T] を押して [ウィジェット][このウィジェットをインストール] の順に選択します。

ブラウザからインストールするには、ウィジェット文書を開き、タブを使用して添付ファイルセクションの extension.xml ファイルを選択し、[Enter] を押してファイルをダウンロードします。次に、Notes に切り替え、[マイウィジェット] サイドバーパネルにナビゲートし、そのパネルのメニューから [インポート] を選択します。

Domino® Designer フィーチャーへの移動

HCL Notes の HCL Domino Designer フィーチャーへのアクセス権限がある場合は、以下の推奨事項に従うことにより、より簡単に移動できます。

  • Domino Designer フレームを順を追って移動するには、[F6] キーを使用します。これにより、次の順でフレームが移動します。列、アクションペイン (開いている場合)、オブジェクト/リファレンスフレーム、プログラムペイン。
  • オブジェクト/リファレンスフレーム内の場合は、[Ctrl] + [Page Up] と [Ctrl] + [Page Down] を使用して 2 つのタブを切り替えます。
  • オブジェクト/リファレンスフレームの内部で移動する場合は、より簡単にリスト内を移動するため、リストをデフォルトモードのままにしておきます。現在の選択項目がわからなくなった場合は、[すべて表示]/[すべて展開] メニューオプションを使用してすべてのサブセクションを展開し、リスト内での現在の位置を確認するのに役立てます。[Home] キーと [End] キーも、リストの最初と最後に素早く移動する場合に役立ちます。
  • プログラムペインまたはオブジェクト/リファレンスペイン内の場合は、[Tab] と [Shift] + [Tab] を使用してリストボックス、フィールド、ボタン間を移動します。

低視力の方のための Notes の設定

低視力の方の場合、Notes の表示フォントのサイズを大きくすることができます。会議を開催するときにスケジューラを [要約] ビューで常に開くように設定すると、色や図形の使用を減らすことができます。

表示フォントのサイズを大きくする Notes

  1. 必要に応じて Notes を終了します。オペレーティングシステムのハイコントラスト設定を Notes に認識させるには、 Notes 開始前に設定する必要があります。
  2. Windows のアクセシビリティオプションで、オペレーティングシステムのハイコントラストモードを有効にします (詳しくはオペレーティングシステムのヘルプを参照してください)。
  3. Notes を起動し、[ファイル] > [プリファレンス] > [フォントと色] をクリックして、[大] を選択します。これにより、受信トレイやプリビューペインなどの Notes データ領域に大きいフォントサイズが適用されます。Notes Basic 版クライアントユーザーの場合: Notes を起動し、[表示] > [文字サイズ] > [最大化][拡大][元のサイズに戻す] を選択して、Notes の文書とビューの文字の表示サイズを変更します。
  4. [拡大フォント] を選択します。これにより、受信トレイやプリビューペインなどの Notes データ領域に大きいフォントサイズが適用されます。
    ヒント: フォントサイズを大きくしたときに Notes クライアントの UI が文字切れする場合 (例えば、検索バーの [表示] -> [検索バー]) は、[表示] -> [右側のサイドバー] メニューにあるショートカットキーを使用することで、サイドバーを簡単に省略表示できます。これにより、Notes のメインウィンドウパネルをより大きく表示することができます。

Microsoft Windows ユーザーの場合、Windows の表示フォントを変更することにより、Notes のフォントサイズを変更することをお勧めします。なぜなら、Windows の表示フォントを変更することにより、使用しているコンピュータのすべてのプログラムにその変更が反映されるためです。詳しくは、Windows のヘルプを参照してください。

ヒント

スケジューラを常に [要約] ビューで開くよう設定する

スケジューラの [要約] ビューまたは [詳細] ビューのいずれかで、会議に参加可能な時間が表示されます。[詳細] ビューは、会議に参加可能な時間を色または図形で示します。低視力の方は、文字列ベースである [要約] ビューを簡単に使用できます。[要約] ビューは [カレンダープリファレンス] にデフォルトで設定されていますが、デフォルトが変更されている場合に元に戻すには、次の操作を行います。

  1. カレンダーから、[アクション] > [オプション] > [プリファレンス] をクリックします。
  2. [スケジュール] タブをクリックして、[スケジューラ表示] タブをクリックします。
  3. [会議の最適時間の提案] を選択し、[OK] をクリックします。

スケジューラの [要約] ビューと [詳細] ビューの使用方法の詳細については、「会議のために空き時間を検索する」を参照してください。

スクリーンリーダーとメールについての特記

外部ソースからメールを読んでいるときに、スクリーンリーダーがヘッダーまたはセクションの終わりまでしか読み上げない場合は、[ファイル] > [プリファレンス] > [ユーザープリファレンス] > [基本] > [追加のオプション] を選択して、Notes クライアントのプリファレンス [MIME メールに対して埋め込みブラウザを無効にする] を設定します。

埋め込み画面メールメッセージのナビゲート

埋め込み画面メールメッセージについては、メッセージウィンドウまたはフォントがサイズ変更されてメールメッセージ全体が画面上に収まらない場合、水平スクロールバーは表示されません。

この制限に対処するには、[Tab] キーを使用してメールメッセージのヘッダーを入力し、スクロールロックを有効にしてから、矢印キーを使用してナビゲートします。

Notes アプリケーション内の文書間の移動

任意の Notes アプリケーションで文書を読む場合、[Enter] キーを押すと次の文書に移動できます。ただし、特定の状況では、JAWS(r) 画面読み取りソフトウェアが [Enter] キーを保留することがあります。これは、現在の文書が MIME 形式で、デフォルトの Notes 組み込みブラウザを使用している場合に発生します。この場合、JAWS は [Enter] キーを捕捉し、何も行いません。

この問題を回避するには、JAWS コマンド Pass next key through を使用できます。[Insert] + [3] を押すだけで次のキーストローク、この場合 [Enter] を Notes に送信します。