Issues with per user installation of AppScan Go! on Windows 7

Symptom

When installing AppScan Go! on Windows 7, if you chose the installation type Only for me (<user>), and click Next, you are able to choose the install location, or Destination Folder.

By default, the per-user destination folder location is:

C:\Users\<username>\AppData\Local\Programs\AppScanGo.

However, if you chose to install in

C:\Program Files\AppScanGo

you see the following error:

Error opening file for writing:

C:\Program Files\AppScanGo\UninstallAppScanGo.exe

Click Abort to stop the installation, 
Retry to try again, or
Ignore to skip this file.

Every subsequent attempt to run the installer will result in the installer aborting.

Cause

The user is specifying a “per-user” installation of AppScan Go! but is choosing a directory location that exists for “all users.”

This is an issue only seen on Windows 7.

Resolution

  1. Go to Start > Settings > Add/Remove Programs.
  2. Uninstall the existing AppScan Go! installation.

    If it does not exist, run the installer one more time to get the above error message. It should then show up in the list of installed programs.

  3. Re-attempt the install in a different directory that is specific to the user only (for example, the user’s home directory), or choose to install for all users.