Error code reference for Meeting Rooms widget

Use this reference when correcting errors generated by the Meeting Rooms widget.

001 Failed to create meeting room.
Possible causes:
  • The sametimeMeetingsServerUrl value is incorrect in the widgets-config.xml file.
  • The X-ST-CSRF-Token is invalid. You may not be in the Meetings LDAP.
  • The Sametime® Meeting Server is not live.
002 Failed to retrieve meeting rooms.
Possible causes:
  • The sametimeMeetingsServerUrl value is incorrect in the widgets-config.xml file.
  • The X-ST-CSRF-Token is invalid. You may not be in the Meetings LDAP directory.
  • The Meeting Server is not live.
003 Failed to get Community members using the Communities API.
Possible cause:
  • Communities API is not responding as expected.
004 You are no longer authorized to create a meeting room.
Possible causes:
  • You were previously an owner of the Community, and now you are a member.
403 Failed to send a request through the Ajax proxy.
Possible causes:
  • The URL value in the proxy policy is incorrect.
  • The incorrect proxy policy is being used.
To test if the AJAX proxy is the cause of the 403 error code, move the policy in the file, so that it is the first policy. Then change the URL value to "*" meaning that it accepts all URLs for cross-domain requests. In WebSphere®, the node must be fully resynchronised and the application server must be restarted for changes to take effect.
Solution:
Use the Meeting Server URL with an asterisk at the end. For example: url="http://myMeetingsServer.ibm.com:9080/*".
412 Failure to create a meeting room.
Possible cause:
  • The X-ST-CSRF-Token is invalid. Connections has set the HTTPONLY flag.
Workaround for error 412:
Note: Only implement this workaround if you understand its effects and consequences.
  1. Log in to the WebSphere Integrated Solutions Console as the WebSphere administrator. (The URL ends with /ibm/console).
  2. Click Servers > ServerTypes > WebSphere application servers.
  3. Select the server you are working with.
  4. In the Container settings section, click Web container settings > Web container.
  5. In the Additional properties section, click Session management.
  6. Click Enable cookies hyperlink.
  7. Ensure that the Set session cookies to HTTPOnly to help prevent cross-site scripting attacks option is NOT selected.
  8. Click Apply.
  9. Resynchronize the nodes, and restart the WebSphere application server.
Other error codes
You may see other error codes which are standard HTTP status codes. Open the browser's developer tools to investigate these issues.