Creating a replica (advanced method)

Use the New Replica command to create a replica of a Notes® application.

About this task

By default, Notes creates new replicas locally. If you attempt to create a replica of a local application, this dialog box is called Overwrite Replica for Application instead of Create Replica for Application, until you specify a server or a local directory different than the one where the source application is stored.

Note: Before creating a replica on a server, make sure you are listed in the application ACL as a Manager. Otherwise, you may not have access to delete server replicas you create. If you attempt to replicate a server-based application to another server, you may encounter issues with server access. If so, ask your Domino administrator for assistance.

If the Create Replica dialog box is not open, select or open the application you want to replicate and click File > Replication > New Replica (note that View > Advanced Menus must be selected from the main menu to see this command).

Tip: If all you need is a local replica, try using the File > Application > Make Available Offline command to streamline the process of creating the replica.
Note: A replica that contains no documents is called a replica stub. If you attempt to open a replica stub, Notes shows a message saying the application is not initialized, and must be replicated.

When creating a replica, keep in mind that your preferences control certain default settings for all replicas, such as general limits on document and attachment size, full-text index creation, and encryption.

For more information see Replication preferences.

CAUTION: If you create a replica of your mail application, make sure you give the new replica the same file name and path as the file specified in the Mail file field on the Mail tab of your current location document. You can use different mail file names/paths for different locations; make sure replicas you use for those locations have matching file names/paths. For more information, see Using different locations.

To create a replica

Procedure

  1. Open the application you want to create a replica for and, from the menu, click File > Replication > New Replica.
    Note: To see this command, you must click the View menu and select Advanced Menus.
  2. If the application you're creating a replica for is on a Domino® server, Notes opens the Create Replica for Application ApplicationName dialog box (where ApplicationName is the title of the application). Do one of following steps:
    • To create the replica locally in the data directory (the default), proceed to step 4.
    • To create the replica on a server, in the Server list, select or enter the name of a server on which you want to create the replica, and click OK.
    • Modify the file name for the replica in the File path field. To specify a file path, click the folder icon and browse to the directory on the server where you want to save the replica.
  3. If the application you're creating a replica for is local, Notes opens the Overwrite Replica for Application ApplicationName dialog box. Do one of the following steps:
    • To create the replica on a Domino server, in the Server list, select or enter the name of a server on which you want to create the replica, and click OK. Notes changes the title of the dialog box to Create Replica for Application ApplicationName.
    • To create the replica locally, modify the file name for the replica in the File path field. To specify a file path, click the folder icon and browse to the directory in your operating system where you want to save the replica. Modifying the file name or path in any way will prevent overwriting if the original application is local.
  4. Optional: Click Replica Settings and do any of the following:
    • Select Encrypt the replica using and click an encryption type (Strong, Simple, or Medium) from the list.
    • To improve full-text searching of this replica, select Create full text index for searching. To save space on your hard disk drive, deselect this option.
    • To use the same security settings for the replica as for the original application, leave Copy Access Control List selected. To use different settings, deselect it. The check box is available only when you are not the application manager and the application's ACL is not set to enforce a consistent ACL across all replicas.
    • To create the new replica when you click OK, regardless of the setting in your replication preferences, leave Create Immediately selected. To wait until the next scheduled replication, deselect this option.
    • To customize settings for this replica, such as whether to replicate to or from the server (or both), a schedule, and which documents in the application to replicate, click More Settings.
  5. Click OK.

Results

Notes adds a bookmark (in your History folder) and an application entry to the Replication page for each local replica you create. You can use the Replication page to update (replicate) your replicas.

Access levels

About this task

When you create a local replica, Notes assigns you Manager access to the replica. However, if you do not have the appropriate access to the original application on the server (for example, you have only Reader access), you cannot replicate changes you make in the replica back to the server.

Note: If an application manager enforces an application's access control list (ACL) across all replicas and you create a replica of the application, Notes assigns you the same access to the replica that you have to the original application. For example, if you have Author access to an application, Notes assigns you Author access to the replica. For more information about an application's ACL, see the application's manager.