What options are available for customizing the basic Notes client?

In HCL Notes®, you can use preferences to change how often Notes will autosave documents, to check subscriptions from your Notes applications, and change default fonts, as well as many other basic preferences.

To set preferences involving basic setup of your HCL Notes client, click File > Preferences (Notes Basic client users: click File > Preferences > User Preferences; Macintosh OS X users: click Notes > Preferences), and then click Basic Notes Client Configuration.

Table 1. Startup and shut down, and Display sections

Setting

Description (for check boxes, describes when selected)

Empty trash on application close (if not emptied at a timed interval)

Controls how often the Trash folder in applications other than Mail is emptied. Use the Mail preference (Basics tab) to control emptying the Trash in Mail.

AutoSave every x minutes

Automatically saves documents you are working on to a local encrypted application so that you can recover your work if there is a power outage or system crash. When you send/save or discard a document, it is removed from the local application.

Note: The application developer controls whether AutoSave is available in an application.

Local application folder

Your Notes data directory (Macintosh OS X users, Data folder) contains local applications, local application templates, your bookmark.nsf file, and Country Language Services (.cls) files, which contain information Notes uses to sort documents and import files.

Note: Changes to the location of the data directory (Data folder) take effect the next time you start Notes.

Check subscriptions

You use subscriptions to receive real-time updated information from your favorite HCL Notes applications. You must enable subscription checking for the subscription feature to work.

Scan for unread

Triggers automatic scanning of your startup Notes® application for unread documents and the display of those documents when you start Notes.

Enable scheduled local agents

Runs scheduled agents when you start Notes. An examples of a task you might create a scheduled agent for is moving certain documents to a folder.

Default Fonts

You can change which serif, sans serif, monospaced, and multilingual fonts are used by default in new Notes documents.

Note: To restore the default font settings, click Default in theDefault Fonts dialog box and then click OK.
Table 2. Startup and shut down, and Display sections - Notes Basic client

Setting

Description (for check boxes, describes when selected)

Empty trash on application close (if not emptied at a timed interval)

Controls how often the Trash folder in applications other than Mail is emptied. Use the Mail preference (Basics tab) to control emptying the Trash in Mail.

AutoSave every x minutes

Automatically saves documents you are working on to a local encrypted application so that you can recover your work if there is a power outage or system crash. When you send/save or discard a document, it is removed from the local application.

Note: The application developer controls whether AutoSave is available in an application.

Save window state on exit

Each time you close Notes, saves whatever window tabs you happen to have open for the next session. If you want to see a specific set of window tabs every time you use Notes, use File > Save Window State instead.

Local application folder

Your Notes data directory (Macintosh OS X users, Data folder) contains local applications, local application templates, your bookmark.nsf file, and Country Language Services (.cls) files, which contain information Notes uses to sort documents and import files.

Note: Changes to the location of the data directory (Data folder) take effect the next time you start Notes.

Check subscriptions

You use subscriptions to receive real-time updated information from your favorite HCL Notes applications. You must enable subscription checking for the subscription feature to work.

Scan for unread

Triggers automatic scanning of your startup Notes application for unread documents and the display of those documents when you start Notes.

Enable scheduled local agents

Runs scheduled agents when you start Notes. An examples of a task you might create a scheduled agent for is moving certain documents to a folder.

Default Fonts

You can change which serif, sans serif, monospaced, and multilingual fonts are used by default in new Notes documents.

Note: To restore the default font settings, click Default in theDefault Fonts dialog box and then click OK.

Icon color scheme

Changes the color scheme of the icons on the Bookmark bar. Clicking the System color makes Bookmark icons coordinate with the color settings you select in your operating system control panel.

Bookmark icon size

Changes the size of the icons on the Bookmark bar and within bookmark folders, whether to show icons at all in bookmark folders.

Table 3. Additional options checklist

Setting

Description for when selected

Mark documents read when opened in preview pane

Previewing a document marks it as read.

Make Internet URLs (http://...) Into Hotspots

Changes URLs into clickable hotspots when you save or send the document.

Textured Workspace

Adds textured background to your workspace.

Right double-click closes window

Right double-clicking the mouse button closes the current Notes window.

Note: This setting is not available on the Macintosh.

Enable Java™ applets

Supports the running of Java applets when opening pages in Web browsers.

Note: This setting is not available on the Macintosh.

Enable JavaScript™

Supports the running of JavaScript when opening pages in Web browsers.

Enable Java access from JavaScript

Allows you to run LiveConnect from Netscape, if the applet is configured to include the CORBA back-end classes.

Note: This setting corresponds to the notes.ini setting EnableLiveConnect(=1).

Enable JavaScript error dialogs

Displays error messages in a dialog box when there is a problem in the JavaScript, requiring you or whoever is reading the document that contains the applet to dismiss the dialog box. If this option is not selected, JavaScript errors appear only in the status bar.

Note: This setting corresponds to the notes.ini setting EnableJavaScriptErrorDialogs(=1).

Accept Cookies

Cookies will be used to store URL login data and to let a website know that you have been to that website before.

Process print requests as a background task

Printing occurs in the background so you can continue working while during intensive printing jobs.

Note: For Macintosh OS X, background printing is always on. For more information, refer to your Macintosh OS Help.

Disable View updates as a background task

Views will update in the foreground. Depending on the size of the view, this could interrupt your work.

Retain View column sorting

Applies to Notes applications that allow you to change the column sorting (by clicking an arrow in a column heading). For example, this is helpful if you always want your mail view sorted with latest messages at the beginning, or your contacts sorted by Business.

Enable MS Office 97 Send to Notes

Causes all mail Send To commands in Microsoft® Office applications to start Notes mail and send the file as an attachment in a mail memo. Appears if you have Microsoft™ Office 97, or certain other Microsoft applications such as Visual Basic, installed. Not necessary for later releases of Microsoft Office.

Use Web palette

Uses the Web color palette (256 colors that most computers can display).

Show extended accelerators

You can use keyboard accelerators (Microsoft Windows® ALT+keys) to access on-screen elements such as the window tabs and action bars.

Note: This setting is not available on the Macintosh.

Enable MIME save warning

Notes will tell you when data you want to send over the Internet cannot be converted to MIME format.

Enable Unicode display

Allows you to see special characters that aren't found on your default keyboard. You may need additional Unicode-based fonts installed on your Microsoft Windows™ operating system. Notes comes with five different Monotype WorldType fonts to install directly from the CD-ROM.

Note: If not enabled, Notes attempts to display text using the native character set of your machine.

Macintosh users: You can use Unicode, but only using characters from your native character set. English Macintosh systems do not support the use of Unicode.

Launch the CORBA (DIIOP) server on Preview in web browser

Intended for HCL Domino® Designer users who preview their designs through the Notes client. When a designer previews any element of a Notes application (.nsf component) in a Web browser, Notes launches a limited version of the Domino server to serve the web page resulting from the element. If the element (for example, a Notes form) contains a Java applet created with the Java Notes classes, this setting allows Notes to launch, in addition, a limited version of a CORBA (DIIOP) server to support the applet's classes.

Note: This setting is not available on the Macintosh.

Standard dialog boxes

You see standard operating system dialog boxes rather than dialog boxes with a custom Notes appearance.

Note: This setting is not available on the Macintosh.

Strict Date/Time Input

Notes will not attempt to correct or change the format of values you enter in date or time fields. Keeping this setting enabled ensures greater accuracy in most cases.

Show in-line MIME images as attachments

Images you receive within the text of a MIME message appear as attachments.

Disable embedded browser for MIME mail

Uses your system browser to display MIME mail. This provides better rendering of your mail when compared with the Notes default browser, but does not provide as accurate printing of the mail header. Use of the system browser might also result in security issues in some cases.

When text language is unspecified use the form's

Applies to multilingual applications: any text of an unspecified language automatically becomes the language specified for the form that was used to create the document.

Note: You must have the Domino Designer client to specify a document's language.

Invoke Notes on vCard files

Invokes Notes when you double-click a vCard (.vcf) file. If Notes is not running, the double-click will start it and open to the My Contacts view in your Contacts. If Notes is running, the double-click opens Contacts or switches to its window tab if it's already open. Once in Contacts, the Contacts in the vCard File dialog box opens with the specified file displayed, so you can add contacts from the file to your Contacts.

Note: This setting is not available on the Macintosh.

Use inline autocomplete in the address bar

A URL will be completed as you type characters in the Address box on the toolbar, based on entries you have previously entered. Typing a single letter displays a listing of all your URLs that begin with that letter.

Prompt for location on startup

When you start Notes you will be prompted for a location.

Note: This setting is visible only if you click the custom feature Client Single Logon when you installed Notes.

Use Tab to navigate Read-Only Documents

Lets you use TAB to move from object to object (for example, linked text, hotspots, document links and so on) in a read-only document. However, you can no longer use TAB, while reading a document, to navigate to the next document in the view.

Note: You must restart Notes for this setting to take effect.

Use Accessibility Keyboard navigation

Disables the up and down arrows and lets you use TAB to move from field to field in a document that is in edit mode. When TAB is a keystroke in a field, such as an editable rich-text field, pressing a directional arrow moves you to the next field.

Enable persistent breakpoints in Script debugger

For Domino designers who are writing Script in an application. Saves all breakpoints set in Script, thus making them available the next time the script is debugged.

Note: This setting is not available on the Macintosh.

Enable Icon Popup Help in View

Enables popup help when you hover over icons in mail, calendar, and to do views and folders.

Expand Names field contents when printing

When printing memos or Calendar entries, prints the contents of the entire To: or cc: fields, as opposed to the default limit of three lines.

Note: Print Preview will display the actual number of lines that will be printed in the To or CC fields.

Start Print Preview On Current® Page

Your preview always begins on the current page when you choose print preview.

Use Notes (not Web) query syntax in the view search bar

Multiple terms in a search query will find documents where those terms appear in the exact order entered in the Search field (as if they were enclosed in quotation marks), rather than find documents that contain those terms regardless of order.

Treat shortcuts as files when selecting in file dialogs

Applies to creating and saving attachments. Shortcut (.lnk) files you select in the Create Attachment dialog box will attach as the full files they reference rather than as shortcuts (links). Shortcuts chosen as the destination location when saving attachments will be treated like full files, in which case the shortcuts are overwritten by the file being saved (rather than the file being saved overwriting the file location that the shortcut points to).

Note: This setting applies only to Notes clients running on Windows operating systems.

Disable type-ahead for all name fields and use the Notes Basic type-ahead

When you add a recipient's name in mail, the type-ahead feature you that helps you complete the name will be the one used in Notes 7 and earlier.

Compress images pasted into documents

Automatically compresses images pasted into documents. Bitmap (.bmp) images that are imported into a Notes document are compressed; bitmap images that are pasted into a Notes document are converted to a .gif or .jpg format.

Do not prompt when marking all documents read or unread

You will not be asked whether you want to proceed when you choose to mark all Notes documents as read or unread.

Do not prompt when exiting

You will not be asked whether you really want to exit before you close the Notes, Administrator, or Designer client.

Do not prompt when closing a document with edited attachments

When you close a Notes document after editing an attachment to that document, you will not be reminded to go back and save the changes to the attachment.

Do not prompt when forwarding a document with edited attachments

When you forward a Notes document after editing an attachment to that document, you will not be reminded to go back and save the changes to the attachment.

Show check marks in margin for selected documents

Uses the selection method in releases prior to Notes 8.0, which includes a check mark in the margin to indicate which documents have been selected. Click and hold the pointer device in this margin to select multiple documents.

Table 4. Additional options checklist - Notes Basic client

Setting

Description for when selected

Mark documents read when opened in preview pane

Previewing a document marks it as read.

Make Internet URLs (http://...) Into Hotspots

Changes URLs into clickable hotspots when you save or send the document.

Textured Workspace

Adds textured background to your workspace.

Right double-click closes window

Double-clicking the right mouse button closes the current Notes window.

Note: This setting is not available on the Macintosh.

Enable Java applets

Supports the running of Java applets when opening pages in Web browsers.

Note: This setting is not available on the Macintosh.

Enable JavaScript

Supports the running of JavaScript when opening pages in Web browsers.

Enable Java access from JavaScript

Allows you to run LiveConnect from Netscape, if the applet is configured to include the CORBA back-end classes.

Note: This setting corresponds to the notes.ini setting EnableLiveConnect(=1).

Enable JavaScript error dialogs

Displays error messages in a dialog box when there is a problem in the JavaScript, requiring you or whoever is reading the document that contains the applet to dismiss the dialog box. If this option is not selected, JavaScript errors appear only in the status bar.

Note: This setting corresponds to the notes.ini setting EnableJavaScriptErrorDialogs(=1).

Accept Cookies

Cookies will be used to store URL login data and to let a website know that you have been to that website before.

Process print requests as a background task

Printing occurs in the background so you can continue working while during intensive printing jobs.

Note: For Macintosh OS X, background printing is always on. For more information, refer to your Macintosh OS Help.

Disable View updates as a background task

Views will update in the foreground. Depending on the size of the view, this could interrupt your work.

Retain View column sorting

Applies to Notes applications that allow you to change the column sorting (by clicking an arrow in a column heading). For example, this is helpful if you always want your mail view sorted with latest messages at the beginning of the list, or your contacts sorted by Business.

To dither images when your system uses 256 colors

When your computer's display is set to a resolution of 256 colors, Notes improves the appearance of images by dithering them (interpreting groups of pixels so that they can appear smoother).

Note: This setting does not appear in the list if your system is set to use more colors than 256. This setting is not available on the Macintosh.

Enable MS Office 97 Send to Notes

Causes all mail Send To commands in Microsoft® Office applications to start Notes mail and send the file as an attachment in a mail memo. Appears if you have Microsoft Office 97, or certain other Microsoft applications such as Visual Basic, installed. Not necessary for later releases of Microsoft Office.

Use Web palette

Uses the Web color palette (256 colors that most computers can display).

Show extended accelerators

You can use keyboard accelerators (Microsoft Windows® ALT+keys) to access on-screen elements such as the window tabs and action bars.

Note: This setting is not available on the Macintosh.

Enable MIME save warning

Notes will tell you when data you want to send over the Internet cannot be converted to MIME format.

Enable Unicode display

Allows you to see special characters that aren't found on your default keyboard. You may need additional Unicode-based fonts installed on your Microsoft Windows operating system. Notes comes with five different Monotype WorldType fonts to install directly from the CD-ROM.

Note: If not enabled, Notes attempts to display text using the native character set of your machine.

Macintosh users: You can use Unicode, but only using characters from your native character set. English Macintosh systems do not support the use of Unicode.

Display Window Menu

The Window menu appears between the Actions and Help menus. Use this menu to switch to any open window, or choose Windows to manage your open windows.

Note: This setting is not available on the Macintosh.

Launch the CORBA (DIIOP) server on Preview in web browser

Intended for HCL Domino Designer users who preview their designs through the Notes client. When a designer previews any element of a Notes application (.nsf component) in a Web browser, Notes launches a limited version of the Domino server to serve the web page resulting from the element. If the element (for example, a Notes form) contains a Java applet created with the Java Notes classes, this setting allows Notes to launch, in addition, a limited version of a CORBA (DIIOP) server to support the applet's classes.

Note: This setting is not available on the Macintosh.

Standard dialog boxes

You see standard operating system dialog boxes rather than dialog boxes with a custom Notes appearance.

Note: This setting is not available on the Macintosh.

Strict Date/Time Input

Notes will not attempt to correct or change the format of values you enter in date or time fields. Keeping this setting enabled ensures greater accuracy in most cases.

Show in-line MIME images as attachments

Images you receive within the text of a MIME message appear as attachments.

Disable embedded browser for MIME mail

Uses your system browser to display MIME mail. This provides better rendering of your mail when compared with the Notes default browser, but does not provide as accurate printing of the mail header. Use of the system browser might also result in security issues in come cases.

When text language is unspecified use the form's

Applies to multilingual applications: any text of an unspecified language automatically becomes the language specified for the form that was used to create the document.

Note: You must have the Domino Designer client to specify a document's language.

Invoke Notes on vCard files

Invokes Notes when you double-click a vCard (.vcf) file. If Notes is not running, the double-click will start it and open to the My Contacts view in your Contacts. If Notes is running, the double-click opens Contacts or switches to its window tab if it's already open. Once in Contacts, the Contacts in the vCard File dialog box opens with the specified file displayed, so you can add contacts from the file to your Contacts.

Note: This setting is not available on the Macintosh.

Use inline autocomplete in the address bar

A URL will be completed as you type characters in the Address box on the toolbar, based on entries you have previously entered. Typing a single letter displays a listing of all your URLs that begin with that letter.

Prompt for location on startup

When you start Notes you will be prompted for a location.

Note: This setting is visible only if you click the custom feature Client Single Logon when you installed Notes.

Use Tab to navigate Read-Only Documents

Lets you use TAB to move from object to object (for example, linked text, hotspots, document links and so on) in a read-only document. However, you can no longer use TAB, while reading a document, to navigate to the next document in the view.

Note: You must restart Notes for this setting to take effect.

Use Accessibility Keyboard navigation

Disables the up and down arrows and lets you use TAB to move from field to field in a document that is in edit mode. When TAB is a keystroke in a field, such as an editable rich-text field, pressing a directional arrow moves you to the next field.

Enable persistent breakpoints in Script debugger

For Domino designers who are writing Script in an application. Saves all breakpoints set in Script, thus making them available the next time the script is debugged.

Note: This setting is not available on the Macintosh.

Use System Color

Sets Notes user interface colors to match, where possible, colors in the scheme specified using the Microsoft Windows Control Panel > Display > Appearance menu sequence.

Because the Notes user interface may actually display more colors than are part of the scheme, schemes other than high contrast schemes may decrease the legibility of elements in Notes.

Note: This setting is not available on the Macintosh.

Enable Icon Popup Help in View

Enables popup help when you hover over icons in mail, calendar, and to do views and folders.

Expand Names field contents when printing

When printing memos or Calendar entries, prints the contents of the entire To: or cc: fields, as opposed to the default limit of three lines.

Note: Print Preview will display the actual number of lines that will be printed in the To or CC fields.

Start Print Preview On Current Page

Your preview always begins on the current page when you choose print preview.

Use Notes (not Web) query syntax in the view search bar

Multiple terms in a search query will find documents where those terms appear in the exact order entered in the Search field (as if they were enclosed in quotation marks), rather than find documents that contain those terms regardless of order.

Treat shortcuts as files when selecting in file dialogs

Applies to creating and saving attachments. Shortcut (.lnk) files you select in the Create Attachment dialog box will attach as the full files they reference rather than as shortcuts (links). Shortcuts chosen as the destination location when saving attachments will be treated like full files, in which case the shortcuts are overwritten by the file being saved (rather than the file being saved overwriting the file location that the shortcut points to).

Note: This setting applies only to Notes clients running on Windows operating systems.

Compress images pasted into documents

Automatically compresses images pasted into documents. Bitmap (.bmp) images that are imported into a Notes document are compressed; bitmap images that are pasted into a Notes document are converted to a .gif or .jpg format.

Do not prompt when marking all documents read or unread

You will not be asked whether you want to proceed when you choose to mark all Notes documents as read or unread.

Do not prompt when closing all currently open window tabs

You will not be asked whether you want to continue when you click the menu command to close all window tabs.

Do not prompt when exiting

You will not be asked whether you really want to exit before you close the Notes, Administrator, or Designer client.

Do not prompt when closing a document with edited attachments

When you close a Notes document after editing an attachment to that document, you will not be reminded to go back and save the changes to the attachment.

Do not prompt when forwarding a document with edited attachments

When you forward a Notes document after editing an attachment to that document, you will not be reminded to go back and save the changes to the attachment.

Table 5. Fields following Additional options checklist

Setting

Description for when selected

Show check marks in margin for selected documents

Allows you to select documents by clicking or dragging the cursor in the column margin of the list of documents; selected documents have a check mark in the column margin of their titles.

Automatically lock my Notes ID after 90 minutes (Notes Basic client users: Logout (and lock Notes display) if you haven't used Notes for 90 minutes

Allows Notes to lock your User ID after a specified time period of inactivity. If you step away from your computer, just make sure that the page you leave up is not sensitive, and be confident that your data is secure.

Note: To unlock your User ID, press Enter and then type your password in the password prompt. Once you enter your password, your Notes display becomes unlocked.