Supported software levels, fixes, and settings for HCL Commerce

The following table provides a list of generally available (GA) software levels, fixes, and settings for the latest HCL Commerce Version 9 release.

Important: HCL Commerce is tested with the versions of companion software that are stated on this page, and is supported against any faults which are encountered when used alongside them. If you encounter an issue operating HCL Commerce with older versions of companion software, upgrade to a tested and supported level before contacting HCL Support.

HCL Commerce maintenance packages contain multiple corrections and improvements in the areas of function, security, stability, and performance. It is recommended that you run your HCL Commerce site with the current update package. As with all production changes, when you apply update packages, ensure that you complete rigorous functional and performance verification tests with your custom code.

Even if an update is not in your schedule, review the information about recommended fixes and settings in the following table to keep informed about corrections and improvements to HCL Commerce. You can use this information to determine how your site might benefit from an upgrade.

Operating Systems / Infrastructure

The operating systems and infrastructure software products that are listed here are ensured to be compatible with all provided and prerequisite HCL Commerce software. It is not an exhaustive list.

Software Operating Systems
HCL Commerce Developer
  • Microsoft Windows 7
  • Microsoft Windows 10
HCL Commerce
  • Kubernetes deployment
    • Bare-metal or hosted Kubernetes cluster 1.16 or newer
    • Helm 3.3.1 or newer
  • Docker deployment
    • Hypervisors
      • KVM
      • Microsoft Hyper-V Server 2016
      • VMware ESXi 6.7
      Important: HCL Commerce is expected to function as designed using a hypervisor with a supported host operating system. Due to the large number of hypervisors available, and the complexity of emulation, no guarantee can be made that your environments will work as expected. Therefore, only combinations which are known by HCL to be problematic will be listed here.
    • Linux
      • Red Hat Enterprise Linux (RHEL) Server Version 7.5 or higher (7.x only)
      • CentOS (7.x only)
      • Compatible Linux operating systems, x86-64 and ppc64le
    • Docker 19.03.2 or newer
Note: The latest Docker images contain:
  • DB2 container: Centos 7.7.1908
  • All other containers: Centos 7.9.2009

Database

Software Supported versions and required fixes
Oracle Database
  • HCL Commerce Version 9.0.0.5 or laterOracle 12c Release 1 (12.1+)
  • HCL Commerce Version 9.0.0.5 or laterOracle 12c Release 2 (12.2.0.1.0+)
  • HCL Commerce Version 9.0.1.8 or laterOracle 18c
  • HCL Commerce Version 9.0.1.8 or laterOracle 19c
IBM Db2
  • HCL Commerce Version 9.0.1.12 or laterIBM Db2 11.5
  • IBM Db2 11.1 Mod 2 Fix Pack 2 (11.1.2.2+)

Integration and development

Software Supported versions and required fixes
IBM WebSphere eXtreme Scale Client
  • WebSphere eXtreme Scale Client 8.6.1.2
HCL Commerce DeveloperIBM Rational Application Developer
  • Rational Application Developer 9.6

Browsers

Software Supported versions and required fixes
Management Center for HCL Commerce
  • Edge 20+
  • Internet Explorer 9+
  • Firefox 39+
  • Chrome 44+
  • Safari 10+
Aurora-based storefronts
  • Internet Explorer 20H2+
  • Edge 87+
  • Firefox 84+
  • Chrome 87+
  • Safari 14+
Business user tooling
  • HCL Commerce Accelerator
  • HCL Commerce Organization Administration Console
  • HCL Commerce Administration Console
  • Internet Explorer 11 (in compatibility mode)
  • Chrome 87+ with the IE Tab extension

Compatibility matrix

The following table describes the minimum requirements for each version of HCL Commerce Version 9.0 that has been released. The database and its level is of particular importance based on the version of HCL Commerce and the search solution that is used.

Commerce Companion software Database Browsers
HCL Commerce Version 9.0.1.17
  • WebSphere Application Server 9.0.5.8
  • WebSphere Application Server Liberty 21.0.0.6
  • IBM SDK, Java Technology Edition, Version 8.0.5.30
  • IBM HTTP Server 9.0.5.8
  • IBM Db2 11.5
  • IBM Db2 11.1 Mod 2 Fix Pack 2 (11.1.2.2+)
  • Oracle 12c Release 1 (12.1+)
  • Oracle 12c Release 2 (12.2+)
  • Oracle 18c
  • Oracle 19c
  • Management Center for HCL Commerce
    • Edge 20+
    • Internet Explorer 9+
    • Firefox 39+
    • Chrome 44+
    • Safari 10+
  • Aurora-based storefronts
    • Internet Explorer 20H2+
    • Edge 87+
    • Firefox 84+
    • Chrome 87+
    • Safari 14+
HCL Commerce Version 9.0.1.16
  • WebSphere Application Server 9.0.5.6 + PH31727 + PH33228 + PH33648
  • WebSphere Application Server Liberty 21.0.0.1
  • IBM SDK, Java Technology Edition, Version 8.0.6.25 (+ IJ31256 with HCL Commerce Developer)
  • IBM HTTP Server 9.0.5.6
  • IBM Db2 11.5
  • IBM Db2 11.1 Mod 2 Fix Pack 2 (11.1.2.2+)
  • Oracle 12c Release 1 (12.1+)
  • Oracle 12c Release 2 (12.2+)
  • Oracle 18c
  • Oracle 19c
  • Management Center for HCL Commerce
    • Edge 20+
    • Internet Explorer 9+
    • Firefox 39+
    • Chrome 44+
    • Safari 10+
  • Aurora-based storefronts
    • Internet Explorer 20H2+
    • Edge 87+
    • Firefox 84+
    • Chrome 87+
    • Safari 14+
HCL Commerce Version 9.0.1.15
  • WebSphere Application Server 9.0.5.5 + PH26220 + PH27509 +PH29871 + PH27157
  • WebSphere Application Server Liberty 20.0.0.9 + TFOLGH13861
  • IBM SDK, Java Technology Edition, Version 8.0.6.15
  • IBM HTTP Server 9.0.5.5
  • IBM Db2 11.5
  • IBM Db2 11.1 Mod 2 Fix Pack 2 (11.1.2.2+)
  • Oracle 12c Release 1 (12.1+)
  • Oracle 12c Release 2 (12.2+)
  • Oracle 18c
  • Oracle 19c
  • Management Center for HCL Commerce
    • Edge 20+
    • Internet Explorer 9+
    • Firefox 39+
    • Chrome 44+
    • Safari 10+
  • Aurora-based storefronts
    • Internet Explorer 20H2+
    • Edge 87+
    • Firefox 84+
    • Chrome 87+
    • Safari 14+
HCL Commerce Version 9.0.1.14
  • WebSphere Application Server 9.0.5.5 + PH26220 + PH27509 +PH29871 + PH27157
  • WebSphere Application Server Liberty 20.0.0.9
  • IBM SDK, Java Technology Edition, Version 8.0.6.15
  • IBM HTTP Server 9.0.5.5
  • IBM Db2 11.5
  • IBM Db2 11.1 Mod 2 Fix Pack 2 (11.1.2.2+)
  • Oracle 12c Release 1 (12.1+)
  • Oracle 12c Release 2 (12.2+)
  • Oracle 18c
  • Oracle 19c
  • Management Center for HCL Commerce
    • Edge 20+
    • Internet Explorer 9+
    • Firefox 39+
    • Chrome 44+
    • Safari 10+
  • Aurora-based storefronts
    • Internet Explorer 20H2+
    • Edge 87+
    • Firefox 84+
    • Chrome 87+
    • Safari 14+