Troubleshooting

Use the information described here to troubleshoot problems.

Problem:

When the automation plan engines are installed on one or more DSA servers in your environment, each step of the automation plan execution is created several times instead of one. The number of times each step is created is equal to the number of DSA servers, with the automation plan engine installed, present in your environment.

Cause:

In a DSA environment, you can install the Server Automation components on both servers, but you must ensure that only one instance is active at any given time. Otherwise, multiple actions will be created for each step in the plan. Both plan engine instances will process the same plan.

Solution:

To disable the plan engine on the DSA server, perform these steps:

  1. Immediately after installing it, go to <BES Root Dir>\Applications\Config and rename the PlanEngine.xml file into PlanEngine.xml.stop.
  2. To ensure that it is stopped, check the <BES Root Dir>\Applications\Logs\pe_console.log file. No new messages should be posted in the log file.

In the event of a primary root server failure, rename the XML file back to PlanEngine.xml on the DSA server but remember to disable the plan engine instance on the primary server as well (by adding the .stop extension to the XML file on the primary server ).