長期実行キャンペーンがデータベースへの接続を失う

IBM® Campaign または Contact Optimization アプリケーションがそのバックエンド・データベースへの接続を失う場合は、データベースに自動的に再接続するように STALE_CONN_TIMEOUT 環境変数を設定してください。

症状

以下のような例外メッセージが発生します: [IBM][CLI Driver] SQL30081N 通信エラーが検出されました。使用された通信プロトコル: "TCP/IP"。使用されている通信 API: "SOCKETS"。エラーが検出されたロケーション: "<ip>"。エラーを検出した通信関数: "send"。プロトコル固有エラー・コード:"32"、"*"、"0"。SQLSTATE=08001。

原因

この問題は、長期実行キャンペーンがそのデータベースへの接続をフローチャート実行中に失うと発生する場合があります。

問題の解決

IBM Campaign または Contact Optimization のリスナー・スクリプト・ファイルの環境変数 STALE_CONN_TIMEOUT を設定します。以下に例を示します。STALE_CONN_TIMEOUT=<seconds>. リスナー・スクリプト・ファイルは rc.unica_ac/cmpServer.bat (Campaign の場合) および ACOServer.sh/.bat (Contact Optimization の場合) です。これは、<CAMPAIGN_HOME>\bin に配置されています。

このパラメーターを調整した後、リスナーを再始動する必要があります。

定義した秒数の間接続がアイドル状態だった場合は、接続が再び開かれます。接続が失われると、Campaign フローチャートまたは Contact Optimization サーバーのログ・ファイルに次のデバッグ・メッセージが置かれます。 [DB QUERY] 接続が失効しているため、データベース接続を再開しています。