Software Requirements

Before you install the HCL OneDB™ server, make sure that your computer meets these software requirements.

Operating system requirements

Install the required operating system patches and library files that are listed in the machine notes for your operating system. The machine notes are available in the doc directory of the media files before installation.

UNIX™, Linux™: The directory on which you plan to install the database server must be local or an NFS-mounted file system with regular operating-system files.

Windows™: The drive on which you plan to install the database server must be formatted with NTFS and must have 8.3 file name creation enabled. Turn off User Account Control (UAC) security before you install the database server.

HCL OneDB Client SDK and Server 1.0 is certified to run on 64-bit versions of these operating systems:

Table 1.
Operating System Version
Linux x86-64
RHEL 7.4 / CentOS​ 7.4
  • Base kernel version 3.10.0
  • Glibc version 2.17
  • Compiler 4.8.5
RHEL 8
  • Base kernel version 4.18.0
  • Glibc version 2.28
  • Compiler 8.2.1
SuSE SLES 12
  • Minimum service pack 3
  • Base kernel version 4.4.73
  • Glibc version 2.22
  • Compiler 4.8.5​
SuSE SLES 15
  • Base kernel version 4.12.14
  • Glibc version 2.26
  • Compiler 7.3.1
Ubuntu 16.04 LTS
  • Base kernel version 4.4.0
  • Glibc version 2.23
  • Compiler 5.4.0
Ubuntu 18.04 LTS
  • Base kernel version 4.15
  • Glibc version 2.27
  • Compiler 7.5
Ubuntu 20.04 LTS
  • Base kernel version 5.4
  • Glibc version 2.31
  • Compiler 9.3
AIX 7.2
Windows​

Windows 2016

Windows 2019

Windows 10

Application software required to run/install Server

Table 2.
Operating System Version
Linux

OpenSSL any of the supported versions 1.0.2, 1.1.0 or 1.1.1.

AIX OpenSSL 1.0.2 is required
Java8​

JRE is required to install OneDB. Some components of OneDB also require Java8

Windows install requires a 1.8.0 JRE

Linux/AIX install requires a 1.8.0 or later JRE