Display options for views

The Options tab of the View Properties box determines the initial display of a view and specifies how users can access and interact with the view.

Setting the view as the default

If you want a view to be the first view displayed when the database opens, check the "Default when database is first opened" option. This only applies the first time the user opens the database. Subsequent openings by the same user display whatever is set on the Launch tab of the Database Properties box.

Using a view or folder as a template

If you want a view or folder to serve as a template, or model, for other views and folders that you design in the same database, check the "Default design for new folders and views" option.

Collapsing the view to show only categories

If you have a view that displays categories, you can show the view in collapsed form every time users open it by selecting "Collapse all when database is first opened."

Organizing response documents in a hierarchy

In an application such as a discussion forum, if you want response documents displayed in a hierarchy, with each level of response indented from its parent, check the "Show response documents in a hierarchy" option. Otherwise, responses will display at the same level as the main topics. If this option is checked but the view only contains response document, no documents will display. Response documents are only visible in hierarchical views when the parent document is displayed.

Adding a view name to the View menu

To make the view available to users from the View menu in Notes®, check "Show in View menu." In addition to this, or in place of in Web applications, you should provide another means of accessing the view, such as an action button, or a link from an imagemap or outline.

Allowing Notes users to customize a view

By default, a Notes client user can customize a view in a variety of ways, including resizing and reordering columns or setting color options. Changes users make are maintained when they close and reopen the view. If you do not want users to customize a view, deselect the "Allow customizations in a view" option on the Info tab. Note that deselecting the option does not disable the user menu option to customize the view. It does, however, disable all the options within that dialog except for sorting. Sorting is retained as an available item for accessibility purposes.

Note: This feature is not supported on the Web.

Evaluating formulas when documents change

A view can have associated actions, such as show/hide formulas, that evaluate when a view is opened. There may be cases when you want an action to evaluate every time a document changes in a particular view. For these cases, check "Evaluate actions for every document change." Be aware that checking this option can have a serious impact on the performance of your application.

Creating new documents at view level

Check this box if you are enabling a view so that a user can create a new document from the view level. In addition to enabling this option, you need to program the InViewEdit event for the column to specify what should happen when the Notes client user creates a document.

For more information, see Allowing users to edit or create documents from a view.

Opening to a particular row in the view

To highlight a particular row when a user opens the view, click "On Open" in the Options tab and select one of the following from the list:

  • Go to last opened document (the default choice)
  • Go to top row
  • Go to bottom row

Displaying the last-used view

If you select "Restore as last viewed by user" (one of the "On Database Open" choices on the Launch tab of the Database Properties box), Notes users see the default view the first time they open a database, and thereafter they see the last view they opened. This option isn't available for views opened by Web users.

Refreshing a view

The On Refresh options let you specify what a user sees when a view is refreshed. For more information, see "Refreshing view indexes."

Page breaks in a view

You cannot set page breaks for a view.

Notes using the Eclipse-based UI

The following options are used to specify how a view will behave when displayed in the Eclipse-based user interface, for the Personal Information Management (PIM) applications Mail, Calendar, and Contacts. These options do not apply to any other applications.

  • Hide the column header

    To show only the data in view columns without the column headers, select this option. Selecting this option allows greater flexibility in visually grouping documents within a view.

  • Show partial response hierarchies

    If this option is selected, missing roots of partial threads will be created so that response trees can be displayed for any message in the view. Otherwise, only those threads which are complete can be displayed.

  • Show Vertical/Horizontal switcher

    The preview pane can be placed in a horizontal layout orientation, before or after the viewer, or in a vertical layout orientation with the viewer. Select this option to enable a pair of icons in the actionbar of the view that enable the user to switch their layout orientation between horizontal and vertical orientations.

  • Show Tab Navigator

    The Tab Navigator is a set of button-like items, used to control the set of documents being showing in the viewer. Select this option to display the Tab Navigator in viewers and make it clickable.

  • Viewers

    This option controls the ability to switch between Table (also called Vertical or Narrow), Calendar, Tile, or third party viewers. If no viewer is specified, the style attribute of the Folder/View will determine which viewer is used. If one viewer is specified, that viewer will be used. If multiple viewers are specified, an action item will be added to the user's Action Bar, allowing the user to change the viewer. A selected viewer persists for that Folder/View. For more information on the viewers available in standard configuration, see To adjust columns for vertical layouts, Creating a calendar view, or To adjust columns for tiled layouts.

  • Thread View

    To enable the inline expand thread feature for a folder or view, specify its name in the Thread View option. If a Folder/View is specified in the Thread View option, an additional option of Allow conversation mode is available. If checked, the Allow conversation mode option will add a button to the user's Action Bar allowing the user to switch between the message mode (showing all messages, and highlighting those in the same thread as a selected message) and the conversation mode (showing only the most recent message in a thread, until the thread is expanded).