Unable to run iOS mobile tests on pCloudy Cloud

When you run mobile tests on an iOS device or emulator on pCloudy Cloud, the test run fails with the error: Could not start a new session. Response code 500. Message: Appium Server Error due to some reason.

Cause

The iOS app that is uploaded to pCloudy Cloud is not resigned as prescribed by the pCloudy platform. For more information, refer to https://www.pcloudy.com/docs/resigning-process.

Resolution

To resolve this issue, you must perform the following steps:
  1. Resign the iOS app by using the process prescribed by the pCloudy platform.
  2. Note down the new .ipa file name with the Resigned tag.
  3. Open Test UI, and then switch to the Application Configuration page.
  4. Update the package name of the application with the new .ipa file name, and then save it on the Edit iOS application page.
  5. Select the test suites as required from the Available tests list, and synchronize the test suite with the application data on the Application Configuration page.
  6. Run the test.