Unable to record or run Web UI tests on Chrome 111 or Edge 112

When HCL OneTest UI opens Google Chrome 111 or Microsoft Edge 112 to record or play back a Web UI test, the browser opens with a blank page and fails to record or run the test.

Cause

The browser opens with a blank page due to an issue with the driver for the browser.

Resolution 1

Download HCL_OT_UI_1052_Install_ChromeEdgeFix and HCL_OT_UI_1052_Install_ChromeEdgeFix_Readme provided for HCL OneTest UI or HCL OneTest Studio from HCL Software License & Download portal, and then install the fix pack.

Resolution 2

  1. Follow these steps in the New Test From Recording wizard while you record the test by using Google Chrome 111 or Microsoft Edge 112:
    1. Select the options as required for the Web UI test in the Recording Session screen.
    2. Click Next.

      The Select Location page is displayed.

    3. Specify the name and location for the test, and then click Next.

      The Select Client Application page is displayed.

    4. Select Google Chrome, and then click Next.

      The Recorder Settings dialog is displayed.

    5. Select the Web UI recording > Launch browser with arguments option in the Advanced section to specify the argument to be used when HCL OneTest UI opens the browser.
    6. Enter the following argument in the text box:
      --remote-allow-origins=*
      browser_argument
    7. Click Finish.

  2. Follow these steps in the Run Configuration dialog while you play back the test in Google Chrome 111 or Microsoft Edge 112:
    1. Select the options as required for the test run in the Run Configuration page.
    2. Click Next.

      The Advanced playback options page is displayed.

    3. Select the Launch browser with arguments checkbox to specify the argument to be used when HCL OneTest UI opens the browser.
    4. Enter the following argument in the text box:
      --remote-allow-origins=*
      browser_argument
    5. Click Finish.