Digital Analytics 統合のトラブルシューティング: レコード数の不一致

フローチャートが実行されるとき、IBM® Campaign は、マップされた変換テーブルにおいて IBM Digital Analytics キーの数と IBM Campaign オーディエンス ID の数の間に不一致があれば検出します。registrationID の数が、オーディエンス ID の数と一致しないと、警告が出されます。

症状

不一致が検出されると、IBM Campaign は、 マップされた変換テーブルに更新されたレコードが含まれていることを確認するよう求める警告メッセージをフローチャート・ログ・ファイルに書き込みます。

原因

この動作は、IBM Digital Analytics キーと、マップされた変換テーブル内の IBM Campaign オーディエンス ID が矛盾することを検出し、防止するためのものです。ETL ルーチンが完了していないために、変換テーブルにまだ追加されていない IBM Digital Analytics セグメントの registrationID がある場合を例に考えます。この場合、IBM Digital Analytics セグメントから取得した 100 人の顧客がいるものの、 IBM Campaign 内には 95 個の CustomerID しかないということがあり得ます。結果が現時点でスキュー (100 レコード対 95 レコード) していても、ETL ルーチンが完了すると解決されます。

問題の解決

この問題を解決するには、社内ポリシーに従ってオンライン・キーとオフライン・キーを (再度) 一致させ、変換テーブルに最新のデータを再設定します。ユーザーは、マップされた変換テーブルが更新された後に、フローチャートを再実行する必要があります。