Digital Analytics 統合のトラブルシューティング: エラー 13156

このトピックでは、「IBM® Digital Analytics セグメントの選択」ポップアップ・ウィンドウの使用時に、エラー 13156 が発生したときの対処方法について説明します。

症状

IBM Campaign ユーザーが、フローチャートで選択プロセス・ボックスを構成しているときに、IBM Digital Analytics セグメントを選択しようとすると、エラー 13156 が表示されます。エラー状態:IBM Digital Analytics 応答でエラーが返されました。詳しくは、ログを参照してください

原因

マップされた変換テーブル内の Digital Analytics ID の列名が registrationid として定義されておらず、Campaign 内の CoremetricsKey 構成プロパティーが registrationid に設定されていない可能性があります。

また、UC_CM_ACCESS データ・ソースに割り当てられた資格情報が間違っている可能性もあります。UC_CM_ACCESS データ・ソースは、統合サービスへのアクセスを提供する資格情報を格納するために Marketing Platform が使用するメカニズムです。このケースに該当するかどうかを検査するには、フローチャートのログ・ファイルのロギング・レベルを DEBUG に上げてください。ログ・ファイルに次のエラーが含まれている場合は、 認証に問題があります:{"error":{"message":"User authentication failed","code":"1000"}}}

問題の解決

Digital Analytics ID が入っている変換テーブルの列の名前が「registrationid」であることを確認するには、「設定」>「構成」>Campaign | partitions | partition[n] | Coremetrics を選択し、「CoremetricsKey」「registrationid」に設定されていることを確認します。

データ・ソースの資格情報を修正するには、「設定」>「ユーザー」と選択し、「ASMUserForCredentials」構成設定で定義されているユーザーを選択し、「データ・ソースの編集」リンクをクリックして、データ・ソースを編集します。

  • 「データ・ソース・ログイン」と「データ・ソース・パスワード」には、必ず Digital Analytics クライアント ID と同じ資格情報を使用してください。
  • データ・ソースが、IBM Campaign 構成設定に定義されている 「ASMDatasourceForCredentials」 (例えば、「UC_CM_ACCESS」など) と完全に一致することを確認してください。