Host prerequisites

You can find the host prerequisites that support the operating capabilities for HCL OneTest UI.

Contents

Development tools

Development Tool

Version

Components

Notes

Functional test

Web UI test

Appium

1.17

image of the crossmark.

supported

Deprecated from 10.2.0.

Appium

1.18

image of the crossmark.

supported

1.19

image of the crossmark.

supported

1.20.0 image of the crossmark.

supported

1.21

image of the crossmark.

supported

Microsoft .NET Framework

3.5

supported

supported

Microsoft Visual Studio

2015 and future fix packs

supported

image of the crossmark.

Required to use HCL OneTest UI from this Integrated Development Environment (IDE).

2017 and future fix packs

supported

image of the crossmark.

2019 and future fix packs

supported

image of the crossmark.

Web browsers

The browsers listed in the following table can be used to view the contents of various assets in a testing project such as a recording session, configured applications, datasets, reports, and so on. You must refer to the Recording and Playback Support section to view the list of browsers along with their versions that are supported to record and play back tests.

Browser

Version

Components

Notes

Functional test

Web UI test

Apple Safari

12 or later

Not Applicable

supported

Google Chrome

78 or later

supported

supported

Microsoft Edge

80 or later

supported supported

Microsoft Internet Explorer

11

supported supported

Deprecated from 10.2.0.

Mozilla Firefox (including ESR versions)

68 or later

supported

supported

Opera

67 or later

supported

supported

Virtualization management

Container

Version

Components

Notes

Functional test

Web UI test

Docker Community Edition (CE)

19.3

supported

supported

Deprecated from 10.2.0.

Docker Community Edition (CE)

20.1 and future fix packs

supported

supported

Docker Compose

1.25 and future fix packs

supported

supported

Deprecated from 10.2.0.

1.26 and future fix packs

supported

supported

1.27 and future fix packs

supported

supported

1.29 and future fix packs

supported

supported