
Getting started with OneTest Embedded 
Eclipse IDE 

 

 

OneTest Embedded is delivered with some examples. For the Eclipse IDE, they are in 
<installation folder>/examplesEclipse. The following tutorial uses the example 
MUIproj. It will demonstrate the following features:  

• The application build 
• Code coverage 
• MISRA rules review 
• The call graph visualization 
• The test generation 
• The stub creation 
• The execution of the test 

1 Import the project into Eclipse 

1.1 Start Eclipse IDE 

Þ On Windows:  
o Before stating, set the environment variables  HCL_LICENSING_URL and 

HCL_LICENSING_ID with the information provided by HCL 
o Open the Windows start menu and select the menu HCL OneTest Embedded 

for Eclipse IDE in the group HCL OneTest Embedded  

 

Þ On Linux:  
o In the installation folder, edit the file testrtinit.sh and update the following 

environment variables  
§ TESTRTDIR with the correct installation folder 



§ HCL_LICENSING_URL and HCL_LICENSING_ID with the information 
provided by HCL 

o Execute the command: . testrtinit.sh 
o Then execute the command: . start_visualtest.sh & 

Þ Then, create your own workspace (alternatively you can select an existing workspace).  

 

1.2 Import the project MUIproj 

Þ Select the menu File > Import…  
Þ In the opened wizard, select General > Existing Projects into Workspace 

and click on Next 

 

 

Þ Then click on Select archive file, click on Browse…  on the same line and select the 
file MUIproj.zip in the folder <installation folder>/examplesEclipse. 



 

Þ Then click on Finish 

A new project MUIproj is created. You can see it in the project explorer (if this view is not already 
open, you can open it by selecting the menu Window > Show View > Project Explorer)  

 

2 Build and execute the application 

OneTest Embedded comes with many Target Deployment Port (a.k.a. TDP) for different compilers 
(for more information about Target Deployment Port, please click here). This project has been 
initially for C Visual Studio 2019. If you have not this compiler already installed, or if you are 
on Linux, you need to change the Target Deployment Port. 

When you install OneTest Embedded on your laptop, the installer checks your compilers installation 
and create the following TDP for you: 

• C GNU if it finds a gcc native compiler (Cygwin or MinGW)  
• C Visual if it finds a Microsoft Visual compilers 

We will update this project with one of them. 

2.1 Modify the TDP in the settings 

Þ In the project explorer, right-click on the project MUIproj and select the menu 
Properties 

Þ In the left menu tree in the wizard, select C/C++ Build > Settings 



 

Þ In the right panel of the wizard, select the tab Build TDP (if this tab is not displayed, 
increase the width of the wizard or use the right arrow to make it appears). 

 

Þ In Target Deployment Port property, click on C Visual Studio 2019 to make 
the dropdown appear and select C GNU (or C Visual depending on the compiler you have 
on your machine) 

 

Þ Then click on Apply and Close 



2.2 Build the project 

Now this project can be built using this TDP. By default, the build will be done with Coverage and 
MISRA Code Review options engaged. 

Þ In the project explorer, right-click on the project MUIproj and select the menu Build 
Project 

 

The console view should display the build log. At the end, the build should be completed until the link 
phase with success (it could take some minutes). 

 

2.3 Execute the application 

This application contains a simple main that can be executed.  

Þ In the project explorer, open the node Binaries in the MUIproj project 

 



Þ Right-click on MUIproj.exe and select the menu Run as > Instrumented 
Application 

 

This menu will execute the just-compiled application and then will launch different tools to generate 
reports depending on the settings. 

Note: if Eclipse prompts you in case of errors in the project, ignore it and click on Yes. 

2.4 See code coverage report 

After the execution, all the reports are gathered in a single file that you can find under the virtual 
node Test.  

Þ In the project explorer, open the node Test > Application Result in the MUIproj 
project. There is a new file called MUIproj.exe with the date of the execution and a status. 

Þ Right-click on this file and select the menu Open With > Coverage  

 



The coverage viewer is opened now, showing a graph with the different coverage level percentages 
(for more information about the coverage levels, click here and here). 

 

The outline view (here on the right) allows you to navigate on the source code for each compilation 
unit. 

Þ Click on one of them. A copy of the source code is now displayed with different colors: 
o Green: the code has been covered 
o Red: the code has been partially covered 
o Orange: the code is partially covered 
o Black: not code 

 

For more details on this page, please click here. A similar report exists in HTML. You can open it in a 
browser: 

Þ Right-click on the same file and select the menu Open With > HTML Reports > 
Coverage  



 

2.5 See MISRA code review report 

OneTest Embedded supports MISRA C 2004 (click here for the detailed description of the MISRA C 
2004 rules) & MISRA C 2012 (click here for the detailed description of the MISRA C 2012 rules). The 
report generated by this feature could be opened in a similar way. 

Þ Right-click on the node MUIproj.exe in the Application Result node this and select 
the menu Open With > Code Review  

  

The code review viewer is opened now. The outline view allows you to navigate in the different files 
of the application (.h and .c). The central panel displays the rules that have been raised during the 
analysis for the selected file. If you click on a rule, the source code editor will open in the selected 
file, at the line where the error has been found. 

  



A similar report exists in HTML. You can open it in a browser: 

Þ Right-click on the same file and select the menu Open With > HTML Reports > Code 
Review  

2.6 Export the HTML reports 

As described earlier, all the reports, including the HTML reports, are store in a single file (a zip file). 
You can easily extract only the HTML reports in a folder with an index that lists all the exported files. 

Þ Right-click on the result file and select the menu Open With > HTML Reports > 
Export Reports  

 

Þ Select a folder on your disk (or create a new one) and click OK. Then, a browser opens with 
the index as following:  

 

3 Create a test case 

The next sections will show you how to create, update and execute a test case with OneTest 
Embedded. 

3.1 Open the call graph 

There are many ways to create a test case. The one we will explore use the call graph. 



Þ In the project explorer, right-click on the project MUIproj and select the menu Open Call 
Graph 

 

This action will open a new view containing the call graph of the application: 

 

The nodes of this graph are the functions of the application. Nodes with dotted line are functions for 
which we don’t have the source code (in this example, these are functions in libc). The lines 
between 2 nodes are the calls between functions. The top level function is at the left of the graph (in 
this example it is the function main) and low level functions on the right. 

Þ Click on one node inside the call graph (in the following example, the node MUIpsCompute 
has been selected) 

 

Now the call graph highlights the following: 

• The grey node is the selected function 
• The blue lines on the right of this node are calls to other functions 
• The blue lines on the left of this node are link to caller functions 
• The blue nodes are functions that are in the same compilation unit 



 

Þ Double click on a node, the corresponding source code will open in the editor. 

3.2 Create a test 

We will now create a test for the function div. In OneTest Embedded, a test is composed of 2 parts: 

• A test case: it is the test itself. It contains: 
o The call of the function under test. 
o A table with the initial values and the expected values of the parameters, the global 

variables and local variables that you can add in this test case. 
o The stub behaviors relative to this test case. 
o Optionally, code that will be added at the beginning (#include for example) and one 

or several requirements. 
• A test harness: this is the container of the test cases (one test harness can contain several test 

cases). It defines how the test will be built to become an executable. It contains: 
o The list of the files under test. 
o Additional source files that can be added to the test harness when linking. This option 

is useful for software integration test. It is also possible to add object files and 
libraries. 

o The build settings. 
o Optionally, code that will be added at the beginning (#include for example) and one 

or several requirements (in such case, these requirements will cover all the test cases 
of the test harness). 

In OneTest Embedded, test cases and test harnesses are files with the extensions .test_case and 
.test_harness. There are compressed XML files. 

Þ Right-click on the node div and select the menu New test harness  

 

A new panel appears at the top of the call graph, called Test Creation Activity: 

 

This is a wizard to help us to create a first test case. 

Þ Click on Next. This is the second page of the wizard. Now the call graph is reduced only to 
the functions that are in the same compilation unit (in blue) and the functions that are called 
by previous one: 



 

The objective of this step is to take into account only the functions that are required in your test 
harness to link properly with your compilation unit without error. By default, the test harness will be 
linked only with the compilation unit of the function under test. So, all the referenced functions 
(nodes in yellow) will generate an error at the link phase as they will be missing. The way to avoid 
that is to stub them. 

Þ Click on the node MUILogInformation  

 

This node is now displayed as a stub, and the node MUILogClear disappears from the call graph 
because its caller will be stubbed.  

Þ Continue the sub selection by clicking on the nodes MUIsetTimer, MUIresetTimer, 
MUILogError and MUIcheckTimer. 

 

At the end, all the yellow nodes should have been supressed and only the blue one are ramaining. 

Þ Click on Next. The next page is the test case name. By default, it is the name of the function 
under test. Let’s go with the default. 

Þ Click on Next. The next page is the test harness name. By default, it is the name of the 
function under test with the suffix th_. Let’s go with the default. 

Þ Click on Finish. 



3.3 Edit a test 

At the end of the wizard, a test harness that includes one test case is created. This test harness 
should be open. It contains 2 parts: 

• On the left panel, an activity diagram that allows to chain the execution of the test cases 
• On the right panel, the configuration of the test harness 

 

For now, let’s have a look only on the following ones: 

• Context definition: Only one file has been added as files under test because we have stubbed 
all the external calls.  

Note that this icon  indicates that the files under test will be included in the code 
generated for the test harness. This will help you to have the visibility on static variables and 
static functions that are hidden from external compilation units.  

• Stubs: You can see here the 5 selected stubbed functions. 

 

Þ To open the test case, double click on the box div in the activity diagram. It contains 2 parts: 
o On the left panel, an activity diagram that display the different phases of the test case 
o On the right panel, the configuration of the phase that is selected on the activity 

diagram (the default one when opening the test case is its general description, that 
you can open when clicking on the background of the activity diagram) 



 

Þ Click on the Code box in the activity diagram: this shows you the generated code for calling 
the function under test. It could be edited. 

 

The variables retValue, a and b will be created locally in the test harness and used as parameters.  

Þ Click on the Check box in the activity diagram  

 

This table displays all the variables used for the test (parameters and global variables) with: 

• Their type 
• Their initial expression (i.e. the value before calling the function under test). No Change 

means that this variable will be not initialized before calling the function under test. 
• Their expected expression (i.e. the expected value after calling the function under test). Same 

as Init mean that the expected value is the same that the initialized value. 



• Their obtained expression (i.e. the actual value after calling the function under test). This 
column is empty for now. It will be automatically filled after an execution. 

Be default, the wizard generates a test case with all the parameters to 0 (or null in case of 
pointers). Let’s modify this test case for having the following division 50/7 that should give 7 as 
result. 

Þ Click on the cell initial expression of the variable a and enter the value 50. Press 

enter to validate this value, or click on the icon . 
Þ Click on the cell initial expression of the variable b, enter the value 7 and validate it. 

Do not modify the expected result of retValue for now. 

3.4 Execute a test 

Þ Go back in the test harness by clicking on the tab th_div in the editor panel. 

Þ Click on the icon  on the top left of the details panel. The console view should display 
build log… This should take less than 1mn.  

3.5 View a test result 

At the end of the execution, the test harness editor is updated to display the result as following: 

 

• The filed Available runs is updated with the last execution result and its status is 
displayed (Failed in this case). 

• The activity diagram is updated with the status of each test case (Failed in this case). 
• A coverage summary is displayed on the top right of the panel.  

 
Þ You can hover over this coverage summary to display a more detailed information 



 

Þ Then click on the link Open full coverage report to open the coverage viewer with 
the information relative to the file under test only.  

Þ Double-click on the test case div inside the activity diagram. You will go back in the test case 
editor which display additional information relative to the last runs:  

 

• The filed Available runs is updated with the last execution result and its status is 
displayed (Failed in this case). 

• The activity diagram is updated with the status of the Check box (Failed in this case). 
• A coverage summary is displayed on the top right of the panel.  
• The column Obtained value is updated with the true values read during the execution 

and their status. 

3.6 Fix the test case 

We can see that the value of retvalue is wrong.   

Þ Fix the expected value of retvalue to 7 
Þ Save the test case div  
Þ Go back in the test harness and re-run the test 

Now, it is passed: 



 

 

3.7 Update the test case with multiple input values 

OneTest Embedded allows you to define not only a single value but multiple values for an input 
variable, and also for the expected values of an output parameter. For multiple input values, you can: 

1. Give a list of values from a min value to a max value with a defined step, 
2. Give a list of values as a list, 
3. Give a list of values that come from a datapool. 

We will illustrate the second case here, with several values on parameter a that should modify 
output value of retvalue. 

Þ Click on the input Expression of the variable a and select menu Multiple. 

 

Þ In the dialog box, select Multiple option, and the Values number to 3. 



 

Þ Then click on OK. A new bar appears on top of the table. Enter the values 10, 20 and 30 in 
the 3 available fields.  

 

Þ Press enter to validate these values, or click on the icon . 
Þ Click on the Expected Expression of the variable retvalue and select menu 

Synchonized. 

 

Þ A new bar appears on top of the table. Enter the values 1, 2 and 4 in the 3 available fields. 

 

Þ Press enter to validate these values, or click on the icon . 



Þ Execute this test case Click by going back on the test harness and clicking on the icon  on 
the top left of the details panel. 

Þ At the end of the execution, the test case is updated with the obtained values. You can 
navigate in the 3 iterations using the breadcrumb bar on the top of the test case: 

 

 


