Accessibility features for Domino Administrator

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products.

Accessibility features

HCL Domino Administrator has accessibility features that help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products successfully.

Attention: All the accessibility features in the Domino Administrator client are the same ones as in the Notes client. These are the major accessibility features in the Notes client:
  • You can use accelerators and command keys to navigate through Notes®.

    An underlined letter on the screen designates an accelerator; for example, F is the accelerator for the File menu. In Microsoft® Windows®, press the Alt key, then the accelerator to trigger an action; for example, Alt+F shows the File menu. If they are enabled, you can use extended accelerators as well.

    Command keys directly trigger an action and usually make use of the Ctrl (Windows) or Command (Macintosh) keys. For example, to print, press Ctrl+P (Macintosh users, Command+P).

  • Notes uses Microsoft Active Accessibility (MSAA). This means that people with limited vision can use screen-reader software, along with a digital speech synthesizer, to listen to what is displayed on the screen.
  • Domino Administator supports your system's display settings, such as color scheme, font size, and high-contrast display. See the following section, Setting up Notes for low vision.

Notes has many other features that you can customize to fit your individual needs. See any of these sections:

  • Settings you can customize in basic preferences
  • Settings you can customize in mail preferences
  • Settings you can customize in location preferences
  • Additional Notes settings
  • Setting up Notes for low vision
  • Hints and Tips

Keyboard shortcuts

For information on available Notes keyboard shortcuts, see Keyboard shortcuts or Keyboard shortcuts for the Macintosh.

This product uses standard Microsoft Windows navigation keys in addition to application-specific keys.

Interface information

Settings you can customize in basic preferences

Click File > Preferences (Notes Basic client users: Click File > Preferences > User Preferences; Macintosh OS X users: Click Notes > Preferences), and then click Basic Notes Client Configuration to do the following:

Change default fonts

You can select different fonts for clarity.

Under Display, click Default Fonts, choose default font options and click OK.

Select or clear the Show extended accelerators option

Extended accelerators offer keyboard methods for operating the bookmarks bar and window tabs. If you have extended accelerators enabled, press and hold Alt to display additional accelerators for each bookmark and window tab. Once you see the extended accelerators displayed on your screen, press the letter or number that corresponds to the area of Notes you want to go to.

Under Additional options, select or clear Show extended accelerators.

Select or clear the Textured Workspace or Right double-click closes window options

The Textured workspace option can be cleared to improve screen clarity or to improve access for screen readers. The Right double-click closes window option offers an alternate way of closing windows in Notes.

Under Additional options, select or clear one or both of these options.

Enable or disable Java™ applets, JavaScript™, Java access from JavaScript, JavaScript error dialogs, Plugins in Notes Browser, or ActiveX in Notes Browser

Notes supports Java Applets, JavaScript, Plugins, and ActiveX technology. Currently, some of these technologies are not accessible. Depending on which access technology you are using, you may want to disable these features.

Under Additional options, enable or disable any of these options.

Select or clear the Use Tab to navigate Read-Only Documents option

Tab moves to next unread document until the last unread document is selected. Then it moves to the next navigable object in the next frame. When a document is open in read mode, Tab navigates to any embedded object such as URLs, application links, and attachments.

Under Additional options, select or clear Use Tab to navigate Read-Only Documents.

Select or clear the Use Accessibility Keyboard navigation option

You can disable the directional arrows and enable Tab to move from field to field within a document in edit mode.

Under Additional options, select or clear Use Accessibility Keyboard navigation.

Notes Basic client users: You can choose to display the Window menu in the menu bar, allowing you to move between open documents and applications. If the Window menu option is enabled, extended accelerators for window tabs are disabled, and instead enabled for the Window menu. Under Additional options, select or clear Display Window Menu. If you have specified one of the Windows high-contrast color schemes (See Windows Help to learn how to enable high-contrast color schemes), you can set Notes to use the same colors in its user interface, views, and documents.
Note: The High Contrast options have a default time out of five minutes. If your system is idle for five minutes the settings may change out of high contrast and back to a default setting.
Under Additional options, select or clear Use System Color.

Settings you can customize in mail preferences

Click File > Preferences (Notes Basic client users: Click File > Preferences > User Preferences; Macintosh OS X users: Click Notes > Preferences), and then click Mail > Sending and Receiving to do the following:

Set audible or visual notification for incoming mail

When you receive a new mail message, Notes can notify you with either a sound or a visual cue.

Under When new mail arrives, click Play a sound, Show a popup, or Slide in a summary.

Select a specific word processor

Although the editing features in Notes are designed to be accessible, you can also use your own word processor to edit documents.

Under Alternate message editor, select Microsoft Word or Word Pro.

Set your Internet mail format or Internet news format

You can select HTML or plain-text format.

Under Mail, click Internet. Then, for Internet mail, select a format under Internet mail format; for Internet news, select a format under Internet news format.

Settings you can customize in location preferences

Choose whether or not Notes should load images

If you are using a screen reader, it may help not to load images. You can turn them off to improve performance.

Click File > Preferences (Notes Basic client users: Click File > Preferences > Location Preferences; Macintosh OS X users: Click Notes > Preferences), click Locations, click the location to edit, and click Edit.

Then, click the Advanced tab and then the Basics tab. In the Load images field, click On request.

Choose a browser other than Notes

You can use Notes as your Internet browser or use another browser, such as a text-only browser, instead. You must already have your preferred browser installed on your system.

Click File > Preferences (Notes Basic client users: Click File > Preferences > Location Preferences; Macintosh OS X users: Click Notes > Preferences), click Web Browser, select Use the browser I have set as the default for this operating system, and then click Apply.

Additional Notes settings

Additional settings are available.

Set your workspace as your home page

For easier navigation, you may prefer to set the Notes workspace, rather than the Notes Home page, to appear when you start Notes. Both the workspace and the Home page are accessible through MSAA. In your bookmarks, open the Applications folder, right-click (Macintosh users, Ctrl+click) the workspace bookmark, and click Set Bookmark as Home Page.

Change font settings in your Notes.ini file

The Notes.ini file configuration file is located in your Notes directory. It stores information about your personal Notes installation. If you need to use slightly larger or smaller fonts at all times, close Notes, open your Notes.ini file in a text editor, and add the following setting as a new line anywhere in the file:

Display_font_adjustment=n

where n is the number of points added to the default size and is a number between -1 and 25. For example, if you want to increase the font size by 3 points, you would type:

Display_font_adjustment=3
CAUTION: Using a value of 4 or higher may result in formatting problems. If you need to use fonts that large, it is best to change your display fonts in Windows, which will affect all the programs on your computer, including Notes. See the Setting up Notes for low vision section.

Save your Notes.ini file after you add the new font line, and then re-open Notes.

Another option is to click File > Preferences > Fonts and Colors and select Large Fonts or Extra Large Fonts.

Enable keyboard navigation of the bookmarks list

Press Alt+B to display the Open menu where you can use the keyboard to access and navigate your bookmarks list. Notes Basic client users: If Show extended accelerators is enabled in your basic preferences, you can enable keyboard navigation along the bookmarks list. Press Alt+B to shift focus to the bookmarks list. For navigation, use the Up and Down arrows, Home, End, Page Up, and Page Down. To select a bookmark, press Enter. To remove focus from the bookmarks list, press Esc.

Enable summaries in your calendar

In the default calendar views, dates are horizontally-oriented with regular vertical time slots. For easier navigation, you may prefer to use summaries in these views, which make the views completely vertically-oriented without the time slots, so you can navigate directly from entry to entry. To do so, open your calendar, and then click View > Show > Summary.

Display date header information in the calendar

If you're using the keyboard and the calendar is sized so that you can't see all of a date's header information, you can use Alt+Minus (-) to open a Size menu for pane borders. Use the menu to select the border to move, and then use the arrow keys to move the selected border. You can also use Alt+Spacebar to open a menu that lets you size the entire Notes window.

Using the preview pane

Depending on how you use Notes, you may want to turn the preview pane on or off in views such as your mail's Inbox.

Screen reader users should turn the preview pane off. To do so from a view, press Alt+V to open the View menu, press P to open the Preview Pane menu, and press P again to deselect the Show Preview option.

Keyboard users and high contrast users may want to keep the preview pane open as it provides a way for them to get information about the selected document (for example, a calendar entry) that is not available from the view.

Accessing mail and calendar preferences

If you're using a screen reader and it has difficulty reading mail or calendar preferences, try accessing mail and calendar preferences using the Actions > More > Preferences command instead of using File > Preferences.

Installing a widget from the XPages-based widget catalog

To install from Notes, open the widget document, press Alt+T, select Widgets, and select Install this Widget.

To install from a browser, open the widget document, tab to the extension.xml file in the Attachment section, and press Enter to download the file. Then switch to Notes, navigate to the My Widgets sidebar panel, and select Import from the panel's menu.

Navigating Domino® Designer features

If you have access to Domino Designer features in HCL Notes, use these recommendations to navigate them more easily:

  • Use the F6 key to move sequentially through Domino Designer frames. This cycles you through the frames in the following sequence: Columns, Action Pane (if open), Objects/References Frame, and Programmer's Pane.
  • When in the Objects/References Frame use Ctrl+Page Up and Ctrl+Page Down to switch between the two tabs.
  • When navigating in the Objects/References Frame, leave the list in default mode to move through it more easily. If you lose your current selection, expand all subsections using the View/Expand All menu option to help orient yourself within the list. The Home and End keys are also helpful to quickly move to the beginning and end of the list.
  • When in the Programmer's Pane or Objects/References pane, use Tab and Shift+Tab to move to and from list boxes, field, and buttons.

Setting up Notes for low vision

If you have low vision, you can increase the size of fonts displayed in Notes, and you can reduce the use of color and graphics when scheduling a meeting by setting the Scheduler to always open to the Summary view.

Increasing the size of fonts displayed in Notes

  1. If necessary, exit Notes. For operating system high contrast settings to be recognized by Notes, they must be set before Notes is started.
  2. In the Windows accessibility options, enable High Contrast mode through your operating system (refer to the operating system's Help for details).
  3. Start Notes and click File > Preferences > Fonts and Colors, and then select Large Fonts. This applies a large font size to Notes data areas such as your Inbox and preview pane. Notes Basic client users: Start Notes and click View > Text Size > Largest, Larger, or Restore to change the size of the Notes display text for documents and views.
  4. Select Large Fonts. This applies a large font size to Notes data areas such as your Inbox and preview pane.
    Tip: If the Notes client UI is truncated when the font size is increased (for example, in the Search Bar [View -> Search this View]), the Sidebar may be easily collapsed by using the shortcut keys documented in the View -> Right sidebar menu, providing more room for the Notes main window panel.

For Microsoft Windows users, it is best to change the size of your Notes fonts by changing your display fonts in Windows, since changing your Windows display fonts affects all programs on your computer. Refer to Windows Help for more information.

Hints and Tips

Setting the Scheduler to always open to the Summary view

The Scheduler indicates when people are available for a meeting in one of two ways--a Summary view or a Details view. Details makes use of color and graphics to indicate whether people are available. If you have low vision, you may find it easier to use the Summary view, which is text-based. The Summary view is the default in your calendar preferences, but if the default has been changed and you want to reset it, do the following:

  1. From your calendar, click Actions > More > Preferences.
  2. Click the Scheduling tab, and then click the Scheduler Display tab.
  3. Select Suggested best times for meeting, and click OK.

Special note about screen readers and email

If your screen reader does not read beyond the ending of a header or section, when you are reading email from an external source, set the Notes Client preference Disable embedded browser for MIME mail, by choosing File > Preferences > User Preferences > Basics > Additional Options.

Navigating embedded experience mail messages

For embedded experience mail messages, when the message window or fonts have been re-sized such that the entire mail message does not fit on-screen, the horizontal scroll bar will not display.

To work around this limitation, use the Tab key to enter the mail message header, enable scroll lock, then use the arrow keys to navigate.

Moving through documents in a Notes application

When reading through documents in any Notes application, you can click the Enter key to move to the next document. In certain circumstances, however, JAWS(r) screen reading software may hold the Enter key. This happens when the current document is in MIME format, and you are using the Notes embedded browser, which is the default. In this case, JAWS will intercept the Enter key and do nothing with it.

To work around this issue, you can use the JAWS command Pass next key through. Simply click Insert+3 to send the next keystroke, in this case Enter, through to Notes.