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Chapter 1. Release notes for HCL OneTest™ Performance

This document contains information about what's new, installation, and known issues in HCL OneTest™ Performance

and contact information of HCL.
Contents

 Product description on page 13

« What's new on page 13

» System requirements on page 15
« Installing the product on page 15
« Known issues on page 15

» Contacting HCL support on page 15

Product description

You can find the description of HCL OneTest™ Performance.

HCL OneTest™ Performance is a scripting-free environment for automating load and scalability testing of web, ERP,
and server-based software applications. HCL OneTest™ Performance provides rich and customizable reporting to
help you identify the presence and cause of system bottlenecks. HCL OneTest™ Performance captures the network
traffic that is rendered when the application under test interacts with a server. This network traffic is then emulated on

multiple virtual users while playing back the test. See Product overview on page 32.

What's new
You can find information about the features introduced in this release of HCL OneTest™ Performance.
 Microsoft Azure DevOps integration

You can now integrate HCL OneTest™ Performance with Azure DevOps by using the HCL OneTest Studio

extension to run tests as tasks in Azure DevOps pipelines. See Integration with Azure DevOps on page 98.
« Support for console mode installation by using the stand-alone installer

You can now install HCL OneTest™ Performance and HCL OneTest™ Performance Agent by using the stand-
alone installer on Ubuntu and Red Hat Enterprise Linux (RHEL) operating systems in console mode where GUI
mode is not supported. See Installing the product in the console mode and Installing Agent in the console

mode.
- Support for Jaeger traces view

You can now use the Jaeger to view test logs of tests or schedules that you run from the command-line
interface to analyze traces of transactions between distributed services. See Integration of Jaeger with the

product on page 141.
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* A quick view in reports

You can now add the additional counters on a separate page without editing an existing report to investigate

performance issues in detail. See Adding additional counters on a separate page on page 754.
 Updates to Dataset CSV Editor

The browser-based CSV Editor provides additional options that include Find and Replace, Undo, and Redo to
organize your data in the dataset in a better way. See Editing datasets on page 402.

- Labels for Resource Monitoring sources

In HCL OneTest™ Performance, you can now select the data sources in a schedule based on the labels that
you added for the data sources in HCL OneTest™ Server. See Enablement of Resource Monitoring services for

a schedule on page 556.
« Environment variables for Jenkins

You can now set environment variables on the Jenkins server as inputs to the text fields that are available for
HCL OneTest™ Performance test in a Jenkins build step. See Testing with Jenkins on page 143.

- Enhancement to performance reports

> The Overall page of the performance report is updated to show the Page VPs, Page Element VPs,
Page Status Codes, Page Element Status Codes, and Page Health information in an individual chart
and the information about the overall verification point in a pie chart. See Overall page on page 786.

> The Resources page of the performance report is updated to show the resource counters information
in front of their Resource Monitoring source name. The Performance Summary table now shows the
Type of the source and Name of the resource counter in two different columns. See Resources page
on page 793.

> You can now view and monitor the counter information generated by the custom code on a graph

when the custom code starts in the test run. See Adding custom counters to reports on page 649.
» Enhancements to SAP GUI

Most of the steps are automated now when you record SAP tests by using an SAP batch input test recording
wizard. See Recording a SAP batch input test on page 191.

« Properties Verification Points in Service Test

You can now add verification points for the properties in a test response when you record a service test or
after you record the service test. See Adding properties verification points to a test response on page 329.
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- Support for Text message in WebSphere MQ protocol configuration

After you create a WebSphere MQ protocol configuration, now you can change the message format by
selecting the Text Message check box in the Message Structure. See Creating a WebSphere MQ protocol

configuration on page 486.

System requirements

You can find information about the hardware and software compatibility required for HCL OneTest™ Performance.

For information about hardware and software compatibility, see the system requirements document.

Installing the product

You can find information about the installation and upgrade instructions for HCL OneTest™ Performance.

For installation instructions, see Installation of the product by using Installation Manager on page 72.

Known issues

You can find information about the known issues identified in this release of HCL OneTest™ Performance.

Known issues

You can find information about the known issues identified in this release of HCL OneTest™ Performance

Table 1. Release documents - Fix list and known issues

Product Download document Knowledge base

HCL OneTest™ Performance Release document Knowledge articles

The knowledge base is continually updated as problems are discovered and resolved. By searching the knowledge
base, you can quickly find workarounds or solutions to problems.

Contacting HCL support

You can find information about HCL technical support assistance for HCL OneTest™ Performance.

« For technical assistance, contact HCL Customer Support.

« Before you contact HCL support, gather the background information that you will need to describe your
problem. When describing a problem to the HCL support specialist, be as specific as possible and include
all relevant background information so that the specialist can help you solve the problem efficiently. To save
time, know the answers to these questions:

- What software versions were you running when the problem occurred?
> Do you have logs, traces, or messages that are related to the problem?

15
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> Can you reproduce the problem? If so, what steps do you take to reproduce it?

o |s there a workaround for the problem? If so, be prepared to describe the workaround.



Chapter 2. Getting Started

This guide provides an overview and describes the task flows to get you to start with HCL OneTest™ Performance.
This guide is intended for new users.

Task flows for performance testing

The task flows are designed to help you understand the end-to-end process of some of the capabilities of
performance testing. For some of the technologies, there are specific task flows that you can follow to gain a clear
understanding of the process.

Task flow: HTTP record

The diagram shows the task flow of HTTP recording to test the performance of an application using HCL OneTest™

Performance.

To test the performance of an application, you must first record the HTTP traffic that traverses between the client and

the server.

Once you complete the basic HTTP recording, play it back and fix the errors, if any. You can then customize your test

by adding other elements such as datasets, loops, and transaction.

17
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Task flow: Generating workload

The diagram shows the task flow of generating workload by creating user groups and dividing the load across

different remote agents.

The agents generate load on the application under test. The number of agents required depends on various factors
including the size of the load you want to put on the application under test, hardware capacity of systems that install
the agents, and the application under test itself.
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Installing
Agent

Adding remote Setting the
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Creating a

VU Schedule R — Creating a
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status
Adding a test

Defining
requirements
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Enabling
RM Service

Playing back
a schedule

Evaluating I Publishing
result results to server

. Installing HCL OneTest Performance on page 72

. Creating a VU Schedule on page 510

. Defining requirements in schedules on page 544

. Enablement of Resource Monitoring services for a schedule on page 556
. Running a local schedule or test on page 594

. Evaluating results in web analytic reports on page 744

. Publishing test results to the server on page 747

. Running a user group at a remote location on page 524

. Checking the status of agents on page 539

. Setting user loads on page 513
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Task flow: Recording a SAP test

The task flow shows the recording of interactions with the SAP GUI client to generate a SAP test.

The recording wizard opens the SAP GUI client and records all the interactions that occur between the client and the
server. You can record a SAP test by using the HTTP SAP Portal option to measure the performance of a SAP Portal
from a web interface. After you complete SAP recording or HTTP recording session with SAP portal, you must play
it back and fix the errors, if any. You can add other HCL OneTest™ Performance elements such as data correlation,
verification points, and loops and playback the test again to evaluate the results.

21
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Note: If a test is not behaving as expected during playback, you must ensure that the connection to the SAP

server is available. For more information, see SAP connection details on page 1178.

Recording a Recording a session
SAP test with HTTP SAP portal
Playing back
tests

Adding data
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pEl"fomEﬂCE test —_—  Adding verification
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1 Adding a loop
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tests
SAP performance
f result
Evaluating
results
SAP functional
report

. Recording a SAP test on page 185

. Recording a session with HTTP SAP Portal on page 188
. Running a local schedule or test on page 594

. Running a local schedule or test on page 594

. Evaluating results in web analytic reports on page 744

. Correlating response and request data on page 429

. Verifying application behavior on page 323

. Adding a loop to a test on page 371
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. SAP Performance report on page 801
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Task flow: Recording a service test to test an SOA application

The task flow shows the testing services in an SOA environment. You can record a test session by invoking service
calls by using a generic service client or an existing client.

To test the performance of an SOA application, you must record a service call and create a service test. After you
complete the service test recording, play it back and fix the errors, if any. You can edit your service test to include
verification points, data correlations, loops, and play back the test again to evaluate the results.
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. Recording service tests on page 211

. Running a local schedule or test on page 594

. Running a local schedule or test on page 594

. Correlating response and request data on page 429
. Verifying application behavior on page 323

. Adding a loop to a test on page 371

. Web service reports on page 809
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. Generating functional test reports on page 746
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Task flow: Recording a SAP batch input test

The task flow shows the recording of certain SAP transaction sessions from SAP GUI with SAP batch input tests
recording wizard. When you record a session, the recording wizard automatically starts a SAP GUI interface and
records the transaction that you specified. Typically, you use batch input tests in a schedule mixed with normal SAP
performance tests to increase the load on the server.

After you complete the recording, the wizard generated a SAP batch input test in HCL OneTest™ Performance. You
can then play it back again to fix the errors, if any.

Note:

* You must perform the recording of certain SAP transaction sessions from SAP GUI. For more
information, see Recording a SAP batch input test on page 191.

- If a test is not behaving as expected during playback, you must ensure that the connection to the SAP
server is available. For more information, see SAP connection details on page 1178.

Later, you can add the other HCL OneTest™ Performance elements such as data correlation, verification points, loops,

transactions, and custom codes to test and playback the test to evaluate the results.
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Task flow Integrating HCL OneTest™ Performance and HCL OneTest™ API

You can execute integration tests in HCL OneTest™ Performance by using HCL OneTest™ Performance Extension for
HCL OneTest™ API. In HCL OneTest™ Performance, you can create a compound test to run the integration tests by
using agents.

To integrate tests, you must install HCL OneTest™ Performance Extension for HCL OneTest™ API. Also, to execute the
tests remotely, you must install HCL OneTest™ Performance Agent and HCL OneTest™ API Agent.

After installing all the required software, you must set the environment variable and connect to the integration project.
To open the HCL OneTest™ API project from HCL OneTest™ Performance Test Navigator, you must set the path to the
execution file in the HOT-API Integration preferences. Later, you must create a compound test and play back the test

to evaluate the results.
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Task flow: Response time breakdown

To collect Response Time Breakdown data, you must follow a workflow that includes installing and configuring
Data Collection Infrastructure, enabling Response Time Breakdown for a schedule, running a schedule, and viewing
Response Time Breakdown reports.
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. Running a local schedule or test on page 594

. Viewing response time breakdown on page 767
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Task flow: Rate Scheduler

The task flow shows running a rate scheduler to monitor the workload at the desired rate (transactions per second).
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After installing HCL OneTest™ Performance agent, you must create a rate scheduler by adding elements such as rate
runner group, tests, user load, and checking the agent status. Then, you must define the performance requirements
for a schedule to specify the acceptable thresholds to validate the service-level agreements. Later, you must enable

the resource monitoring service and play back the scheduler to evaluate the results.
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Product overview

You can gain the conceptual understanding of the product and its test extensions with these topics.

HTTP performance testing overview

There are five stages when performance testing HTTP applications: test creation, test editing, workload emulation

with schedules, schedule execution, and evaluation of results.

- Test creation. Although it is possible to write a test from scratch, you generally create HTTP performance
tests by recording representative interactions with an application. These actions are saved and a test is
generated from these recorded actions. Test recording and related tasks are explained in Recording HTTP
tests on page 155.

- Test editing. After recording a test, run it individually and inspect the results to make sure that the HTTP tests
are doing what you expect. You might want to edit your tests. Typical changes that you might make are:

> Replacing a value in a recorded test with values in a dataset. This produces more realistic test data.
Providing tests with variable data (datasets) on page explains how to use datasets to replace
data.

> Adding dynamic data to a test (referred to as data correlation). Data correlation, including how to
manually correlate test values, is explained in Correlating response and request data on page

> Enabling verification points, so that you can determine whether an expected behavior occurred.
Verification points are explained in Verifying expected behavior on page 276.

- Workload emulation with schedules. After editing HTTP tests, you create a schedule. You add user groups
to the schedule and add appropriate tests to each group to emulate a task. A typical schedule contains the
following:

> User groups and tests. A schedule requires at least these items to run.

= User groups running from a remote location. This separates your workbench activity and your load-
adding activity. For more information, see Running a user group at a remote location on page 524.

- Optional schedule items, such as loops, delays, and think time behavior settings, to further emulate a
load. For more information, see Emulating workloads on page 508.

« Schedule execution. You typically run a schedule as explained in Running a local schedule or test on
page 594.

- Evaluation of results. Reports are displayed during the schedule run. You can also regenerate reports after the
run, customize reports, and export reports in HTML format, so that others who do not have the product can

see them.

SAP performance testing overview

With HCL OneTest™ Performance Extension for SAP Solutions, you can test the performance of SAP applications.
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Informative performance test results rely upon sound test development. Each of the following stages contributes to

generating meaningful results when performance testing SAP applications:
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« Test creation. You create your test by recording a session with the SAP GUI client. Typically, the recorded
session starts when you log on to the SAP server. You then interact with the application in order to produce
a relevant performance test, and the session ends when you log out. The recorded session is split into
transactions and SAP screens. Response time measurements and verification points are automatically added
to transactions and SAP screens.

- Test editing. After recording, you can edit the events in each transaction and SAP screen. With the SAP
Protocol Data view, you can use snapshots of the SAP screen to edit the events. You can replace recorded test
values with variable test data, or add dynamic data to SAP tests. You can also set verification points on field
values or window titles to validate that the test behaved as expected.

- Test validation. Before deploying the test, you can run the test manually as a single virtual user to make sure
that the test runs smoothly and produces the expected results in a nominal environment with minimal server
load. You can experience multiple test editing and validation cycles before your test is robust.

- Workload emulation with schedules. When the test runs repeatedly as anticipated, you specify an execution
schedule and user groups to emulate a workload that is generated by a large number virtual users. You can
add SAP batch input tests to the schedule to simulate a heavy load on the servers while minimizing virtual
tester resources.

« Schedule execution. You run the schedule, deploying test execution over virtual users that can be hosted on
remote hosts. Each virtual user runs an instance of the SAP GUI client. Response time results are provided by
the SAP server and recorded. Verification points are checked and results are recorded.

- Evaluation of results. You evaluate the results produced by the SAP performance tests through the various

reports that are generated during execution. You can also design custom reports.

Citrix performance testing overview

HCL OneTest™ Performance Extension for Citrix Presentation Server allows you to test the performance of Citrix

applications.

Informative performance test results rely upon sound test development. Each of the following stages contributes to

generating meaningful test results:

- Test creation. You create your test by recording a session with the Citrix XenApp client. Typically, the recorded
session starts when you log in to the Citrix server. You then interact with the application to produce a relevant
performance test. The session ends when you log out. The recording is split into window events and contains
keyboard and mouse interactions with the Citrix server. You can use the Citrix Recording Control window to
add screen captures or comments. You can add image synchronizations to help the test remain synchronized
with the server.

« Test editing. After recording, you can edit the events in each window element. Because the recorded input is
primarily made of low-level keyboard and mouse input, you can streamline the test by, for example, replacing
key-press events with string inputs. You can use the comments and recorded screen captures to make
navigating through the test easier. You can replace recorded test values with variable test data, or add
dynamic data to the test. You can also set verification points on window titles or image synchronizations to

validate that the application behaves as expected.
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- Test validation. Before deploying the test, you can run the test manually as a single virtual user to make
sure that the test synchronizes user input actions and server output correctly in a nominal environment with
minimal server load. You might experience multiple test editing and validation cycles before your test runs as
expected.

- Workload emulation with schedules. When the test runs repeatedly as anticipated, you specify an execution
schedule and user groups to emulate a workload that is generated by a large number of virtual users.

« Schedule execution. You run the schedule, deploying test execution over virtual users that can be hosted on
remote hosts. Each virtual user runs an instance of the Citrix client.

- Evaluation of results. You evaluate the results produced by the tests through the various reports that are

generated during execution. You can also design custom reports.

Prerequisites

Before you can test the performance of Citrix applications, a Citrix XenApp client must be installed on the same
computer as HCL OneTest™ Performance. The Citrix XenApp client is required for recording and execution of

performance tests.
Ensure that you have a working Citrix client environment and that you can connect to a Citrix server. .

If you are deploying tests over remote computers to emulate a large number of users, the following software must be
installed on each remote computer:

« The Citrix XenApp client
» The HCL OneTest™ Performance Agent

Limitations

Citrix performance tests use window creation and change events, and optionally image recognition techniques,

to synchronize user input with server output. Before you record a session with a Citrix application, the behavior of

that application must be perfectly reproducible. Specifically, the application must always create windows and GUI
elements at the same locations and in the same sequence. Mouse or keyboard events must always produce the same

output. Consider these examples:

« If the application displays windows or dialog boxes on only the first execution of a particular program or
feature, such as tips or security warnings, ensure that they are disabled when you record the test. Any
windows or dialog boxes that were recorded but are not displayed on subsequent executions, or displayed at
different coordinates on the screen, will fail the test and cause synchronization timeouts.

« If you save a file during a recorded session, the application might issue a warning for an existing filename
when you replay the tests. If the warning was not in the recorded session, this will fail the test and cause

errors.

It is essential to be aware of the context of user actions when you edit a test. Because the Citrix performance tests

interact with the Citrix XenApp client at a very low level (mouse movements and key presses) any changes that you

34



Chapter 2. Getting Started

make to the test after the recording, such as moving test elements, adding loops or conditions, or inserting new

sequences, can alter the context of the emulated user actions and cause synchronization timeouts.

Service testing overview

The service testing capabilities of HCL OneTest™ Performance automate the creation, execution and analysis of
functional, regression and performance tests for SOAP-based web services, including support for Java Messagine
Service (JMS), Websphere MQ, WebSphere Java MQ, and Microsoft .NET Windows Communication Foundation
(WCF), as well as any service that produces XML, plain text, or binary data.

Informative test results rely upon sound test development. Each of the following stages contributes to generating
meaningful test results:

- Preparation. Set up your test environment with the libraries and configuration files required for SOAP-based
web services or custom security algorithms. You can import Web Service Description Language (WSDL)
definition files and digital certificates that are required by the web services to automatically generate your
tests. You can create SOAP security profiles with security algorithms for the web service calls and message

returns.

Test creation: Create your test by recording the service requests and responses either with the generic
service client, or with an existing client or a web browser through a recording proxy. When you start the
recording, you interact with the service by performing service requests and receiving responses. You can also

create service tests manually or from a synchronous Business Process Execution Language (BPEL) model.

Test editing: After recording, you can edit the requests and responses in the test. You can use XML Schema
Description (XSD) documents to facilitate XML edition. You can replace recorded test values with variable test

data, or add dynamic data to the test.

Functional testing: You can run the test to ensure that service matches the expected behavior defined in
verification points. During the run, each verification point is checked and receives a pass, fail or inconclusive
status.

Performance testing: If you are using HCL OneTest™ Performance, you can specify an execution schedule
and user groups to emulate a workload that is generated by a large number of virtual users. Then, you can run
the schedule, deploying test execution on virtual users that can be hosted on remote computers. Each virtual
user runs an instance of the test client. Response times are measured and recorded. Verification points are
checked and recorded.

Stub simulation: Service stubs are functional simulations of an existing service. Service stubs are useful for
replacing a service that is unavailable or impractical to use in a test environment. They can also be used to
input specific data into a service under test or for prototyping. You can deploy stubs onto a stub server, which

can replace the actual server in your test or development environment.

Evaluation of results: You evaluate the results that the tests produce through the performance and verification
point reports that are generated during execution. You can also design custom reports by manipulating
various counters. Functional reports provide a comprehensive view of the behavior of the service under test.

Reports can be exported and archived for validation.
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Service testing tools

The following tools are available in the product:

- The generic service client enables you to manually perform service requests for a wide variety of transport
protocols, authentication configurations and security profiles, making it an extremely versatile service client.
It effectively replaces a dedicated client and can be used to record service calls or for manual testing and
debugging a service during development. To open the generic service client, click the Generic Service Client
[ toolbar button.

The WSDL security editor allows you to set up sophisticated algorithm stacks for your service requests

and responses. Algorithm stacks contain digital certificate information and the security algorithms that
are applied to messages to perform secure communication with a web service. Algorithm stacks are made
of blocks, which can be key definitions, encryption , time stamp, or signature operations which can be
associated with any operation in the WSDL file. To open the WSDL security editor, right-click a WSDL file in

your workspace and select Edit WSDL Security or click the WSDL Security Editor “:= button in the generic

service client..

.

The test editor is where you develop your test. After recording, you can modify the test to add data correlation
or verification points. You can also add loops and conditions and you can edit every detail of the service

requests.

The stub editor enables you to create service stubs. With the stub editor, you can define multiple input
conditions, which are similar to verification points. Each condition triggers a predefined simulated response,

which is functionally identical to a response from the simulated service.

In HCL OneTest™ Performance, the schedule editor lets you deploy multiple virtual users on local and remote
computers to generate a heavy load for performance testing. A schedule typically contains multiple tests and

multiple virtual users.

Generic service client overview

The purpose of the generic service client is to send requests to any service that uses an HTTP, JMS, WebSphere®
MQ, or Microsoft™ .NET transport. The generic service client also displays the response returned by the service.

The generic service client is useful for debugging or testing a service when you do not have access to a dedicated
client to send the request. You can set up a large variety of transport and security configurations for the service, edit

the parameters of the request and send attachments.

When a request is successfully invoked, its message return is added to the Request History. You can use this feature

to look back at results that were produced at different times.

If you are using HCL OneTest™ Performance, you can select requests in the Request History and click Generate Test
to generate a test that will replay all the selected requests. You can edit the test to replace recorded test values with
variable test data, or add dynamic data correlation to the test. You can also set verification points on the contents of

the XML documents in the service response.
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Supported services

The generic service client enables you to send requests for many types of services that use the following transport

protocols:

« HTTP
« Java™ Message Service (JMS), including JBoss and WebSphere® implementations
» WebSphere® MQ

* Microsoft™ .NET Framework Windows™ Communication Foundation (WCF).
Note: If you are using IBM® Security AppScan®, only the HTTP transport protocol is supported.

Encryption and security

The Java™ Runtime Environment (JRE) that the product uses must support the level of encryption required by the
digital certificate that you select. For example, you cannot use a digital certificate that requires 256-bit encryption with
a JRE that supports only 128-bit encryption. By default, the product is configured with restricted or limited strength
ciphers. To use less restricted encryption algorithms, you must download and apply the unlimited jurisdiction policy

files (| ocal _policy.jar and US_export_policy.jar).

For Oracle Java, download the files from this site:http://www.oracle.com/technetwork/java/javase/downloads/jce8-
download-2133166.html.

Before installing these policy files, back up the existing policy files in case you want to restore the original files later.

Then overwrite the filesin/jre/li b/ security/ directory with the unlimited jurisdiction policy files.

SSL Authentication

Service tests support simple or double SSL authentication mechanisms:

« Simple authentication (server authentication): In this case, the test client needs to determine whether the
service can be trusted. You do not need to setup a key store. If you select the Always trust option, you do not

need to provide a server certificat key store.

If you want to really authenticate the service, you can configure an certificate trust store, which contains the

certificates of trusted services. In this case, the test will expect to receive a valid certificate.

« Double authentication (client and server authentication): In this case, the service needs to authenticate the
test client according to its root authority. You must provide the client certificate keystore that needs to be

produced to authenticate the test as a certified client.

When recording a service test through a proxy, the recording proxy sits between the service and the client. In this
case, you must configure the SSL settings of the recording proxy to authenticate itself as the actual service to the
client (for simple authentication), and as the client to the service (for double authentication). This means that you

must supply the recording proxy with the adequate certificates.
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When using stub services, you can also configure the SSL settings of the stub service to authenticate itself as the

actual server. This means that you must supply the service stub with the adequate certificate.

NTLM and Kerberos Authentication

The product supports Microsoft™ NT LAN Manager (NTLMv1 and NTLMv2) and Kerberos authentication. The
authentication information is recorded as part of the test during the recording phase.

To enable NTLMv2 support, you must add a third party library to the workbench. For more information, see
Configuring the workbench for NTLMv2 authentication on page 485.

Digital certificates

You can test services with digital certificates for both SSL and SOAP security protocol. Digital certificates must be
contained in Java™ Key Store (JKS) keystore resources that are accessible in the workspace. When dealing with
keystore files, you must set the password required to access the keys both in the security editor and the test editor.
For SOAP security you might have to provide an explicit name for the key and provide a password to access the
private keys in the keystore.

Limitations
Arrays are not supported.

Because of a lack of specification, attachments are not supported with the Java™ Message Service (JMS) transport.

The envelope is directly sent using UTF-8 encoding.

All security algorithms are not always available for every Java™ Runtime Environment (JRE) implementation. If a
particular security implementation is not available, add the required libraries to the class path of the JRE that this

product uses.

The Microsoft™ .NET transport protocol does not support transactions, scopes, or duplex mode requests such as

callbacks or two-way services based on the MS-MQ transport.

Socket API performance testing overview

With HCL OneTest™ Performance Extension for Socket Protocols, you can test the performance of any application

that uses a TCP/IP socket-based protocol.

Informative performance test results rely upon sound test development. Each of the following stages contributes to

the generation of meaningful test results:

- Test creation. You create your test by recording a session with a client application. Typically, the recorded
session starts when you run the client application. You then interact with the application in order to produce
relevant network traffic, and the session ends when you close the application or end the recording. The
recording is used to generate a performance test that reproduces the behavior of the client application.

- Test editing. After recording, you can edit the events that were recorded. You can replace recorded test values
with variable test data or add dynamic data to the test.
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- Test validation. Before deploying the test, you can run the test manually as a single virtual user to make sure
that the test runs smoothly and produces the expected results in a nominal environment with minimal server
load. You might experience multiple test editing and validation cycles before your test runs as expected.

» Workload emulation with schedules. When the test runs repeatedly as anticipated, you specify an execution
schedule and user groups to emulate a workload that a large number of virtual users generates.

» Schedule execution. You run the schedule, deploying test execution over virtual users that can be hosted on
remote hosts. Each virtual user runs an instance of the test. Response time results are collected.

- Evaluation of results. You evaluate the results produced by the tests through the various reports that are

generated during execution. You can also design custom reports.

TN3270 performance testing overview

With HCL OneTest™ Performance Extension for Socket Protocols, you can test the performance of TN3270 terminal

server applications.

Informative performance test results rely on sound test development. Each of these stages contributes to the

generation of meaningful test results:

- Test creation. You create a test by recording a session with a client application. Typically, the recorded
session starts when you run the TN3270 terminal client. You then interact with the application in order to
produce relevant network traffic. The session ends when you close the terminal client or end the recording.
The recording is used to generate a performance test that reproduces the behavior of the client application.

- Test editing. After recording, you can edit the recorded events. You can replace recorded test values with
variable test data or add dynamic data to the test.

« Test validation. Before deploying the test, you can run the test manually as a single virtual user to make sure
that the test runs smoothly and produces the expected results in a nominal environment with minimal server
load. You might complete multiple test editing and validation cycles before your test is robust.

« Workload emulation with schedules. When the test runs repeatedly as anticipated, you specify an execution
schedule and user groups to emulate a workload that a large number of virtual users generates.

» Schedule execution. You run the schedule, deploying test execution over virtual users that can be hosted on
remote hosts. Each virtual user runs an instance of the test. Response time results are collected.

- Evaluation of results. You evaluate the results that the tests produce through the various reports that are

generated during execution. You can also design custom reports.

Rational® Quality Manager overview

IBM® Rational® Quality Manager is a collaborative, web-based, quality management solution that offers

comprehensive test planning, manual testing, and integration with other test tools.

Quality Manager is based on the IBM® Rational® Jazz™ platform (http://jazz.net and http://www.ibm.com/software/
rational/jazz/) and inherits many characteristics from that platform. Rational® Quality Manager is designed to be
used by test teams of all sizes and supports a variety of user roles, such as test manager, test architect, test lead,

tester, and lab manager, as well as roles outside the test organization.
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Comprehensive test planning

A test plan that you define in Rational® Quality Manager drives activity for distributed teams through all phases of
the project life cycle. The test plan defines the objectives and scope of the test effort and contains criteria to help

teams determine the answer to the question "Are we ready to release?"

The test plan can be configured to meet the needs of your organization. You can use the test plan to do any and all of

the following tasks:

- Define business and test objectives

« Establish a review and approval process for the test plan and for individual test cases

» Manage project requirements and test cases and establish the interdependencies between the two
- Estimate the size of the test effort

« Define the schedule for each test iteration and track the dates of other important test activities

« List the various environments to be tested and generate test configurations

- Create a read-only snapshot of the test plan at a particular point in time

- Define quality goals, entrance criteria, and exit criteria

« Create and manage test cases

Test script construction, execution, and reuse

Rational® Quality Manager provides a full-featured manual test editor. You can also import manual test scripts
from IBM® Rational® Manual Tester. You can add reuse and automation capabilities to your manual tests by using

keywords.

With Rational® Quality Manager, you can manage and execute test scripts that are created with tools such as HCL
OneTest™ Performance, IBM® Rational® Service Tester for SOA Quality, and IBM® Security AppScan® Tester Edition.

You can also import test artifacts from external test management solutions, such as IBM® Rational® ClearQuest®

Test Manager and IBM® Rational® TestManager.

Test analysis and reporting

Rational® Quality Manager includes several standard test reports to help you evaluate test results. Reports are
available during all phases of the test process.

You can use reports to perform these tasks:

« Determine the validity of a test run.

- Check feature coverage against test plans, test inputs, configurations, and so on. This can also be used to
measure test progress and to analyze trends.

« Run a gap analysis to measure the resources needed to do your testing versus the resources that are available
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Team collaboration

Rational® Quality Manager makes it easy to share information with other members of your team. With the Jazz-
based work-item system, team members can assign tasks and defects to each other and to view everyone's status.
Test plan authors and test case designers can distribute their work for review and track the status of each reviewer.
New and changed requirements are visible to the team, as are the test cases that are needed to satisfy those
requirements. Team members are notified automatically of any changes and milestones that impact their work.

Lab management

With Rational® Quality Manager lab management capabilities, you can create requests for the test environments that
your test plan specifies. You can then work with the lab manager to ensure that lab resources and test environments
are available when needed. Lab managers can track all lab resources from a centralized resource repository and fulfill

requests from the test team.

Web application security

Rational® Quality Manager helps IT and security professionals protect against the threat of attacks and security
breaches through its integration with IBM® Security AppScan® Tester Edition. Security testing for your web
applications can result in higher-quality, more secure applications at a reasonable cost.

Governance

Rational® Quality Manager helps ensure that your business processes comply with industry, corporate, and
departmental standards and regulations. Throughout the testing life cycle, Rational® Quality Manager provides

you with the tools to obtain an up-to-the-minute measurement of software quality and project metrics. With its
comprehensive test plan and integration with requirements management and defect tracking tools, Rational® Quality

Manager helps streamline your test strategy and produce reliable records of test results and project history.

Streamlined Eclipse and full Eclipse overview

When you work in the streamlined Eclipse mode, only those functions that are directly related to the product are
enabled in the workbench. When you install the product, by default, the check box to use the streamlined Eclipse

mode is selected. With the full Eclipse mode, you have access to all Eclipse functions.

The streamlined Eclipse mode disables options from the menus that are not typically used during testing. Both the
fully-enabled and streamlined Eclipse modes can operate using the same workspace, so if you start the product in
the streamlined mode and discover that you cannot accomplish all of your tasks, you can close the workbench and
restart it in the full Eclipse mode.

The choice of the mode in which to start the product depends on the user's activity and objectives. The streamlined
mode is designed for straightforward testing and shows only those menu items that are related to testing. However,

this restricts functions. The following list includes use cases where the full Eclipse mode might be preferred:
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* You have multiple products installed and you want to use them in the same session.

- You are using the profiling and logging features. The profiling and logging view is not available in the
streamlined mode.

* You are using advanced features of custom code including debugging custom code. For more information on

custom code, see Extending test execution with custom code on page

Starting HCL OneTest™ Performance in full Eclipse mode

You can start the product in the full Eclipse mode to continue to use native Eclipse features along with HCL OneTest™

Performance.

Before you begin

You must have installed HCL OneTest™ Performance.

1. Click Start > HCL > HCL OneTest Performance - Full Eclipse.
2. Perform the following steps to select a working directory, if you are starting the installation of HCL OneTest™

Performance for the first time.
a. Enter the path of a working directory in the Workspace field or click Browse to select the directory.

b. Select Use this as the default and do not ask again to make this your default workspace.
You can change your workspace from HCL OneTest™ Performance by clicking File > Switch

Workspace.

3. Click OK.

Results
You have started HCL OneTest™ Performance in full Eclipse mode.

Starting HCL OneTest™ Performance in streamlined Eclipse mode

If you do not want to view native Eclipse Ul, you can start HCL OneTest™ Performance in streamlined mode.

Before you begin

You must have installed HCL OneTest™ Performance.

Note: To start HCL OneTest™ Performance in the streamlined mode, the streamlined mode must be installed

as an optional feature. It is automatically selected during the installation process.

1. Click Start > HCL.
2. Perform the following steps to select a working directory, if you are starting the installation of HCL OneTest™
Performance for the first time.
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a. Enter the path of a wor ki ng direct ory in the Workspace field or click Browse to select the directory.

b. Select Use this as the default and do not ask again to make this your default workspace.

You can change your workspace from HCL OneTest™ Performance by clicking File > Switch

Workspace.

3. Click OK.

Results
You have started HCL OneTest™ Performance in streamlined Eclipse mode.
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Chapter 3. Tutorials
This section contains the tutorials which explains the main features of HCL OneTest™ Performance.

You can find the following information:

» Performance test a Web application on page 44
- Performance test an SAP application on page 52

« Performance test a Citrix application on page 58

Performance test a Web application

The movies in this tutorial show you the main features of HCL OneTest™ Performance. The tutorial requires Flash
Player to view.

Learning objectives
You will learn how to perform the following tasks:

« Record user actions to create a test

« Create a schedule, which enables you to run multiple tests and control how they run
* Run the schedule

« Analyze the results from the schedule run

Time required
45 minutes

Introduction: Test a Web application

This tutorial is designed to introduce you to testing.

Learning objectives
The tutorial is divided into six modules, each with its own learning objectives. You will learn to:

« Record a user actions to create a test
- Create a schedule, which enables you to run multiple tests and control how they run.

 Analyze the results from the schedule run

Time required
This tutorial should take approximately 45 minutes to finish. If you explore other concepts related to this tutorial, it
could take longer to complete.

Skill level
Beginner
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Prerequisites
This tutorial assumes that you are familiar with using the perspectives and views in the IBM® Rational® Software
Delivery Platform.

Module 1: Creating projects and recording user actions

Learn how to create projects and record user actions for testing. The second part of this module will help you to build
an understanding of a recorded test.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

« Create a project
» Record a test of user interactions

» View a test in the test editor

Time required
This module requires approximately 8 minutes to complete.

Lesson 1.1: Recording a test

In this lesson, you will learn how to create a project and record user actions. Note that the server under test in this

Watch and Learn tutorial is not publicly available.

About this task

See video

Lesson 1.2: Understanding a recorded test

In this lesson, you will become familiar with your recorded test.
About this task

See video

Module 1 summary

In this tutorial module, you learned how to create projects and record user actions for testing

Lessons learned
By completing this module, you learned about the following concepts and tasks:

« Creating a project is the first step in testing
« Associating elements of the project, such as the tests, with the project
 Recording the actions of your users

- Identifying the components of a recorded test
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Related information

Recording HTTP tests on page 155

Editing HTTP tests on page 261

Module 2: Editing a test

See how to edit your recorded test to include variable data using datasets and verification points.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

- Enable a verification point
« Create a dataset

» Use a dataset in a test

Time required
This module requires approximately 8 minutes to complete.

Lesson 2.1: Enabling a verification point

In this lesson, you will learn how to add verification points to a test. Verification points check whether the expected
behavior actually occurs during a run.

About this task
See video

Lesson 2.2: Creating a dataset

In this lesson, you will learn how to create a dataset, which enables you to vary the values from what you recorded in
the test.

About this task

See video

Lesson 2.3: Using a dataset in a test

In this lesson, you will learn how to enable your test to use a dataset.
About this task

See video
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Module 2 summary

In this tutorial module, you learned how to use variable data to edit and manage testing situations.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

- Adding verification points to check whether an expected behavior occurs during a test run

- Enabling datasets to provide substitute variable data for the fixed values stored in the recorded test

« Importing data that is contained in a comma-separated-value (CSV) file

 Updating your test with a reference to the dataset so that the test can use variables from a dataset during a
run

Related information

Providing tests with variable data on page

Module 3: Validating a test with a single user

Watch a demonstration on running a single-user test for debugging and getting dataset values to work properly.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

« Run a test with a single user
« View the test log

Time required
This module requires approximately 5 minutes to complete.

Lesson 3.1: Running a test with a single user

In this lesson, you will learn how to run a test with a single user, to ensure that your test and the dataset values are
working properly.

About this task

See video

Lesson 3.2: Viewing the test log

In this lesson, you will learn how to open the test log and view a record of all the events that occurred during your test
run or schedule run.

About this task

47


../topics/tvardata.html
../topics/tvardata.html
../topics/tvardata.html
../topics/tvardata.html

48

HCL OneTest Performance

See video

Module 3 summary

In this tutorial module, you learned how to run a test with a single user and view the test log.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

« Viewing changes in the reports while the schedule is running
* Running a test locally with one user

 Running a schedule with a default launch configuration

Related information

Viewing test logs on page

Module 4: Representing workloads

View how to create schedules that represent a typical workload for your site.

Learning objectives
After completing the lessons in this module, you will understand how to do the following tasks and understand the

associated concepts:

« Create a schedule and add user groups

» Add loops to a schedule

- Add tests to a schedule

« Display your assets by type or in alphabetical order.

« Enable resource monitoring

Time required
This module requires approximately 10 minutes to complete.

Lesson 4.1: Controlling test execution with a schedule

In this lesson, you will learn how to control test execution by creating a schedule and adding user groups, loops, and

tests to the schedule. At the end of the lesson, you will learn how to display your assets in a logical order.
About this task
See video

Lesson 4.2: Enabling resource monitoring

In this lesson, you will learn how to enable resource monitoring in a schedule and to add data sources.
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About this task

See video

Module 4 summary

In this tutorial module, you learned how to represent a workload accurately by creating a schedule and adding user
groups, tests, and other elements to it.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

 Grouping tests in a logical order with user groups

- Adding a loop to a schedule to repeat a test for a number of iterations and set the test run rate
- Adding a test to a schedule to emulate accurately the actions of individual users

« Displaying your assets by type or in the default alphabetical order.

» Monitoring resources to capture system resource data, such as processor or memory usage

Related information

Emulating workloads on page 508

Monitoring resource data on page 556

Module 5: Running the test

Become familiar with configuring a schedule, running a schedule, and adding virtual users during a test run.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

« Configure and run the schedule
* View the report

 Add virtual users during a run

Time required
This module requires approximately 10 minutes to complete.

Lesson 5.1: Configuring the schedule

In this lesson, you will learn how to set up a schedule configuration, which controls where the execution results are
stored.

About this task

See video
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Lesson 5.2: Running the schedule and viewing the reports

In this lesson, you will learn how to run the schedule.
About this task

See video

Lesson 5.3: Adding virtual users during a run

In this lesson, you will learn how to increase the number of virtual users during a schedule run.
About this task

See video

Module 5 summary

In this tutorial module, you learned how to configure and run a schedule, and add virtual users to the schedule during

arun.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

- Specifying the name and location for your execution results by configuring the schedule
* Running a schedule and viewing the reports

« Increasing the number of virtual users in a schedule during the test run

Related information

Running schedules on page 594

Setting a launch configuration on page 607

Module 6: Evaluating results

Learn how to retrieve stored test results in reports, customize a report, and get detailed information on an event that

occurred in a test.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

 Review reports after the schedule has run
« View the verification report

» Customize and compare reports.
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Time required
This module requires approximately 5 minutes to complete.

Lesson 6.1: Viewing verification point status

In this lesson, you will learn how to view the status of the verification points that you set in the test.
About this task

See video

Lesson 6.2: Customizing and comparing reports

In this lesson, you will learn how to customize reports to investigate a specific performance problem in more detail
than that provided in the default reports. You will also learn how to compare two reports.

About this task

See video

Module 6 summary

In this tutorial module, you learned how to retrieve stored test results in reports, customize a report, and get detailed
information on an event that occurred in a test.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

« Evaluating the results that are generated dynamically during a run
 Regenerating the results for viewing and analysis after a run
« Customizing and comparing reports

Related information

Customizing reports on page 750

Summary

This tutorial has taught you the basics of Rational® Performance Tester. You have learned how this product provides
the following functions and features:

« Ease of recording
« A graphical test editor for programmers and nonprogrammers alike
« Datasets to supply realistic test data

- Real-time reporting of response time
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Lessons learned
After completing all of the modules, you should now be able to perform the following tasks:

- Create projects and record user actions

« Edit and manage variable data using datasets
« Represent workloads

 Run schedules

» View reports

» Add virtual users

« Retrieve reports from previous runs and customize them

Performance test an SAP application
The movies in this tutorial show you the main features of IBM® Rational® Performance Tester for testing

applications on SAP servers. The tutorial requires Flash Player to view.

Learning objectives
You will learn how to perform the following tasks:

» Record a test for SAP
« Create a multi-user schedule
« Analyze SAP test results

45 minutes

Introduction: Performance test SAP solutions

This tutorial introduces you to performance testing applications running on SAP servers.

Learning objectives
The tutorial is divided into six modules, each with its own learning objectives. You will learn to perform the following

tasks:

« Record an SAP test
» Create a multi-user schedule

» Analyze SAP test results

This tutorial requires approximately 45 minutes to finish. If you explore other concepts related to this tutorial, it might
take longer to complete.

Skill level
Beginner
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Prerequisites
To complete this tutorial, you need to be familiar with using the perspectives and views in IBM® Rational® Software
Development Platform, with SAP, and with the SAP GUI environment.

Module 1: Creating projects and recording user actions

In this module, you will learn how to create projects and record user actions for testing. The second part of this
module will help you understand a recorded test.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

« Create a test project
» Record a test of user interactions
« View a test in the test editor

This module requires approximately 8 minutes to complete.

Lesson 1.1: Recording an SAP test

In this lesson, learn how to create a test project and record user actions in the SAP GUI client.
About this task

The most convenient way to create a test in IBM® Rational® Performance Tester is to record an SAP session. The
recording contains SAP events that are transmitted between the SAP GUI client and SAP server.

For each SAP transaction, the recorder logs all the SAP events that occur in the SAP GUI and generates a test that can
reproduce the sequence of events in the SAP GUI.

For SAP recording tips, see SAP performance testing guidelines on page 182.

See video

Lesson 1.2: Understanding a recorded test

In this lesson, become familiar with your recorded test.

About this task

With the test editor, you can edit and view the elements that constitute your SAP performance test.

The left pane of the editor displays the structure of the test as a sequence of SAP transactions, which contain
the recorded SAP Set, Get, and Call events. You can add elements to this sequence, such as transactions, loops,
conditions, synchronization points, or comments. However, if you change the structure of the test, you must ensure

that the SAP Set events are always applicable to the situation on the SAP GUI screen.
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The right pane displays details about the current test element.

See video

Lesson 1.3: Creating an SAP batch input test

In this lesson, learn how record a batch input test for generating a load on the SAP server.
About this task

With SAP batch input tests, you can generate a load on the server without requiring that each virtual tester run the
SAP GUI client. For performance testing, this is particularly useful because the test computer can typically simulate a
much larger number of users with batch input virtual testers than with SAP GUI virtual testers.

However, SAP batch input tests cannot contain verification points and do not produce performance results by
themselves. Therefore, you typically use batch input tests in a schedule mixed with SAP GUI tests to increase the load
on the server. The actual test results are produced by the SAP GUI tests.

See video
Module 1T summary

In this module, you learned how to create projects and record user actions for testing.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

- Creating a project is the first step in performance testing

- Associating elements of the project, such as tests, with the project
- Recording the actions of your users in a test and a batch input test
« Identifying the components of a recorded test

Module 2: Editing an SAP test

In this module, you will see how to edit your recorded test to include variable data using datasets and verification
points.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

» Add a verification point
« Create a dataset
« Use a dataset in a test

This module requires approximately 8 minutes to complete.
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Lesson 2.1: Adding verification points

In this lesson, learn how to add verification points to check whether an expected behavior occurs during a run.
About this task

With verification points, you can verify the behavior of the SAP application during a test. For example, you can use
verification points to ensure that a particular transaction returns the expected result in any graphical element of the
SAP GUI screen. You can also use regular expressions and you can search for the occurrence of an expected string in

a list.

Each verification point returns a Pass, Fai | Or I nconcl usi ve verdict in the test log. You can view a summary of

verification point verdicts in the verification point report after running the test.

See video

Lesson 2.2: Creating and using datasets
In this lesson, learn how to create a dataset that can provide tests with variable data and how to enable your test to
use a dataset during a run.

About this task

Datasets provide tests with variable data during a run. When you record a test, you perform a sequence of steps
that you expect a typical user to perform. From the recording, a test is generated that exactly reproduces these
interactions. During a run, this test uses the same data that you used during recording. To vary the data in the test,
you use a dataset, which is typically a table that contains variable data. At run time, this variable data is substituted
for the data in the recorded test.

See video

Module 2 summary

In this module, you learned how to use variable data to edit and manage testing situations.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

« Adding verification points to check whether an expected behavior occurs during a test run

« Enabling datasets to provide substitute variable data for the fixed values stored in the recorded test

« Importing data that is contained in a comma-separated-value (CSV) file

- Updating your test with a reference to the dataset so that the test can use variables from a dataset during a

run

Module 3: Running tests

In this module, you will see how to create schedules that represent a typical workload for your SAP server.
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Learning objectives
After completing the lessons in this module, you will understand how to do the following tasks and understand the
associated concepts:

« Create a schedule and add user groups
« Add loops to a schedule

» Add tests to a schedule

This module requires approximately 10 minutes to complete.

Lesson 3.1: Running a single test and viewing the test log

In this lesson, learn how to validate a test by running it with a single user and viewing the results in the test log.
About this task

Before deploying a full emulated workload test with a schedule, ensure that your test runs adequately with a single
user. Developing a performance test often requires several iterations of editing the test and validating changes with a

single user run.

See video

Lesson 3.2: Creating a schedule and adding user groups

In this lesson, learn how to control test execution by creating a schedule and adding user groups.
About this task

A schedule can be as simple as one virtual user running one test, or as complicated as hundreds of virtual users in

different groups, each running different tests at different times.

A schedule is the "engine" that runs a test. You add user groups, tests, and other items to the schedule to emulate
a workload. However, schedules are much more than simple vehicles for running tests. For example, you can use a

schedule to control tests in the following ways:

- Group tests under user groups to emulate the actions of different types of users.
« Set the order in which tests run: sequentially, randomly, or in a weighted order.

« Set the number of times that each test runs.

* Run tests at a certain rate.

 Run tests for a certain time and increase or decrease virtual users during the run.

See video

Lesson 3.3: Running the schedule and viewing the performance report

In this lesson, learn how to run a schedule in a custom run configuration and to view the results in the SAP

performance report.
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About this task

After you have validated your individual tests and added them to a schedule, you are ready to deploy the schedule and
run the virtual users on remote computers. By using remote computers, you can multiply the number of virtual users

to simulate a real work load. During the run, you can monitor the behavior of each virtual user.
When the test is finished, you can view the performance report to help locate bottlenecks in your SAP environment.

See video

Module 3 summary

In this module, you learned how represent a workload accurately by creating a schedule and adding user groups,
tests, and other elements to it.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

 Grouping tests in a logical order with user groups
- Adding a test to a schedule to emulate accurately the actions of individual users

- Adding a loop to a schedule to repeat a test for a number of iterations and set the test run rate

Summary

This tutorial introduced you the basics of the Rational® Performance Tester Extension for SAP Solutions. You have

learned how this product provides the following functions and features:

- Ease of recording
« A graphical test editor for programmers and nonprogrammers alike
« Datasets to supply realistic test data

« Real-time reporting of response time

Lessons learned
After completing all of the modules, you can perform the following tasks:

- Create projects and record user actions

« Edit and manage variable data using datasets
 Represent workloads

* Run schedules

 View reports

 Add virtual users

* Retrieve reports from previous runs
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Resources

To learn more about using Rational® Performance Tester to test the performance of your SAP environment, visit

developerWorks®, IBM's resource for developers, at: http:/www.ibm.com/developerworks/

Performance test a Citrix application

The movies in this tutorial show you the main features of using IBM® Rational® Performance Tester for testing

applications running in a Citrix XenApp environment. The tutorial requires Flash Player to view.

Learning objectives
You will learn how to perform the following tasks:

» Record a test for Citrix
« Create a multi-user schedule
« Analyze Citrix test results

45 minutes

Introduction: Performance test Citrix applications

This tutorial is designed to introduce you to performance testing applications running on Citrix XenApp.

Learning objectives
The tutorial is divided into five modules, each with its own learning objectives. You will learn to perform the following

tasks:

» Record a Citrix test
« Create a multi-user schedule

 Analyze Citrix test results

This tutorial requires approximately 45 minutes to finish. If you explore other concepts related to this tutorial, it might
take longer to complete.

Skill level
Beginner

Prerequisites
To complete this tutorial, you need to be familiar with using the perspectives and views in the IBM® Rational®

Software Development Platform and with Citrix XenApp.

Module 1: Creating projects and recording user actions

In this module, you will learn how to create projects and record user actions for testing. The second part of this

module will help you to build an understanding of a recorded test.
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Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the

associated concepts:

« Create a project
» Record a test of user interactions

» View a test in the test editor

This module requires approximately 8 minutes to complete.

Lesson 1.1: Recording a Citrix performance test

In this lesson, you learn how to create a test project and record user actions in Citrix XenApp.
About this task

The most convenient way to create a new test in IBM® Rational® Performance Tester is to record a Citrix session.
The recording contains mouse and key strokes as user input actions and window events as responses from the Citrix

server.

Because of the way the recorder works, consider these issues during the recording:

- Set up your application so that all actions are repeatable. For example, turn off "tips of the day," ensure
thatanyfile already existswarnings are consistent, and avoid using dynamic menu items such as recent
documents.

« Ensure that mouse movements are clearly decomposed. The recorder does not record mouse wheel scrolls.

- Use specific Microsoft® Windows® accounts for performance testing that have limited potential for data loss

if there are errors or synchronization failures during the test run.

For more Citrix recording tips, see Citrix performance testing guidelines on page 195.

The recorder synchronizes user actions and window events automatically so that the generated test waits for a

window event before triggering the next user input. In some cases, however, you must manually add synchronizations.

For example, add synchronizations when screen updates do not result directly from a user action. These
synchronizations tell the test to wait for a specific window, text, or graphic to open on the screen before running the

next user input.

See video

Lesson 1.2: Understanding a recorded test
In this lesson, you become familiar with your recorded test.
About this task

With the test editor, you can edit and view the elements that constitute your Citrix performance test.

59



60

HCL OneTest Performance

The left pane of the editor displays the structure of the test as a sequence of input actions and window events. You
can add elements to this sequence, such as transactions, loops, conditions, synchronization points, and comments.
However, if you change the structure of the test, you must ensure that the input actions always apply to the context of
the actual Citrix screen.

The right pane displays details about the current test element.

See video
Module 1 summary

In this module, you learned how to create projects and record user actions for testing.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

- Creating a project is the first step in performance testing.
« Associating elements of the project, such as tests, with the project.
- Recording the actions of your users in a test.

- Identifying the components of a recorded test.

Module 2: Editing a Citrix performance test

In this module, you will see how to edit your recorded test to include verification points and response time

measurements.

Learning objectives
After completing the lessons in this module, you will know how to do the following tasks and understand the
associated concepts:

- Enable a verification point

» Create a response time measurement

This module requires approximately 8 minutes to complete.

Lesson 2.1: Enabling verification points

In this lesson, learn how to add verification points to check whether an expected behavior occurs during a run.
About this task

With verification points, you can test the behavior of the application during a test. For example, you can use
verification points to ensure that a particular window is displayed after a specific action or that a portion of the screen

graphically matches an expected bitmap.
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Each verification point returns a Pass, Fai I, Or I nconcl usi ve verdict in the test log. You can view a summary of

verification point verdicts in the verification point report after running the test.
In Citrix tests you can also use optical character recognition (OCR) on a screen capture to check for text content.

See video

Lesson 2.2: Creating a response time measurement
In this lesson, learn how to create a response time measurement that can record the time that the application spends
processing an event.

About this task

Response time measurements report how fast the application responds to a specific user input event. Typically,
response time measurements are automatically created between a user input action and the window event that
occurs immediately after.

In addition, you can manually add your own response time measurements, for example to record a global response

time that covers multiple window events.

See video

Module 2 summary

In this module, you learned how to use verification points and response time measurements to evaluate server
response.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

- Adding verification points to check whether an expected behavior occurs during a test run

- Setting up timers inside the test to measure response times

Module 3: Representing workloads

In this module, you will see how to create schedules that represent a typical workload for your Citrix server.

Learning objectives
After completing the lessons in this module, you will understand how to do the following tasks and understand the

associated concepts:

* Run individual validation tests

« Create a schedule and add user groups
» Add loops to a schedule

 Add tests to a schedule
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« Run schedules using a run configuration
- View results in the test log and the Citrix performance report

This module requires approximately 20 minutes to complete.

Lesson 3.1: Running a single test and viewing the test log

In this lesson, learn how to validate a test by running it with a single user and viewing the results in the test log.
About this task

Before you deploy a full emulated workload test with a schedule, ensure that your test runs adequately with a single
user. Developing a performance test often requires several iterations of editing the test and validating changes with a

single user run.

See video

Lesson 3.2: Creating a schedule and adding user groups

In this lesson, learn how to control test execution by creating a schedule and adding user groups.
About this task

A schedule can be as simple as one virtual user running one test, or as complicated as hundreds of virtual users in
different groups, each running different tests at different times.

A schedule is the "engine" that runs a test. You add user groups, tests, and other items to the schedule to emulate
a workload. However, schedules are much more than simple vehicles for running tests. For example, you can use a

schedule to control tests in the following ways:

- Group tests under user groups to emulate the actions of different types of users.
« Set the order in which tests run: sequentially, randomly, or in a weighted order.

« Set the number of times that each test runs.

* Run tests at a certain rate.

« Run tests for a certain time, and increase or decrease virtual users during the run

See video

Lesson 3.3: Running the schedule and viewing the performance report
In this lesson, learn how to run a schedule in a custom run configuration and to view the results in the performance
report.

About this task

After you have validated your individual tests and added them to a schedule, you are ready to deploy the schedule and
run the virtual users on remote computers. By using remote computers, you can multiply the number of virtual users
to simulate a real work load. During the run, you can monitor the behavior of each virtual user.
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When the test is finished, you can view the performance report to help locate bottlenecks in your Citrix environment.

See video

Module 3 summary

In this module, you learned how represent a workload accurately by creating a schedule and adding user groups,
tests, and other elements to it.

Lessons learned
By completing this module, you learned about the following concepts and tasks:

 Running a test locally with one user

« Viewing changes in the reports while the schedule is running

» Grouping tests in a logical order with user groups

- Adding a test to a schedule to emulate accurately the actions of individual users

- Adding a loop to a schedule to repeat a test for a number of iterations and set the test run rate
* Running a schedule with a default run configuration

Summary

This tutorial has taught you the basics of the Rational® Performance Tester Extension for Citrix Presentation Server.
You have learned how this product provides the following functions and features:

- Ease of recording
« A graphical test editor for programmers and nonprogrammers
« Real-time reporting of response time

Lessons learned
After completing all of the modules, you can now perform the following tasks:

- Create projects and record user actions
 Represent workloads

* Run schedules

 View reports

 Add virtual users

* Retrieve reports from previous runs

Resources

To learn more about using performance tests on your Citrix environment, visit developerWorks®, IBM's resource for

developers, at: http://www.ibm.com/developerworks/
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This section describes about the sample project which can be used with HCL OneTest™ Performance to test the

functionality of an application.

Installation tuning tests for WebSphere® Application Server

The installation tuning tests were created to quickly and conveniently apply load to an application server for the
purpose of tuning the application server for maximum throughput. The three tests that are provided stress various

parts of the application server.
Time required to import sample project: 5 minutes

The installation tuning tests are designed to test IBM® WebSphere® Application Server Version 7. Each test has
different requirements that must be met before you run the test.

» The Schedule_Snoop test is ready to use with any WebSphere® Application Server installation.

» The "Schedule_Plants: PlantsByWebSphere" sample application must be installed. The sample application is
provided with WebSphere® Application Server, but its installation is optional.

« The Schedule_Daytrader test application is freely available from the Apache project Geronimo. Daytrader

requires access to an IBM DB2 database.

Best results can be achieved for all tests by using one or more separate, dedicated computers to provide the greatest
possible loads on the application server. When testing a large WebSphere® Application Server application, a single
computer that runs HCL OneTest™ Performance and provides a load on the application might not provide sufficient

stress to test the application.

An installation tuning test is designed to stress your application server to achieve maximum throughput from
basic tuning. Tuning is a complex procedure with many possible adjustments available according to the varying
requirements of the application that you plan to run. For more information on tuning WebSphere® Application Server,

see http://www.ibm.com/developerworks/websphere/techjournal/0909_blythe/0909_blythe.html.

A simple goal when you run the installation tuning tests is to achieve the highest percentage of CPU utilization on the

application server while the test runs. Follow these guidelines as you run each test:

» Use Task Manager, vmstat, or a similar tool to observe CPU utilization on the computer that runs the
application server. With maximum throughput as a goal, you work to achieve the highest CPU percentage
possible. To achieve maximum throughput, this number must increase as you make tuning adjustments.

« Monitor the CPU utilization of the computer that runs HCL OneTest™ Performance. If CPU utilization exceeds
70%, you might be approaching the limits of what that computer can provide. However, HCL OneTest™
Performance supports using multiple computers to achieve an even greater load.

- Because these tests provide high throughput, the tests might exceed the capabilities of your network. A tool
such as Task Manager can show network utilization. If you are limited by a 100 Mbps network, access to a
1000 Mbps network might be required to fully stress the application server.
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Related information

Installing the assets for tuning tests on page 65
Testing with the Snoop test on page 65
Testing the Daytrader application on page 66

Testing the PlantsByWebSphere application on page 65

Installing the assets for tuning tests

HCL OneTest™ Performance provides Installation Tuning Tests for WebSphere Application Server as a sample project

that you can import into your workspace.

1. Right-click on Installation Tuning Tests for WebSphere Application Server and save the sample project.

Note: After saving, import the sample project in Eclipse. To import the sample, click File > Import >
Existing projects into workspace > Select archive file and select the downloaded sample project file.

2. Click Finish. If you are asked to switch to the Performance Test Perspective, click Yes.

What to do next
Expand the sample in the Test Navigator view to open the project and explore the resources and reports.

Testing with the Snoop test

The Snoop test stresses the servlet engine of IBM® WebSphere® Application Server.

Snoop is an application that is provided with all WebSphere® Application Server installations. This exercises only a
small, direct portion of the application server. The Plants test is more complex than the Snoop test.

1. Select Snoop in the Test Project to open it in the editor.

2. Open Test Variables.

3. In hostname enter the name of the WebSphere® Application Server to stress test.
4. Select Schedule_Snoop in the Test Project to open the test in the editor.

5. Click Run to start the test. The test runs for approximately 5 minutes.
Testing the PlantsByWebSphere application
The Plants test provides load using the PlantsByWebSphere application.

This application is provided with IBM® WebSphere® Application Server, but it must by installed. Use the WebSphere
Administrative console to ensure that the PlantsByWebSphere application is installed and running.

The Plants test is more complex than the Snoop test, because the test exercises more parts of the application server.
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1. Select Plants in the Test Project to open the test in the editor.

2. Open Test Variables.

3. In hostname enter the name of the WebSphere® Application Server to stress test.
4. Select Schedule_Plants in the Test Project to open it in the editor.

5. Click Run to start the test. The test runs for approximately 5 minutes.

Testing the Daytrader application

The Daytrader test provides a load using the Daytrader application.

This application is available at http://geronimo.apache.org/GMOxDOC30/daytrader-a-more-complex-application.html.

1. Click Daytrader in the Test Project to open the application in the editor.

2. Open the Test Variables.

3. Change the hostname variable to the name of the IBM® WebSphere® Application Server to stress test.
4. Select Schedule_Daytrader in the Test Project to open the schedule in the editor.

5. Click Run to start the test. The test runs for approximately 5 minutes.

On the Daytrader application configuration page, you can change the configuration from Enterprise JavaBeans (EJB)
to Java Database Connectivity (JDBC). Run the Daytrader test in both modes to obtain the widest possible coverage.


http://geronimo.apache.org/GMOxDOC30/daytrader-a-more-complex-application.html

Chapter 5. Administrator Guide

This guide describes how to install HCL OneTest™ Performance. After you install the product, you can perform
administration tasks such as license configuration and integration with other products. This guide is intended for

administrators.

Installation of HCL OneTest™ Performance

Installing the product involves verifying requirements, planning, managing licenses, and configuring web-based help.

This section lists all such topics.

This installation guide covers two independent products: HCL OneTest™ Performance and the HCL OneTest™
Performance Agent. The HCL OneTest™ Performance Agent is a tool that you use with HCL OneTest™ Performance. It

is included as part of the HCL OneTest™ Performance product kit.

HCL OneTest™ Performance Agent consists of two capabilities:

 Generate load for the application under test by using the virtual users. You can increase the load generation

capacity by installing additional agents on remote computers.

- Gather data for the Response Time Breakdown feature and in support of the startup and control of web

services stubs in the SOA protocol.

Note: The HCL OneTest™ Performance and HCL OneTest™ Performance Agent are separate offerings and
must be installed separately.

Installation requirements

Installation requires the correct hardware, software, server environment, operating systems, and user privileges for

installing and running your software.

Hardware and Software requirements

Before you install the product, verify that your system meets the hardware and software requirements.

User privileges requirements

You must have a user ID that meets the following requirements to install HCL OneTest™ Performance and HCL

OneTest™ Performance Agent.

Notes:
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« Your user ID must not contain double-byte characters.
 For Windows operating system, you must have a user ID that belongs to the Administrators group.

« For Linux operating system, you must be able to log in as root.

Installation conventions and terminology
Understanding these terms and conventions can help you take full advantage of the installation information and your

product.

The following conventions are used in this installation information:

 The default installation directory is written as C:\installation_directory\product\inst.file.

- The default log location for installation information is C:\log_file_dir\log.txt.

These terms are used in the installation topics.
Installation directory
The location of product artifacts after the package is installed.
Package

An installable unit of a software product. Software product packages are separately installable units
that can operate independently from other packages of that software product.

Package group

A package group is a directory in which different product packages share resources with other
packages in the same group. When you install a package using Installation Manager, you can create

a new package group or install the packages into an existing package group. Eclipse-based packages
installed in the same package group are able to use the shell-sharing features of Eclipse. Some
packages cannot share a package group, in which case the option to use an existing package group is

unavailable.
Repository

A storage area for installable software packages. A repository can be disc media, a folder on a local

hard disk, or a server or web location.
Shared directory

In some instances, product packages can share resources. These resources are located in a directory

that the packages share.

Installation Manager overview

Installation Manager is a program for installing, updating, and modifying packages. It helps you to manage the
applications or packages that it installs on your computer. Installation Manager also helps you to keep track of what
you have installed, determine what is available for you to install, and to organize installation directories.
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Installation Manager provides features that help you keep packages up to date, modify packages, manage the
licenses for your packages, and uninstall packages.

Installation Manager includes six wizards that make it easy to maintain packages:

- The Install wizard walks you through the installation process. You can install a package by simply accepting
the defaults or you can modify the default settings to create a custom installation. Before you install, you get
a complete summary of your selections throughout the wizard. Using the wizard you can install one or more

packages at one time.

The Update wizard searches for available updates to packages that you have installed. An update might

be a released fix, a new feature, or a new version of the product. Details of the contents of the update are
provided in the wizard. You can choose whether to apply an update. The Update wizard searches connected
repositories for updates. If you are not connected to the Internet, you may not see newly available updates
for your installed products. To apply an update to a computer that is not connected to the Internet, you must
download the update and extract it to a local repository.

The Modify wizard helps you modify certain elements of a package that you have already installed. During

the first installation of the package, you select the features that you want to install. Later, if you require other
features, you can use the modify packages wizard to add them to your package. You can also remove features
and add or remove languages.

The Manage Licenses wizard helps you set up the licenses for your packages. Use this wizard to change your
trial license to a full license, to set up your servers for floating licenses, and to select which type of license

to use for each package. HCL OneTest™ Performance requires runtime floating license keys to run tests with
multiple virtual users and to use product extensions such as protocols. Runtime floating license keys are not
managed using Installation Manager. Use the License Key Administrator program, installed with the Rational®
License Server, to manage runtime floating license keys.

« The Roll Back wizard helps you to revert to a previous version of a package.

« The Uninstall wizard removes a package from your computer. You can uninstall more than one package at a
time.

Installation locations

Installation Manager retrieves product packages from specified repositories and installs the products into selected

locations, which are referred to as package groups.

Package groups

During installation, you specify a package group into which to install a product.

- A package group represents a directory in which products share resources.

« When you install a product by using Installation Manager, you either create a package group or install the
product into an existing package group. A new package group is assigned a name automatically; however, you
choose the installation directory for the package group.

- After you create a package group you cannot change the installation directory. The installation directory
contains files and resources that are shared by the products that are installed into that package group.
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« Product resources that are designed to be shared with other packages are installed in the shared resources
directory. Not all products can share a package group, in which case the option to use an existing package
group is disabled.

« When you install multiple products at the same time, all products are installed into the same package group.

Shared resources directory

The shared resources directory is where product resources are installed so that they can be used by multiple product
package groups. You define the shared resources directory the first time that you install the first product package.
For best results, use your largest disk drive for shared resources directories. You cannot change the directory location
unless you uninstall all product packages.

Coexistence

Some products are designed to coexist and share functions when they are installed in the same package group. A
package group is a location where you can install one or more software product packages.

Offering coexistence considerations

When you install each product package, you select whether to install the product package into an existing package
group or to create a package group. Installation Manager prevents you from installing products into package groups
products that are not designed to share or do not meet version compatibility and other requirements. To install more
than one product at a time, the products must be able to share a package group.

Any number of eligible products can be installed to a package group. When a product is installed, the product
functions are shared with all the other products in the package group. If you install a development product and a
testing product into one package group, when you start either of the products, you have both the development and
testing functions available to you in your user interface. If you add a product with modeling tools, all the products in

the package group have the development, testing, and modeling functions available.

Eclipse instance overview

The product package that you install using Installation Manager comes with a version of Eclipse, which is the
base platform of this product package. If you already have Eclipse installed on your workstation, you can add your
product package directly to that Eclipse installation and extend the functions of the Eclipse integrated development

environment (IDE).

Extending an Eclipse IDE adds the functions of the newly installed product, but maintains your IDE preferences and
settings. Previously installed plug-ins are also still available.

In most cases, your current Eclipse IDE must be the same version as the Eclipse that the product you are installing
uses. Installation Manager checks that the Eclipse instance that you specify meets the requirements for the

installation package and helps you install the latest updates from eclipse.org, if required.
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Increasing the number of file handles on Linux™ workstations

For best product performance, increase the number of file handles above the default setting of 1024 handles.

About this task

! Important: Before you work with your product, increase the number of file handles. Most products use more
than the default limit of 1024 file handles per process. A system administrator might need to make this

change.

Exercise caution when using the following steps to increase your file descriptors on Linux™. If the instructions are not
followed correctly, the computer might not start correctly.

To increase your file descriptors:

1. Log in as root. If you do not have root access, you must obtain it before continuing.

2. Change to the et c directory.

! Attention: If you decide to increase the number of file handles in the next step, do not leave an empty
i ni tscript file onyour computer. If you do so, your computer will not start up the next time that you

turn it on or restart.

3. Use the vi editor to edit the i ni t scri pt file in the et ¢ directory. If this file does not exist, type vi initscript
to create it.
4. On the first line, type ulinit -n 30000. The point is that 30000 is significantly larger than 1024, the default

value on most Linux™ computers.

! Important: Do not set the number of handles too high, because doing so can negatively impact
system-wide performance.

5. On the second line, type eval exec "$4".

6. Save and close the file after making sure that you have completed steps 4 and 5.

Note: Ensure that you follow the steps correctly. If this procedure is not completed correctly, your
computer will not start.

7. Optional: Restrict the number of handles available to users or groups by modifying the |l i mi t s. conf filein
the et ¢/ securi ty directory. Both SUSE Linux™ Enterprise Server (SLES) Version 9 and Red Hat Enterprise
Linux™ Version 4.0 have this file by default. If you do not have this file, consider using a smaller number in step
4 in the previous procedure (for example, 2048). Do this so that most users have a reasonably low limit on
the number of open files that are allowed per process. If you use a relatively low number in step 4, it is less
important to do this. However, if you set a high number in step 4 earlier and you do not establish limits in the

l'imts. conf file, computer performance can be significantly reduced.
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The following sample | i mi t s. conf file restricts all users, and then sets different limits for others
afterwards. This sample assumes that you set handles to 8192 in step 4 earlier.

i soft nofile 1024
i hard nofile 2048
root soft nofile 4096
root hard nofile 8192

userl soft nofile 2048

userl hard nofile 2048

Note that the * in the preceding example sets the limits for all users first. These limits are lower than the limits
that follow. The root user has a higher number of allowable handles open, while the number that is available to
user1 is between the two. Make sure that you read and understand the documentation that thel i mi t s. conf
file contains before making changes.

What to do next

For more information on the ulimit command, see the main page for ulimit in the Linux™ documentation.

Installation of the product by using Installation Manager

You must download the product bits and then from the Installation Manager point to the Setup disk.

Note: For Linux™ computers, you must log in as the root user before you begin installation process.

Installing HCL OneTest™ Performance

To test the performance of an application, you must install HCL OneTest™ Performance.

Before you begin

- Download and install Installation Manager from https://jazz.net/downloads/ibm-installation-manager/.
« If you were using the IBM testing product and want to reuse the test assets in the HCL testing product, follow
these instructions:
> From the IBM testing product, export all the test assets with dependencies. Follow instructions till step
5 in Copying test assets with dependencies on page 379.
> Uninstall the IBM testing product.
o Install the HCL testing product by following the instructions.
> Import the test assets with dependencies to the HCL workspace. Follow instructions from step 6 in

Copying test assets with dependencies on page 379.

About this task

For more information about installing the product from the command prompt in the silent mode, see IBM Installation
Manager Knowledge Centre.

72


https://jazz.net/downloads/ibm-installation-manager/
https://www.ibm.com/support/knowledgecenter/SSDV2W_latest/com.ibm.silentinstall12.doc/topics/t_silent_install_IMinst.html
https://www.ibm.com/support/knowledgecenter/SSDV2W_latest/com.ibm.silentinstall12.doc/topics/t_silent_install_IMinst.html

Chapter 5. Administrator Guide

Notes:

- You cannot upgrade to the latest version of the product. You must uninstall the existing version of the
product before installing the latest version of the product.

- Currently, collection of response time breakdown data from macOS system is not supported.

1. In the Installation Manager, click File > Preferences > Repositories, and add a repository link to the product's
setup disk and click OK.

2. Click Install.

3. Click a product package to highlight it.

Result
The description of the package is displayed in the Details pane at the end of the screen.

4. To search for updates to the product packages, click Check for Other Versions, Fixes, and Extensions. If
updates for a product package are found, then they are displayed in the Installation Packages list on the
Install Packages page under their corresponding products. Only recommended updates are displayed by
default.

Choose from:
> To view all updates that are found for the available packages, click Show all versions.
> To display a package description in the Details pane, click the package name. If additional information
about the package is available, such as a r eadne file or release notes, a More info link is included at
the end of the description text. Click the link to display the additional information in a browser. To fully

understand the package that you are installing, review all information.

Note: For Installation Manager to search the predefined IBM® update repository locations
for the installed packages, the Search the linked repositories during installation and updates
preference on the Repositories preference page must be selected. This preference is selected
by default. Internet access is also required. A progress indicator shows that the search is
taking place. You can install updates at the same time that you install the base product

package.

5. Select the product package and any updates to the package to install. Updates that have dependencies are

automatically selected and cleared together. Click Next to continue.

Note: If you install multiple packages at the same time, then all the packages are installed into the

same package group.

6. On the Licenses page, read the license agreement for the selected package.
a. If you agree to the terms of all of the license agreements, click | accept the terms of the license
agreements.

b. Click Next to continue.
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7. On the Location page, type the path for the shared resources directory in the Shared Resources Directory field,
or accept the default path. The shared resources directory contains resources that can be shared by one or
more package groups. Click Next to continue.

The default path to use follows:
B Windows Fol Program Fi | es\ HCL\ HCLI Mshar ed
° / opt / HCL/ HCLI Mshar ed
° / Appl i cati ons/ HCL/ HCLI Mshar ed

! Important: You can specify the shared resources directory only the first time that you install a
package. Use your largest disk for this to help ensure adequate space for the shared resources of
future packages. You cannot change the directory location unless you uninstall all packages.

8. On the Location page, create a package group to install the product package into or if this is an update, use
the existing package group. A package group represents a directory in which packages share resources with

other packages in the same group. To create a package group:
a. Click Create a new package group.

b. Type the path for the installation directory for the package group.
The name for the package group is created automatically.

The default path follows:
N - viindows FolW=" ogram Fi | es\ HCL\ HCLOneTest
[ opt / HCL/ HCLOneTest
. / Appl i cati ons/ HCL/ HCLOneTest

c. Click Next to continue.

9. Optional: On the next Location page, you can choose to extend an existing Eclipse IDE that is installed on your
computer, which adds the functions in the packages that you are installing. You must have Eclipse Version 3.6
with the latest updates from eclipse.org to select this option. Click Next to continue.

Note: HCL OneTest™ Performance does not support extending an existing Eclipse IDE.

10. On the Features page under Translations, select the languages for the package group. The corresponding
translations for the user interface and documentation for the product package will be installed.
11. On the next Features page, select the package features to install.

a. Optional: To see the dependency relationships between features, select Show Dependencies.

b. Optional: Click a feature to view its brief description under Details .



Chapter 5. Administrator Guide

c. Select or clear features in the packages. Installation Manager automatically enforces any
dependencies with other features and displays updated download sizes and disk space requirements
for the installation.

d. When you integrate HCL OneTest™ Performance along with Rational® Application Developer or
Rational® Software Architect in a shell-shared mode, you must clear Java 8 OpenJDK with Eclipse
OpenJ9 check box during the installation. If you not clear this check box, multiple instances of
OpenJDK are installed as Rational® Application Developer and Rational® Software Architect already

have an existing OpenJDK.

Note: If you install Rational® Application Developer or Rational® Software Architect in a
separate package, you can select the Java 8 OpenJDK with Eclipse OpenJ9 check box.

e. When you are finished selecting features, click Next to continue.

12. On the Summary page, review your choices before installing the product package. To change the choices that
you made on previous pages, click Back, and make your changes. When you are satisfied with your installation
choices, click Install to install the package.

Result
A progress indicator shows the percentage of the installation that is completed.
13. When the installation process is complete, a message confirms the completion of the process.
a. Click View log file to open the installation log file for the current session in a new window. You must
close the Installation Log window to continue.
b. In the Install Package wizard, select whether to start the product when you exit.
c. Click Finish to start installing the selected package.
14. License the product.

See the Applying the license on page 81 topic.

Installing HCL OneTest™ Performance Agent

You must install HCL OneTest™ Performance Agent on different computers to apply load on the server that hosts the
application under test.

Before you begin

« To install the software using Installation Manager, download and install Installation Manager from https://

jazz.net/downloads/ibm-installation-manager/.

About this task

For more information about installing the product from the command prompt in the silent mode, see IBM Installation

Manager Knowledge Centre.
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Notes:

- To use the response time breakdown feature in HCL OneTest™ Performance Agent 8.7 or later,
uninstall the existing version of the agent and install it afresh.

- Currently, collection of response time breakdown data from macOS system is not supported.

- You cannot upgrade to the latest version of the product. You must uninstall the existing version of the

product before installing the latest version of the product.

1. In the Installation Manager, click File > Preferences > Repositories, and add a repository link to the product's
setup disk and click OK.

2. Click Install.

3. Click a product package. Its description is displayed in the Details pane at the end of the screen.

4. To search for updates to the product packages, click Check for Other Versions, Fixes, and Extensions.
Make sure you are connected to the Internet. If updates for a product package are found, they are displayed
in the Installation Packages list on the Install Packages page under their corresponding product. Only
recommended updates are displayed by default.

Choose from:

> To view all of the updates that are found for the available packages, click Show all versions.

- To display a package description under Details, click the package name. If additional information
about the package is available, such as a r eadne file or release notes, a More info link is included at
the end of the description text. Click the link to display the additional information in a browser. To fully
understand the package that you are installing, review all of the information.

5. Select the product package and updates to the package to install. Updates that have dependencies are

automatically selected and cleared together. Click Next to continue.

Note: If you install multiple packages at the same time, all the packages are installed into the same
package group.

6. On the Licenses page, read the license agreement for the selected package:
a. Read and understand the terms of all of the license agreements before clicking | accept the terms of
the license agreements.
b. Click Next to continue.
7. On the Location page, in the Shared Resources Directory field, type the path for the shared resources directory
or accept the default path. The shared resources directory contains resources that one or more package

groups can share. Click Next to continue.

The following default paths are provided:
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8 viindows FolW=" ogram Fi | es\ HCL\ HCLI Mshar ed
° / opt / HCL/ HCLI Mshar ed
o IIEEXTEM / Appl i cat i ons/ HCL/ HCLI Mshar ed

Important: You can specify the shared resources directory only for the first time when you install
a package. You must use your largest disk for this directory to help ensure adequate space for the
shared resources of future packages. You cannot change the directory location unless you uninstall all

packages.

8. On the Location page, create a package group to install the product. If you are updating the product, use the
existing package group. A package group represents a directory in which packages share resources with other
packages in the same group. To create a package group, complete these steps:

a. Click Create a new package group.

b. Type the path for the installation directory for the package group.
The name for the package group is created automatically.

The following default paths are provided:
N Vindows FoRWSY ogram Fi | es\ HCL\ HCLOneTest
. [ opt / HCL/ HCLOneTest
. / Appl i cati ons/ HCL/ HCLOneTest

c. Click Next to continue.

9. HCL OneTest™ Performance Agent does not support extending an existing Eclipse IDE, so you can ignore this
page.
10. On the Features page, under Translations, select the languages for the package group. The corresponding
translations for the user interface and documentation for the product package will be installed.

11. On the next Features page, select the features to install.

Note:

> The Load Generation Agent is used to generate a load on the system under test and gather
data for the Response Time Breakdown feature.

> Installation Manager automatically enforces any dependencies with other features and
displays updated download sizes and disk space requirements for the installation.

a. Optional: To see the dependency relationships between features, select Show Dependencies.
b. Optional: Click a feature to view its brief description under Details.
c. After you are finished selecting features, click Next to continue.

12. On the next Features page, configure the agent:

77



HCL OneTest Performance

a. T The Web Ul test panel is applicable only if you are shell-sharing HCL OneTest™ Performance
and HCL OneTest™ Ul and executing a Web Ul test on the remote agent computers. If you are not
running a Web Ul test, do not select the The agent will be used primarily to support remote execution
of Web Ul tests check box so that Majordomo runs as a service. When Majordomo runs as a service,
it starts automatically after the computer reboots. However, if you must run the Web Ul test on
remote agent computers, select the check box so that, after the installation of the agent, Majordomo
runs as a batch file instead of a service. When Majordomo runs as a batch file, it stops after the
machine reboots. You must restart Majordomo by double-clicking Agent | nst al | Di r/ Maj or dono/
Maj or dono. bat .

On Linux, this check box is not available, and by default, the agent runs as a service and can run a Web
Ul test.

Click Next.

b. For Load Generation Agent, type the host name of the workbench . If needed, change the port number.
You can also change the port number after you install HCL OneTest™ Performance Agent. For more

information, see Configuring ports for agents on page 540.

c. To connect the agent with HCL OneTest™ Server, specify the fully qualified domain name in Server
Hostname, the port number, and the offline user token. For information about offline user token, see

Managing access to HCL OneTest™ Server.
Note: Use the default port number 443 to connect to the server.

d. Click Next.

13. On the Summary page, review your choices before installing the product package. To change the choices that
you made on previous pages, click Back, and make your changes. When you are satisfied with your installation
choices, click Install to install the package.

Result
A progress indicator shows the percentage of the installation that is complete.

14. When the installation process is complete, a message confirms the completion of the process.

a. Click the View log file button to open the installation log file for the current session in a new window.
You must close the Installation Log window to continue.
b. Click Finish to install the selected package.

What to do next
After the installation, the agent starts polling the workbench based on the IP address or the host name provided by
you. You can check the status of agents from the workbench. See Checking the status of agents on page 539.
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Uninstalling the product by using Installation Manager

When you no longer require HCL OneTest™ Performance Rational® Service Tester for SOA Quality, you can use
Installation Manager to uninstall HCL OneTest™ Performance Rational® Service Tester for SOA Quality that you have
installed.

Before you begin

You must have completed the following tasks:

« Installed Installation Manager.
« Closed any open windows of HCL OneTest™ Performance Rational® Service Tester for SOA Quality.
« Closed any open web browsers.

« Closed all the other applications that are enabled by HCL OneTest™ Performance Rational® Service Tester for
SOA Quality.

1. Open Installation Manager.

2. Click Uninstall.

3. Select the HCL OneTest™ Performance Rational® Service Tester for SOA Quality package checkbox on the
Uninstall Packages window, and then click Next.

4. Review the list of packages that are ready to uninstall, and then click Uninstall.
Result
The Complete page is displayed after the uninstallation process is complete.

5. Click Finish to exit the Installation Manager wizard.

Results

You have uninstalled HCL OneTest™ Performance Rational® Service Tester for SOA Quality from your computer.

Installing the software by using stand-alone installer

This guide intended for an administrator, describes how to install the product by using stand-alone installer on
different operating systems.

Installing HCL OneTest™ Performance Agent

To get started with HCL OneTest™ Performance Agent, you must install the product by using the stand-alone installer.

License management

Licensing for your HCL software is administered through HCL® License & Delivery portal. This portal is FlexNet-based

web application to manage software entitlements and licenses.
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You must have ordered software. When a software order is placed and acknowledged, a software entitlement is
created. Then, you have to follow the instructions in Software Order Acknowledgment document that you received to
activate your entitlement, create devices, and download the software from the Portal.

If you do not have access to the Internet, you can install and configure a local license server.

License descriptions

The usage of base product and test extensions are enabled by floating licenses, whereas schedule runs can be
enabled by either floating or consumption-based licenses. With floating licenses, multiple users can use the product;
however, the total number of concurrent users cannot exceed the number of floating licenses you purchase.

Starting from 9.2.1.1, you can choose to use overdraft licenses. With standard floating licenses, you pay in advance
for the number of licenses, but for overdraft licenses you pay periodically based on your usage over time. When
choosing to use overdraft licenses, you are provided with special overdraft licenses in addition to any standard
licenses you purchased. When no standard licenses are available/remaining on a server, the product automatically
falls back to using any available overdraft licenses. Overdraft licenses can also be used without any standard licenses
as a sort of "On-Prem SaaS" payment plan.

When a software order is placed and acknowledged, a software entitlement is created for the user. You can then
create devices and map the software entitlement with the devices. Every device is associated to a server ID. This
server ID is applied in the product. Multiple software entitlements can be created based on the requirements.

You can use any of these licenses according to your requirements:

Product licenses

* Floating license to use the product:

To use the product, you need a floating license that is mapped to the product or you can also use a HCL
OneTest™ Studio floating license. A floating license is checked out when you use the product and is returned

to HCL® License & Delivery portal when the license is not used for 15 minutes.

- Floating licenses for test extensions:

For HCL OneTest™ Performance, in addition to the license for product usage, if you use SOA, SAP, Citrix,
and Siebel test extensions, you need separate software entitlements. You can map all the entitlements to
one server ID. If you have an HCL OneTest™ Studio license, it is enough to start using the product as well as
use the above test extensions. A license is checked out when you use the product and is returned to HCL®

License & Delivery portal when the license is not used for 15 minutes.

« Overdraft licenses:
When you ask for the capability for five overdraft licenses, you would get an entitlement for five ACO licenses
and five RUM licenses. To enable five users to use the product, you must map equal amounts of each of the

license in your cloud license server. The overdraft licensing capability is not available on the local license

server.
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Licenses for A schedule, in this context, is used to refer to both VU Schedule and Rate Schedule. runs

* HCL® OneTest™ Studio - Virtual Users:

These are floating licenses that are purchased in blocks of 100 virtual users each. After the run, the licenses
are checked back in to the server. For example, if you have 200 HCL® OneTest™ Studio - Virtual Users
available, you can run schedule A with 100 virtual users and schedule B with 20 virtual users, leaving 80
virtual users for other team members to use for schedule execution using the same license server. After the
schedule run completes, the all the virtual users are returned to the server for others to use. The overdraft

license for Virtual Users work in the same way as the floating license.

HCL® OneTest™ Studio - Virtual User Execution Capacity:

These licenses are referred as consumption-based license. They are purchased in blocks, for example, 1000
hours. Every time you run a schedule or compound test, the number of hours are deducted from the block.
Prior to schedule run, the product provides an estimate of the VU-Hours required to run the schedule. At the
end of successful schedule run, the product sends a request to the HCL® License & Delivery portal to deduct
the number of VU-Hours consumed. For Run Until Finished schedule run, the estimate warns that the actual

number of VU-Hours to be consumed cannot be determined.

When you run a schedule, the product first searches HCL® OneTest™ Studio - Virtual Users licenses. If they
are unavailable or insufficient, the schedule looks for HCL® OneTest™ Studio - Virtual User Execution Capacity
licenses. For example, suppose you are entitled to 500 HCL® OneTest™ Studio - Virtual Users and 1000

hours HCL® OneTest™ Studio - Virtual User Execution Capacity license. If a team member starts schedule A
that requires 400 virtual users and another team member starts schedule B that requires 200 virtual users,
schedule A picks up 400 virtual users and runs as expected. Schedule B searches 200 virtual users but

does not find them. So, the duration of schedule B will beis calculated and the estimated number of hours is
displayed to the user. If the user clicks OK, HCL® OneTest™ Studio - Virtual User Execution Capacity licenses
are consumed. The calculation of Rate Schedule VU-Hours is based on 1 transaction per second being the

equivalent of one virtual tester.

Overdraft for Virtual User Execution Capacity:

Unlike overdraft floating license, this license works in a different manner. This license does not require ACO

and RUM licenses. You have to only map this license to your license server and start using the product.

You can add more virtual users or change the rate of execution during the test or schedule run only if there are
sufficient number of Virtual User licenses or if a sufficient number of VU-Hours are on balance in the customer's

account.

Applying the license

To start using a product, you must first apply a license.

About this task
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When you start the product for the first time, a licensing dialog box is displayed. Specify the server ID that was
provided to you or copy the ID from the HCL® License & Delivery portal. When you submit the server ID, the product
connects with the HCL® License & Delivery portal to verify it and if there is a license available, it is checked out

so that you can use the product. If the license is not available, a message is displayed about it. In most cases, you

should not change the server URL in the licensing dialog.

Note:

« If the license is not used for 15 minutes, the license is returned to the server for others to consume it.
If the workbench looses connectivity to the HCL® License & Delivery portal, you can use the product
for two hours only if the server ID that you entered last time is correct.

- After the product installation, when you apply the license to the product, the license information
is cached in a system directory. If there are any permission issues accessing the directory or the
directory is deleted, there would be licensing error when starting the product. The workaround is to
create an environment variable HCL_ONETEST_LICENSING_STORAGE and specify a directory path. The

licensing information will now be stored in this new directory. For example,

MNew User Variable *
Variable name: | HCL OMETEST_LICEMSING_STORAGE |
¢ Variable value: | :/Users/<username> /HCLOneTest] |

Browse Directory... Browse File... Cancel

You can also apply the license after starting the product. To apply the license from the product, click Window >
Preferences > Test > Licensing and specify the server ID. You can also use this page to check the balance Event-

hours on the server.

To apply license without opening the product, add the licensing parameters as environment variables:

Variable Value
HCL_ONETEST_LICENSING_URL https://hclsoftware.compliance.flexnetoperations.com

HCL_ONETEST_LICENSING_ID  Enter your server ID. The ID is a 12-character alphanumeric identifi-
er.

When running the tests from command line, you do not have to specify any licensing argument. However, when
running a schedule for HCL OneTest™ Performance or accelerated/distributed tests for HCL OneTest™ Ul in an
uninterrupted mode, you must specify vimar gs - Dhpt cost conf i r margument in the command. Uninterrupted
mode refers to any of the non-GUI based test execution scenarios such as the following use cases:
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« Running a test from the command line

* Running a test with Jenkins

 Running a test with Ant

 Running a test with UrbanCode™ Deploy

* Running a test with IBM® Rational® Quality Manager

What to do next
You can now work with the product.

Using a local license server

In some cases, your computer might not be connected to the open Internet. In these cases, you can set up a local
license server behind your company firewall. You must install the server on a physical computer and not on a Virtual
Machine.

Before you begin

As part of configuration, the local license server must already have mapped your entitlements and be able to serve
your requests.

About this task

The local license server is supported on 64-bit Windows™ and Linux® platforms. For more information about
installing and configuring the local license server, see the documentation for the local license server on the HCL®
License & Delivery portal product download site.

The local license server will be available soon after the 9.2.0.1 release.

1. After the license server is installed and configured, start the testing product.

2. Within the test product, click Windows > Preferences > Test > Licensing.

3. When the licensing dialog opens, select the Server Type as Local and replace the URL of the cloud-based
license server with the URL of your own local license server. Enter the Server URL of the local license server in
this format - http://myserver:portNumber/request. Do not specify the server ID.

4. To test the connection to the server, click Test Connection.

What to do next
You can now work with the product.

Configuring product licensing to use a proxy server

In most cases, you connect directly to a cloud-based license server when you start the testing product for the first
time. As an alternative, you can configure the testing product to use a proxy server.

1. Within the test product, click Windows > Preferences > Test > Licensing.
2. Select the Server Type as Cloud or Local.
3. Enter the Server URL and Server ID of the license server (if applicable)
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4. Select the Use Proxy Server check box and specify the Host and Port of the proxy server.

5. If login credentials are required to access the server, select the Provide Credentials check box and specify the
User Name and Password.

6. To test the connection to the server, click Test Connection.

Collecting usage metrics data

To provide an insight into the usage patterns of the product itself and not necessarily the application that it is testing,
the usage metrics are collected. The product can collect the metrics about the usage of the tool including and not
limited to the number of tests executed, the number of actions performed against an application under test, the

number of successful versus failed actions, verification points, and so on.

Before you begin

« Ensure that HCL® Quality Server is installed.. See the HCL® Quality Server documentation for the installation
instructions.
« Ensure that the license key is applied. See Applying the license on page 81

About this task

When you collect usage metrics, the data is collected for internal use to provide you better services. For example, in a
Web Ul test, all user actions such as click, enter text, and so on are counted and collected. Similarly, for an HTTP test,
the number of HTTP Pages and Requests are counted and logged. No information about the application under test is

collected.

1. From the product, click Window > Preferences > Test > HCL Quality Server.

2. Specify the IP address or host name of the computer where HCL® Quality Server server is installed.

Note: If the IP address or host name is not specified, depending on the license key setting, a warning
message might be logged every time you run a test, the test execution itself might be blocked, or the

tests can be executed without any warning messages.

3. Click Test Connection to check whether the connection is established. Click OK if the connection is
established.

Product upgrade and migration

When you want to use the enhanced functionalities of HCL OneTest™ Performance, you must upgrade to the latest

version of the product software.

You can upgrade HCL OneTest™ Performance to the latest version by uninstalling the existing version of HCL

OneTest™ Performance. You can then install the latest version of HCL OneTest™ Performance.
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Migrating test assets to new version of the product

After you install a later version of the product and you open the product, you are prompted to migrate test projects,

tests, schedules, rules, and reports. Tests and schedules are migrated automatically when you modify and save them.

HCL OneTest™ Performance and Rational® Service Tester for SOA Quality restrict the number of versions that are
installed on your computer. You cannot have both of these products or two versions of these products installed at
one time. Before you install a new version, uninstall the previous version of the product. If you update the product with
IBM® Installation Manager, you do not have to uninstall the previous version.

Uninstalling a previous version does not delete your test assets.

When you open a project that contains an older test asset, a message is displayed in the Test Navigator view.

Typically, you upgrade your tests, schedules, and rules.

The Asset dependencies builder window is not displayed unless an older test asset is included in the Test
Navigator view. To upgrade older test assets to the latest version, open the projects that contain those
assets in the Test Navigator view. Double-click the project folder to open the project. When you open a test
project that was created in a previous version of the product, you are prompted to upgrade the project and its

contents to the latest version. Typically, you upgrade test projects.

! Important: Do not open a migrated test project with a previous version of the product.

If you leave tests, schedules, and rules unchanged, they will not have the new functions that current release adds. You
can always save a modified test asset under a new name, which preserves the older asset. You can identify an older

asset by its version, which is listed in brackets:

(‘E&E visitIBM [7.0.1.0] &2

Note: A new release might include enhancements to the default reports. When you run a test or schedule or
open a report, you are prompted to upgrade reports to the latest version. If you upgrade the default reports to

the latest version, you lose customizations that you have made to the reports.

If you encounter errors when you open a workspace from a different version of the product, reset the perspective. To

reset the perspective, click Window > Reset Perspective.

Configuration of the product

You must configure HCL OneTest™ Performance when you want to run SAP tests, collect response time breakdown

data, or use the product in the Docker container.

The following topics provide more information about the configuration of HCL OneTest™ Performance:
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Configuring the environment for SAP tests

Some of the capabilities of service tests require that you manually install additional libraries and files or that you

configure some elements of the test environment.

Configuring SAP for performance testing

Performance test recording and execution requires scripting to be enabled on the SAP application server and on all
SAP GUI clients that are installed on remote computers. The following instructions are for SAP version 6.40 and might
vary with other versions. Refer to SAP documentation for further information.

Before you begin

Performance testing relies on the SAP Scripting API and ActiveX. Make sure that Active X is installed when installing

the SAP GUI client and enable scripting on the SAP server.

Note: You only need to perform the following actions once. Scripting should remain enabled on the SAP

server after a restart.

To enable scripting on the SAP server:

1. Check that there is a Scri pt i ng directory located in the SAP GUI installation directory.
If this directory does not exist, then the SAP Scripting API is not installed and you must reinstall SAP GUI with
the SAP Scripting API option.
2. Run the SAP GUI client and logon to SAP with your user name and password.
Administrator privileges might be required to enable scripting on the server.
3. In SAP run the transaction rz11, type the parameter name sapgui / user _scri pti ng, and then click Display.
If the parameter is not found, then make sure you have the correct support package level from SAP. Contact
your SAP representative for guidance.
4. If the Current value is FALSE, click the Change value button, and then set the New value to TRUE in uppercase
characters.
5. Click Save, and then end the transaction.
Scripting will be enabled the next time you log on.
6. In the SAP GUI client toolbar, click the Customizing of Local Layout toolbar button, and then select Options.
7. Select the Scripting page.
8. Select Enable Scripting, and then disable both Notify When a Script Attaches to Running GUI and Notify
When a Script Opens a Connection.
9. Click OK.
10. In the Help menu, select Settings, and then select the F4 Help page.
11. In Display, select Dialog (modal) and then click the Enter %" button.

What to do next

Repeat steps 5 through 9 for SAP GUI clients on all remote computers. For more information about enabling scripting

on the SAP application server, refer to the following SAP notes, available from SAP:
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» 480149: ABAP and patch level requirements

» 587202: Limitations of SAP GUI Scripting

» 527737: Composite SAP Note on SAP GUI Scripting

» 612454: SAP GUI Scripting status and lifetime

» 619459: SAP GUI Scripting support of SAP applications

Configuring the environment for batch input tests

To play back SAP batch input tests, you must install the SAP Java™ Connector (JCo) libraries provided by SAP on

local and remote computers running the HCL OneTest™ Performance agent.
Before you begin

The following files are required:

* sapjco3.jar

* sapjco3.dll

Contact SAP for instructions on obtaining these files.

On each local and remote computer used for running batch input tests and schedules, you must prepare an
environment with these libraries, set the class path of the Java™ Runtime Environment (JRE) that the HCL OneTest™
Performance Agent uses.

To configure a computer for SAP batch input tests:

1. Copy sapj co3. j ar intothejre/lib/ext directory of the JRE.

By default, this is the following directory: C: \ Progr am Fi | es\ HCL\ HCLOneTest\j dk\jre\li b\ ext.

2. Copy sapco3. dl | into the C: \ W ndows\ Syst enB2 directory. If you are using a 64 bit machine, you must
copy the file to C: \ W ndows\ SysWOW64.
3. Click Start > Control Panel > Administrative Tools > Services, and then stop and restart the Majordomo

service.

What to do next
When running a simple SAP batch input test, results should appear in the Batch Input Transaction Rate page of the
SAP performance report. If not, look at the test log for connection and transaction execution information.

Configuring the data collection infrastructure

If you want to collect response time breakdown data from remote computers used in distributed applications, you
must install and configure the data collection infrastructure on the remote computers.
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Data collection infrastructure overview

The data collection infrastructure collects performance profiling data for distributed applications and sends the data
to the workbench computer, where you can view and analyze the collected data. The data collection infrastructure
must be installed, configured, and running on all remote computers that will be used in your distributed application.
The data collection infrastructure is installed when you install HCL OneTest™ Performance Agent.

You can monitor a live application in a development or testing environment and collect data from the application in
real time. Data collection is supported on the following web servers:

- IBM® WebSphere® Application Server, Version 6.1, 7.0, 8.0, or 8.5 running on Microsoft™ Windows™, AIX®,
and Linux™
« Oracle WebLogic Application Server, Version 9 or 10 running on Microsoft™ Windows™ and Linux™

You can also query IBM® Tivoli® Monitoring for Transaction Performance, IBM® Tivoli® Composite Application
Manager for Response Time Tracking, IBM® Tivoli® Composite Application Manager for WebSphere® or IBM®
Tivoli® Composite Appliciuiu.uation Manager for Application Diagnostics management server databases to collect
past performance data for an application that is deployed in a production environment. Data collection is supported

on the following software versions:

« IBM® Tivoli® Monitoring for Transaction Performance, Version 5.3 fix pack 1 (5.3.0.1)

+ IBM® Tivoli® Composite Application Manager for Response Time Tracking, Versions 6.0 and 6.1
* IBM® Tivoli® Composite Application Manager for WebSphere®, Versions 6.0 and 6.1

- IBM® Tivoli® Composite Application Manager for Application Diagnostics, Version 7.1

Instrumenting local servers

You must instrument application servers to collect response time breakdown data. You can use either a command-

line or graphical user interface to instrument application servers to work with the data collection infrastructure.

Before you begin

- The data collection infrastructure must be installed on any computer from which you want to collect
performance data.

« If you are instrumenting a WebSphere® application server, the application server must be running.

» The Application Server Instrumenter prompts you to restart BEA WebLogic application servers.

« You must have root or administrator user privileges to instrument servers.

1. In Windows™, click Start > Programs > __BRAND_NAME__ Data Collection Infrastructure > Application Server
Instrumenter.
In Linux™, use the start menu to open the Application Server Instrumenter. In the AIX® operating system, type
/ opt / HCL/ HCLOneTest / DCI / r apa_pr od/ i nst runent _conp/ ASl at a command prompt to start the Application Server
Instrumenter.
Result

The Application Server Instrumenter starts.
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2. Use the Application Server Instrumenter to instrument the server. See the examples that follow.

3. If you are instrumenting a BEA WebLogic server, after you have instrumented the server you must restart the
application server.
The Application Server Instrumenter automatically restarts WebSphere® application servers.

Note: All HCL OneTest™ Performance systems that are involved with the data collection infrastructure
must have the data collection software running for the transaction breakdown function to be available

within the results of a HCL OneTest™ Performance test schedule.

Note: The application server instrumenter or the i nst r unent Ser ver . bat (or
i nst runent Ser ver . sh) batch file can fail with a generic error message (Error during install/
uni nst al I ) when instrumenting or uninstrumenting a server. If this error occurs, you can find more
information to help troubleshoot the error in the log files in the IBM® Tivoli® common directory. On
Windows™, the default location of this directory is C: \ Program Fi | es\ I BM ti vol i \ comon.
On Linux™, the default location of this directory is/ var/i bni ti vol i / cormon. If the IBM® Tivoli®
common directory is not in the default location, search for a path that contains ti vol i / conmon, or

for any of these log files:trace-instal | .| og,trace-nma. | og,ortrace-tapnagent. | og.

Note: For IBM® WebSphere® Application Server 6.0 or later, if you create a new profile and then
use the application server instrumenter to instrument this profile without first starting WebSphere®
Application Server, the application server instrumenter reports that the server is instrumented and
prompts you to restart the server manually. This message is incorrect; the server is not actually
instrumented. To work around this problem, complete these steps:
a. Close and then restart the application server instrumenter.
b. Select the entry that you just added from the list of instrumented servers, and click Remove.
c. Restart WebSphere® Application Server.
d. Restart the application server instrumenter, and use it to instrument the server.
To avoid this problem, after you create a new profile, start the WebSphere® Application Server profile

manually. Then, use the application server instrumenter to instrument the server.

Exemple

To instrument a Linux™ computer that is equipped with the 64-bit version of IBM® WebSphere® Application Server,
Version 6.1, where the server is named server2, the server is installed in the / opt / WebSpher e/ AppSer ver
directory, with the profile name set to the default value, and security enabled:

1. Click Instrument Local Server.

2. From the Type list, select IBM WebSphere Application Server v6.1.
3. Type / opt/ ebSpher e/ AppSer ver in the Server home field.

4. Type server 2 in the Server name field.

5. Type def aul t in the Profile name field.
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6. Under Server JVM, click 64-bit.

7. Select the Requires global security check box.

8. Type the WebSphere® user ID in the User field.

9. Type the WebSphere® password in the Password field.
10. Click OK.

To instrument a Microsoft™ Windows™ computer that is equipped with a BEA WebLogic 10 application server named
server1 that is installed in the C: \ bea\ webl ogi c10 directory, using the 32-bit version of JRockit JVM, and the C:
\ bea\ webl ogi c10\ nydomai n\ st ar t WebLogi c. cnd start script file :

. Click Instrument Local Server.

. Select BEA WebLogic Application Server v10.x from the Type list.

. Type server 1 in the Server name field.

. Type C:\ bea\ webl ogi c10 in the Server home field.

. Type C:\ bea\ webl ogi c10\ nydomai n\ st art WebLogi c. cnd in the Start script field.
. Under Server JVM, select Oracle JRockit 32-bit.

. Click OK.

. Stop and restart the server.

o N o o b WODN =

What to do next

Repeat the instrumentation steps for every application server that is involved in data collection for the applications
that you will profile. Typically, there will be only one application server. You can instrument only one local application

server per computer.

Tips for instrumenting Oracle WebLogic Application Server

Tips when instrumenting Oracle WebLogic Application Server to collect response time breakdown data.
* You must instrument using an account with root or administrator privileges.

You must provide correct information in the Application Server Instrumenter.

Server name is the name of the server to instrument. For example, for Oracle WebLogic Application Server 10.3
running on Microsoft™ Windows™ with the default sample application MedRec installed, the server name is

MedRecSer ver .

Server home is the path to the server bin directory. For example, for Oracle WebLogic Application Server 10.3 running
on Microsoft™ Windows™ with the default sample application MedRec installed, the server homeis: C: \ Or acl e
\' M ddl ewar e\ W server _10. 3\ sanpl es\ donai ns\ nedr ec.

Start script is the script, a .cmd or .sh file, used to start the Oracle WebLogic Application Server. For example, for
Oracle WebLogic Application Server 10.3 running on Microsoft™ Windows™ with the default sample application
MedRec installed, the start script is C: \ Or acl e\ M ddI ewar e\ W server _10. 3\ sanpl es\ donmai ns\ nedr ec
\ bi n\ startWblLogi c. cnd.
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Server JVM is the type of Java™ Virtual Machine (JVM) used by Oracle WebLogic Application Server. To determine
the server JVM, examine the system processes while the server is running and see whether the JRockit JVM or the
Oracle JVM is active.

Tips for instrumenting WebSphere® Application Server

Follow these tips when you instrument WebSphere® Application Server to collect response time breakdown data.

 The instance of WebSphere® Application Server to instrument must be running.

 You must instrument with an account with root or administrator privileges.

- If security is enabled for WebSphere® Application Server, you must know the WebSphere® Application Server
administrator ID and password before you can instrument the server.

« Vertical clusters are not supported. You can instrument a horizontal cluster by instrumenting each physical

server separately.

You must provide correct information in the Application Server Instrumenter.

Server home is the complete path to the WebSphere® Application Server installation directory. By default, on
Microsoft™ Windows™ the server home is C: \ Progr am Fi | es\ | BM WebSpher e\ AppSer ver . In Linux™ and AIX®,
the default server home is / opt / | BM WebSpher e/ AppSer ver .

Server name is the name of the WebSphere® Application Server instance to instrument. To see a list of server names,
change to the bi n directory, and type this command at a command prompt: wsadni n -conntype none -c "puts stdout

[ $Adm nConfig list Server]".
An example of output from this command is as follows:

WASX73571: By request, this scripting client is not connected to any server process. Certain configuration
and application operations will be available in |ocal nbde. serverl(cells/Machi nenameNodeO1Cel | / nodes/

Machi nenaneNodeO1/ servers/ server 1| server. xm #Server_1183122130078)
In this case, server1 is the server name.
Profile name is the name of the profile that is associated with the server to instrument.

To see a list of profiles from WebSphere® Application Server, change to the bi n directory, and type this command
at a command prompt: manageprofiles -1istProfiles. By default, in Microsoft™ Windows™ the bi n directory is C:
\ Program Fi | es\ | BM WebSpher e\ AppSer ver\ bi n. In Linux™ and AIX®, the default bi n directory is/ opt /

| BM WebSpher e/ AppSer ver / bi n.

Instrumenting servers by using the command prompt

You must instrument application servers to collect response time breakdown data. You can use either a command

prompt or graphical user interface to instrument application servers to work with the data collection infrastructure.

Before you begin
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The data collection infrastructure must be installed on each computer from which you want to collect performance
data. The application server must be running. You must have administrator or root user privileges to instrument

servers.

1. Open a command prompt, and go to the i nst r unent _conp folder in the directory where the data collection
infrastructure is installed.
By default, in Microsoft™ Windows™, this directory is C: \ Pr ogr am Fi | es\ HCL\ HCLOneTest \ DCl
\rapa_prod\i nstrument _conp. In Linux™ and IBM® AIX®, this directory is / opt / HCL/ HCLOneTest /
DCl / rapa_prod/instrument _conp.

2. Type the command name with the arguments to use to instrument a server. See the examples that follow.
The instrumentation utility is i nst r unent Ser ver . sh on AIX® and Linux™ systems and
i nstrunent Server. bat on Windows™ systems. Enter the command name with no arguments to see the
syntax details for the command.

3. After you have instrumented the application server, you might have to restart the application server.

Instrumentation changes take effect after the application server is restarted.

Exemple

Assume that you must instrument a Windows™ computer that is configured as follows:

* IBM® WebSphere® Application Server, Version 7.0.

* The server is named my_Server2.

« The application server is installed in the C: \ Pr ogr am Fi | es\ was7. 0 directory.
* The profile name is default.

« Security is enabled.

« The server Java™ Virtual Machine (JVM) is a 64-bit JVM.

Type the following command and arguments:

instrunent Server -install -type was7 -serverNane ny_Server2 -serverHone "C: \Program Fi |l es\was7. 0" -server VMArch

64 -user nmy_WAS userld -password nmy_WAS password -profil eNane default

To instrument a Linux™ computer that is equipped with a BEA WebLogic 10 application server, with configuration
details as indicated, using the 32-bit version of JRockit JVM, type the following command and arguments:

.linstrument Server.sh -install -type wl s10 -serverNanme serverl -serverHonme /opt/bea/ webl ogi c10 -serverVM oracl e

-server VMArch 32 -startScript /opt/beal/webl ogi c10/ nydonai n/ st artWbLogi c. sh

To instrument a Liberty Profile, for -t ype use I i bert y85, and for - ser ver Hone use the path to the Liberty server
installation directory until W p.

What to do next
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Repeat the instrumentation steps for each application server that is involved in data collection for the applications
that you will profile. Typically, there will be only one application server. You can instrument only one local application
server per computer.

Removing instrumentation

Before you uninstall the data collection infrastructure, you must remove instrumentation from all application servers
that were instrumented to work with the data collection infrastructure.

To remove the instrumentation from an application server:

1. Click Start > Programs > __BRAND_NAME__ Data Collection Infrastructure > Application Server Instrumenter.
On the IBM® AIX® operating system, type / DCl / r apa_pr od/ i nst rument _conp/ ASI at a command prompt to start
the Application Server Instrumenter.

2. Select the server to remove the instrumentation from.

3. Click Uninstrument Server.

4. Restart the server if prompted to do so.

What to do next
You can uninstall the data collection infrastructure.

Removing instrumentation using the command prompt

Before you uninstall the data collection infrastructure, you must remove instrumentation from all application servers

that were instrumented to work with the data collection infrastructure.

Before you begin

If you have uninstalled the application server or removed an instance of the application server, you cannot use

the instrumentation utility to remove instrumentation from the server. This situation will block the data collection
infrastructure uninstall process. Do not uninstall an application server before you have removed instrumentation from

the application server.

Instrumented servers are listed in the file | nst runent ati onRegi st ry. xm . After you have removed
instrumentation from a server, the | nst r unent at i onRegi st ry. xnl file will be empty of references to any
application server. If you uninstall an application server before you have removed instrumentation, to uninstall the
data collection infrastructure you must edit | nst r ument at i onRegi st ry. xml to remove the appl i cati onServer
element for the application server that you uninstalled.

To remove instrumentation from application servers:

1. Open a command prompt, and change directories to the i nst r unent _conp folder in the data collection
infrastructure installation directory. By default, on Microsoft™ Windows™ this directory is C: \ Pr ogr am
Fi | es\ HCL\ HCLOneTest \ DCI \ r apa_pr od\ i nst r ument _conp. On Linux™ and IBM® AIX®, this directory
is/ opt/HCL/ HCLOneTest / DCl / r apa_pr od/ i nst runment _conp.

2. Type the command name with the - uni nst al I argument and all of the other arguments that you used when

instrumenting the server.
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The instrumentation utility, which is also used to remove instrumentation from servers, is
i nstrunent Server. sh on AIX® and Linux™ systems and i nst r ument Ser ver . bat on Windows™
systems. Enter the command name with no arguments to see the syntax details for the command.

3. Restart the server if prompted to do so.

What to do next
You can uninstall the data collection infrastructure.

Configuring Docker containers

Instead of reading through system requirements list and installing the products, you can now deploy the Docker
containers on any computer and get started with testing. To automate playing back tests, you can push the product
images to the Docker container.

1. Download and install Docker-CE. For more information, see the following links:
o Windows - https://store.docker.com/editions/community/docker-ce-desktop-windows.
o Ubuntu - https://docs.docker.com/install/linux/docker-ce/ubuntu/.
o Others - https://store.docker.com/search?type=edition&offering=community.
2. To verify whether your Docker installation was successful, open PowerShell or a terminal of your choice and
run:

$ docker run hello-world

3. Download the container image for the agents from the same location you downloaded the product bits and

extract the compressed files.
! Important: The version of the workbench and agents must match.

4. Load the agent image into the Docker repository:
$ docker load -i "imageFileName.tar.gz"

Result

When the image is loaded, the following message is displayed - Loaded i mage: i mageFi | eName: ver si onNunber

What to do next

You can now set up the playback environment on Docker by following instructions in Running tests with containerized
agents on page 597 and Running automated tests with containerized workbench and agents from Docker on

page 599.

Integration with other products

You can integrate HCL OneTest™ Performance with certain products to run tests, manage test assets, and create

defects.

The following topics provides more information about the integration of HCL OneTest™ Performance with other

products:


https://store.docker.com/editions/community/docker-ce-desktop-windows
https://docs.docker.com/install/linux/docker-ce/ubuntu/
https://store.docker.com/search?type=edition&offering=community
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Integration plugin compatibility matrix

You can find information about the versions of the integration plugin that are compatible with HCL OneTest™

Performance.

The following table lists the versions of the integration plugin that are required to integrate Jenkins, Ant, and

UrbanCode™ Deploy with HCL OneTest™ Performance.

Note: You must download the required version of the integration plugin from the HCL® License & Delivery
portal based on the existing version of HCL OneTest™ Performance. You can then integrate Jenkins, Ant, and

UrbanCode™ Deploy with HCL OneTest™ Performance.

HCL OneTest™ Ant plugin Jenkins plugin UrbanCode™ Deploy plugin
Performance

10.1.0
HOT-PERF-Ant-5.0 HOT-PERF-Jenkins-6.0 HOT_PERF_1010_UCD-5.0

Testing with Ant

You can use ant to run performance and compound tests from the command line. Starting from V2.0 of the ant
plugin, you can run multiple tests simultaneously. V5.0 of the ant plugin is supported in HCL OneTest™ Performance
V10.0.2 of the testing products.

Before you begin

You must have completed the following tasks:

« Installed Installation Manager.
* Installed HCL OneTest™ Performance.
« Verified that you have test assets residing within HCL OneTest™ Performance.

« Downloaded the HCL OneTest™ Performance Ant plugin from the HCL® License & Delivery portal on to the
computer where you install the product.

For more information about specific versions of plugin, see Integration plugin compatibility matrix on
page 95.

» Added ant to the PATH environment variable.
About this task

To run performance tests on Mac OS, you must add an environment variable that points to the installation directory of
HCL OneTest™ Performance.

For example, export TEST_WORKBENCH HOVE=/ opt / HCL/ HCLOneTest .
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Note: For Windows™ and Linux®, the environment variable is set when you install the product.

If you installed HCL OneTest™ Performance on Windows by using the stand-alone installer, then you must specify the

environment variable that points to the installation directory of the product.

For example, export TEST_WORKBENCH_HOVE=C: \ Progr am Fi | es\ HCL\ HCLOneTest .

1. Extract the following files from the downloaded plugin:

o HOT- PERF- Ant - x. 0. j ar

Where, x is the version number of the ant plugin.

o Execut ePer f or manceTest . xm

o READIMVE. t xt
2. Open the Execut ePer f or manceTest . xii file and provide required parameter values.
For example,

<pt name="test1" workspace="C:\workspace" projectname="TestProject" suite="Tests/testl.testsuite"

resul ts="Results/testl on_anttask" />

Note:

You can add an additional <pt > task and provide the details for each test to run multiple tests

simultaneously.

The following table explains each field.

Field Description
-name |Required. The name of the test for the particular test product.
- work- |Required. The complete path to the Eclipse workspace.
space
- project- | Required. The path, including the file name of the project relative to the workspace.
name
- suite | Required. The path, including the file name of the test to run relative to the project. A test can be
a performance schedule or a compound test.
- varfile |Optional. The complete path to the XML file that contains the variable name and value pairs.
- configfile | Optional. The complete path to a file that contains the parameters for a test or schedule run.
- results | Optional. The name of the results file. The default result file is the test or schedule name with a
time stamp appended.
- overwrite | Optional. Determines whether a results file with the same name is overwritten. The default val-

ue is true, which means the results file can be overwritten.
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Field Description
- quiet | Optional. Turns off any message output from the launcher and returns to the command shell
when the run or the attempt is complete.
-vmargs |Optional. Java™ virtual machine arguments to pass in.
- swap- |Optional. For a test or schedule, the default value is the dataset specified in the test editor or
datasets |schedule editor. Overrides the default dataset value to run if required.
Note: You must use the swapdatasets option to replace dataset values during a test
or schedule run. You must ensure that both original and new datasets are in the same
workspace and have the same column names. You must also include the path to the
dataset. For example: / pr oj ect _nane/ ds_path/ds_fil enane. csv:/ proj ect _-
nane/ ds_pat h/ new_ds_fi | enane. csv. You can swap multiple datasets that are
saved in a different project by adding multiple paths to the dataset separated by a semi-
colon. For example: / proj ect _nanmel/ds_path/ds_fil ename. csv:/ project _-
nanel/ ds_path/ new ds_fil enane. csv;/ proj ect _nane2/ds_path/ds_-
filenanme.csv:/project_nanme2/ds_pat h/ new_ds_fil enane. csv
- export- | Optional. The complete path to a directory that can be used to store exported statistical report
stats data.
- export- | Optional. A comma-separated list of absolute paths to custom report format files (.view files) to
statre- | use when exporting statistical report data with the -exportstats option.
portlist
- export- | Optional. The complete path to a directory that can be used to export web analytic results. The
statshtml |results are exported in the specified directory. Analyze the results on a web browser without us-
ing the test workbench.
- user- |Optional. Add text within the double quotation mark to display it in the User Comments row of
comments | the report.
- users | Optional. For a schedule, the default value is the number of users specified in the schedule edi-
tor. For a test, the default value is one user. Overrides the default number of users, if required.
-imshared- | Optional. The complete path to HCLIMShared location, if it is not at the default location.
loc

3. Open a command prompt and navigate to the directory where you downloaded the ant plugin.

4. Enter ant -f ExecutePerformanceTest.xml to run the test.

5. Type ant -f ExecutePerformanceTest.xnl to start test execution.

Results

You have run the test by using the ant plugin.
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What to do next

You can view that the ant execution output is logged into the | ogfi | e. t xt file, and a test log is created in a temp
directory called HOT- PERF- Ant - x. 0.

If you have configured the URL of HCL OneTest Server in the preferences (Window > Preferences > Test > HCL
OneTest Server) of HCL OneTest™ Performance and set Publish result after execution as Always, then the Reports

information section on the Log file displays the names of the report along with its corresponding URLs.

Integration with Azure DevOps

When you use Azure DevOps for continuous integration and continuous deployment of your application, you can
create tests for your application in HCL OneTest™ Performance and run those tests in Azure DevOps pipelines. You
can integrate Azure DevOps with HCL OneTest™ Performance by using the HCL OneTest Studio extension that is
available in the Visual Studio Marketplace portal.

Prerequisites

Before you integrate Azure DevOps with HCL OneTest™ Performance, you must have completed certain tasks. See

Prerequisites for Azure DevOps Integration.

Overview

You can use the HCL OneTest Studio extension that enables you to select any type of test created in HCL OneTest™
Performance that you can add to your task for the job in the Azure DevOps pipelines.

Running HCL OneTest™ Performance tests in an Azure DevOps Pipeline

After you create the tests in HCL OneTest™ Performance for the application that you are testing, and after you install
the HCL OneTest Studio extension in your organization, you can run the tests in Azure DevOps pipelines.

Before you begin
You must have completed the following tasks:

« Installed the HCL OneTest Studio extension in your organization. See Installing the HCL OneTest Studio
extension.

« Installed an agent in your pipeline. See Azure Pipelines agents.

About this task

After you add the HCL OneTest Studio extension in your Azure DevOps organization, you can use an existing pipeline
or create a new one to add HCL OneTest™ Performance test tasks. You can install an agent or use the one that you
installed in your default agent pool. You can add the HCL OneTest™ Performance tests to your task for the agent job,

configure the task, and then run the task in the Azure DevOps pipeline.


https://docs.microsoft.com/en-us/azure/devops/pipelines/agents/agents?view=azure-devops&tabs=browser
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1. Open your Organization page in Azure DevOps and perform the following steps:
a. Click the project you want to use.

b. Initialize the repository by performing the following steps:
i. Click Repos from the left pane.

ii. Click Initialize from the Initialize with a README or gitignore section.
Note: Select the Add a README check box if it is not selected.

c. Click Pipelines from the left pane.
d. Click Create Pipeline.
e. Click Use the classic editor to create a pipeline without YAML.
f. Verify the project, repository, and branch for manual and scheduled builds, and then click Continue.
g. Click Empty job.
2. Select Pipeline and complete the following steps:
a. Change the name for the build pipeline if required.
b. Select the Agent pool for your build pipeline.
You can use the agent from the default agent pool or use the one you have installed.
c. Select the Agent Specification for the agent if required.

3. Add a task to the agent job by completing the following steps:

a. Click the Add Task icon T for the agent job.

Result
The Add tasks pane is displayed.

b. Search for the HCL tasks defined in the HCL OneTest Studio extension.
Result

The tasks that you can select are displayed.
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Add tasks ) Refresh

HCL OneTest APl Task

<

<

HCL OneTest Performance Task

tacte

<

HCL OneTest Ul Task

<

HCL OneTest Server Task

i hel

Depending on the type of test that you have created in HCL OneTest™ Performance, you can select the

type of task. You must use the following table to identify the task you must select:

Type of test

Task to select

= Compound tests
= Performance tests

= Schedules

HCL OneTest Performance Task

c. Select the HCL OneTest Performance option, and then click Add to add the task to the agent job.

Result

The selected task is added to the agent job and it is displayed with a warning that some settings

require attention. You must configure the settings mentioned in step 4 on page 100.

You can also remove the tasks that are not required in your job. Select the tasks in the list that you

want to remove. You can then right-click the tasks, and click Remove selected task(s) to remove them.

4. Configure the settings by performing the following steps:

a. Select the task version from the list if required.

b. Follow the action for the performance task by referring to the following table:
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Note: All mandatory fields are marked with an asterisk (*) in the Ul.

Field Description Action
Display | Displays the name of the se- Enter the name of the task.
name lected task.
Product | The path where the desktop Enter the complete path of the installation directory of
Path client is installed on your com- | the desktop client. For example, C: \ Program Fi | es
puter. \ HCL\
IMShared | The path to the IMShared fold- | Enter the complete path to the location of the
Path er on your local computer. HCLIMShared folder. For example, C: \ Program Fi | es
\ HCL\ HCLI Mshar ed
Work- The complete path to the Enter the complete path of the Eclipse workspace.
space Eclipse workspace.
Location
Project | The name of the project con- | Enter the name of the project containing the test.
Name taining the test.
VM Argu- | Java™ virtual machine argu-
. Enter the Java™ virtual machine arguments.
ments ments to pass in.
Note: You can add multiple virtual machine argu-
ments files separated by a conma.
Test The name of a test within the | Enter the name of the test that you want to run.
Suite project to use. A test can be a
Name performance test, schedule, or
compound test.
Var File | The complete path to the XML | Enter the complete path to the location of the variable
file that contains the variable [ file.
name and value pairs.
Dataset |For atest or schedule, the de- | Use the Dataset Override option to replace dataset val-
Override | fault value is the dataset spec- |ues during a test or schedule run. If a test or schedule is

ified in the test editor or sched-
ule editor. Overrides the de-
fault dataset value to run if re-
quired.

associated with a dataset, you can replace the dataset
at run time while initiating the run from the command

line.

Note:
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Field Description Action

Py You must use the Dataset Override option to re-
place the dataset values during a test or sched-
ule run. You must ensure that both original and
new datasets are in the same workspace and
have the same column names. You must also in-
clude the path to the dataset.

For example,

/ proj ect _nane/ ds_path/ds_file-
nane. csv:/ proj ect _nane/ds_pat h/ new ds_fil e-

nane. csv.

You can swap multiple datasets that are saved
in a different project by adding multiple paths to
the dataset separated by a senicolon (;).

For example,

/ proj ect _nanel/ds_path/ds_file-

nane. csv:/ proj ect _nanel/ds_path/ new ds_-
filenane. csv;/project_nane2/ds_path/ds_file-
nane. csv:/ proj ect _nane2/ ds_pat h/ new ds_fil e-

nane. csv

c. Expand Control Options and configure the settings for your task if required.
d. Expand Output Variables and configure the settings for your task if required.
5. Select the following options:

a. Click Save to save the configured settings for the task.
Note: The task is not queued for a run.

You can save the task to a build pipeline and opt to run the build at a later time.

b. Click Save & queue to save the configurations and queue the run in the pipeline.
Result

The Run pipeline dialog box is displayed.

6. Complete the following steps:
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a. Enter a comment for the test in the Save comment field.

b. Select the agent that you configured for the test from the Agent pool list.

c. Select the agent specification from the Agent Specification list for the agent if required.

d. Select the branch from the Branch/tag list.

e. Add the variables and demands for the task run from the Advanced Options pane if required.
f. Select the Enable system diagnostics check box for a detailed log view.

g. Click Save and run.
Result

The pi pel i ne sunmary page displays the progress of the job run.

Results

You have run the tests for the application you are testing, in the Azure DevOps pipeline.
What to do next
You can open the job to view the task logs from the pi pel i ne sumary page.

You must click the task to open the Task page to view the test results.

Related information

Running a test or schedule from a command line

Integrating with Apache JMeter

Starting from 9.5, you can use JMeter tests extension with HCL OneTest™ Performance to execute JMeter tests.

In HCL OneTest™ Performance, you have the option to import JMeter tests, add tests to a schedule or compound test
to run them. Additionally, JMeter test helps to simulate a heavy load on a server, group of servers, or to investigate

overall sample response time under different load types.

JMeter samples are terminal elements in JMeter tests that inform JMeter to send requests to a server and wait for a
response. When you execute a JMeter test, a JMeter performance report is generated during a run and saved after a
run. This report contains the data most significant to the run, shows the response trend of the lowest 25 samples in
the test, and graphs the response trend of each sample for a specified interval.

With JMeter test, you can load and test the performance of an application that uses the following protocols:

« HTTP/HTTPS
- SOAP/REST
- FTP
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- LDAP
- MOM

« SMTP/POP3/IMAP
- TCP

Installing the JMeter

To work with JMeter tests, you must download the JMeter executable from https://jmeter.apache.org/
download_jmeter.cgi and unzip it. To run the JMeter test as part of schedule, you must install JMeter on the remote

agent machine and set the JMETER_HOME environment variable to the root installation folder.

To run the JMeter tests, you must either specify the Apache JMeter path in Preferences or set the environment

variable.

Note: When you run the compound test or schedule, an error message is displayed, if you have not specified

the preferences or set the environment variable.

« To access the preference settings for Apache JMeter, click Window > Preferences > Test > Apache JMeter
and point it to the apache-jmeter-5.0 directory.

@ preferences O x

type filter text Apache JMeter o )
Data Managemern ~
Help
Install/Update
v Java
Logging
Plug-in Developm
Prafiling
Quality Manager A
Report Design
Run/Debug
Server
» Team
« Test
Accounts
Apache IMeter
Data Correlatio
Data Cormrelatio
Dataset Creatio v
< >

(@ Apply and Close Cancel

JMeter Installation directory | C\Program Files\IBM\apache-jmeter-3.0\apache-jmeter-5.0 Browse...

Restore Defaults Apply
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« Set the environment variable JMETER_HOME and point it to the apache-jmeter-5.0 directory.

Edit System Variable d

Variable name: ‘JMETER_HOME ‘

Variable value: ‘ C\Program Files‘\lBM‘\apache-jmeter-S.G\apache-jmeter-S.Dl ‘

Browse Directory... Browse File... OK Cancel

Importing a JMeter test to a Test Workbench project

You can import your JMeter tests to HCL OneTest™ Performance to run them as part of VU schedule.

About this task

If you have an existing JMeter test, you can import the test by dragging and dropping a JMeter file (JMX file) into the

project in the test navigator. Alternatively, you can use the following procedure to import the tests.

1. In the Test Navigator, right-click and click Import.

2. In the Import dialog box, expand General in the source list, select File System and then click Next.

3. Specify the directory where the JMeter test resides.
Click Browse to select a directory from where you can import the JMeter test. The JMeter test assets in the
folder you selected are displayed.

4. Select the JMeter test you want to import.

5. Click Browse to choose the location to import JMeter test.

6. Click Finish. The imported JMeter test is displayed in the JMeter Tests folder.

Adding a JMeter test to an existing VU schedule

You can add a JMeter test to an existing VU schedule to test the performance of both static and dynamic resources

and web applications.
About this task

When you add a JMeter test to a VU schedule, a user group with a loop is created and this loop contains the JMeter

test invocation.

1. In the Test Navigator, browse to the schedule and double-click it. The schedule editor opens.

2. In the VU schedule editor, right-click the Schedule, and then click Add > JMeter Test.

3. In the Select Tests window, expand the project name and JMeter Tests folder and choose the test that you
want to add.

4. Click OK. A new User Group with a loop that contains the JMeter test invocation is created.
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What to do next

You must run the schedule or compound test, to view the statistics on the executed sequences.

- To install the JMeter, see Installing the JMeter on page 104.

« To run the schedule or compound test, see Running a local schedule or test on page 594 or Running

compound tests on page 472.

Converting JMeter tests to VU schedule
You can convert a JMeter test to a VU schedule to load and test the performance of an application under test.
About this task

HCL OneTest™ Performance analyzes the selected JMeter test to add the number of users and loop iteration count in
the VU schedule. When you convert the JMeter test to a VU schedule, the following events occur:

« The load information identified within the Thread Group nodes from the original JMeter test is examined to

build a new VU schedule.

- The content of each Thread Group node is extracted from the original JMeter test and copied into a new

JMeter test.
» The new JMeter test is then invoked by the VU schedule as an external test.

Note: The extracted JMeter test does not contain any load information such as the number of users

and loop count, because the VU schedule manages all the information.

n Remember:

« The content of the original Thread Group is not considered during the conversion process. Therefore,
if there are any loops in the JMeter Thread Group, those cannot convert into a loop element in the new
VU schedule.

« If you have a JMeter test with more than one Thread Group node, each Thread Group is extracted to

separate the JMeter test.

« If you have a complex JMeter test, you must extract the functionalities that are included in the
Modules or Include controllers into another JMeter tests. You must then add those JMeter tests to a

VU schedule to run it.

1. Browse and select the JMeter test from the Test Navigator.
2. Right-click the selected test, and then click Convert to VU Schedule.

3. Verify that the name of the schedule is same as name of the JMeter test.
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4. Click Finish.
Result
The schedule editor opens.

What to do next

You must perform the following tasks:

« Install JMeter on the remote agent machine and set the JMETER_HOME environment variable to the root

installation folder to run the JMeter test as part of schedule. See Installing the JMeter on page 104.

« Run the converted test assets against successive builds of the application under test. See Running a local

schedule or test on page 594.
 Analyze the test results that are recorded. See Running compound tests on page 472.

JMeter Performance report

The JMeter performance report summarizes the validity of the run, shows the average sample response time for the

requests in the test, and graphs the sample response time of each sample for a specified interval.

Overall page

The Overall page provides a progress indicator that shows the status of the run and a bar chart that shows
percentage of passed JMeter samples.

Summary page

The Summary page provides important information about the run. This page shows the following Run Summary
information:

» The name of the test.

» The number of active users and the number of users who completed testing. This number is updated during

the run.
 The elapsed time is the run duration, which is displayed in hours, minutes, and seconds.

« The status of the run. For example, the status can be Initializing Computers, Adding Users, Running,
Transferring data to test log, Stopped, or Complete.

JMeter Samples page

JMeter samples are terminal elements in JMeter tests that informs JMeter to send requests to a server and wait for a
response. The JMeter Samples page shows the average sample response time for all the requests in the test. The bar
chart shows the average sample response time for all the requests. Each bar represents a sampler of the JMeter test.
The corresponding table provides the following additional information:
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» The minimum, average, and maximum duration for each sample in the run.
« The standard deviation of the duration.

« The completed sample rate and total number of completed samples per request.

JMeter Transaction page

The JMeter Transaction page shows the average transaction response time for all the requests in the test. The bar
chart shows the average transaction response time for all the requests. Each bar represents a page that you visited

during recording. The corresponding table provides the following additional information:

« The minimum, average, and maximum duration for each transaction in the run.
» The standard deviation of the duration.

- The completed transaction rate and total number of completed transaction per request.

Samples versus Time Summary page

The Samples versus Time Summary page shows the sample response trend as graphed for a specific interval. The
Sample Response versus Time graph shows the sample response time for all the requests during the run. Each point
on the graph is an average of what has occurred during that sample interval. The table after the graph lists the total
average duration for all requests in the run and the standard deviation. To set the sample interval value, open the

schedule, choose the Statistics tab from the drop-down menu, and then view or modify Statistics sample interval.

Samples versus Time Detail page

The Samples versus Time Detail page shows sample response trend for each of the request in the test. The line graph
shows the average sample response time of each requests for a specific interval. The table after the graph provides
the minimum, average, and maximum duration for the run and the standard deviation in the average sample response

time.
Sample Throughput page

The Sample Throughput page summarizes the frequency of requests that are transferred per sample interval. The line
graph on the left side shows the sample rate and passed sample rate per interval for all samples. The summary table
after the graph lists the passed rate of total samples and counts for each passed samples. The line graph on the right
side shows active users and the users who completed testing, per interval, over the course of a run. You can set the
Statistics sample interval value in the schedule, as a schedule property. As the run nears completion, the number of
active users decreases and the number of completed users increases. The summary table after the graph lists the
active and completed users for the entire run.

To set the sample interval value, open the schedule, choose the Statistics tab from the drop-down menu, and then
view or modify Statistics sample interval.
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Server Throughput page

The Server Throughput page lists the rate and number of bytes that are transferred per interval and for the entire run.
The page also lists the status of the virtual users for each interval and for the entire run. The line graph on the left side
shows the rate of bytes sent and received per interval for all intervals in the run. The summary table after the graph
lists the total number of bytes sent and received and bytes sent and received throughput rate for the entire run.

The line graph on the right side shows active users and users who are completed testing, per interval, over the
course of a run. You set the Statistics sample interval value in the schedule, as a schedule property. As the run nears
completion, the number of active users decreases and the number of completed users increases. The summary table

after the graph lists the active and completed users for the entire run.

Server Health Summary page

The Server Health Summary page gives an overall indication of how well the server is responding to the load. The bar
chart shows the total number of samples and total number of passed samples for the run. The table under the bar
chart lists the same information.

Server Health Detail page

The Server Health Detail page provides specific details for 25 samples with the lowest success rates. The summary
table lists the number of samples completed and passed in the run, and the passed sample percent and completion

rate.

EGit integration

EGit is an Eclipse plugin for the Git version control system. You can store your test assets in the Git repository and
use EGit for the daily version control operations.

When you install the product, by default EGit is part of the product. To avoid the clutter, EGit is a separate Eclipse
perspective in the product. For more information about EGit, read its documentation.
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In Eclipse perspective, when you initialize a new Git repository for a project, a. gi t i gnor e file is created in the
project folder, by default. While committing the contents of a project to Git, the . gi t i gnor e file ignores the report
files.

Note:

- After you pull a project in Git perspective, 'Project is missing required Library' error appears in the
Verify Problems tab. This error occurs due to the .classpath file which is specific to a workspace or
system and needs to be pointed to the newly imported location. To resolve this issue:

1. Under Package Explorer, from the required project, navigate to Java Build Path > Libraries.
2. Delete all the jar files that are missing after the pull. These files are marked with a red cross.
3. Playback the project. The required jar files are added to the project.
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- You can also specify additional file types in the . gi t i gnor e file so that these file types are ignored
while committing the project contents to Git.

Integration with Rational® Quality Manager

You can integrate Rational® Quality Manager with HCL OneTest™ Performance to initiate test runs from Rational®

Quality Manager.

To run tests from Rational® Quality Manager, you must configure the default adapter that is installed when you
install HCL OneTest™ Performance.

You can run the adapter in the following modes:

« GUI
« CLI

» Windows™ service

Rational® Quality Manager reports

When you run a test script from Rational® Quality Manager, the default report that is displayed during a test run is
attached to the results of Rational® Quality Manager. You can customize the reports based on your requirements.

See Customizing reports on page 750.

If you use Rational® Quality Manager 4.0 or later, you can view and analyze the test reports in Rational® Quality
Manager. You can analyze the test reports while the test is in running state and after the test run is complete. You can
click the Analyze Results Interactively using HCL OneTest™ Performance option from the Execution Results dialog

box to view the test reports in Rational® Quality Manager.

Note: To access reports from outside of HCL OneTest™ Performance, you must enable the remote access

from HCL OneTest™ Performance. See Access reports remotely on page 772.

The result completion state that is reported to Rational® Quality Manager reflects the overall verdict of the test
log that is associated with the run. See Logs overview on page 769. In many cases, a test might contain a failed
verification point, but still is considered as passed. You can view the attached report in the execution result of

Rational® Quality Manager, and then set the execution results status accordingly.

You can view the full run results from within HCL OneTest™ Performance by opening HCL OneTest™ Performance in

the workspace that is configured to be used by the adapter.

If the adapter is running from the command line or as a Windows™ service, you must stop the adapter before opening
HCL OneTest™ Performance. When HCL OneTest™ Performance is opened, you can access the full test reporting and
test log capabilities. The test results for the runs that are initiated from Rational® Quality Manager are under the
Rational® Quality Manager Results page.
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For HCL OneTest™ Performance schedules, the result completion state that is reported to Rational® Quality Manager
is based on the overall Requirements status. Only performance and functional requirements for the last user stage
that is defined in the schedule are covered by the report. If no requirements are specified, the result completion state
in Rational® Quality Manager is set to inconclusive. In this case, you can view the attached performance reports

and manually set the completion state in Rational® Quality Manager. See Defining requirements in schedules on

page 544.
Known limitations

- You cannot run tests from Rational® Quality Manager with encrypted datasets. When using such datasets,
a password prompt is not displayed in the adapter service or in the command-line interface. The use of
encrypted datasets are not recommended in the GUI mode, because it requires user interaction with HCL
OneTest™ Performance to initiate test runs from Rational® Quality Manager.

« You can start only one adapter per product installation on a given computer. If you use multiple adapters on
the same computer, it requires you to install each product as its own software package in its own directory. If
you want to run multiple adapters on the same computer, you must ensure that adapters are using different

workspaces.

For information about using Rational® Quality Manager, refer to the IBM® Rational® Quality Manager

documentation.

Refer to the following topics to learn more about integrating Rational® Quality Manager with HCL OneTest™

Performance.

Configuring the Rational® Quality Manager adapter

You must configure the Rational® Quality Manager adapter to establish a successful connection between HCL

OneTest™ Performance and Rational® Quality Manager.

Before you begin

« You must have the following information:
o The URL of the Rational® Quality Manager server.
> A user credential and valid license to access Rational® Quality Manager.

> The user account must be added to the project area that is being accessed by the adapter with write
permissions to the project.

« You must have added - Dhpt cost confi r mto the ecl i pse. i ni file before you run a test from Rational®
Quality Manager.

The ecl i pse. i ni file must be available at the installation directory of HCL OneTest™ Performance.
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For more information about Rational® Quality Manager, refer to the IBM® Rational® Quality Manager

documentation.

1. Open HCL OneTest™ Performance.
2. Click Window > Preferences > Quality Manager Adapter.
3. Enter the following information of the Rational® Quality Manager:

Fields

Actions

Server URL

Enter the URL of Rational® Quality Manager.
For example, ht t ps: // <host nanme>: <por t nunber >/ gm
Note: If you rename the Rational® Quality Manager server, you must perform
the following tasks:

a. Update the Rational® Quality Manager server name in the hosts file

with a new name.

b. Update the Server URL field with the new name.

c. Configure the adapter to point to the new URL.

Adapter name

Enter a unique name to identify the Rational® Quality Manager adapter. The Ratio-
nal® Quality Manager adapter uses the name of the computer as the default name of

the adapter.

Project area

Enter the name of the project area in Rational® Quality Manager.

4. Select one of the following Authentication type from the drop-down list to connect to Rational® Quality

Manager:

Authentication type

Actions

Username and

Perform the following steps:

Password
a. Enter the username associated with Rational® Quality Manager in the User ID
field.
b. Enter the password associated with the username of Rational® Quality Man-
ager in the Password field.
KERBEROS

Click Browse to locate and select the ker ber os. i ni file in the Configuration File

field.

113


https://www.ibm.com/docs/en/elm/6.0.6.1?topic=rational-quality-manager
https://www.ibm.com/docs/en/elm/6.0.6.1?topic=rational-quality-manager
https://www.ibm.com/docs/en/elm/6.0.6.1?topic=rational-quality-manager
https://www.ibm.com/docs/en/elm/6.0.6.1?topic=rational-quality-manager
https://www.ibm.com/docs/en/elm/6.0.6.1?topic=rational-quality-manager

HCL OneTest Performance

Authentication type Actions

Note: The ker ber os. i ni file is automatically created when you set up Ker-

beros.

For example, on Windows systems, you can locate the file in the c: \ wi ndows\ kr -
b5. i ni . The file name and the location might change based on the operating sys-

tems.

SSLCERT
Perform the following steps:

a. Enter the location of the SSL certificate keystore in the Certificate Location

filed.

b. Enter the keystore password in the Password field.

Note: The expected format of the keystore is p12. The keystore must contain
the client certificate that the adapter uses when you authenticate with Ratio-

nal® Quality Manager.

SMARTCARD Select a certificate from the drop-down list from the Certificate Selection field.

5. Optional: Select the Enable Proxy checkbox to connect through a proxy computer and perform the following
steps to enter the Proxy Details of the computer:
a. Enter the hostname of the proxy computer in the Host field.
b. Enter the port number of the proxy computer in the Port field.
c. Enter the username and password of the proxy computer in the User and Password fields.

6. Click Apply and Close to save and close the configuration.

Results

You have configured the details of Rational® Quality Manager on HCL OneTest™ Performance.

What to do next

You must start the adapter from HCL OneTest™ Performance, command-line interface, or as a Windows service.

Related information

Connecting and disconnecting the Rational Quality Manager adapter from the GUl mode on page 115

Starting and stopping the Rational Quality Manager adapter from the command line on page 117

114



Chapter 5. Administrator Guide

Starting and stopping the Rational Quality Manager adapter as a Windows service on page 118

Importing test assets into Rational Quality Manager on page 120

Configuring the workspace directory of the adapter

You must configure the workspace directory of the adapter to start or stop the Rational® Quality Manager adapter

either from command-line interface or as a Windows service.

About this task
If the Use resources that are local to a test machine option is set in Rational® Quality Manager, then the

WORKSPACE_DIR must be set to the same workspace where your test assets are located.

1. Locate the adapt er . confi g filein the product _i nstal | _di r \ HOT- PERF_RQVAdapt er\ confi g\
directory.

Where product_install_dir is the directory where HCL OneTest™ Performance is installed.

For example, C: \ Progr am Fi | es\ HCL\ HCLOneTest .

2. Edit the WORKSPACE_DIR variable in the adapt er . confi g file to point to the same test workspace that you
want the adapter to use.

For example, WORKSPACE_DI R= C:\ User s\ user nane\ HCL\ HCLOneTest \ ny_adapt er _wor kspace.

Results

You have configured the workspace directory of the adapter.

What to do next
You can start or stop the Rational® Quality Manager adapter either from command-line interface or as a Windows

service.

Connecting and disconnecting the Rational® Quality Manager adapter from the GUI
mode

You can use the Quality Manager Adapter view to connect, disconnect, and view adapter activities from HCL
OneTest™ Performance.

Before you begin
You must have configured the Rational® Quality Manager adapter. See Configuring the Rational Quality Manager
adapter on page 112.

About this task
In the GUI mode, when a script is run from Rational® Quality Manager, you can see the test run in progress inside

HCL OneTest™ Performance as though the test were run manually in HCL OneTest™ Performance.
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Push buttons to connect and disconnect to the Rational® Quality Manager server are located in the upper-right
corner of Quality Manager Adapter view. This view also has a local preferences menu that you can use to control
some behavior of the GUI mode adapter. If you see errors or warnings, use the Error Log view for further investigation.

Note: You must not use HCL OneTest™ Performance while the adapter is running. If you do so, you might
interfere with the ability of the adapter to run test scripts. You must stop the adapter before you open HCL
OneTest™ Performance.

The following image displays the activities of the adapter in the Quality Manager Adapter view:

g, Problems &9 Recording Control [ Protocol Data &l Quality Manager Adapter 22 % Git Staging

Connection status; Communication error with server.

Test script: -

Start time: 5

End time: =
Messages Date

| i Adapter is successfully connected to the server. 26-Nov-2021, 11:43:23 am
% Communication errar with server. 26-Nov-2021, 11:43:22 am

1. Open HCL OneTest™ Performance.
2. Click Window > Show View > Quality Manager Adapter.
3. Perform the following actions either to connect or disconnect the adapter:

(-]
o Click the Connect to RQM icon to connect the adapter.

e

o Click the Disconnect from RQM icon to disconnect the adapter.

Results
You have connected or disconnected the Rational® Quality Manager adapter from HCL OneTest™ Performance.
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Related information

Rational Quality Manager overview on page 39

Configuring the Rational Quality Manager adapter on page 112

Starting and stopping the Rational Quality Manager adapter from the command line on page 117
Starting and stopping the Rational Quality Manager adapter as a Windows service on page 118

Importing test assets into Rational Quality Manager on page 120

Starting and stopping the Rational® Quality Manager adapter from the command
line
You can use the command-line interface to start, stop, and view activities of the conref="../prodnames/

prodnames.dita#prodnames/RQM_fam" /> adapter that you configured in conref="../prodnames/

prodnames.dita#prodnames/RPT_fam" product="rpt"/>.
Before you begin

You must have performed the following tasks:

« Configured the adapter in conref="../prodnames/prodnames.dita#prodnames/RPT_fam" product="rpt'/>. See

Configuring the Rational Quality Manager adapter on page 112.

- Configured the workspace directory of the adapter. See Configuring the workspace directory of the adapter on

page 115.

About this task

When you run test assets from the command-line interface, the adapter activities are printed to the adapt er . | og file
that can be accessed from pr oduct _i nstal | _di r\ HOT- PERF_RQVAdapt er\ | ogs.

To print the current status of the adapter, you must navigate to the pr oduct _i nst al | _di r\ HOT-
PERF_RQVAdapt er\ bi n directory, and then you can run the RQMAdapter.bat STATUS command.

Where, product _i nst al | _di r is the installation directory of conref="../prodnames/prodnames.dita#prodnames/
RPT_fam" product="rpt"/>.

1. Warning: You must not use conref="../prodnames/prodnames.dita#prodnames/RPT_fam" product="rpt"/
> while the adapter is running. You must stop the adapter before you open conref="../prodnames/
prodnames.dita#prodnames/RPT_fam" product="rpt"/> for any reason.

1. Open a command-line interface.
2. Navigate to the pr oduct _i nst al | _di r\ HOT- PERF_RQVAdapt er \ bi n\ directory.
3. Perform the following step either to start or stop the adapter:
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> Run the following command to start the adapter from the command line:

Operating system Command to be run
Windows™ RQMAdapter.bat START
Linux™ RQMAdapter.sh START

> Run the following command to stop the adapter from the command line:

Operating system Command to be run
Windows™ RQMAdapter.bat STOP
Linux™ RQMAdapter.sh STOP

Results
You have started or stopped the conref="../prodnames/prodnames.dita#prodnames/RQM_fam" /> adapter from the

command-line interface.

Related information

Rational Quality Manager overview on page 39

Configuring the Rational Quality Manager adapter on page 112

Connecting and disconnecting the Rational Quality Manager adapter from the GUI mode on page 115
Starting and stopping the Rational Quality Manager adapter as a Windows service on page 118

Importing test assets into Rational Quality Manager on page 120

Starting and stopping the Rational® Quality Manager adapter as a Windows™
service

You can use the Windows™ service to start, stop, and view adapter activities.
Before you begin

You must have completed the following tasks:

« Configured the adapter in HCL OneTest™ Performance. See Configuring the Rational Quality Manager adapter
on page 112.

« Installed Microsoft™ .NET Framework 3.5.x in Windows systems for the adapter service.

- Configured the workspace directory of the adapter. See Configuring the workspace directory of the adapter on
page 115.

About this task
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When you install HCL OneTest™ Performance, you must install the adapter as a Windows™ service. The default status
of Startup Type is set to Manual.

A e i geigge mm e g

£ Group Palicy Client The service is responsible for applying setti. Running  Automatic (Tri. Local System

:#3 HCL OneTest Performance adapter for ROM Manual Local System

&} Human Interface Device Service Activates and maintains the use of hot butt. Manual (Trigg. Local System

L HV Hnct Sanire Prewsicdee an intarfars far tha Huner.\ huner Mannal Mrinn  Local Suctam

Optionally, to configure the service to start automatically, you can right-click the adapter listing, and then select
Properties. You can then select Automatic from the drop-down list in the Startup Type field. Therefore, the adapter

can start automatically when you restart your computer and does not require you to log in.

Notes:

- When you start the adapter as a service, you cannot run the Web Ul tests of HCL OneTest™ Studio
from Rational® Quality Manager.

« You must not open HCL OneTest™ Performance in the same workspace while the adapter is running
as a Windows™ service. You must stop the adapter before you open HCL OneTest™ Performance in
the configured workspace.

When you run the adapter as a service, the status of the adapter is printed to the adapt er . | og file that can be
accessed from pr oduct _i nst al | _di r\ HOT- PERF_RQVAdapt er \ | ogs.

You can also print the current status of the adapter by navigating to the pr oduct _i nst al | _di r\ HOT-
PERF_RQVAdapt er\ bi n\ directory, and then run the RQMAdapter.bat STATUS command.

1. Open the Windows™ services.

2. Perform the following step either to start or stop the adapter:
o Right-click adapter for RQM and, then click Start to start the service.

o Right-click adapter for RQM and, then click Stop to stop the service.

Results

You have started or stopped the Rational® Quality Manager adapter as a Windows service.

Related information

Rational Quality Manager overview on page 39
Configuring the Rational Quality Manager adapter on page 112

Connecting and disconnecting the Rational Quality Manager adapter from the GUI mode on page 115
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Starting and stopping the Rational Quality Manager adapter from the command line on page 117

Importing test assets into Rational Quality Manager on page 120

Importing test assets into Rational® Quality Manager

You can import the performance and service tests into Rational® Quality Manager by using an adapter.
Before you begin

The adapter must be running on a computer where the test assets are located.

About this task

The names of script types, HCL OneTest™ Performance, HCL OneTest™ Ul, and HCL OneTest™ Studio, are compatible
with HCL OneTest™ Performance, HCL OneTest™ Ul, and HCL OneTest™ Studio products.

1. Login to Rational® Quality Manager.
2. Click Construction > Import Test Scripts.
3. Select one of the following test scripts in the Script Type field:
a. HCL OneTest Performance to import a performance test or schedule from HCL OneTest™
Performance.
b. HCL OneTest Ul to import a functional test from HCL OneTest™ UL.
c. HCL OneTest Studio to import a Web Ul test from HCL OneTest™ Ul or import a test from HCL
OneTest™ Studio.
4. Select Use test resources that are local to a test machine, and click Select Adapter.
5. Select the computer on which the adapter is running, and click Next.
6. Enter the name of the project in the Project Path field, and then click Go.

Note: You must specify only the project name and not the entire path to the project.

7. Select the test assets that you want to import, and then click Finish.

8. Select those test assets to import again, and then click Import.

Results
You have imported the test assets to Rational® Quality Manager by using the adapter.

Related information

Rational Quality Manager overview on page 39
Configuring the Rational Quality Manager adapter on page 112
Connecting and disconnecting the Rational Quality Manager adapter from the GUI mode on page 115

Starting and stopping the Rational Quality Manager adapter from the command line on page 117
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Starting and stopping the Rational Quality Manager adapter as a Windows service on page 118

Testing shared assets with Rational Quality Manager on page 121

Testing shared assets with Rational® Quality Manager

You can make test projects and assets shareable in Rational® Quality Manager. By sharing assets, any computer

with your product, that is connected to Rational® Quality Manager can execute a test or schedule.
Before you begin

When you are working with tests or schedules from a remote shared location, HCL OneTest™ Performance uses

a local workspace for the Rational® Quality Manager adapter. This adapter workspace is different from normal
workspaces because the test assets are stored remotely. This means that every asset that is related to the test or
schedule is downloaded from the shared location into the local workspace before execution. The following limitations
apply:

« Assets in the adapter workspace might be deleted or overwritten with newer versions when updates are made

to the shared location.

« If you change the shared location in the adapter workspace, the entire project is removed from the adapter

workspace.
« Test results are stored in a different project, called RQM_Resul t s, and are never deleted. The Rational®

Quality Manager test result page links to the correct location.

Note: Do not edit test assets in the adapter workspace because you might lose your work. You must use
these assets only for running tests and schedules.

If you are using source control and want to include only the minimum required assets, then include the following files:

« All *. t est sui t e tests and schedule files
» The/ sr ¢ directory if you use custom code
- All *. dp dataset files

« All*. | ocat i on location files

« All digital certificates

« All WSDL and SOA security files

121



HCL OneTest Performance

Note: All other assets, such as test results, are not required.

Custom code Java™ classes in the shared assets cannot use libraries that are outside the workspace. If your custom
code must use such a library, then copy the library into the project, and update the classpath to use the local copy.

1. Create a shared directory on the computer that hosts the UNC file system that contains the test projects to
share.
Example
For example, create a directory called: C: \ MyRenot eWor kspace.

2. Copy the test projects to share into the shared directory.
If a project is stored in source control software, then copy it from there.

3. Check that the Rational® Quality Manager server can access the shared directory by using UNC paths.
Example
For example, the \\ MySer ver \ RPTRenot eAsset s\ path must be mapped to the C:
\ MyRenot eWr kspace directory.

4. In Rational® Quality Manager, specify the directory that contains the actual test projects that are located in
the shared directory.

5. Verify that you have correctly specified the UNC shared directory by browsing for the shared resource. Ensure
that the first dialog box contains the projects at the first level.
You must not have intermediate directories between the UNC shared directory and the project directory.

Related information

Rational Quality Manager overview on page 39
Configuring the Rational Quality Manager adapter on page 112

Importing test assets into Rational Quality Manager on page 120

Integration with Rational® Team Concert™

You can integrate Rational® Team Concert™ to create and track defects (bugs) or other work items, as a defect

tracking tool in HCL OneTest™ Performance.

You can use HCL OneTest™ Performance to record and play back tests for the application that you develop and view
their results. When you discover that you might want to raise defects, issues, or other types of work items for the test

assets, you can create defects, issues, or other work items without the need to open Rational® Team Concert™.
For more information, refer to the Rational® Team Concert™ documentation.

The following table lists the tasks that you must perform to integrate HCL OneTest™ Performance with Rational®

Team Concert™:
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Tasks

Go to...

Install HCL OneTest™ Performance.

Installing the software by using stand-alone installer on

page 79

Create any or all of the following types of test assets in

HCL OneTest™ Performance to test your application:

« Compound tests
 Performance tests
« Schedules (Rate or VU Schedules)

Test Author Guide on page 153

Install Rational® Team Concert™ and gain access to it.

Rational® Team Concert™ documentation

Run the test assets.

Running a local schedule or test on page 594

Configure the Rational® Team Concert™ server URL in

HCL OneTest™ Performance.

Configuring the URL of Rational Team Concert on

page 123

Create defects from HCL OneTest™ Performance.

Tracking defects with Configuring the URL of Rational

Team Concert on page 124

Configuring the URL of Rational® Team Concert™

You must configure the URL of the Configuring the URL of Rational® Team Concert™ server to use it as defect

tracking tool in HCL OneTest™ Performance.

Before you begin

You must have the URL of the Configuring the URL of Rational® Team Concert™ server.

About this task

Bugzilla is configured as the default defect tracking tool in the Preferences window of HCL OneTest™ Performance.

If you are using Configuring the URL of Rational® Team Concert™ to create and track defects (bugs), you can provide

the URL of the Configuring the URL of Rational® Team Concert™ server to search, submit, or add work items to test

results from HCL OneTest™ Performance.

1. Open HCL OneTest™ Performance.

2. Click Window > Preferences > Test > Test Log Editor.

3. Enter the URL of the Configuring the URL of Rational® Team Concert™ server in the following fields:

Fields

Format of the URL

Submit URL

https://rgm exanpl e. com 9443/ ccm web/ proj ect s/ pr oj ect nanme#ac-
ti on=com i bmteam workitem newbrkltem
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Fields Format of the URL

Search URL |https://rgm exanpl e. com 9443/ ccni web/ pr oj ect s/ pr oj ect name#ac-

tion=comibmteam workitem neworkltem

Open URL https://rgm exanpl e. com 9443/ ccm web/ proj ect s/ pr oj ect nanme#ac-

tion=comibmteam workitem neworkltem& d=

Where,
o rgm exanpl e. com 9443 is the URL of the Configuring the URL of Rational® Team Concert™ server.

> proj ect name is the name of the project in the Configuring the URL of Rational® Team Concert™ server.

Note: You must update the URL, if there is a change in the name of the project in Configuring the URL
of Rational® Team Concert™.

4. Click Apply and Close to save the configuration and close the Preferences window.

Results
You have configured the URL of Configuring the URL of Rational® Team Concert™ in HCL OneTest™ Performance.

What to do next
You can create defects for the test results that are available in your project in HCL OneTest™ Performance. See
Tracking defects with Configuring the URL of Rational Team Concert on page 124.

Tracking defects with Configuring the URL of Rational® Team Concert™

You can submit defects to Rational® Team Concert™ from HCL OneTest™ Performance. By default, the test log editor
uses Bugzilla as the defect tracking site. You must configure the product to use Rational® Team Concert™ for defect

tracking.

1. Click Window > Preferences > Test > Test Log Editor.
Result
The Test Log Editor preferences window opens.
2. Specify the URL of Rational® Team Concert™ server in the Submit URL, Search URL, and Open URL fields.
Contact the administrator of the Rational® Team Concert™ server for more information.
Example
The following are the example of URLs, where the name of the Rational® Team Concert™ server is

rgm.example.com and the name of the project is projectname:

124



Chapter 5. Administrator Guide

Table 2. Example of EVM Server URL

Field

names

Field values

Submit |https://rgm exanpl e. com 9443/ j azz/ web/ pr oj ect s/ pr oj ect name#ac-
URL tion=comibmteam workitem newMérkltem

Search |https://rgm exanpl e. com 9443/ azz/ web/ pr oj ect s/ pr oj ect nane#acti on=j az-

URL z.vi ewPage& d=com i bmteam workitem

Open https://rgm exanpl e. com : 9443/ j azz/ web/ pr oj ect s/ pr oj ect nane#ac-

URL tion=comibmteam workitem vi ewMbr kl t en&i d=

Note: You must change the URLs, if there is change in name of the Rational® Team Concert™ server.

Related information

Logs overview on page 769

Testing with HCL OneTest™ API

Starting from v9.1.1, you can use HCL OneTest™ API extension to execute API tests. In HCL OneTest™ Performance,
you can either import the projects from HCL OneTest™ APl or manage them from HCL OneTest™ Performance by
establishing the connection between the products. In HCL OneTest™ Performance, you can create a schedule or

compound test to run the IntegrationAPI tests by using the Agents.
Before you begin
To be able to work with API tests, you must install HCL OneTest™ Performance Extension for HCL OneTest™ API.

You also need a HCL OneTest™ Performance agent or a HCL OneTest™ API agent to execute the tests remotely. When

installing HCL OneTest™ API agent, it is recommended to choose This Agent will only run probes option.

Moreover, if you update API tests in HCL OneTest™ Performance and want to apply the updates back to HCL
OneTest™ API, you must install HCL OneTest™ API and define the path to its installation directory to set the
connection.

Following are the use cases to work with API tests in the HCL OneTest™ Performance:

« Both the products are installed and you connect to the API project, or you open the API resource directly from
Test Navigator view and you work directly with the sources files.

« HCL OneTest™ APl is not installed and you import the projects in the HCL OneTest™ Performance workspace.
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Note: The imported tests must be edited in HCL OneTest™ API. Similarly, the schedules and

compounds tests must be edited in HCL OneTest™ Performance.

» To execute Performance tests with imported tests on page 133, the HCL OneTest™ APl agent
must be installed along with the HCL OneTest™ Performance agent. The environment variable
INTEGRATION_TESTER_AGENT_HOME must be defined on each location where the agent is installed, and
must point to the root directory of the HCL OneTest™ API agent installation.

The following environment variables must be set to apply licenses:
HCL_LICENSING_ID = ServerID

HCL_LICENSING_URL = Server url
Connecting to an existing API project
When you connect both the products any change or delete action made in one product workspace is reflected on the

other product workspace, if both the products are installed on your machine.

1. Warning: If you delete a project from the Test Navigator, be sure that the option Delete project contents on

disk is not selected in the Delete Resources dialog, otherwise the project would be deleted in HCL OneTest™

APl if it is connected.
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@ Are you sure you want to remove project ‘RIT-DOC from the workspace?

Remaove references to the deleted resources in other test assets
[ Delete files that are referenced only by the deleted test assets (requires preview)
%Delete project contents on disk (cannot be undone)

Project location:
ChUsers\IBM_ADMIN\IBMYrationalsdphworkspace\RIT-DOC

« In HCL OneTest™ Performance, right-click on the Test Navigator, select New > Other > Connect to an HCL
OneTest™ API Project and click Next.

Wizards:
conr|
4 = Connection Profiles
< Connection Profile
" Connection Profile Repositony
4 = Integration Tester
1 Cmnectgu an Integration Tester project

« In the wizard page, click Browse and select the root folder that contains the project.

If the path contains a project, its name should automatically appear in Project Name and the Finish button
should be enabled.
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- In When project is connected, you have to perform one of the following actions:
> Click Do nothing to only import the project.
- Click Open Create Rate Schedule wizard to select the test, create a Rate Schedule, and add the test to
it.
o Click Open Create VU Schedule wizard to select the test, create a VU Schedule, and add the test to it.
o Click Open Create Compound Test Wizard to select the test, create a Compound test, and add the
test to the Compound test. For more details, see Creating a compound test on page 469 and Adding

tests into a compound test on page 471.

For example: select the Open Create VU Schedule wizard action and click Next.

| Connect to Rational Integration Tester Project
Choose a folder containing Integration Tester projects

To use an éxisting project you must first connect 1o it
Select folder where existing Rational Integration Tester project is located.

Project path: C\Users\IBM_ADMIN\RITTest2

Project pame: RITTest2

When project is connected:
) Do nothing.

Open create Compound Test wizard.

The Create Rate Schedule for Integration Tester or Create VU Schedule for HCL OneTest™ API

wizard displays the list of tests contained in your project.

o Select one or more tests and click Next.
o In Schedule File Name and Location wizard, select a schedule in an existing project, or create it from
this window. You just need to enter a name for the new schedule and click Finish. The procedure is the

same for the compound test.

- Connect to Hi

Choose a fold

Touse an exist

- Zelectfolder wl

4 = : r-
- Project path: |

 Project name:

When project
71 Do nothin
@ Open crea
(71 Open crea

() Open crea
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> The Test Navigator displays the projects:

= The HCL OneTest™ API project you are connected to, or that you imported, with the tests.
= The HCL OneTest™ Performance project containing the schedule or compound test. If HCL
OneTest™ API is installed, Connected is indicated near the name of the project in the Test

Navigator. The Schedule or compound test automatically opens in the dedicated editor.
=

i @ RTCP
# o Framples
* &% pRONeDO0K
@ % AD
> getEntry

) gueryPhonebook

(0]

4 = Performance Tester project
= src
Compound Tests
Datapools
Locations
Results
4 (= Schedules

& PhoneBookSchedule
Tests

Setting HCL OneTest™ API preferences

To be able to open an HCL OneTest™ API project from HCL OneTest™ Performance Test Navigator, you need to have

both the products installed on the same computer, and you must set the path to the execution file in the Preferences.

« In HCL OneTest™ Performance, click Window > Preferences > Test > HIT Integration.

« Click Browse and set the installation path to HCL OneTest™ API execution file. On Windows, the default
location would be C: \ Progr am Fi | es\ HCL\ | nt egr ati onTest er. exe.

« Click Apply and OK.
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B Preforences.

[ : RAIT Integration =i -

£
i

Tegem Bashd
Tesm Process
S
* Argouty
Dt Coerelation Rids |
Dty Crarelation Rk |
BTTP Protocod Dust Wi
Limresing
Parfarmance Resonce
Farformancs Test Fron
Parfremance Test Rep
Eustional Test Conkrol F
+ - Bngording
RIT nbegration
Tl
% Test Edboe
Test Exeoution a=d
- Wash Garvration
Tast Lo Ector
Wahdation =
i 3

4

7

@l Preferences

type filter text

a Test -

Accounts

Apache IMeter

Data Correlation Rule Editor
Data Correlation Rule Log View
Dataset Crestion

FT Expenmental Features
Functional Test

HCL Licensing

HCL Quiality Server

HOT-AP] Integration

HTTP Protocol Data View
Mobile and Web Ul

Perfecto Mobile

Perfarmance Resource Maonitor)
Performance Test Provisioning |~
Performance Test Reports
Recording

Server

Test Editor

Test Execution

Test Generation

Test Log Editor -

] m 3

¥+ Rational Integration Tester s rntabed on this maching
Enbegration Tester Laurcher: I':."l?-'w-r-? SN stonalintegrath | Browse. I

l!crs-rml:w:l'uf-l Apply E

= [2 =]
HOT-AFI Integration R T
W HCL OneTest APLis installed on this machine
HCL OneTest APTlauncher: | C:AProgram FilessHCLYHCLProducks\APInteqrationT ester, exe 'Brm_:...‘
lesbore Defwlti| . Apply

Apply and Clusei [ Cancel ]

Opening HCL OneTest™ API resources from the Test Navigator

« Once the preferences are set, you can open an HCL OneTest™ API project.

« In the Test Navigator, open the project root node and children nodes, and at any level, right-click and select
Open in HCL OneTest™ API Workbench.
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=¥ custom_code_tests

«@Rr MNew
4 {3 @ en in Integration Tester Workbench...
“ Go Into
iE Copy

If HCL OneTest™ API is automatically detected, the workspace opens for the selected resources.

If HCL OneTest™ API is not detected, a dialog opens on a Preference page where you need to verify the path to

the execution file.

+ /1. Warning: HCL OneTest™ API cannot open more than one project at a time. If you have another project

open, you will get an error. In that case, close HCL OneTest™ API and try to open the project again.

Importing HCL OneTest™ API project

If both the products are not installed on the same machine, you can import an HCL OneTest™ API project in your
workspace. Another reason for the import is when you have HCL OneTest™ API installed but you do not want
to connect to the HCL OneTest™ API project. In that case, the project is duplicated, any updates in one product

workspace will not be reflected in the other product's workspace.

» To import an HCL OneTest™ API project:
« Right-click on the Test Navigator, choose Import and select Existing project into workspace.
» Choose Select root directory or Select archive file; select a project to import and click Finish.

The selected project appears in the Test Navigator and the compound test or schedule editor automatically

opens.

Modifying HCL OneTest™ API environments in HCL OneTest™ Performance

In the schedule or compound test, you can select HCL OneTest™ API tests and change the environment of each
test. The environments are set in HCL OneTest™ API, you can only change the selection from the edited schedule or

compound test.

» Open the schedule or compound editor and select a test.
- In the HCL OneTest™ API details, you can browse and change the properties of the selected test. The Test

path, the Environments and Decription are automatically updated accordingly.
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Performance Schedule - PhoneBookSchedule & Run Schedule
Schedule Contents Integration Test Details
Enter filter text Options *  Test name: Phon k
« % ﬁhG”EB‘:’DE‘h’Ed”'e Add Test path:  /RIT-DOC/L.nebook.tsq
a i} User Group 1 (100%) .
4 {7+ Rate Generator (30 seconds L IM€™ | [Environment:  1BM180-R903SMLW v
% Datapool Mapper " | Select | Teet description:

5/ getEntryTags

% queryPhonebook '. Remmel -
F:Up
Down |
Prev |

« To select another environment for the Integration Tester test, use the dropdown menu.
Alternatively, you can change the environment selection for a test for a collection of tests:

« Right-click on the tree at any level under a node in the schedule or compound test and select Replace HCL
OneTest™ API Environments.

« In the Set Invocation Tester Environments wizard, the first page displays the list of projects that use the
selected environment and the number of tests from project that use this environment in the schedule or
compound test.

) s T = .55

Set Invocation Tester Environments

Replace enviscnment for selected node and thedr chilidnen _

Project & RITTest uses environment @ TEMLB0-RI0ISMLW for 1 tests)

Replace emdronment by: |BMIS0-RO0ISMUN. =] - " &
Development
IBAMLBI-RODISMLW |

« Select another used environment in the dropdown list. Click Finish. The new choice applies to the selected
node and its children.

Next step is to create a compound test or schedule in to run the Integration tests on page 133, see Creating a VU

Schedule on page 510 or Creating a compound test on page 469.
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You can add a dataset mapper in the compound test or schedule for tests that are using multiple tags. See Adding
Dataset Mapper on page 373 to map tags in the HCL OneTest™ API tests with the variable values of HCL OneTest™
Performance.

Running HCL OneTest™ API tests

You can use HCL OneTest™ Performance Extension for HCL OneTest™ API to run HCL OneTest™ API tests.

You can install both the products on the same machine, establish the connection, and run HCL OneTest™ API tests.
See Testing with HCL OneTest™ APl on page 125.

You also have the option to just import the projects to HCL OneTest™ Performance, add the tests to a schedule or
compound test to run them. You can either use HCL OneTest™ Performance Agent or HCL OneTest™ APl Agent to
generate the load. You need a compound test or schedule that contains the HCL OneTest™ API tests.

Setting environment variable

To run the tests with HCL OneTest™ API Agent, set the environment variable INTEGRATION_TESTER_AGENT_HOME
and point it to the HCL OneTest™ API Agent installation directory.

On Windows, set:

INTEGRATION_TESTER_AGENT_HOME = C:\Program Files\HCL\HCLProducts\Agent

On Linux, set:

INTEGRATION_TESTER_AGENT_HOME=/ opt/ HCL/ HOT- API - Agent
export INTEGRATION_TESTER_AGENT_HOME
echo SINTEGRATION_TESTER_AGENT_HOME

If the variable is not set, you will get a test log with error message when the compound or schedule test is run.

* Problems & Javadoc i Declaration + Search 2 Console | '8 Execution Evert Console :
Sep 20, 2017 10:17:38 AM]

Message
%' Environment variable not set - Integration Tester Agent installation location.
1 ERROR verdict reported
%" 1 ERROR verdict reported

Running the compound test or schedule
« Click Run Compound Test or Run VU Schedule or Run Rate Schedule.

HCL OneTest™ API Performance Report

The report contains the following pages.

133



HCL OneTest Performance

OVERALL

The Overall page provides this information:

- A progress indicator that shows the state of the run.

- A bar chart on the left shows the overall percentage of passed sequences for the entire run. A
sequence corresponds to a test run.

« A bar chart on the right shows the overall percentage of passed timed sections, which are
corresponding to individual sections within the steps of the tests.

RITCompTest [2/26/2019, 7:28 PM] ~

Complete | HOT-AP] Performance Report ~ ‘ Entire Run ~ ‘ All Sources ~ Q

:
- © © © ©
Summary

Initializing Computer(s) Running Performing Test Log Complete

Sequence Throughput Summary data transfer
Sequence Throughput
Sequence Performance 100 #

&0

60

40

20

Passed sequences Passed timed sections
SUMMARY

This page displays information about the run:

» The number of users that are active and the number of users that have completed testing. This
number is updated during the run.

« The elapsed time (run duration)
« The status of the run.

 The Performance Requirements: validates the performance requirements that you set in a
schedule.

The summary page also summarizes the data about the sequence run and timed sections: Total

number of sequences that were started and the total number that have been completed, or failed, with a
minimum and maximum rate.
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dule [8/4/17, 11:14 AM] ¥ | Complete | RIT Performance Report ¥ ‘ Entire Run ¥ | localhost ¥

Run Summary

Owerall
Summary @ Executed Test (cumulated) PhoneBookSchedule
Active Users (cumulat
Sequence Throughput ‘ [ 10
Summary Completed Users (cumulated)
Sequence Throughput Total Users (cumulated)
Elapsed Time (cumulated)
Sequence Performance
Run Status (cumulated)
Displaying Results for Computer: n/d
Performance Requirements - Status (cumulated) n/d
Performance Requirements - Fail Count {cumulated) 0
Performance Requirements - Pass Count (cumulated) 0
Sequence Summary
Total started sequences 6,278
Total passed sequences 5,664
Tatal failad conuancac [_FX¥]

= RITCompTest [2/26/2019, 7:28 PM] ~ | Complete | HOT-API Performance Report ~ | Entire Run ~ All Sources ~

Menu

Owerall Run Summary

Counters
Summary ®@

Executed Test (cumulated) RITCai J& est
Sequence Throughput Summary Active Users (cumulated) |

Completed Users (cumulated)

Total Users (cumulated)

Sequence Throughput

Sequence Performance Elapsed Time {cumulated)

0:01:47
Run Status (cumulated) Complete
Displaying Results for Computer: n/d
Requirements - Status (cumulated) n/d
Requir - Fail Count lated) 0
Requirements - Pass Count (cumulated) 0

Sequence Summary

Counters
Total storted sequences

SEQUENCE THROUGHPUT SUMMARY

This page shows a bar chart of average throughput in seconds for each sequence.

It provides times section throughput for each sequence. You can use the filters to have displayed results
for one sequence only.

And if you add filters, you can see the timed sections throughput for each sequence.
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PhoneBookSchedule [8/4/17, 11:14 AM] ¥ | Complete | RIT Performance Report ¥ | Entire Run ¥

localhost ¥

Timed Section Throughput by Sequence = All Instances = |

Overall === e T -
- All Instances
Summary Average Timed queryPhonebook put

getEntryTags

Sequence Throughput
Summary @

Sequence Throughput

Sequence Performance

%1,000 Timed Sections

getEntryTags - Sectionl queryPhonebook - Section2

Section Summary

| Passed - Min Rate | Passed - Max Rate |  Passed - Rate | Pa:
getEntryTags -
sectiont |0.000 1238 201 3126
on
queryPhonebook -
<ections |0.000 136.0 3318 3,152
1o,

‘= | RITCompTest [2/26/2019, 7:28 PM] ~ | Complete | HOT-APIPerformance Report + | EntireRun v | All Sources ~ Q

Menu

Search a counter, a view o 3 page...

Overall
Summary Average Sequence Throughput
109,
Sequence Throughput 2
Summary @ g
0.84%
g
Sequence Throughput A
0.6
Sequence Performance
04
02 k
00 AddNumTest
Sequence Summary
Sequence “ Passed - Min Rate | Passed - Max Rate Passed - Rate Passed
AddNumTest lo.ooo 0.6000 002727 3

This page shows the average throughput for all combined sequences during the last recorded interval
over the time period. Click on one of the Total rate boxed to have one graph displayed at a time or click
Select All to see all rates on the same graph.

The User Load graph shows active users compared to users that have completed testing. The table
after the graph lists the number of active users, the number of users that have completed testing, and
the total user count for the entire run.
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= RITCompTest [2/26/2019, 7:28 PM] ~ Complete | HOT-API Performance Report ~ | Entire Run ~ All Sources ~
Menu

Search a counter, a view or a page...

Overall Average Sequence Throughput
R Bl Totel started sequences - Rate I Active Users Completed Users
ummary
Total passed sequences - Rate
Sequence Throughput Summary [ Total timed out sequences - Rate 109,
Total failed sequences - Rate @
E
Sequence Throughput @ 05
107
Sequence Performance & 0D secpnds
058 20 40 60 50 100
Tz e
5 seconds
| |
20 40 &0 80 100
I I Performance Summary
Counters
Sequence Summary Active Users 3
Counters Completed Users
Total started sequences Total Users
Total passed sequences Sequence Summary (Passed)
Total timed out sequences 0 Sequence =
Total failed
lfoledseuences 0 AddmTest
Sequence Summary (Started) Sequence Summary (Failed)
Sequence Sequence * |

The chart displays the response time of the sequences as the test progresses. You can apply a filter to
see the timed sections of all sequences or the timed sections of a particular sequence.

The table under the chart shows the average duration for each section of a sequence, the standard

deviation of the average response time, the passed rate.

= | RITCompTest [2/5/2019, %19 PM] ~ | Complete | HOT-APIPerformance Report v | Entire Run ~ | Al Sources
Merig

Overall ) 4})
Timed Section Performance by Sequence  .onse Time Average Timed Section Response Time
Surnmary
Il AcaNumTest
Sequence Throughput Summarny

Sequence Throughput

E 500
Sequence Performance: @ 1 ‘E %
10 ) E] 40 50 60 0 2 0 4“0 50 &

Timed Sections Performance Summary

Duration -
Timed Section * D::'"““ Standard Passed - Rate Passed
g Deviation

Sequences Performance Summary

Duration -
Sequence * Duration - Standard Passed - Rate Passed
Average Devintion
AddNumTest 157.1ms | 004000 3
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Integration with UrbanCode Deploy

With the development team adopting a continuous delivery model, the testing team needs to follow a stringent
timeline. Integrating UrbanCode™ Deploy with your product automates the test execution process. If you have many
tests to run at regular intervals automatically, you can use UrbanCode™ Deploy to initiate test execution.

Before you begin

You must have completed the following tasks:

« Installed HCL OneTest™ Performance and UrbanCode™ Deploy agent on computers where the tests will be
run.

» Downloaded the HCL OneTest™ Performance UCD plugin from the HCL® License & Delivery portal.
For more information about specific versions of plugin, see Integration plugin compatibility matrix on
page 95.

* Installed UrbanCode™ Deploy server and deploy the Performance plugin on the server.

Note: To install the UrbanCode™ Deploy plugins, see its documentation.

About this task

With the HCL OneTest™ Performance plugin for UrbanCode™ Deploy, you can automate the execution of tests,
compound tests, and schedules. For a performance test, install HCL OneTest™ Performance on the target computer

where the test will be run. When you run a schedule, ensure that the workbench is connected to the agent computers.

Note:

To run tests on Mac 0S, you must add an environment variable that points to the installation directory of the
product, for example, export TEST_WORKBENCH HOVE=/ opt / HCL/ HCLOneTest . For Windows™ and Linux®, this
environment variable is already defined.

If you installed HCL OneTest™ Performance on Windows by using the stand-alone installer, then you must

specify the environment variable that points to the installation directory of the product.

1. To create a workflow for the newly created component process, click the component process. The Tools view
displays the available plugin steps.

2. From HCL OneTest Studio > HCL OneTest Performance, drag the Run HCL OneTest Performance Test step to
the design space.

3. Specify the properties for the step. For information about the properties, see Properties of steps.

4. After you configure the step properties, click Save.

Exemple
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A typical process for the performance test plugin will look like the following snapshot:

Start

aﬂ Run an HCL OneTest Performance test

Run an HCL CneTest Performance test (v. 4)

A process with multiple tests will look like the following snapshot:
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Run myFirst HOT PERF Test
Run an HCL OneTest Performance test (v. 4)

a&

Run mySecond HOT PERF Test

e
o Run an HCL OneTest Performance test (v. 4)

Run myThird HOT PERF Test

L
" Run an HCL OneTest Performance test (v. 4)

If you have multiple products installed on one target machine, either in the same or different package groups, you can
use a single process that includes steps from different products. The process will look like the following snapshot:
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o Run an HCL OneTest Performance test
Run an HCL OneTest Performance test (v. 4)

Run an HCL OneTest Ul - Web Ul test
Run an HCL OneTest Ul - Web Ul test (v. 6)

& Run an HCL OneTest Ul test 9
Run an HCL OneTest Ul test (v. 4)

Integration of Jaeger with the product

Jaeger is software for tracing transactions between distributed services. You can use Jaeger to monitor and
troubleshoot complex microservices environments.

You can set up the Jaeger Ul in your local environment by using one of the following methods:

» One Jaeger agent shared by all HCL OneTest™ Performance agents

- One Jaeger agent for each HCL OneTest™ Performance agent

One Jaeger agent shared by all HCL OneTest™ Performance agents

When you use this method, ensure that the Jaeger agent is accessible by HCL OneTest™ Performance
and all the HCL OneTest™ Performance agents. You must set the JAEGER_AGENT_HOST property as an
environment variable by using the command line before running the schedule.
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You must also ensure that the Jaeger agent ports 6831, 6832, and 5778 are accessible from other
computers to communicate with the HCL OneTest™ Performance agent via the User Datagram Protocol
(UDP). If you want to define any other Jaeger environment variables, set those environment variables
only on HCL OneTest™ Performance.

One Jaeger agent for each HCL OneTest™ Performance agent

When you use this method, you must install the Jaeger agent in the same location where you installed

HCL OneTest™ Performance and on all the HCL OneTest™ Performance agents.

You must also ensure that the Jaeger agent ports 6831, 6832, and 5778 are accessible from other
processes on the same computer to communicate with the HCL OneTest™ Performance agent via the
UDP. If you want to define any other Jaeger environment variables, set those environment variables on
all the computers where the Jaeger agent is installed.

For more information about Jaeger, refer to Jaeger documentation.

Related information

Viewing test logs in Jaeger on page 142

Running a test or schedule from a command line

Viewing test logs in Jaeger

You can use the Jaeger Ul to view the test logs of the tests or schedules that you run from the command-line interface
to analyze traces of transactions between distributed services.

Before you begin

You must have completed the following tasks:

« Downloaded Jaeger components from the Jaeger website.
« Created a test or schedule to run it from the command-line interface. See Creating tests on page 153 or
Creating a VU Schedule on page 510.

About this task

While running tests or schedules by using the command-line interface, you must include the command -history jaeger
in your test or schedule run. Adding the -history jaeger enables you to view the test log of the completed test or
schedule from the Jaeger Ul in a web browser.

1. Run a test or schedule from the command-line interface by adding the -history jaeger option.
For example: cmdline.bat -workspace workspace_full_path -project proj_rel_path -suite suite_rel_path -
stdout -history jaeger
Result

The test or schedule runs and the result of the run is displayed.
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https://www.jaegertracing.io/download/
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2. Open the Jaeger Ul in a browser.

For example: htt p: // <host | P>: <port>.
3. Select HCL OneTest Product from the Service list.
4. Click Find Traces.

In the Jaeger Ul, you can view the entire test log of the test or schedule that you ran from the command-line.
What to do next

« You can use the Jaeger traces to analyze test results.
- You can compare the traces in the Jaeger Ul with test logs in HCL OneTest™ Performance to confirm that they

are the same.

Related information
Running a test or schedule from a command line
Viewing test logs on page 770

Integration of Jaeger with the product on page 141

Testing with Jenkins

You can use the HCL OneTest™ Performance Jenkins plugin for performance testing to run tests on a Jenkins server
by using a Jenkins build step.

Introduction

To automate testing with Jenkins, you must configure two computers: A Jenkins master and a Jenkins slave. This
master-slave configuration allows a single Jenkins installation on the master computer to host multiple slave
environments for building and running tests. You must install the latest version of the HCL OneTest™ Performance
Jenkins plugin on the master computer, and install the products themselves on the slave computer, where you create
the tests. For detailed information about the Jenkins master-slave relationship, see the Distributed Builds section on
the Jenkins site.

Note: You can download the HCL OneTest™ Performance Jenkins plugin from the HCL® License & Delivery
portal.

For more information about specific versions of plugin, see Integration plugin compatibility matrix on
page 95.

You can then install the plugin on the Jenkins server. After you create the tests in HCL OneTest™
Performance, you can run the tests on the Jenkins server by using this plugin. If you have earlier version of
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pw the HCL OneTest™ Performance Jenkins plugin, you must uninstall it before installing the latest version of the
plugin on the Jenkins server.

Before you begin

You must have completed the following tasks:

« Installed Installation Manager, which is required for installing the products.

- Installed HCL OneTest™ Performance.

« Verified that you have a Jenkins master computer where Jenkins and the HCL OneTest™ Performance Jenkins
plugin is installed.

« Verified that you have a Jenkins slave computer where the products are installed.

- Verified that you have a test residing within an Eclipse workspace on the Jenkins slave where the products are
installed.

Note:

To run performance on Mac 0S, you must add an environment variable that points to the installation
directory of the product, for example, export TEST_WORKBENCH_HOVE=/ opt / HCL/ HCLOneTest . For Windows™, this
environment variable is already defined.

If you installed HCL OneTest™ Performance on Windows by using the stand-alone installer, then you must

specify the environment variable that points to the installation directory of the product.

Installing the HCL OneTest™ Performance Jenkins plugin on the Jenkins master computer

1. Download the HCL OneTest™ Performance Jenkins plugin 6. 0 from the HCL® License & Delivery portal.
2. From the Jenkins dashboard, perform the following tasks:
a. Click Manage Jenkins > Manage Plugins.
b. Click Advanced.
c. From the Upload Plugin section, click Choose File to locate and Open the HCL OneTest™ Performance
Jenkins plugin.
d. Click Upload.

The HCL OneTest™ Performance Jenkins plugin is displayed in the Installed tab.

3. To allow Random TCP Ports for Java™ Network Launch Protocol (JNLP) agents, perform the following steps:
a. Click Manage Jenkins > Configure Global Security.
b. In the Agents section, Select Random.
c. Click Save to save and apply the changes.
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Job Configuration

1. Create a new Jenkins free-style software project. For more information to create a free-style Jenkins project,
see Building a software project in Jenkins.
2. Optionally, set an environment variable in Manage Jenkins > Configure System > Global properties from the

Jenkins dashboard.

Select the Environment variables check box if it is not selected. Add the variable and save the details.

3. From the Jenkins dashboard, perform the following tasks:
a. Open the Jenkins free-style software project, and then click Configure.
b. Click Build > Add build step.
c. Click Run HCL OneTest Performance test.
4. Provide the details about the test run as shown. The following table explains each field.

Field Description
Name Required. The name of the test.
Work- Required. The complete path to the Eclipse workspace.
space
Project Required. The path, including the file name of the project relative to the workspace.

Test Suite | Required. The path, including the file name of the test to run related to the project.

Name

IMShared [ Optional. The complete path to HCLIMShared location,if it is not the default location.

Location

Var File Optional. The complete path to the XML file that contains the variable name and value pairs.

Config File | Optional. The complete path to a file that contains the parameters for a test or schedule run.

Results Optional. The name of the results file. The default result file is the test or schedule name with a
File time stamp appended. The results file is stored in the Results directory. If you are running multi-
ple tests, do not provide a name for the results file.

Overwrite | Optional. Determines whether a results file with the same name is overwritten. The default val-

Results ue is true, which means the results file can be overwritten.
File
Quiet Optional. Turns off any message output from the launcher and returns to the command shell

when the run or the attempt is complete.

Number Optional. For a schedule, the default value is the number of users specified in the schedule edi-
of Virtual |tor. For a test, the default value is one user. Overrides the default number of users, if required.

Users

VM Args | Optional. Java™ virtual machine arguments to pass in.

145


https://wiki.jenkins-ci.org/display/JENKINS/Building+a+software+project

HCL OneTest Performance

146

Field Description
Dataset Optional. For a test or schedule, the default value is the dataset specified in the test editor or
Override | schedule editor. Overrides the default dataset value to run if required.
Note:
You must use the Dataset Override option to replace the dataset values during a test
or schedule run. You must ensure that both original and new datasets are in the same
workspace and have the same column names. You must also include the path to the
dataset.
For example,
/ proj ect _nane/ ds_pat h/ds_fil enane. csv:/ proj ect _nane/ ds_pat h/ new_ds_fil enane. csv.
You can swap multiple datasets that are saved in a different project by adding multiple
paths to the dataset separated by a seni colon (;).
For example,
/ proj ect _nanel/ds_path/ds_fil enane. csv:/project_nanmel/ds_path/new ds_file-
nane. csv; / proj ect _nane2/ds_path/ds_fil enane. csv:/proj ect _nane2/ds_pat h/ new ds_-
fil enane. csv
Exported | Optional. The complete path to a directory to store exported statistical report data.
Statistical
Report Da-
ta File
Custom Optional. A comma-separated list of absolute paths to custom report format files (.view files) to
Report use when exporting statistical report data with the Export Statistical Report Data File option.
Format
Files
Exported | Optional. The complete path to a directory to export web analytic results. Analyze the results on
Statistical |a web browser without using the test workbench. If you run multiple tests, do not provide a val-
Reportin [uein this field. The web analytic results will be exported to Jenkins workspace.
html
User Com- | Optional. Add text within the double quotation mark to display it in the User Comments row of
ments the report.

If you do not supply a value for Exported Statistical Report Data File, these logs will be saved in Jenkins

workspace/temp directory.
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5. Click Save.

6. Optionally, to run multiple tests under the same job, click Add build step again, and provide details for the next
test.

Environment variable configuration

After you set the environment variable in Manage Jenkins > Configure System > Global properties on the Jenkins
server, you can enter the variable name by using any of the following methods for the corresponding text fields in the

Run HCL OneTest Performance test step:

+ Use the dollar sign (8) followed by the variable name.

For example, $wor kspace

« Use the dollar sign (8) followed by the variable name between braces.

For example, ${wor kspace}

You can then run the Jenkins build by using environment variables in the Run HCL OneTest Performance test step.
The environment variable that you added to your test is substituted with the actual value associated with the variable
that you set in Manage Jenkins > Configure System > Global properties for the job. The HCL OneTest™ Performance
Jenkins plugin uses the actual value while running the job.

For example,

If you set the environment variable named wor kspace with the value C: \ User s\ HCL\ wor kspacel in Manage
Jenkins > Configure System > Global properties, then you can use $wor kspace or ${wor kspace} as input to the
corresponding text field of your choice for the Run HCL OneTest Performance test step in the Jenkins build step.
When you run the build, $wor kspace or ${wor kspace} is substituted with its corresponding value C: \ User s\ HCL

\ wor kspacel.

Master/Slave Configuration

Master and slave configurations are supported by HCL OneTest™ Performance Jenkins plugin . Refer to Distributed
builds for more information.

While creating the job configuration, in addition to the preceding steps, you must select the Restrict where this
project can be run check box and provide the name of the slave node in the Label Expression field. This is the
location where the products are installed and where tests can be run.
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General

Running tests

After you save the project, you must open the project, and then click Build Now. This action starts the test run on the
slave computer. You must specify the relative path from the project to the test including the file name of the test. To
run multiple tests from different projects, you must add new build step for each project.

Building result and logs

1. After the build completes, click the build number and open the console for the project. Locate the Test Resul t
to check the test execution status.

Note: If you add multiple build steps to run multiple tests, multiple Test Result instances are
displayed.

2. For product logs, log in to the slave computer and search in the Jenkins slave workspace/temp directory.

Testing with Maven

Starting from V9.2.0, you can use the Maven plug-in that is provided with the testing product to run tests as part of

your Maven build. Apache Maven is a software build tool based on the concept of a project object model (POM).
Before you begin

« You must have installed the testing product from V9.2.0 and set an environment variable that points to the

installation location.

For Mac OS, add an environment variable that points to the installation directory of the product: expor t
TEST_WORKBENCH HOME=/ opt / HCL/ HCLOneTest

For Windows and Linux OS, the environment variable is already defined.
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- If you installed HCL OneTest™ Performance on Windows by using the stand-alone installer, then you must

specify the environment variable that points to the installation directory of the product.

 You must have installed Maven from V3.2 and set up an environment variable that points to the M2_HOVE

installation directory.

Introduction

To automate testing with Maven, you must configure a pom.xml file and launch your tests from the command line

using Maven command. You can either use your own pom.file, or one that is delivered with the product.

Three files are delivered with the product installation in the <pr oduct install | ocation>\ HCLOneTest

\ maven?2\ folder:

» ponCust onBur ef i r eSanpl e. xnl for Windows, Linux and macOS.
- ponivbj oExecPl ugi nSanpl e_Li nux. xm for Linux and MacOS.
- ponivbj oExecPl ugi nSanpl e_W ndows. xm for Windows.

The files contain all types of dependencies as well as arguments required to execute the test scripts. There are two

methods to run tests with Maven.

Method 1
With this method, you can run one or several tests. If you use your own pom.xml file, edit it with the following lines
and indicate which test(s) must be executed, otherwise, use the ponCust onBur ef i r eSanpl e. xri file as follows:

» Copy the pontCust onfSur ef i r eSanpl e. xnm to a directory.

- Edit the file and update the lines, enter the name and location of the test(s) that must be run. If the product
is installed on a different drive or a different location, or if | BM Mshar edHCLI Mshar ed location has been
changed, enter the correct path to the HCLI Mshar ed plug-in folder. For aftsuite attribute, you can input aft

xml file as the parameter value.

<!--test suite="testSources/Testl.testsuite"/-->

<l--test suite="Test2.testsuite"/-->

<test suite="C:/Runtimes/runtime-RptMvn/AA/testSources/Test2.testsuite" plugins="C:/Program
Fi | es/ HCL/ HCLI Mshar ed/ pl ugi ns"/ >

<!--test schedule="Schedule.testsuite" project="AA" workspace="C:/Runtimes/runtime-RptMvn"
plugins="C:/ Program Fi | es/ HCL/ HCLI Mshar ed/ pl ugi ns"/ - ->
<!--test suite="Test2.testsuite" project="AA" workspace="C:/Runtimes/runtime-RptMvn"/-->

<!--test aftsuite="Testl.xml" project="AA" workspace="C:/Runtimes/runtime-RptMvn"
plugins="C:/Program Files/IBM/IBMIMShared/plugins"/-->

« Run Maven to update the pom file version command and use the plug-in version currently available on

delivered repositories.

mvn versions:update-properties -Dincludes=com.hcl.products.test.it -f pomCustomSurefireSample.xml

* Run the test(s).
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mvn clean verify -f pomCustomSurefireSample.xml

Fail safe reports are generated in the target directory, especially int ar get / f ai | saf e-reports/
<Pr oj ect Name>/ <Test Nane>_<t i nest anp>. t xt that will contain the screen capture of the execution.

Method 2

With this method, no Maven report is generated. If you use your own pom.xml file, copy the following lines
and provide your parameter values. Otherwise, you can use the pomivbj oExecPl ugi nSanpl e_Li nux. xmi
or porm\bj oExecPl ugi nSanpl e_W ndows. xm sample file. Example with the

ponivbj oExecPl ugi nSanpl e_W ndows. xm sample file:

» Copy ponmivbj oExecPl ugi nSanpl e_W ndows. xm to a directory.
- Edit the file and update the arguments to reflect which test to execute. If the product is installed on a different
drive or a different location, or if | BM MShar ed location has been changed, update the two last lines with the

path to the | BM Mshar ed plug-in folder.

<argument>/C</argument>
<argument>${pt-plugin-cmdline}</argument>
<argument>-workspace</argument>
<argument>C:\Runtimes\runtime-RptMvn</argument>
<argument>-project</argument>
<argument>AA</argument>
<argument>-suite</argument>
<argument>Testl.testsuite</argument>
<argument>-plugins</argument>
<argument>C: / Program Fi | es/ HCL/ HCLI Mshar ed/ pl ugi ns</argument>
« In the argument tags, instead of the -suite option, you can use the -aftsuite option and input the aft xml file
as the parameter value in the subsequent argument tag to run the AFT test. For example, in the preceding
template, <ar gunment >- sui t e</ ar gunent > <ar gunent >Test 1. t est sui t e</ ar gunent > can be
replaced with <ar gunent >- af t sui t e</ ar gument > <argunent >aftfil e. xm </ ar gunent >.

» Run the test.

For Windows:

mvn clean verify -f pomMojoExecPluginSample_Windows.xml

For Linux or MacOS:

mvn clean verify -f pomMojoExecPluginSample_Linux.xml

Related information

https://maven.apache.org/index.html
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Integrating and running performance test scripts in Micro Focus ALM

To obtain test result details, you must integrate and run performance test scripts in Micro Focus Application Lifecycle

Management (ALM) by using a readily available template available in HCL OneTest™ Performance installation

directory.

About this task

The performance test template is available in the installation directory of HCL OneTest™ Performance. You must copy
the contents of the template to a new VAPI-XP VBScript test script in Micro Focus ALM, add your test script details
into the VAPI-XP VBScript test script, and then run the test script.

Note: You can use Micro Focus ALM client only on Microsoft™ Internet Explorer. For more information, see

Micro Focus ALM system requirements.

1. Navigate to the directory HCL\ HCLOneTest \ al min HCL OneTest™ Performance installation directory.

You can use PT_ALM W ndows. t xt file for performance test scripts.

2. Copy the contents of the template.

3. From Micro Focus ALM, create a blank VAPI-XP Vbscript test script.

4. Paste the content of the template to the VAPI-XP Vbscript test script.

5. Enter the test details in the VAPI-XP Vbscript test script by referring to the following table:

Parameter Description
Workspace | Required. The complete path to the Eclipse workspace.
Project | Required. The path, including the file name of the project relative to the workspace.
Testsuit- | Required. The path, including the file name of the test to run relative to the project.
eName
IMShared- | Optional. The complete path to HCLIMShared location.
Location
Varfile Optional. The complete path to the XML file that contains the variable name and value pairs.
Configfile |Optional. The complete path to a file that contains the parameters for a test or schedule run.
ResultsFile | Optional. The name of the result file. The default result file is the test or schedule name with a
time stamp appended.
Overwrite- | Optional. Determines whether a results file with the same name is overwritten. The default val-
ResultsFile | ue is true, which means the results file can be overwritten.
Quiet Optional. Turns off any message output from the launcher and returns to the command shell

when the run or the attempt is complete.

151


https://admhelp.microfocus.com/documents/alm/alm-qc-system-requirements.htm

HCL OneTest Performance

Parameter Description
Users Optional. For a schedule, the default value is the number of users specified in the schedule edi-
tor. For a test, the default value is one user. Overrides the default number of users, if required.
VMArgs |Optional. You can use this parameter to pass Java™ virtual machine arguments.
Dataset- [ Optional. For a test or schedule, the default value is the dataset specified in the test editor or
Override |schedule editor. Overrides the default dataset value to run if required.
Note:
You must use the Dataset Override option to replace the dataset values during a test
or schedule run. You must ensure that both original and new datasets are in the same
workspace and have the same column names. You must also include the path to the
dataset.
For example,
/ proj ect _nane/ ds_pat h/ds_fil enane. csv:/ project _nane/ ds_pat h/ new_ds_fil enane. csv.
You can swap multiple datasets that are saved in a different project by adding multiple
paths to the dataset separated by a seni col on (;).
For example,
/ proj ect _nanel/ds_path/ds_fil enanme.csv:/project_nanel/ds_path/new ds_file-
nane. csv; / proj ect _nanme2/ds_pat h/ds_fil ename. csv:/ proj ect _nanme2/ds_pat h/ new_ds_-
fil enane. csv
ExportS- | Optional. The complete path to a directory that you can use to store exported statistical report
tatsFile |data.
ExportStat- | Optional. A comma-separated list of absolute paths to custom report format files (.view files)
Reportlist | that you can use to export statistical report data with ExportStatsFile.
ExportS- | Optional. The complete path to a directory that you can use to export web analytic results. The
tatsHtml | results are exported to the specified directory. You can analyze the results on a web browser
without using the test workbench.
UserCom- | Optional. You can add text within the double quotation mark to display it in the User Com-
ments ments row of the report.

6. Run the VAPI-XP Vbscript test script.

Results

The test result details are displayed in the Output window of Micro Focus ALM.
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This guide describes how to create test scripts in HCL OneTest™ Performance and enhances tests by applying

different test elements such as dataset, variables, and verification points. This guide is intended for testers.

Creating tests

To create a test, you record representative interactions with an application.

About this task
After you record a test, you can play it back to confirm that the recorded actions do what you expect.

Note: When you record a test that includes a file download, the file is not physically saved to disk. However,
you can confirm that the file was retrieved from the server by looking in the response of the request that
asked for the file. One method to locate the request for large downloaded files is to look for a request with a

large response size.

1. Click the test name in test editor.
2. Click Select.
3. Select HTTP Request.

Performance testing tips

Use these tips to make HCL OneTest™ Performance run faster and more efficiently.

The following suggestions can help you to get the best performance from HCL OneTest™ Performance:

- Number of computers. Have at least two computers for a test. The user interface consumes significant
resources; therefore play back a test or schedule on a computer (agent) that is separate from the computer
that is running the workbench (Ul).

* Number of virtual users at remote locations. When you assign a user group to a remote location, do not
overload the remote computer (agent). If you exceed the number of virtual users that the remote computer
can run, the performance measurements of the server will be skewed because they will be affected by the
performance of the computer. The test results will reflect the load of the computer more than the load of
the server. For best results on a computer with a 1 GHz processor and 1 GB of RAM, do not exceed 1000
concurrent virtual users.

« TCP/IP ports. Your computer must have a sufficient number of TCP/IP ports. On computers with Microsoft™
Windows™, the typical limit is 5000. Issue the netstat -a command to observe port use. If the largest
number you see is 5000, then you need to increase the number. To increase it, open the registry. Under
HKEY_LOCAL_MACHI NE/ SYSTEM Cur r ent Cont r ol Set / Ser vi ces/ Tcpi p/ Par anet er s, create a new dwr d named
MaxUser Por t, and set its value up to 65000. Restart the computer.

« Open file limit for Linux™. Computers that are running Linux™ need a per-process open file limit higher than

1024. As root, enterulinit -n 30000 (or another appropriate value) before starting Agent Controller.
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- Looping within tests. If you are stress testing a server, your test typically contains a loop. Your connection
behavior differs depending upon whether the loop is set at the schedule level or at the test level. Setting a loop
at the test, rather than the schedule, level gives you a performance advantage, because the connections are
reused during the looping process. For more information, see Add a loop on page

Logging levels. After the test is stable, for maximum performance, reduce the test log level and problem
determination log level and sample a small number of users. Increase the statistics sample interval to 30 or
60 seconds for long-running tests.

Workbench heap size. The Java™ Virtual Machine (JVM) heap size on the workbench is based on the
available physical memory. Do not run the workbench on a computer with less than 768 MB of physical
memory. The maximum workbench heap size depends on your JVM. Although the heap size is not strictly
necessary for playback performance, you can increase the workbench heap size. To increase the heap size,
set the -Xmx parameter in the ecl i pse. i ni file, which is located in the product installation directory. For
Windows™, if your physical memory is 3 GB or more, then the maximum heap size must not exceed 1200 MB.
For Linux™, the maximum heap size is approximately 3000 MB. If the workbench is sluggish or fails to start
after you increase the heap size, reset the heap size to the default by removing the vmarGs=- xnx line from the
eclipse.ini file.

Location (agent) heap size. To access maximum heap, after one successful test of any size, search for a
location (agent) attribute called RPT_DEFAULT_MEMORY_SI ZE. If you cannot find this attribute, you can specify a
maximum heap by creating a new attribute: RPT_vMARGS=- xmx1500m (for example, max heap 1.5 GB). For more

information, see Increasing memory allocation on page 612.

HCL OneTest™ Performance sets heap size for RPT_DEFAULT_MEMORY_SIZE based on the bit-type of the
JRE:
o For 32-bit Java Runtime Environment (JREs), HCL OneTest™ Performance sets 70% of the size of
physical memory to RPT_DEFAULT_MEMORY_SIZE. Typically, the maximum limit is set to 1200m.
» For 64-bit JREs, some workloads might perform better with a lesser heap size than 70% of physical
memory up to a maximum of 12000m.
- Disk space. Verify that there is sufficient free disk space on the workbench and agent computers. Also, verify
that there is sufficient free disk space on the drive that contains the system temporary directory.
« Recording length. If you record for a relatively long time, test generation also takes a long time. If test
generation is taking a relatively long time, try shorter recording scenarios.

Creating a project

The tests that you create, and the assets associated with the tests, reside in a project on your desktop. You can
create the project separately, or you can simply record a test, which automatically creates a project named t est proj .

1. Select File > New > Performance Test Project.

Result

The Create a Project window opens.
2. In the Project Name field, type a name for the project.

If you plan to collect response time breakdown data, do not use a project name that contains spaces.
3. Select Use default location.
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4. Optional: Click Next and select the folders to create in the new project. These folders organize your files by
asset (Test s, Resul t s, and so on).

5. Click Finish.
Result

After you click finish, you are prompted to record a test. You can create a test from a new recording or from an
existing recording, or just click Cancel to create a test project without recording a test.

Recording HTTP tests

When you record a test, the test creation wizard records your interactions with a web-based application, generates
a test from the recording, and opens the test for editing. You can record tests from Internet Explorer (which is the

default on Windows™) or from another browser.

Recording reliable HTTP tests

You use a web browser to capture the HTTP test. To record reliable HTTP tests, certain configuration of the web

browsers are required. Read the guidelines in this topic for robust HTTP tests.

Remove temporary files

To ensure that your recording accurately captures HTTP traffic, remove temporary files from the web browser's cache

before you record a test.

To remove temporary files from the Microsoft Internet Explorer cache:

1. Open Internet Explorer, and click Tools > Options.
2. On the General tab, click Delete.

3. In the Delete Browsing History window, click Delete, and then click OK.
To remove temporary files from the Mozilla FireFox cache:

1. Open Mozilla Firefox and click Tools > Options.

2. Click the Advanced tab and then the Network tab.
3. Click Clear Now.

4. Click OK.

Allow recorded pages to load completely

When recording, wait for each page to load completely. This wait does not affect performance results, because you

can remove extra think time when you play back the test.

Recording with IP addresses

When recording, you can enter the IP address of the website to connect to instead of entering the host name. When
you play back the test, however, make sure that the IP address can resolve to a host name. Typically, this resolution
occurs via a reverse DNS lookup.
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Note: While recording a test in Internet Explorer, if you use I ocal host in the URL, Internet Explorer does not
route the traffic through HCL OneTest™ Performance Agent. The test will not contain any recorded data. You

must use a host name or IP address to record the traffic.

To resolve the IP address, map each IP address to a host name in the / et c/ host s file. On a Windows system, the

file is typically stored in C: \ wi ndows\ syst enB2\ dri ver s\ et c\ host s.

If an address cannot be resolved, your test shows a slower connection time. This time might be delayed by as much

as 8 seconds, depending on the network configuration of the computer.

Recording an HTTP test

To test the performance of an application, you must first record the HTTP traffic that traverses between the client and
the server. You record the HTTP traffic of the application by initiating the recording from the product. When you record
the test, a proxy recorder intercepts the HTTP traffic between the browser and the web server.

Before you begin

Certain websites require appropriate certificates to use a proxy recorder to record the site. The recorder certificate is
required to record all the secured sites. The client certificate is different and it serves as an additional layer of security
that is required by the web server to authenticate the client/browser. If some applications use Secure Sockets Layer
(SSL), the proxy recorder can cause authentication problems because SSL relays traffic between the client and the
server. Depending on the authentication method in place, the client might require the proxy recorder to authenticate
itself as the server, and the server might require the proxy recorder to authenticate as the client. If the client program
requires an authenticated server, you must either have access to the server certificate keystore and provide it to

the proxy recorder or configure the client to accept the default certificate from the proxy recorder instead of the

certificate from the actual server.

If you have recorded a test that does not use SSL, you can convert that test to be secure by adding an SSL object to
the corresponding Server Access Configuration in the test.

Test Contents
ter text View ™

a M

4 =] Test Resources

T EME S W ST N |
¥= TLoL VAITAdUWINC S

4 E8 Server Access Configurations

= SSL

P et el W o e =l W1

= Al Lo
LU LI UIVEAL DUIOIIN
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To record an application that requires a client-side certificate, import the client certificate to the HCL OneTest™

Performance project. To import the certificate, click File > Import > General > File System, and navigate to the folder

that contains the certificates and click Finish.

' - =ARch X |
@ Import s »
File system g—1
Import resources from the local file systern. B
-

From directory: C\Program Files\IBM\SDPYjdictjretbin

-

Browse...

¢ [W = bin

[ [ msverl00.dil

E my_keystore.pfx
E my_keystorel .pfx
(% my_keystore2 pfx
[[] = MativeCreds.dll
O] = netdil

] = nic.dll

[C] [l npt.dil

[7] =l ntthreadsubject.dll

Filter Types... | | SelectAll || DeselectAll |

Inte folder:  Import_Cert

Options
[] Qverwrite existing resources without warning

[] Create top-level folder

-~
(4
_

@

v
B

Finish

Cancel

About this task

The following recorders are available for recording HTTP traffic from a browser:

« SOCKS proxy recorder: Use this recorder when no proxy connections are required.

« HTTP proxy recorder: Use this recorder when proxy connections are required to connect to the network or

when the client program does not support SOCKS.

 Socket recorder: Use this recorder for low-level network traffic when the client does not support proxies.
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You can also record and generate a test by using REST APIs. The APl documentation to record a test

islocated at C: \ Program Fi | es\ __VENDOR NAME__\ __VENDOR NAME__| MSHARED!\ pl ugi ns

\comibmrational.test.|t.server.recorder.jar.The APl documentation to generate a test after the

recording completes is located at C: \ Program Fi | es\ __VENDOR NAME__\ __ VENDOR NAME__| MSHARED

\plugins\comibmrational .test.lt.server.testgen.jar.
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To record an HTTP performance test with a browser:

. In the Performance Test perspective, on the toolbar, click the New Test From Recording icon “& or click File >

New > Test From Recording.

. In the New Test From Recording wizard, click Create a test from a new recording, select HTTP Test, and click

Next.
If you are recording sensitive data, click Recording encryption level and select the encryption level to record.

. On the Select Location page, select the project and folder to create the test in, type a name for the test, and

click Next.

If necessary, click the Create the parent folder icon [T to create a performance test project or folder.

. On the Select Client Application page, select the web browser to use.

The type of application defines the recorder that can be used. The following client application types are
supported for recording a service test:
Choose from:
> Microsoft Internet Explorer: This option records traffic that is sent and received with Internet Explorer.
> Mozilla Firefox: This option records traffic that is sent and received with Firefox.
- Google Chrome: This option records traffic that is sent and received with Chrome.
- Apple Safari: This option records traffic that is sent and received with Safari.
- Opera: This option records traffic that is sent and received with Opera.
- Managed Application: This option starts a browser that is not on the list.
- Unmanaged Application: This option records HTTP traffic from one or multiple client programs that
use a proxy. You must manually start the client programs, and the proxy recorder records all traffic that
is sent and received through the specified network port.

5. Depending on your selection in Step 4, perform one of the following steps: On the Recorder Settings page,

depending on the browser that you selected, specify the following details:

a. If you selected a browser, specify the recording method:
= To record HTTP or SOCKS traffic through a proxy, click Record traffic with the proxy recorder.
To record low-level network traffic for applications where a proxy cannot be used, click Record
traffic with the socket recorder. Use this option when you are not using Mozilla Firefox or
Microsoft™ Internet Explorer.
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Note: When using proxy recording, you can filter out HTTP or HTTPS requests to a
specific endpoints so that any requests to those endpoints are not recorded. See Proxy

recording preferences on page 1162.

= [f HCL OneTest™ Ul is installed and shell-shared with HCL OneTest™ Performance, for the Web
Ul tests, you can use the Record user actions option to record the functional aspects of the
application in the same HTTP recording session. Thus, both the functional and performance
aspects of the application are recorded.

If the server requires client SSL authentication, provide the client certificate for the proxy
recorder to be authenticated by the server as though the proxy recorder were the client. Select
The server requires a specific client certificate.

To provide single certificate keystore, specify the file name and password of the server
certificate keystore. If multiple certificates are required, click Multiple certificates, and click
Add to specify a certificate keystore file name and password for each host name and port.

To record a secured site using Internet Explorer or Google Chrome on Windows, install the
recorder certificate by selecting Register the recorder root certificate authority. Before the
recording starts, the browser prompts you to install the certificate. After the recording is
stopped, the browser prompts you to uninstall the certificate. To avoid multiple prompts for

each recording, select Keep the recorder root certificate authority after recording.

Note: If you already had the certificate from a version prior to 9.2.1 and then install the

latest version of the product, you might have to install the certificate again.

This option is not available when you record by using the Firefox or Safari

browser. To record a secured site on these browsers, manually import the

certificate in the browser from the default location C. \ Pr ogram Fi | es

(x86)\ __VENDOR_NAME__\ __ VENDOR_NAME__ | Mshar ed\ pl ugi ns
\comibmrational.test.|t.recorder.proxy_version\SSLCertificate.For

information about how to import the certificates, see the browser's documentation.

If you selected Mozilla Firefox, you can choose to use a temporary Firefox profile. This
option starts the Firefox browser without any bookmarks, plug-ins, or toolbars that might be
associated with your usual profile. Select Use an alternate Firefox profile, and then select Use

a temporary Firefox profile.

If you clicked Record traffic with the proxy recorder, click Advanced to specify whether to use
an HTTP or SOCKS proxy recorder to review and edit network connection settings that the
browser uses or to specify advanced SSL authentication settings. If you clicked Record traffic

with the socket recorder, specify the advanced SSL authentication settings.

b. If you selected Managed Application, complete the following steps:
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i. On the Recording Method page, click a recorder to record HTTP traffic and click Next.

ii. On the Managed Application Options page, for Program path, click Browse to select the
program. If necessary, specify the Working directory, and in the Arguments field, type the
command-line arguments that the program requires. Click Next.

iii. If the program requires user input from a command-line interface, select the Open console for
user input check box. Click Next.

iv. Depending on the recording method that you selected, complete one of the following steps:

= On the Proxy Recorder Settings page, specify whether to use an HTTP or SOCKS proxy
recorder to review and edit network connection settings that the browser uses or to
specify the advanced SSL authentication settings.

= On the Socket I/0 Recorder Secured Settings page, specify the advanced SSL
authentication settings.

c. If you selected Unmanaged Application, on the Proxy Recorder Settings page, specify whether to use
an HTTP or SOCKS proxy recorder to review and edit network connection settings that the browser
uses or to specify the advanced SSL authentication settings.

To record an HTTP test from a mobile device, see Recording an HTTP test for mobile applications on
page 162.

6. Click Finish.
Result
A progress window opens while your browser starts.

7. In the browser address field, type the address of the web application to test, and activate the link.

Note: If you enter the address of a secure website (one that starts with ht t ps: ), your browser might
display a security alert. Depending on the security certificate for the site, you might be required to

accept a security risk to proceed with the recording.

8. Complete the user tasks to test. While you are recording, adhere to the following guidelines:
> Wait for each page to load completely. This wait does not affect performance results, because you can
remove extra waiting time (think time) when you play back the test.
> Do not change any browser preferences.

You can use the Recorder Test Annotations toolbar to add comments, record synchronizations, or take screen
captures during the recording.

o To change the page name, click the Change page name icon T_. In the resulting test, the page element
in the test editor uses the new name; however, the original name is preserved in the Page Title
Verification Point area so that page title verification points still work correctly.

> To add a comment to the recorded test, click the Insert comment icon E'E..J Add a comment when you

get a prompt.
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> To add a screen capture to the recorded test, click the Capture screen icon 21, The screen and
window captures make your tests easier to read and help you visualize the recorded test. You can
change the settings for screen captures and add a comment to the image.

> To manually add a synchronization point to the recording, click the Insert synchronization icon IEl

> To manually add a transaction folder to the recording, click the Start Transaction icon ﬁi} and Stop
Transaction icons E'E} to start and stop the transaction. Transactions can be nested.

> To insert a split point into the recorded test, click the Split pointicon 5. With split points, you can
generate multiple tests from a single recording, which you can replay in a different order with a
schedule. See Splitting an HTTP test during recording on page 167 for more information about
splitting a test.

> To filter packets that display during recording sessions, click the Filter packets “* ¥ icon. You can
specify the filter criteria for the following elements:
= SAP packet type
= SAP packet attribute
= Socket packet type
= Socket packet attribute
= Packet type
= Proxy connection IDs
= Citrix events
= A group of conditions
= Remote host
You can add and remove packet filters as needed.

9. After you finish the user tasks in the browser, stop the recorder. You can stop the browser by closing the client

program or by clicking the Stop icon H in the Recording Control view.

10. Select the domains to include in the test and click Finish. The domains that are not selected are not included
in the test. You can add them back by generating the test again from the recording.
To include all the domains for all of the recordings, click the Select all and remember my decision check box.
To enable the filter again for HTTP tests, click Window > Preferences > Test > Test Generation > HTTP Test
Generation, and, for Service tests, click Service Test Generation and then click the Enable domain review
before test generation check box.

Results

A progress window is displayed while the test is generated. After the test is complete, the Recording Control view
displays the Test generation conpl et ed message, the test navigator lists your test, and the test opens in the test
editor.
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Related information

Creating tests on page 153
Recording reliable HTTP tests on page 155

Recording sensitive session data on page 258

Recording a WebSocket test

If your application is based on the WebSocket protocol, you can check the performance of the application by creating

a recording of the application and playing it back.
About this task

WebSocket is not a separate test extension in the product. To test a WebSocket application, you have to record the
HTTP test. After the recording completes, you must not delete or change the content of the requests, response, and

connection objects in the test script.

To record the HTTP test, see Recording an HTTP test on page 156. The requests and responses contain text or

binary data. You can do data correlation on the text data.

Starting from 9.1.1.1, the WebSocket test generation automatically does data correlation. See Correlating request and

response data on page 429.

Starting from 9.1.1.1, you can specify error handling behavior for WebSocket tests. See Specifying error handling
behavior on page 281.

Starting from 9.2, you can add verification points to the requests and responses just as you would do to HTTP tests.
See Verifying expected behavior on page 276.

After the test run completes, view the test results by selecting the HTTP WebSocket Report. The report displays the

number of requests attempted, succeeded, and the rate of success.

Recording an HTTP test for mobile applications

You can use HCL OneTest™ Performance to test a native or web application from the mobile device by using an HTTP

protocol.

Before you begin

« You must have installed HCL OneTest™ Performance on your computer.
» You must have a mobile device.
« HCL OneTest™ Performance and the mobile device must be connected to the same wireless network.

About this task
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To record the HTTP traffic to and from the mobile applications, you must download a digital certificate to connect

to a wireless network, which is same as that hosts HCL OneTest™ Performance. To record communication between

the mobile device and the internet, the computer on which HCL OneTest™ Performance is installed must be set up as

a proxy server. This setup communicates all mobile network traffic through HCL OneTest™ Performance's recording

proxy.

1. To download the certificate from HCL OneTest™ Performance to your computer, perform the following sub-

steps:

a.

™ QO O T

In the Performance Test perspective, on the toolbar, click the New Test From Recording icon

click File > New > Test From Recording.

certificate on your local desktop.

% or

. In the New Test From Recording wizard, select HTTP Test, and click Next.

. On the Select Location page, select the project and folder, type a name for the test, and click Next.
. On the Select Client Application page, select the Unmanaged Application.

. On the Proxy Recorder Settings page, click hyperlinked save option to save the recorder root

2. Share the downloaded certificate with a mobile device that is under test.

3. To download and install the certificate on a mobile device, perform the following sub-steps depending on your

mobile device:

iPhone device

. Open the email that contains certificate on

the mobile device.

. Select the certificate.
c. Choose iPhone as the device.

. Go to Settings > General > Profile > HCL

OneTest Performance Recorder.

. From Install Profile screen, tap Install.

f. If you have a PIN or passcode set on your

iPhone, you must enter it. After you enter the
PIN or passcode, ignore the warning and tap

Install.

. Tap Done to exit the screen.

. Open the email that contains certificate on

. Download the certificate.

. Go to Settings > Additional settings > Priva-

. Select the certificate to install.

. If you have a PIN or password set on your An-

. Specify a name for the certificate and click

. Go to Settings > Additional settings > Privacy

Android device

the mobile device.

cy > Encryption & credentials > Install from

storage.

droid device, you must enter it and tap OK.

oK.

> Encryption & credentials > User credentials
to view the installed certificate.

4. If you are using an iPhone, go to Settings > General > About > Certificate Trust Settings to manually enable

the installed certificate.

5. To configure the mobile device proxy, perform the following sub-steps depending on your mobile device:
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iPhone device

a. From iPhone, go to Settings > Wi-Fi and tap
the connected network.

b. In the HTTP PROXY section, select Manual
for Configure Proxy and specify the following
settings:

= Server - The IP address or the host
name of the computer that hosts HCL
OneTest™ Performance.

= Port - Enter 1080 as HCL OneTest™
Performance listening port.

= Authentication - Do not enable.

Android device

a. From your Android device, go to Settings >
Wi-Fi and tap the connected network.
b. In the PROXY section, select Manual and
specify the following settings:
= Hostname - The IP address or the
host name of the computer that hosts
HCL OneTest™ Performance.
= Port - Enter 1080 as HCL OneTest™
Performance listening port.
= Bypass for - Leave this field blank.
c. In the IP SETTINGS section, select DHCP.

6. To record an HTTP performance test:

placed, and select New > Test From Recording.

traffic from a mobile device that uses a proxy.

e. Click Next.

Finish.

. From HCL OneTest™ Performance project, right-click the folder where you want your recording to be

. Select HTTP Test in the Recording Session window and click Next.
. On the Select Location page, select the project and folder, specify a name for the test, and click Next.

. Select Unmanaged Application in the Select Client Application window. This option records HTTP

. Select Proxy Type as HTTP and Proxy port as 1080 on the Proxy Recorder Settings page and click

. From your mobile device, navigate through your installed application to start the recording. If all

settings are configured correctly, you can see some activities on the HTTP Proxy Recorder tab during

recording.
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~ HTTP Proxy Recorder :: Recording
i HTTP Proxy Recorder starting to accept connections on port 1080

Open connections; 35

~ Annotation Recorder :: Recording ) @ [E

i Current state: Recording
Annotations

h. To pause your recording, and if you want to navigate to other section of mobile application that needs
no recording, click the Pause/Resume Recording button. Click the button again to resume recording.

i. When you finish recording all the required transactions from your mobile application, click the Stop

button to stop the recording.

j. Select the domains to include in the test and click Finish.

Results
A progress window is displayed while the test is generated. After the test is complete, the Recording Control view
displays the Test generation completed message, the test navigator lists your test, and the test opens in the test

editor.

Generating HTTP tests from a Web Ul test

The performance tests record the HTTP traffic against the HTTP server that hosts the application under test. You
would have recorded many scenarios against the server. If a new version of the server is about to be used, there can
be changes in the HTTP traffic for all of the existing tests. You might have to re-record all of the tests to bring them
back to the state where they can be run successfully. This is a time-consuming process.

Before you begin
You must have installed HCL OneTest™ PerformanceHCL OneTest™ Ul in the same package group, also referred to as

shell-share mode.
About this task

When you know that a new version of the HTTP server is going to be installed and it would impact your performance
tests, you can record the scenarios with the Web Ul Test recorder of HCL OneTest™ Ul and then just generate the
HTTP tests. When you have all of the HTTP tests generated, you can add the required test elements and run them to
view the performance results. When the new version of the server is installed, you can start refreshing the generated
HTTP tests. This action records the traffic from the Web Ul test and uses the test elements such as loops and dataset
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that were edited in the HTTP test with the new HTTP traffic. The new HTTP tests are re-recorded with new HTTP

traffic without manual intervention.

1. From the Web Ul perspective, create a Web Ul test.
For information about creating a Web Ul test, see Recording a Web Ul test .
2. In the Test Navigator view of Performance Test perspective, right-click the Web Ul test and click Generate
HTTP Test.
You can have only one Web Ul test as the master test.
Result
The HTTP Test recorder opens the web browser and automatically records the HTTP traffic for the Ul actions
that were recorded in the Web Ul test and generates the HTTP test.
3. To refresh the HTTP test, right-click the generated HTTP test and select Refresh HTTP Test.
This option is available only for the HTTP tests that were generated out of Web Ul tests.
4. Specify a name for the test, select a project, and click Next.
5. Click Finish.
The HTTP Test recorder opens the web browser and automatically records the HTTP traffic from the Web Ul

test and generates the HTTP test against the new version of the server.

Preparing to record a test for the HTTP/2 protocol

To collect the performance data of an application that supports HTTP/2 protocol, record a test against the HTTP/2

application. Before recording the HTTP/2 application, follow the procedure in this topic to configure your computer.

About this task
This configuration is required because this feature is released as Beta and is intended for the non-production use.
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1. Download the following Application Layer Protocol Negotiation (ALPN) boot jar file https://
mvnrepository.com/artifact/org.mortbay.jetty.alpn/alpn-boot/8.1.8.v20160420

2. Create or rename the product I nstal | Di r\j dk folderto..\j dk. abc. You can rename the folder back to
j dk later to test with Java.

3. Download Oracle Java 1.8.0u92 from http://www.oracle.com/technetwork/java/javase/downloads/
jdk8-downloads-2133151.html. You can then either extract the compressed file or install Java at
productlnstall Di r\j dk.

4. Copy the ALPN jar file to pr oduct I nst al | Di r\ maj or dono\ | i b.

5. From pr oduct I nst al | Di r, open ecl i pse. i ni and add the following flags:

-Xbootclasspath/p:<productinstallDir>\majordomo\lib\alpn-boot-8.1.8.v20160420.jar
Note: If there are any other flag starting with -X, delete those flags.

6. Configure HCL OneTest™ Performance Agent to use Oracle Java.


https://hclonetestui.hcldoc.com/v10/help/topic/com.ibm.rational.test.lt.rtw.webgui.doc/topics/t_rec_test.html
https://mvnrepository.com/artifact/org.mortbay.jetty.alpn/alpn-boot/8.1.8.v20160420
https://mvnrepository.com/artifact/org.mortbay.jetty.alpn/alpn-boot/8.1.8.v20160420
http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
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a. Stop the Majordomo process.

On Windows systems, run the following command: cd “c:\program fil es\ hcl\ hcl onet est\ maj or dono”

ngast op
On Linux systems, run the following command: cd / opt / HCL/ HCLOneTest / Maj or donp . / MDSt op. sh
b. Set the environment variable RPT_JAVA to the Oracle Java binary or executable.

On Windows systems, run the following command: set RPT_JAVA=c:\program fil es\j ava
\j dk1.8.0_92\bin\java. exe

On Linux systems, run the following command: export RPT_JAVA=/root/j dk1.8.0_92/jre/bin/java

c. Start the Majordomo process.

What to do next

You can now record a test for the HTTP/2 application. After the recording, in the Version field of request details, the
requests are marked with HTTP/2 indicating that the HTTP/2 traffic is captured. If the test playback fails, check if all
the steps are correctly followed.

Splitting an HTTP test during recording

You can insert split points when you record a test. With split points, you can generate multiple tests from a single
recording that you can replay in a different order with a schedule. You can also create a schedule that contains all of
the tests that are generated from the split points.

About this task

During the recording process, you can select the option to create a schedule for the tests that are generated from the
split points. The schedule will contain these attributes:

» One user
« One user group for the local computer
« All of the tests from the recording, in serial order
« One stage: Run until finished
» Recorded think times, with the maximum think time set to 2 seconds
« Statistics:
Statistics log level: All
Statistics sample interval: 5 Seconds
Only store All Hosts statistics

« Test Log:

167



168

HCL OneTest Performance

Show errors and failures: All

Also show warnings: All

And also show all other types: All
 Problem Determination log level: Warning

To insert split points when you record a test:

1. Start recording the test. The Recorder Test Annotations toolbar opens near the top of the screen.

2. To insert a split point into the recorded test, click the Split point icon *-. The Insert Split Point window is
displayed.
Choose from:

> Click Test name, and then type a name for this section of the test.
0 Tip: You are naming the previous section of the test, not the upcoming section of the test.

Repeat this step between recorded user actions as needed to split tests.
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3. Close the client program to stop the recording. The Generate HTTP Test window is displayed.

@'&nerate HTTP Test

Destination

Choose a location and a name faor the tests,

%:

i

Location: | [Test_project

Browse

select Al

Test prefix: (optional}
From To Marne
00:00 01:13 MyTest1
01:13 03:07 MyTest2
03:07 End LastPart

Unselect Al

Reset

[ ]Generate a scheduls containing tests

[ ] customize automatic data correlation

Configure Workspace Settings...

@

Finish

] [ Cancel

Choose from:

> Type a Test prefix for all the tests in the schedule.

- Select Generate a schedule containing tests to create a schedule for the tests. When you select this
option, you can modify the name of the schedule.

o Select Customize automatic data correlation to choose automatic data correlation or rule-based data

correlation. If you select this option and choose rule-based data correlation, you can specify which

data correlation rule sets to use.

4. Click Finish.
Result
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The Test Generation window displays the status of generating the tests and schedule and the data
correlation. You can view the test generation log from this window.

5. When test generation is complete, you can select the test to open and then click Open Selected Tests, or you
can click Close to finish this process.

Results

The schedule and tests are generated using the names that you specified in the wizard.

Returning a browser to its initial state if recording is interrupted

Browser options are changed during recording and are reset after recording is complete. If you interrupt recording, the
browser stays in its changed state, and you may receive The page cannot be di spl ayed messages. To fix this, reset the
browser to its initial state.

1. Right-click the Internet Explorer icon, and select Properties.
2. On the Connections page, click LAN Settings.

a. If you do not use a proxy, in the Local Area Network (LAN) Settings window, clear Use a proxy server
for your LAN.

b. If you use a proxy:

In the Local Area Network (LAN) Settings window, select Use a proxy server for your LAN, and then
click Advanced.

In the Proxy settings window:
i. Add the proxy address and port number to the HTTP and the Secure fields.
ii. Remove the proxy address and port number from the Socks field.
iii. In the Proxy Settings window, click OK.

3. In the Local Area Network (LAN) Settings window, click OK.
4. In the Internet Properties window, click OK.

Creating HTTP tests manually

The typical—and simplest—way to create a test is by recording it. However, you can also write a test from scratch.

Creating an empty test

You can create an empty template for a test that you plan to write manually.

. In the Test Navigator, right-click a project and click New > Other.

. In the New window, expand Test, expand Test Assets, click New Test, and then click Next.

. In the Enter, create, or select the parent folder field, click the test project in which to store the test.
. In the Name field, type a name for the test, and then click Next.

. Optionally, in the Test Attributes window, type a description for the test, and then click Next.

o g~ WN =

. In the Protocol and Features window, select HTTP Protocol, and then click Next.
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7. In the HTTP Extension window, enter the name of the host, and set the options for the test.
8. In the New test summary window, inspect your selections, and then click Finish.
9. Confirm that you want to open the editor.

Result

A test template opens for you to edit. The following figure shows HTTP test template with the default options

(one page, one request per page, and a response for the request).
DE MyEmptyTest 52
Test - MyEmptyTest

Test Contents Test Element Details

This section shows the test conkentks MyEmpty Test

= %E MyErmphy Tesk

[1._ Test Variables
=R Datapools

Dy e g Ol e, SecUrity | HTTP Oplions

ey
=" f'_"‘_YHDEU Mame sage Location
#% Connection
&7 Response: 200

Add Datapaoal

= O

[ 1Enable response time breakdown  [parent]

Adding templates for new elements
You can add a template for a new test element that you plan to write by hand.

To add a template for a page, page request, or basic authentication block to a test:

1. Open the test. If you are writing a test completely by hand, you can create an empty test as explained in

Creating an empty test on page 170.
2. Click the parent or sibling element.
3. Click Add or Insert.

Result
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The editor enforces the test hierarchy: tests contain pages, pages contain requests, and requests contain
authentication blocks.

- Add adds the template to the bottom of the selected element: a page is added to the bottom of the
test, a request is added to the bottom of the selected page, and an authentication block is added to the
end of the selected page request.

> Insert inserts the template at the point of the cursor: a page is inserted before the selected page, a
page request is inserted before the selected request, and an authentication block is inserted at the top
of the selected page request.

4. Select one of the following options. The options that are displayed depend on the element that you select.

Option Description
HTTP Page Adds a page to the test.
HTTP Request Adds a request to the test.
Basic Authentication Adds an authentication block to a request. A fold-

er named Authentication is added, and the Test El-
ement Details area displays the User id, Password,

and Realm fields.

Custom Code Adds a block of custom code to the test. For more in-
formation on custom code, see Extending test execu-

tion with custom code on page

Delay Adds a delay to the test.

Loop Runs part of the test a specific number of times.

In addition to setting the number of iterations, you
can control the rate of iterations and randomly vary
the delay between iterations. For more information,
see Extending test execution with custom code on

page

Condition Adds a conditional block to the test. In most cases,

a conditional block issues HTTP requests depending
on the value of a reference or field reference. The ref-
erence or field reference must exist in the test and
precede the conditional block. For more information,

see Adding conditional logic on page

Transaction Enables you to view performance data about the
transactions that you have added. In the Test Ele-
ment Details area, give the transaction a meaningful

name. This is useful in the Transactions report, which
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Description

lists transactions by name. For more information, see

Adding a transaction to a test on page

Random Selector

Enables you to run test elements in random order.
For more information, see Running test elements in

random order on page

Comment

Adding a header

Adds a comment that appears in the Test Element

Details area and in the actual test.

You can add a standard header or a custom header to a request or response.

1. Open the test.

2. In the test hierarchy, click a request (to add a request header) or the Response Data folder for a request (to

add a response header).

3. In the Test Element Details area, locate the Request Headers table, and then click Add.

Result
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The Add/Edit Headers window
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4. To add a standard header:

a. In the Available Headers list, locate the header to add and click it.
Use the Quick search field (start typing the name of a header) and Header types list (select the type of
header you are looking for) to quickly locate a header in the Available Headers list.

b. Click the right angle bracket (>).
Result
The selected header moves into the Selected headers list and your cursor is placed in the value

column.
c. Type the value for the header.
5. To add a custom header:
a. In the Header types list, select Custom.

b. At the bottom of the window, in the New custom header area, type the header information in the Name
field and the Value field, and then click Insert.
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Result

The custom header is added to the Selected headers list.

6. When you have finished adding headers, click OK.

Editing header contents

You can modify the contents of the headers that are contained in requests and responses.

1. Open the test.

2. In the test hierarchy, click a request (to edit a request header) or the Response Data folder for a request (to
edit a response header).

3. In the Test Element Details area, locate the Request Headers table, and double-click the cell containing a
value that you want to edit.
Result
An ellipsis button is displayed in the Value column.

Request Headers

Header Mame | YWalue |
Accept image/aif, image|x-xbitmap, ima...
Accepk-Lan,.,  en-us,ja;q=0.8,fr;0=0.5,zh-bw;...
Accept-Enc... | gzip, deflate
|zer-fgent Mazillaj4.0 (compatible; MSIE &....
Hosk: b, corm
Conneckion keep-alive
Cookie IBMISP=477cbh9asb1951 1d9bba, .

4. Click Modify.

5. In the Edit Header window, edit the header value as desired.
You can create a reference or field reference in the header value.
6. Click Table View to return to the Request Headers table.

Creating tests from HTTP Archive files

To migrate your tests from another tool to HCL OneTest™ Performance, you can export tests in the HTTP Archive
(-har) file format and then import or copy the HTTP Archive files to HCL OneTest™ Performance. You can then create
test scripts from the HTTP Archive files.

About this task

Depending on the tool that you use to export tests to the HTTP Archive format, Google Chrome and Mozilla Firefox,
for example, do not save enough information to reflect exactly what happened on each connections. The tool exports
the contents, HTTP requests and responses, timings, but connections and SSL information is not exported. Use a tool

such as Fiddler2 that exports enough information about tests.
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When you import or copy an HTTP Archive file, the product displays a message if the Archive file does not contain

enough information to generate the test.

1. To create tests from the HTTP Archive file, you must first copy or import the archive file to the Test Navigator
view of the product. To import the HTTP Archive files in the product, initiate the Import action from the Test

Navigator view and choose the File System option in the wizard.

@ oo o o=
Select
Irmport resources from the local file systern into an existing project. E - E ]

aselect an import wizard:

type filter text

4 = General
JE Archive File
=% Existing Projects into Workspace
[} File Systemn
] Preferences
) Prajects fram Falder ar Archive
» e CWE
¢ = Install
¢ = Plug-in Developrnent
» [== Profiling
» == RunfDebug
= Teamn
¢ = Test
¢ == HML

After the import is finished, a new category HTTP Archive is created in the Test Navigator view.

2. Generate the test from one of the following methods:

a. In the Test Navigator view:
i. Right-click the HTTP Archive file, click Generate Test.

ii. Specify a name for the test, and click Finish.

b. In the product:
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i. Click File > New > Test from Recording > Create a test from an existing recording
ii. Select the HTTP Archive file and follow the wizard to create the test.

Note: If the HTTP Archive file cannot generate a test, a message is displayed when you

select it.

3. Select the type of test that you want to create and click Next.

4. Select the domains that you want to include in the test and click Finish.
Result
A new test is generated.

What to do next

You can now run the test. See Running a local schedule or test on page 594.

Recording Adobe™ Flex content

You can record an HTTP session that contains traffic to and from a . swf Adobe™ Flex application.
About this task

The Adobe™ Flash plugin must be installed in your web browser to run flex applications (.swf files) and to record the
HTTP session.

Adobe™ Flex technology allows communication through XML, SOAP, or AMF. AMF is compressed binary data that
must transformed into XML to be used in an HTTP performance test.

1. Record the HTTP as described in Recording an HTTP test on page 156.
By default, HCL OneTest™ Performance transforms the AMF format in to the XML format.

2. Optional: If you configured the default setting of HCL OneTest™ Performance to not transform after the
recording, follow the steps in the Transforming binary data in tests on page 463 topic.

Results

After the transformation, the XML data is generated in the test with "amf" prefixes in the names, as in the following

example:

<amf3Property amfName="zipcode" amfType="amf3String" zipcode="94103"/>

The generated XML can be used for data correlation. Only the anf val ue attributes or attirbutes without the ant prefix
can be used for data correlation.
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Note: Do not modify or use data correlation on any XML attributes that start with the ant prefix except for

anf val ue. If these attributes are modified, the replay of the test will cause errors.

Related information

Recording an HTTP test on page 156

Recording Microsoft Silverlight applications
To test the performance of an application that was developed by using Microsoft™ Silverlight, you can record the

application.

Before you begin

HCL OneTest™ Performance supports Microsoft Silverlight 5.

About this task

Microsoft™ Silverlight communicates with the server in the Windows™ Communication Foundation (WCF) Binary
format. After recording the Microsoft Silverlight application, you can transform the format to XML for better
readability and to apply data correlation.

1. Record the HTTP application as described in Recording an HTTP Test on page
By default, HCL OneTest™ Performance transforms the WCF Binary format into XML format.

2. Optional: If you changed the default setting of HCL OneTest™ Performance to not transform after the
recording, follow the steps in the Transforming binary data in tests on page 463 topic.

Changing HTTP test generation preferences

You can change how performance tests are generated, such as how tests process verification points, data correlation,
and pages.

1. Click Window > Preferences > Test > Test Generation > HTTP Test Generation.
2. Select the preference to change.
The test generation preferences are as follows:
Do not generate a new page if think time is less than

Enter the shortest time, in milliseconds, that the generator uses as a delay to emulate user think

time for an HTTP page. If your tests contain fewer pages than expected, try a shorter interval.
Create a new page if delay between requests is greater than

Enter the longest delay, in milliseconds, that the generator allows between page requests. If this
time is exceeded, a new page is generated. If your tests contain more pages than expected, try a

longer interval.
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Maximum request delay

Enter the longest delay, in milliseconds, that the generator allows before truncating HTTP
requests. The requests are truncated on the generated test. The recorded test still contains the

original values, and you can get them back by generating a new test.
Save only the first 4KB of responses larger than

Enter the limit of response data, in KB, that the generator saves. If a response is larger than the
specified limit, only the first 4 KB of data is saved.

Suppress NSLookup() and use numeric IPs

Select this option to shorten test generation time. The disadvantage is that IP addresses in a
test are less user-friendly than web page format (www.example.com).

Disable Page Cache Emulation during test generation

Select this option to disable page cache emulation. When page cache emulation is enabled,
caching information in server response headers is honored. Additionally, requests are not
submitted to the server for content that is confirmed by the client as fresh in the local cache.

Page cache emulation is enabled by default.
Enable domain review before test generation

Clear the check box to not show the test generation page to select specific domains to be added
to the test. By default, in addition to the domain that you intend to record, other domains linked
to the original domain are also recorded.

Remove HTTP request delays from page response times

To not include the client delays in the page response times for the test or A schedule, in this
context, is used to refer to both VU Schedule and Rate Schedule., select this check box. By
default, the page response times include delays to represent processing time caused by clients
such as a web browser. Sometimes this delay could exceed the logical limit causing page
response times to increase drastically.

Use Legacy Test Generator
Select this option if you have been instructed to use the legacy HTTP test generator.
Automatically include verification point of

Click to specify the types of verification points to be automatically included. If a check box for
a verification point is selected, the code and edit controls for this type of verification point are

generated in all tests. Verification points can also be enabled or disabled within specific tests.
Relaxed

Response codes that are in the same category (for example, 200, 201, 203, 209) are considered
equivalent. An error is reported if the response code is not in the same category.

Exact

An error is reported if the response code does not match the recorded value exactly.

179



HCL OneTest Performance

Accept sizes for primary request within

If you are automatically generating response size verification points, click to specify the
acceptable size range for primary requests. No error is reported if a response is within the
specified percentage above or below the expected size. By default, for primary requests, HTTP

response size verification points use range matching.

The data correlation preferences are as follows:
Automatically correlate host and port data

By default, host and port data is correlated automatically. If tests in a previous release have
significant manual correlations, or you are using proxies, the migration of the replace-host
functionality feature is likely to fail during playback. In this situation, clear the check box. When

you reopen your tests, they will not have the automatic correlation feature in them.
Automatically correlate URL pathname if redirected by response

Specifies whether URL path names are correlated if they are redirected by a selected response
code. If a check box for a response code is selected, the test generator performs correlations for
that response code. This option applies only to responses that are redirects, with a status code
between 300 and 399.

Automatically correlate Referers

By default, the Referer field in an HTTP request header is correlated automatically. Clear the
check box if you plan to correlate Referers manually. If you run tests against servers that do not
require a Referer field, clearing this check box reduces the number of correlations performed

when the test runs, and can increase user throughput.
Enable all other data correlation

By default, request and response data is correlated automatically. Clear the check box to disable
automatic data correlation of request and response data. Consider clearing the check box if you

create your own data correlation rules in the rules editor.
Create substitutions for empty strings

Select this check box to correlate empty strings. For example, strings such as spouse name or
middle initial sometimes become important to correlate. However, correlating empty strings

increases the time to generate a test.
Optimize automatic data correlation for execution

Specifies the characteristic that tests are automated for.
o With the Accuracy setting (the default), many references with an identical session
ID value are created and the value of each session ID is substituted from the nearest
previous reference.
> To make a test run faster by reducing the number of references that are created during
automatic data correlation, change the optimization to Efficiency. For example, consider
a test where a session ID, which is assigned when a user logs in, is included in every
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subsequent request in the test. With the Efficiency setting, all session IDs are substituted
from a single previous reference. The downside of this setting is that it can result in
incorrect correlations. For example, a request that contains the Joe sni t h string might be
incorrectly correlated with a request that contains the Joe Brown string.

URL rewriting for execution

Specifies how web addresses (URLs) are rewritten during test execution. When correlating data,
the test generator replaces part of a URL request string with a value that the server returned in
response to a previous request.
o Automatic (default): The test generator automatically determines when rewriting the
entire URL during substitution will facilitate test execution.
- On: Select to rewrite URLs in every instance of data correlation. This produces larger
tests that take longer to run. Try this setting if your tests fail unexpectedly.
o Off: Select to manually correlate the instances where URL rewriting is needed. This

setting might cause execution errors.
URL encoding for execution

With this option, you can control the encoding of the URLs. If you set it to Automatic, the tool
detects the encoding that already exists in the test and applies it to the substitution site. If you
set it to ON, the tool always encodes the substitutions according to the encoding standards. If
you set it to OFF, no encoding occurs.

Note: To turn data correlation off entirely or to set whether names are automatically generated for
data correlation references, click Window > Preferences > Test > Test Generation > HTTP Test
Generation, and click the Data Correlation tab.

The data correlation type preferences are as follows:
Data Correlation Types

Specify when to generate data correlation constructs. With the Automatic setting, the test
generator creates the required constructs where needed. If the test does not contain the
required constructs, change the setting to On, which will always perform data correlation. If tests
do not require a specific construct, select Off, which has the additional benefit of improving

performance on subsequent test generation.
Jazz Foundation Services

The On and Automatic options enable data correlation for Jazz applications that use REST
storage or query APIs from Jazz Foundation Services. An example of such an application is
Rational DOORS Next Generation. Although data correlation does not typically apply to browser-
based Jazz web clients, it may be useful for other HTTP client-server applications that use REST

services and the Atom Publishing Protocol for updating web resources.
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Jazz Web Applications

The On and Automatic options enable data correlation for Jazz web applications that use the
Jazz Foundation web Ul framework Examples of these web applications are the web interfaces
for Rational Quality Manager and Rational Team Concert. Data correlation can also be useful
for other web applications that contain javascript that employs JSON for client-server data
exchange. This is a common practice with DOJO- and AJAX-based applications.

JSON

To perform data correlation on web applications that uses JSON framework, ensure that
Automatic or ON is set to the JSON entry.

Prioritize correlation based on ID

Select On to correlate HTML response code based on its ID attribute. Generally, the HTML
response code after the recording would appears as <i nput type="user name" nanme="User"

i d="aaa" val ue="John"/>. Some applications dynamically update the name attribute. Therefore,
when you play back the test, the HTML response code would appear as <i nput type="user nane"
name="i dt 020" id="aaa" val ue="John"/>. Because the name attribute is changes dynamically,
data correlation does not occur and the playback fails. When this option is turned on, the ID
attribute is considered as the basis to correlate the name attribute in the request and to locate

the value attribute.

3. After changing a setting, click Apply.

Recording SAP tests

When you record a test, the test creation wizard records your interactions with the SAP server, generates a test from
the recording, and opens the test for editing. You can record tests from the SAP GUI. You can also record SAP batch
input tests that can be used to produce a heavy load on the server while minimizing the processing requirements for

virtual testers.

SAP performance testing guidelines
Before you test the performance of SAP applications, you must set up your test environment and incorporate these

guidelines to produce reliable SAP performance tests.

SAP configuration

The SAP GUI client software must be installed on the same computer as HCL OneTest™ Performance. The SAP GUI
client is required for recording and running performance tests. For information about support of SAP GUI versions,
refer to the SAP Note 1412821 - SAP GUI for Windows: Support on Windows for SAP.

The product is optimized by default for SAP GUI version 7.10 or later. To improve performance with older SAP
GUI 6.20 and 6.40 versions, when running long tests, you must change the bri dge2j ava. dl | file located in
the C: \ Program Fi | es\ HCL\ HCLOneTest \ pl ugi ns\comibmrational .test.|t.runtime. sap

182



Chapter 6. Test Author Guide

\ <bui |l d_i denti fi er > directory by renaming br i dge2j ava. dl | to bri dge2j avaV7. dl I, and then renaming
bri dge2j avaVé. dl | tobridge2java.dll.

If you are deploying tests on remote computers to simulate a large number of users, the following software must be

installed on each remote computer:

« The SAP GUI client software, configured with the same logon properties as the client on which the tests were
recorded

» TheHCL OneTest™ Performance Agent software that is provided with the product

Performance testing relies on the SAP Scripting API and ActiveX. Make sure that these options are selected when
installing the SAP GUI client.

Performance test recording and running also require that scripting be enabled on the SAP application server and on
all SAP GUI clients that are installed on remote computers. See the topic on configuring SAP for performance testing

for more information.

Limitations

During playback of the performance tests, each virtual user runs SAP GUI in silent mode by default (the user interface
is not displayed on the screen). However, some modal dialog boxes from the SAP GUI might briefly flash on the

screen.

Avoid recording SAP tests with the SAP GUI low speed connection setting. You cannot run with a normal speed
connection tests that you recorded with this setting.

You can have a maximum of only 50 virtual users on an agent for a SAP GUI test.

Batch input tests

You can use batch input tests to simulate a large number of virtual users while minimizing the load on the virtual user

computers.

Batch input tests access the SAP server at a low level, bypassing the SAP GUI interface, and therefore cannot contain
any verification points or SAP GUI elements. Their main purpose is to simulate a load on the server when added to
a test schedule that already contains SAP performance tests. Only the SAP performance tests will provide accurate

SAP application performance measurement.

Batch input transactions are recorded in the SAP GUI and exported to the file system. You can then generate batch

input tests that are based on those recorded transactions.

Note: Sometimes the default values of the SAP Java Connectors (JCo) parameters are not sufficient for
the load tests. The default values require some updates both at the SAP R/3 server and client end. For the

client, in the Additional SAP Connection Properties window, you must configure the SAP JCo parameters
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options that are available in the test. Alternatively, you can specify the properties as RPT_VMARGS in the
agent location. For example, RPT_VMARGS=- Djco.cpic_maxconv=1000

Performance tests

When deploying your performance tests, it is important to use a relevant number of virtual users on a given computer.
For example, if you deploy too many virtual users on a single computer, the results produced will reflect more the load
of the test computer than the load of the SAP application server.

For best results with performance tests on an average test computer with a 1 GHz processor and 1 GB of RAM, do
not exceed 50 concurrent virtual users. With batch input tests, the maximum number of concurrent virtual users is

approximately 500.

If you exceed the number of virtual users that a single test computer can run, the measured performance of the server

will be affected by the performance of the test computer, which will invalidate the final results.

When editing a schedule for long performance tests, use these recommendations:

* In the schedule editor, reduce the Test log level to None.

« In the schedule editor, set the Statistics sample interval to approximately 1/60 of the run time, for example 12
minutes for an estimated 12-hour session.

» When possible, use loops inside test suites rather than loops in the schedule. Using loops inside test suites
avoids connection problems that might occur over long duration tests and emphasizes measurement of the

actual SAP transactions rather than the logon process.

If you run a schedule that has an SAP test from HCL OneTest™ Performance Agent in Windows, you must then start
HCL OneTest™ Performance Agent as a Process. However, HCL OneTest™ Performance Agent starts as a Service by

default.

To start the agent as a process, you must perform the following steps:

1. Open Windows Services.

2. Change the Status of the Majordomo service from Running to Stop.

3. Double-click the Majordomo file from the <SDP_| nst al | _Di r ect or y>\ Mpj or dono directory to run the
agent as a compatible process.

Note: You must install SAP GUI in the agent computer to run a schedule that has an SAP test.

Long duration test runs

When running long duration test schedules that exceed many hours, use the long run mode process to reduce
resource consumption with the SAP GUI client. This mode increases the reliability of long duration test runs because
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a new process starts every time the specified number of SAP sessions completes. Hence, Windows resource

consumption is bare minimum. You must enable this option for each user group in the schedule.

In the long run mode, a new process is created each time the number of SAP test instances reaches the specified

number.

For more information about how to run a long run mode test, see Running a long run mode SAP GUI test on

page 595.

Cleaning the SAP work directory

In some cases, trace files are created by SAP GUI under SapWor kDi r directory when running SAP performance
tests. You can delete these files by setting and environment variable RPT_CLEAN_SAPWORKDIR or a java VMARG
rptCleanSapWorkDir. For example:

¢ - Dr pt d eanSapWor kDi r =C: \ Docunent s and Setti ngs\ User Nane\ SapWor kDi r

* RPT_CLEAN_SAPWORKDI R="C: \ User s\ User Nane\ AppDat a\ Local \ SAP\ SAP GUI \ Tr aces"

If you set the variable to the SapWor kDi r folder location, the contents (*.trc files) of the folder are removed when
a schedule starts. If the variable is set to t rue or on, the product automatically searches for the SapWor kDi r folder

before removing its contents. If the variable is set to f al se or of f, no action is taken.

Related information

Configuring SAP for performance testing on page 86
Configuring the environment for batch input tests on page 87
Running long duration Citrix tests on page 596

Running long run mode SAP GUI test on page 595

Recording a SAP test

You can record your interaction with the SAP GUI client to generate an SAP test. When you record, the recording

wizard opens the SAP GUI client and records all the interactions that occur between the client and the server.
Before you begin

Verify that SAP GUI Scripting is enabled on the SAP server and the SAP GUI client. See Configuring SAP for

performance testing on page 86 for more information.
Ensure that you have a working SAP GUI and that you can connect to a SAP server.

Tests are stored in performance test projects. If your workspace does not contain a project, the test creation wizard

enables you to creates one.
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Ensure that the session that you are recording is reproducible. For example, if you create items in SAP and do not

delete them, then they will already exist when the test is run, which might cause the test to not run as expected.
Note: HCL OneTest™ Performance 64-bit workbench does not support the SAP protocol.

About this task

You can also record and generate a test by using REST APIs. The APl documentation to record a test

islocated at C: \ Program Fi | es\ __ VENDOR_NAME__\ __ VENDOR_NAME__ | MSHARED!\ pl ugi ns
\comibmrational.test.lt.server.recorder.jar.The APl documentation to generate a test after the
recording completes is located at C: \ Program Fi | es\ __VENDOR_NAME__\ _ VENDOR NAME__ | MSHARED
\plugins\comibmrational .test.|lt.server.testgen.jar.

To record an SAP test:

1. In the Performance Test perspective, click the New Test from Recording toolbar button £ or click File > New
> Test from Recording.

2. In the New Test from Recording wizard, click Create a test from a new recording, select SAP Test, and click
Next.
If you are recording sensitive data, you can select a Recording encryption level.

3. On the Select Location page, select the project and folder for the new test, type a name for the test, and click
Next.
If necessary, click the Create Parent Folder icon [ _ to create a project or folder

4. On the SAP Connection page, select how to connect to the SAP server:
Choose from:

> In most cases, select SAP Logon; then enter the description normally used by SAP Logon to identify
the server in SAP system name.

o If your environment does not support SAP Logon, select Server information. In Application server,
enter the host name or IP address of the server. Then specify a value for System number. Enter
information in Other options, if required. Refer to your SAP documentation for details about the other
SAP Logon options.

o If your environment uses gateways or routers to connect to the SAP server, select Connection by
string. Click Edit to specify a valid connection string. Refer to your SAP documentation for details
about connection strings.

o If you have an SAP shortcut file to automate the connection, select SAP shortcut file. Click Browse to
specify the location of the file.

> You also have the option of logging on to SAP through the HTTP SAP Portal. See Recording a session
with HTTP SAP Portal on page 188 for more information.

o If you want to skip the logon process and start the recording from a specific screen in the middle
of a session, start a session with the SAP Logon program, go to the screen, and then select Record
a running session started from SAP-Logon. The recorded test will not contain any connection

information. This option can be useful for creating split tests.
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5. If this is the first time you record a SAP performance test, read the privacy warning, and select Accept.
6. Click Finish to start recording.
Result
In some cases, you might see a warning that a script is opening a connection to SAP.
7. Log on to SAP and complete the transactions to test.
For security reasons, the password cannot be recorded by the SAP test recorder. Instead, it is requested at the
end of the recording session.
8. In the SAP GUI window, perform the tasks for testing.
You can use the Recorder Test Annotations toolbar to add comments, record synchronizations, or take screen
captures during the recording.
o To add a comment to the recorded test, click the Insert comment icon E.J
> To add a screen capture to the recorded test, click the Capture screen icon 20 Screen and window
captures make your tests easier to read and help you visualize the recorded test. You can change the
settings for screen captures and add a comment to the image.
> To manually add a test synchronization to the recording, click the Insert synchronization icon Izl
> To insert a split point into the recorded test, click the %~ Split point icon *-button. Split points allow.
With split points, you can generate multiple tests from a single recording, thatwhich you can replay
in a different order with a schedule. SeeSplitting a test during recording on page 167 for more
information about splitting a test.
9. When you have completed the transactions to be tested, stop the recorder by closing the SAP GUI or by
clicking Stop [ in the Recorder Control view.
10. In the Enter Password window, enter the password for the account that was used for recording.
This step is required because SAP GUI does not allow direct recording of the password.
Result
A progress window opens while the test is generated. On completion, the Recorder Control view displays this
message: Test generation conpl et ed. The Test Navigator lists your test and the test opens in the test editor.

What to do next
You can now play back the test and check the performance results. Before playing back a test, in SAP Connection
Details editor, click Test Connection to test the connection to the SAP GUI server.

Related information

Creating tests on page
Recording sensitive session data on page 258

Running long run mode SAP GUI test on page 595

Inserting a new recording into a SAP test

You can insert a new recording into a test. Use this feature to add or replace a part of a recorded session.

Before you begin
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Inserting a new sequence into a test requires that the SAP session reaches the same state as is expected at the point
where the new sequence is inserted. To do this, the SAP test recorder automatically replays the existing scenario up
to the insertion point before starting the new recording.

1. In the test editor, select the element before which you want to insert the new recording.
It is easier to manage the new test sequence when the insertion point is at the transaction level of the test.
2. Click Insert, and then New recording.
Result
The test starts replaying up to the selected insertion point.
3. When the New Recording window is displayed, perform the sequence of actions that you want to add to the
existing test.
4. When you have finished, in the New Recording window, click Stop to stop the recording.
Result
A progress window opens while the test is generated. On completion, the Recorder Control view displays the
message, Test generation conpl et ed, and the test is updated with the new contents.
5. After the test has been updated in the Test Navigator, check that the new sequence was properly inserted into

the test, and then click File > Save to save the test or File > Revert to cancel the inserted recording.

Recording a session with HTTP SAP Portal

To measure the performance of a SAP Portal from a web interface, you can record a SAP test by using the HTTP SAP

Portal option.
Before you begin

Verify that the HCL OneTest™ Performance Agent is running on the local computer and that SAP GUI Scripting is
enabled on the SAP server and the SAP GUI client.

Tests are stored in performance test projects. If your workspace does not contain a project, the test creation wizard
creates one with a name that you can change. To store a test in a specific project, verify that the project exists before

you record the test.

Ensure that the session that you are recording is reproducible. For example, if you create items in SAP and do not

delete them, then they will already exist when the test is run, which might cause the test to fail.

Certain websites require appropriate certificates to use a proxy recorder to record the site. The recorder certificate is
required to record all the secured sites. The client certificate is different and it serves as an additional layer of security
that is required by the web server to authenticate the client/browser. If some applications use Secure Sockets Layer
(SSL), the proxy recorder can cause authentication problems because SSL relays traffic between the client and the
server. Depending on the authentication method in place, the client might require the proxy recorder to authenticate
itself as the server, and the server might require the proxy recorder to authenticate as the client. If the client program
requires an authenticated server, you must either have access to the server certificate keystore and provide it to

the proxy recorder or configure the client to accept the default certificate from the proxy recorder instead of the
certificate from the actual server.
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To record an application that requires a client-side certificate, import the client certificate to the HCL OneTest™
Performance project. To import the certificate, click File > Import > General > File System, and navigate to the folder
that contains the certificates and click Finish.

' - =ARch X |
@ Import s »
File system g—1
Import resources from the local file systern. B
-

From directory: C\Program Files\IBM\SDPYjdictjretbin - Browse...

=T [ = msverl00.dil
Emy_keystore.pﬁc
Emy_keystorﬂ.pfx
(8 my_keystore2.pfx
[ = NativeCreds.dll
] = net.dll

] = nie.dl

HEE! npt.dll

7] =l ntthreadsubiect.dll

Filter Types... | | SelectAll || DeselectAll |

(A
Inte folder:  Import_Cert

Options
[] Qverwrite existing resources without warning

[] Create top-level folder

v
B

@

Einish || Cancel

To record an SAP Portal session:

1. Click File > New > Test from Recording; then select SAP Recording, and click Next.

2. Select the project and folder where you want to create the batch input test, type a name for the new test, and
then click Next.

3. On the SAP session page of the wizard, select Record a session initiated from HTTP SAP Portal.

4. Select a web browser and click Next.
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5. Depending on your selection, take one of the following steps. On the Recorder Settings page, depending on

the browser that you selected, specify these details:

o

o

o

o

o

To record HTTP or SOCKS traffic through a proxy, click Record traffic with the proxy recorder. To
record low-level network traffic for applications where a proxy cannot be used, click Record traffic with
the socket recorder. Use this option when you are not using Mozilla Firefox or Microsoft™ Internet

Explorer.

Note: When using proxy recording, you can filter out HTTP or HTTPS requests to a specific
endpoints so that any requests to those endpoints are not recorded. See Proxy recording

preferences on page 1162.

If HCL OneTest™ Ul is installed and shell-shared with HCL OneTest™ Performance, for the Web Ul tests,
you can use the Record user actions option to record the functional aspects of the application in the
same HTTP recording session. Thus, both the functional and performance aspects of the application
are recorded.

If the server requires client SSL authentication, provide the client certificate for the proxy recorder to be
authenticated by the server as though the proxy recorder were the client. Select The server requires a
specific client certificate.

To provide single certificate keystore, specify the file name and password of the server certificate
keystore. If multiple certificates are required, click Multiple certificates, and click Add to specify a
certificate keystore file name and password for each host name and port.

To record a secured site using Internet Explorer or Google Chrome on Windows, install the recorder

certificate by selecting Register the recorder root certificate authority. Before the recording starts, the
browser prompts you to install the certificate. After the recording is stopped, the browser prompts you
to uninstall the certificate. To avoid multiple prompts for each recording, select Keep the recorder root

certificate authority after recording.

Note: If you already had the certificate from a version prior to 9.2.1 and then install the latest

version of the product, you might have to install the certificate again.

This option is not available when you record by using the Firefox or Safari browser. To record a
secured site on these browsers, manually import the certificate in the browser from the default
location C:\ Program Fil es (x86)\__ VENDOR NAME__\__VENDOR NAME__| Mshar ed
\plugins\comibmrational.test.lt.recorder.proxy_version\SSLCertificate.For
information about how to import the certificates, see the browser's documentation.

If you selected Mozilla Firefox, you can choose to use a temporary Firefox profile. This option starts
the Firefox browser without any bookmarks, plug-ins, or toolbars that might be associated with your
usual profile. Select Use an alternate Firefox profile, and then select Use a temporary Firefox profile.
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> If you clicked Record traffic with the proxy recorder, click Advanced to specify whether to use an
HTTP or SOCKS proxy recorder to review and edit network connection settings that the browser uses
or to specify advanced SSL authentication settings. If you clicked Record traffic with the socket
recorder, specify the advanced SSL authentication settings.

6. To start the recording, click Finish.

Result
The web browser opens.

7. In the web browser, type the URL of an SAP Portal web interface.

8. On the web page, follow the logon procedure, and click the link to open the SAP GUI session. The web browser
downloads an SAP Portal shortcut file and opens the SAP GUI application with the session information that
the shortcut file contains.

9. In the SAP GUI client, complete the transactions to record for the test.

10. When you complete the transactions to be tested, stop the recording by closing the SAP GUI and the web

browser.

Results

At the end of the recording session, one test is created that will contain both HTTP and SAP GUI pages. To run an
SAP Portal test, click Run Test.

Recording a SAP batch input test

You can record certain SAP transaction sessions from SAP GUI with SAP batch input tests recording wizard. When
you record a session, the recording wizard automatically starts a SAP GUI interface and records the transaction
that you specified. After you finish the recording, the wizard generates a SAP batch input test in HCL OneTest™

Performance.
Before you begin

You must have added the SAP Java™ Connector (JCo) libraries on your computer. See Configuring the environment
for batch input tests on page 87.

About this task

During a SAP batch input test recording, the SAP batch input test produces only a batch input transaction that you
specified. The SAP batch input tests do not contain any verification point and do not produce any performance result.

1. Access HCL OneTest™ Performance.

2. Click the New Test From Recording & icon or click File > New > Test From Recording from the toolbar.
Result
The New Test From Recording page is displayed.

3. Click Create a test from a new recording, and then select the SAP Test.
4. Click Next.
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. Optionally, click Recording encryption level and select the encryption level when you are recording any

sensitive data.
Result

The Select Location page is displayed.

. Create a test by performing the following steps:

a. Select a project and select a folder from the project.
b. Enter a name for the test, and then click Next.
Result

The Select Client Application page is displayed.

. Select SAP Batch Input Recording, and then click Next.

8. Perform the following steps to enter the connection and transaction details provided by the SAP

administrator.

a. Enter the following details in the Connection section.

Fields Action
Client Enter the SAP client details.
User Enter the user name associated with the SAP server.
Password Enter the password associated with the user name.
Language Select your language.
Host Enter the SAP host server details.
System Number Enter the system number that corresponds to an SAP in-
stance with the SAP server.
Note: For HCL OneTest™ Performance, the default
value is 00.

b. Click Test Connections to verify if the connection is established.

Result

The SAP Batch Connection dialog box is displayed.

A confirmation message is displayed that states that the connection is successful.
c. Click OK.
d. Enter the SAP transaction code in the Code field.

e. Click Finish.
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Result

The SAP GUI window is displayed.

9. Record the batch input transaction, and then click Save.
Result

The SAP GUI Transaction page is displayed.

The page displays the details of the transaction that you recorded.

10. Click Exit.

Note: To exit the SAP GUI Transaction page, you must click Exit. If you exit the page by using any other
methods, an exception error is displayed.

11. Select the directory where you want to export the recording on your local computer, and then click Generate.
Result
The SAPGUI Security dialog box is displayed.

The dialog box displays the file path for the recording and the directory where the recording is being stored.
12. Click Allow to confirm.
Result

A Test Generation Progress window is displayed while the test is being generated.

The following message is displayed on the progress window: Test Generation conpl et ed.

Results
The SAP batch input transaction is recorded.

What to do next
You can click Open Test to open the test in HCL OneTest™ Performance. You can then verify the SAP transaction

details and save the test. Later, you can run the test and view the transaction details from the following pages:

» Test Log page
« SAP Performance report page (SAP Performance Report > Batch Input Transaction)
« Functional Test report page

Related reference

SAP Performance report on page 801
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Changing SAP test generation preferences

You can change how SAP performance tests are generated, such as how tests processes verification points, data

correlation, and pages.

About this task
To change the SAP test generation preferences:

1. Click Window > Preferences.
2. Expand Test > Performance Test Generation, and then click SAP Test Generation.

3. Select the preference to change.
Automatic Generation

The following settings specify test elements that are automatically generated after recording the

test.
Use connection by string

When enabled, tests are generated with the connection by string launch method
instead of using the SAP Logon program. This option is enabled by default.

Verification points for SAP screen titles

When enabled, this option generates verification points on screen titles with each
SAP screen. This option is disabled by default.

Verification points for SAP request response time threshold

When enabled, this option generates verification points on the response time of the
SAP server. If the server response time is above the specified threshold, the test

produces a failed verification point. This option is disabled by default.
Calculate threshold from recorded (%)

This specifies the default response time threshold that is calculated when response time
verification points are generated. The threshold value is calculated as a percentage of the actual
response time that was measured during the recording. By default, the response time threshold

is generated with a value of 120% of the recorded response time.
Default request timeout [ms]

Specify a timeout value for a request to ping the server. When the request is timed out, it no

longer pings the server for that request.
GUI on execution

During test execution, it might not be desirable to display the SAP GUI. Hiding the SAP GUI
improves the performance of the virtual users. This setting specifies the default behavior when
the test is generated. However, you can change this setting in the test editor by selecting the

SAP test element.
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Hide GUI during execution

When selected, all instances of the SAP GUI are hidden. In some cases, modal
dialog boxes from the SAP GUI can flash briefly on the screen. This is the default

setting.

Note: If you run a test in the hidden mode and the test fails due to modal
dialog boxes or pop-up windows in transactions, you must add the
RPT_VMARGS property with value set to r pt SapFor ceShowNone=t r ue in the

Location property.

O New Property 3
Property Mame: Operator: Property Value:
RPT_WMARGS | |= = | | rptSapForceShowMone=true -
QK ] | Cancel

Show GUI for only one virtual user

When selected, the SAP GUI is displayed only for the first virtual user. All other
instances of the SAP GUI are hidden. This allows you to monitor the execution.

Show GUI for all virtual users
When selected, the SAP GUI is displayed for all virtual users.
Password prompt
Specifies behavior of the password request.
Prompt me for password when generating test

When enabled, a password is requested at the end of the recording session. If
disabled, the password is recorded with an empty string. The recorder cannot
record the password during the test. Therefore, if this option is disabled, the test

uses an empty string for the password.

4. Click Apply after changing a setting.

Recording Citrix tests

When you record a test, the test creation wizard records your interactions with the Citrix server, generates a test from
the recording, and opens the test for editing. You can record a test session in the Citrix XenApp client.

Citrix performance testing guidelines

Citrix performance tests use synchronization mechanisms to replay the tests on multiple Citrix sessions
independently of server performance.
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These guidelines will help you record a reliable test and avoid synchronization timeouts during test execution.

Ensure that you have a working Citrix client environment and that you can connect to a Citrix server. .

The most efficient recording method is to specify a published application or a server in the recording wizard. It is

preferable to specify your login credentials in the wizard instead of recording the login sequence as part of the test.

Ensure that the session that you are recording will be reproducible. To record tests that can be reliably replayed,

follow these guidelines:

.

.

If you save a file during a recorded session, when replaying the tests, some applications might produce a
warning for an existing filename. If the warning was not in the recorded session, this might break the test and
cause synchronization timeouts.

Do not use the mouse wheel to scroll when recording Citrix tests. Mouse wheel events are not recorded and
will result in synchronization timeouts on execution.

Anticipate and make provisions for avoidable warnings and unrecorded windows and dialog boxes. For
example, if you save a file while recording, the test will try to save the same file during the replay. Although
the file might not exist during the initial recording, it does after recording. Attempting to save will generate an
overwrite warning and cause synchronization timeouts.

Disable or turn off warnings, windows, and dialog boxes that are displayed during the first start of an
application. These items will be captured during the recording, but they might not be displayed in subsequent
application starts. This will cause synchronization timeouts.

Use dedicated test user accounts for performance tests. Ensure that the user accounts have minimal
potential to cause problems if unpredictable mouse events occur outside of the application window after a
synchronization timeout.

Set up the test accounts and applications to minimize unpredictable window events, such as new mail
notifications, automatic updates, or daily tips. Disable extensible menus and hover text tooltips when possible.
Ensure that all computers used for recording and playback of Citrix tests use the same international settings
and character sets. Different locales can cause some characters to be unavailable or keyboard inputs to be
incompatible.

To launch applications from the desktop, use the Quick Launch bar, desktop shortcuts, or select Start > Run
and enter the name of the application. Do not launch applications or open files from locations that are likely to
change, such as Favorites, Recent Files, or other dynamic menus.

When using cascading menus like the Start menu, always wait for a moment for the submenu to display. After
the recording, when editing the test, look at the mouse sequences that were generated to ensure that they
follow the correct path to display the submenu.

When recording your tests, before interacting with a window or dialog box, click the element to ensure that it
gets focus, then provide input.

When an application is busy, for example when the mouse cursor is a sand glass, avoid using the mouse or
attempting to perform other operations.

After recording a session, some applications require user input before quitting (for example, to record any
changes). This can cause discrepancies between the state of the application at the end of a session and at

the beginning of a test execution. To avoid problems, at the end of a recording session, close all applications
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manually and cleanly end the session by clicking Stop or Close on the Citrix Recorder window, rather than
from the Start > Log Off menu.

« To ensure long duration schedules are run without issues such as test log transfer not completed, Citrix Online
Plugin or Receiver crashes when virtual users are ramping down, and Citrix processes remaining, you must
select the Uninterruptible iteration check box for the loops. When you use this option, you must increase the
value of Time limit for a user to respond to a stop request in the User Load tab of the schedule as per the

requirement.

After recording, and while you edit the test, it is important to perform regular verification runs in order to validate

the test with a single user. After each run, open the test log to make sure that the test synchronizes correctly. If
necessary, change the synchronization level from Mandatory to Conditional or Conditional to Optional on window
events or image synchronizations that produce unnecessary timeouts. Only deploy the test on virtual users or run it in

a schedule when the test is robust enough to run flawlessly with a single user.

HCL OneTest™ Performance Agent requirements

When you install HCL OneTest™ Performance Agent, by default, the agent starts as a service. To use the agent for
Citrix recording, it must run as a process. For Windows, open Windows Services. If the MajordomoService is set to
Automatic start up, set it to Manual and then stop the MajordomoService. You can now open the Majordomo folder
from the HCL OneTest™ Performance Agent installation path and double-click Maj or donp. bat .

Optical Character Recognition

You can use optical character recognition when performing image synchronizations. This allows the test to
synchronize itself by recognizing the contents of a screen area. In some cases, the software can fail to correctly

recognize portions of text or letters.

To improve results of the optical character recognition, follow these guidelines:

« Use preferably high contrast screen areas where the text is clearly separated from the background.

« Select text areas with a homogeneous font size, style, and color. Mixing text styles will produce poor results.

- Try changing the OCR language, OCR zoom factor, OCR brightness, OCR recognition rate or settings in the
image synchronization test element. You can change the default values for these settings in the Preferences >
Test > Test Generation > Citrix Test Generation window.

« If the test produces image synchronization timeouts because of inconsistent text recognition, open the Image
Synchronization view in the test log, and add click the Add value button to add the unrecognized text as an
alternate synchronization value.

« In some cases, it might be more efficient to use the bitmap hash code method for image synchronization,
instead of optical character recognition.

When recording image synchronizations with optical character recognition, accuracy of the recognized text is not
essential. It is only important that the recognized text is consistent each time the test is executed for the test to
synchronize. For example, if a portion of text is displayed as "Hello" on the screen, and recognized as "He110" in the

197



HCL OneTest Performance

recorded test, you should not attempt to correct the value in the image synchronization test element, because the

same result should occur when the test is executed for the test to synchronize.

Long duration test runs

When running long duration test schedules that exceed 24 hours, use the long run mode to reduces resource
consumption with the Citrix client. This mode increases the reliability of long duration test runs by running the tests in

multiple process. You must enable this option for each user group in the schedule.

In long run mode, a new process is created for each virtual tester.

Related information

Running long duration Citrix tests on page 596

Recording a Citrix test

You can record a Citrix session with the Citrix XenApp or XenDesktop. When you record, the recording wizard
automatically starts the client and configures it for recording. When you have finished recording the session, the
wizard generates a Citrix performance test.

Before you begin

« Install Citrix Receiver and connect to Citrix XenDesktop.

- If you use Microsoft Windows 2008, you must have Citrix Receiver 3.3 or 4.1. To run a citrix test on Microsoft
Windows 2008, you must install Citrix Receiver 3.3 or 4.1 and .Net Framework 3.5. To install the .Net
Framework 3.5 feature, open Control Panel and click Turn Windows features on or off. In the Add Roles and
Features Wizard, on the Features page, select the .Net Framework 3.5 Features check box, and click Next. To
specify the source files path of the feature, click Specify an alternate source path, specify the path, click OK,
and click Install.

« The behavior of the recording wizard is controlled by recorder preferences. To inspect the current settings,
click Window > Preferences, expand Test, and click Citrix Recording. This procedure assumes that default
settings are used.

« After you record a test or when you run a test on Windows 2008, the Citrix Image Synchronization tab does
not display the captured screenshot for Actual Image. The bitmap hash code also varies for the actual and
expected screenshot. You must use the bitmap hash code of the Expected Image for Actual Image. To do
that, in the Citrix Image Synchronization, click the Add Value icon and click Yes in the confirmation message.
The Image Synchronization entry is added to the test. Save the test.

« By default, HCL OneTest™ Performance Agent starts as a service. If you run a Citrix test on an agent, you must

start HCL OneTest™ Performance Agent as a process.

To start an agent as a process:
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1. Open the Windows Services window.

2. For the Majordomo service, change the Startup Type to Manual and then change the Status to Stop.

3. From the agent's installation directory, open the Majordomo folder, and double-click the
Majordomo.exe file.

About this task

You can also record and generate a test by using REST APIs. The APl documentation to record a test

is located at C: \ Program Fi | es\ __VENDOR _NAME__\ __VENDOR_NAME__ | MSHARED!\ pl ugi ns
\comibmrational.test.|t.server.recorder.jar.The APl documentation to generate a test after the
recording completes is located at C: \ Program Fi | es\ __VENDOR _NAME__\ __ VENDOR NAME__ | MSHARED

\plugins\comibmrational .test.lt.server.testgen.jar.

To record a Citrix test:

1. In the Performance Test perspective, click the New Test from Recording toolbar button & or click File > New
> Test from Recording.
2. In the New Test from Recording wizard, select Create a test from a new recording, select Citrix Test, and click
Next.
If you are recording sensitive data, you can select a Recording encryption level.
3. On the Select Location page, select the project and folder locations to contain the new test, type a name for
the test, and click Next.
If necessary, click the Create Parent Folder 1 push button to create a new project or folder.
4. On the Citrix Connection Settings page, specify how to connect to the Citrix server. Complete one of these
tasks:
Choose from:
> If your Citrix administrator has provided you with an ICA file, complete these steps:
a. Select With ICA file to use its settings to connect to the server.
b. Click Browse to locate and select the ICA file on your computer.
c. Click Next to continue.
Choose from:
o If you want to manually specify the Citrix server to use for the session, complete these steps:
a. Select On server to connect directly to the server.
b. Specify the name or IP address of the server or click Browse to locate a server or server farm on your
local network.
c. Optional: If you need to change the Citrix farm parameters, click Farm Settings.
d. To record a Windows™ desktop session, leave Initial program blank.
Choose from:
- If your Citrix administrator has published applications on the network, complete these steps:
a. Select On published application, and click Browse to choose the application from the list of published
applications on the server or server farm.
b. Optional: If you need to change the Citrix farm parameters, click Farm Settings.

In this case, the server farm performs the load balancing and selects the server automatically.
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5. To make the logon sequence part of the session parameters, select Logon with user-specified credentials,

type your credentials, and specify the domain name. If this option is disabled, your credentials are recorded as
part of the logon sequence during the recording.

Note: If you use the With ICA file option and the ICA file contains the LogonTicket command, even
after you type your credentials as part of this step, you must type your credentials again on the
Citrix server to start a Citrix test. To avoid entering credentials twice, you can manually remove the
LogonTicket command from the ICA file.

6. Click Next to continue.

10.

. On the Citrix Session Preferences page, you can provide a description for the test, change the video settings,

encryption mode, and advanced options for the Citrix XenApp client. Click Next to continue.

Note: Because Citrix performance tests are based on low-level interactions with the server, including
mouse and window coordinates, the Citrix desktop must be large enough to support the application

under test. You must particularly avoid scrolling windows during the recording.

. If this is the first time you record a Citrix performance test, read the Privacy Warning, and then select Accept

to proceed.

. To start the recording, click Finish.

Result

The Citrix Recording window opens, displaying the Citrix XenApp session and a set of recorder controls.
In the Citrix Recording window, complete the tasks to test.

You can use the recorder controls in the toolbar to add comments, record synchronizations, or take screen
captures during the recording.

a. To add a user comment to the recorded test, click the Insert user comment icon =
Because Citrix tests can be long and difficult to read, meaningful comments can help you locate
important elements.

b. To add an image synchronization to the recorded test, click the Insert image synchronization icon

fél, select an area of the screen to be used for synchronization, and then click the Insert image
synchronization icon again.

Image synchronizations enable the test to keep track of the contents of a screen area during the
replay instead of focusing only on window events. You can use these screen captures to maintain
synchronization of a test in applications that do not create or modify many windows, but update
the contents of a window regularly. The contents of an image can be evaluated either as a bitmap

hashcode or as a text value obtained by optical character recognition.

c. To insert a response time measurement during the recording, click the Insert response time icon = to
create a start for the measurement in the recording, and click the icon again to create a stop.
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d. To add a screen or window capture to the recorded test, click the Capture screen icon .=. or Capture
window icon ..
Screen and window captures make your tests easier to read and help you visualize the recorded test.

To change the settings for screen and window captures, click the Screen capture preferences icon

+H, and then select one of these options:
No automatic screen capture

Select this option if you do not want the test recorder to record screen captures
automatically. When this option is selected, you can still record screen captures

manually. This option is selected by default.
Capture screen every

Select this option to automatically record a periodic screen capture and specify the time
between captures.

Capture screen on window creation
Select this option to record a screen capture each time a window object is created in
Citrix.

Exclude tooltips

When Capture screen on window creation is selected, enable this option to prevent
creating a screen capture each time a tooltip event is displayed during the recording. If

this option is disabled, screen captures are recorded when tooltips are displayed.

To preview all screen captures, window captures, and image synchronizations on the side of the Citrix

Recording window, click the Screen capture preview button icon L)

11. When you have completed the sequence of actions to be tested, close the session, and stop the recorder by

clicking the Stop recording icon 1}
Result
A progress window opens while the test is generated. On completion, the Recorder Control view displays the

Test generation conpl et ed message, the Test Navigator lists your test, and the test opens in the test editor.

Related information

Creating tests on page

Recording sensitive session data on page 258

Recording a test with the Citrix Web Interface

You can record a Citrix session from the Citrix Web Interface to use the load balancing feature provided by this

connection method.When you have finished recording the session, the wizard generates a Citrix test.
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Before you begin

- By default, HCL OneTest™ Performance Agent starts as a service. If you run a Citrix test on an agent, you must

start HCL OneTest™ Performance Agent as a process.

To start an agent as a process:
1. Open the Windows Services window.
2. For the Majordomo service, change the Startup Type to Manual and then change the Status to Stop.
3. From the agent's installation directory, open the Majordomo folder, and double-click the

Majordomo.exe file.

Certain websites require appropriate certificates to use a proxy recorder to record the site. The recorder certificate is
required to record all the secured sites. The client certificate is different and it serves as an additional layer of security
that is required by the web server to authenticate the client/browser. If some applications use Secure Sockets Layer
(SSL), the proxy recorder can cause authentication problems because SSL relays traffic between the client and the
server. Depending on the authentication method in place, the client might require the proxy recorder to authenticate
itself as the server, and the server might require the proxy recorder to authenticate as the client. If the client program
requires an authenticated server, you must either have access to the server certificate keystore and provide it to

the proxy recorder or configure the client to accept the default certificate from the proxy recorder instead of the

certificate from the actual server.

To record an application that requires a client-side certificate, import the client certificate to the HCL OneTest™
Performance project. To import the certificate, click File > Import > General > File System, and navigate to the folder

that contains the certificates and click Finish.
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the browser that you selected, specify these details:

. On the Select Location for Test Suite page, select a project.

. In Test file name, type a name for the Citrix test, and then click Next.

. Click File > New > Test from Recording, and then select Citrix Recording, and click Next.

. On the Citrix Connection Settings page, select Through a Web interface, and click Next.
. On the Select Client Applications page, select the web browser to use and click Next.
. Depending on your selection, take one of the following steps. On the Recorder Settings page, depending on
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To record HTTP or SOCKS traffic through a proxy, click Record traffic with the proxy recorder. To
record low-level network traffic for applications where a proxy cannot be used, click Record traffic with
the socket recorder. Use this option when you are not using Mozilla Firefox or Microsoft™ Internet
Explorer.

Note: When using proxy recording, you can filter out HTTP or HTTPS requests to a specific
endpoints so that any requests to those endpoints are not recorded. See Proxy recording

preferences on page 1162.

If HCL OneTest™ Ul is installed and shell-shared with HCL OneTest™ Performance, for the Web Ul tests,
you can use the Record user actions option to record the functional aspects of the application in the
same HTTP recording session. Thus, both the functional and performance aspects of the application
are recorded.

If the server requires client SSL authentication, provide the client certificate for the proxy recorder to be
authenticated by the server as though the proxy recorder were the client. Select The server requires a

specific client certificate.

To provide single certificate keystore, specify the file name and password of the server certificate
keystore. If multiple certificates are required, click Multiple certificates, and click Add to specify a

certificate keystore file name and password for each host name and port.

To record a secured site using Internet Explorer or Google Chrome on Windows, install the recorder
certificate by selecting Register the recorder root certificate authority. Before the recording starts, the
browser prompts you to install the certificate. After the recording is stopped, the browser prompts you
to uninstall the certificate. To avoid multiple prompts for each recording, select Keep the recorder root
certificate authority after recording.

Note: If you already had the certificate from a version prior to 9.2.1 and then install the latest
version of the product, you might have to install the certificate again.

This option is not available when you record by using the Firefox or Safari browser. To record a
secured site on these browsers, manually import the certificate in the browser from the default
location C:\ Program Fil es (x86)\ __VENDOR NAME__\ __VENDOR NAME__| Mshar ed
\plugins\comibmrational.test.lt.recorder.proxy_version\SSLCertificate.For
information about how to import the certificates, see the browser's documentation.

If you selected Mozilla Firefox, you can choose to use a temporary Firefox profile. This option starts
the Firefox browser without any bookmarks, plug-ins, or toolbars that might be associated with your
usual profile. Select Use an alternate Firefox profile, and then select Use a temporary Firefox profile.
If you clicked Record traffic with the proxy recorder, click Advanced to specify whether to use an
HTTP or SOCKS proxy recorder to review and edit network connection settings that the browser uses
or to specify advanced SSL authentication settings. If you clicked Record traffic with the socket

recorder, specify the advanced SSL authentication settings.

7. To start the recording, click Finish.
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Result

The web browser opens.

8. In the web browser, specify the Citrix Web Interface server URL

. On the Citrix Web Interface page, type your user name, password, and domain to open a session. The Citrix
Web Interface displays the list of applications published on a server and available to the user. Select the
application to test.

The Citrix Recording window opens. You can use the recorder controls in the toolbar to add comments, record
synchronizations, or take screen captures during the recording.

a. To add a user comment to the recorded test, click the Insert user comment icon =,
Because Citrix tests can be long and difficult to read, meaningful comments can help you locate

important elements.

b. To add an image synchronization to the recorded test, click the Insert image synchronization icon

+2), select an area of the screen that will be used for synchronization, and then click the Insert image
synchronization icon again.

Image synchronizations enable the test to keep track of the contents of a screen area during the
replay instead of focusing only on window events. You can use image synchronizations to maintain
synchronization of a test in applications that do not create or modify many windows, but update

the contents of a window regularly. The contents of an image can be evaluated either as a bitmap
hashcode or as a text value obtained by optical character recognition. You can also add verification

points to image synchronizations in the test editor.

[ - ]

c. To add a screen capture to the recorded test, click the Capture screen icon =..

Screen captures make your tests easier to read and help you visualize the recorded test.

d. To change the settings for screen captures, click Screen capture preferences icon =, and then select
one of these options:

No automatic screen capture

Select this option if you do not want the test recorder to record screen captures
automatically. When this option is selected, you can still record screen captures

manually. This option is selected by default.
Capture screen every

Select this option to automatically record a periodic screen capture and specify the time

between captures.
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Capture screen on window creation
Select this option to record a screen capture each time a window object is created in
Citrix.

Exclude tooltips

When Capture screen on window creation is selected, enable this option to prevent
creating a screen capture each time a tooltip event is displayed during the recording. If

this option is disabled, screen captures are recorded when tooltips are displayed.

10. When you complete the sequence of actions to be tested, close the session and stop the recorder by clicking

the Stop recording (E|) or close the Citrix application and web browser..

Result

A progress window opens while the test is generated. On completion, the Recorder Control view displays the
Test generation conpl et ed message, the Test Navigator lists your test, and the test opens in the test editor.

Results
The Test editor displays both the HTTP pages and the Citrix user actions.

What to do next

To run the Citrix Web Interface test, click Run Test in the Test editor.

Inserting a new recording into a Citrix test

You can insert a new recording into a Citrix test. Use this feature to add or replace a part of a recorded session.
Before you begin

Inserting a new sequence into a test requires that the Citrix session reaches the same state as is expected at the
point where the new sequence is inserted. For example, if your new sequence must interact with a particular window
that was created earlier in the test, you must advance to the point where that window is in the expected state before
the recording can start. To do this, the Citrix test recorder can either automatically replay the existing scenario up to

the insertion point, or you can manually advance the session to the expected state.

When inserting a new sequence into a test, it is important that the context of user actions is preserved to ensure that
the test synchronizes properly during the replay. The resulting test will probably require manual editing to make sure

that test can replay smoothly.

Note: Because Citrix tests contain low level user input and synchronizations, minor changes can prevent the
test from working. When editing these tests, you must ensure that they are functionally identical.

To insert a recording into a test:

1. In the test editor, select the element before which you want to insert the new recording.
It is easier to manage the new test sequence when the insertion point is at the window event level of the test.
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2. Click Insert, and then Record scenario.
3. In the Update Recording window, specify how you want the session to reach the state expected at the
insertion point, and then click OK.
Choose from:
> Select Automatically replay the scenario to replay the test up to the insertion point. With this option,
the test replays and stops when it reaches the insertion point. If the replay fails to synchronize, you will
be asked to manually bring the session to the expected insertion point state.
> Select Manually advance to the expected state to manually put the Citrix session into the state that
will be expected at the insertion point.
4. After the Citrix session is in the expected state and you are ready to start the new recording, engage the
Enable/Disable recording @ button in the toolbar.
If you chose the automatic replay option, the recording is enabled automatically.
5. Perform the sequence of actions that you want to add to the existing test. When you have finished, click the

Enable/Disable recording & again to stop the recording.

Note: You can restart the recording several times. However, you must be sure that the Citrix session
resumes from the same state that it was in when it was stopped. If actions are missing from the

recorded sequence the test is unlikely to synchronize correctly during the replay.

6. When you have completed the sequence of actions to be inserted into the test, close the session and stop the

recorder by clicking Stop recording 1y
Result
A progress window opens while the test is generated. On completion, the Recorder Control view displays the
message Test generation conpl et ed, the Test Navigator lists your test, and the test opens in the test editor.

7. After the test has been updated in the Test Navigator, check that the new sequence was properly inserted into
the test before saving the new test.
Check that the context of the Citrix session is compatible with the user actions at the beginning and at the end
of the of the inserted sequence. If the results of the insertion were not what you expected, you can revert to
the previously saved version of the test by clicking File > Revert or try to correct any problems manually.

Changing Citrix recording preferences

You can change the behavior of the recorder by changing the preference settings.

1. Click Window > Preferences.
2. Expand Test > Recording, and then click Citrix Recording.
3. Select the setting you want to change.

Screen capture options

These settings specify how the test recorder performs screen captures of the Citrix desktop
during recording.
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No automatic screen capture

Select this option if you do not want the test recorder to record screen captures
automatically. When this option is selected, you can still record screen captures
manually. This option is selected by default.

Capture screen every

Select this option to automatically record a periodic screen capture and specify the
time between captures.

Capture screen on window creation
Select this option to record a screen capture each time a window object is created
in Citrix.

Exclude tooltips

When Capture screen on window creation is selected, enable this option to
prevent creating a screen capture each time a tooltip event is displayed during the
recording. If this option is disabled, screen captures are recorded when tooltips are
displayed.

Capture screen on image synchronization

Select this option to ensure that a screen capture is recorded each time an image
synchronization is recorded.

4. After changing a setting, click Apply.

Changing Citrix test generation preferences

You can change how Citrix events are converted into performance test elements.

1. Click Window > Preferences.
2. Expand Test > Test Generation, and then click Citrix Test Generation.
3. Select the setting you want to change.

Recording Optimization Options
These settings specify how mouse and window events are interpreted in the generated test.
Window activate recording

Specify whether to record no, last, or all window-activate actions when a sequence
of similar actions is detected.
- none disables recording of window-activate events.
o last records only the last of an uninterrupted sequence of window events.
This eliminates redundant window-activate actions from the recording.

o all records all events of the sequence.
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Mouse move recording

This setting specifies which mouse move events are recorded. Relevant is the
default setting.
> All records an uninterrupted sequence of mouse movements in the
generated test.
> Relevant records only the mouse movements that generate a response,
such as hover text.

> First and last records a simplified mouse-move action.
Automatic Generation
These settings specify test elements that are automatically generated after recording the test.
Verification point on every window title change

When enabled, this option generates a window title verification point whenever the
caption changes. If this option is disabled, the window title is verified only when a
new window is created. This option is disabled by default.

Response times for main windows

When enabled, this option generates response time measurements for all recorded
main window-create events. A main window is a window that is created at the top
level of the test contents tree and contains user actions. The generated response
time measurement starts with the keyboard or mouse action that immediately
precedes the window-create event. This option is enabled by default.

Window event synchronization criteria

Use this option to disable window recognition on the window position, size, or title. Disable any
of these options if the test produces synchronization timeouts because a window changes its
position, size, or title between or during test runs.

Default Test Execution Delays

This page specifies the default keyboard and mouse delays for the test client. Do not change

these settings unless you are experiencing problems with events that do not run correctly.
Synchronization timeout delay

This is the delay after which a timeout error is produced when a window event or
an image synchronization element is not recognized during test runs. The default
value is 15000 milliseconds. The specified delay is for synchronizations that are
set as conditional. Mandatory synchronizations use a delay of three times the

specified delay. Optional synchronizations use a fixed delay of 2 seconds.
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Note: In the generated test, the Override synchronization timeout for a
particular window creation event will be enabled with the corresponding

recorded time only if it is greater than what is specified in this preference.

If think time is under x ms, then replace with

If the delay between two events is above the specified limit, then it is handled as a
think time. If the delay is below the limit, then the test generator replaces the think
time with one of the following delays. The think time is the delay spent by a virtual

user before performing an action. The default limit is 20000 milliseconds.

Note: In the generated test, the think time for a particular user action will
be enabled only when the recorded think time is greater than the value

specified for this preference.

Delay between mouse down and mouse up in a click

This is the default delay used to generate a mouse click action using a mouse
down and a mouse up action. The default value is 20 milliseconds.

Delay between two mouse clicks in a double click

This is the default delay used to generate a double-click action using two mouse

clicks. The default value is 50 milliseconds.
Delay between key down and a key up in a stroke

This is the default delay used to generate a key-stroke action using a key-down and

a key-up action. The default value is 20 milliseconds.
Delay between two keyboard strokes in a text input

This is the default delay used to generate a text input action using multiple key
stroke actions. The default value is 50 milliseconds.

Default OCR settings

This page specifies the settings for text extraction by optical character recognition in image
synchronizations. You might need to experiment with various settings to obtain good results.
These settings define the default behavior for new image synchronizations. You can change the
behavior for individual image synchronization elements by changing the OCR settings in the test

editor.
OCR default language

This is the language of the dictionary that is used to recognize words for the
application that you are testing. This setting defines the subset of languages that

will be available in image synchronization elements in the test editor.
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OCR default zoom factor

This is the enlargement factor that is applied to the image. The default setting is
medium for standard font sizes. Increase the zoom factor to improve recognition

of smaller fonts or decrease for larger fonts.
OCR default brightness

This is the brightness level from 0 to 250 that is applied to the image. The default
setting is 70 for text with normal contrast. Increase the brightness setting to
improve recognition of darker images or decrease for lighter images.

OCR default recognition rate

This is the rate of recognition that is required for the extracted string to match
the expected text. Decrease the recognition rate to tolerate a proportion of
mismatching characters in the recognized text. The default is 100%, which means

that an exact match is required.

4. After changing a setting, click Apply.

Recording service tests

When you record a test, the test creation wizard records your interactions with the service, generates a test from the
recording, and opens the test for editing. You can record a test session by invoking service calls with the generic
service client or by using an existing client. You can also create a service test manually or from a Business Process

Execution Language (BPEL) model.

Service testing guidelines

Before you can test a service, you must set up your test environment and incorporate these guidelines in order to

produce reliable tests.

Test prerequisites

Before creating service tests, you might need to perform some initial tasks. These tasks depend on the transport and

security protocols that are implemented by the web service under test.

- HTTP: This transport method is supported by default; no additional configuration is required.

« SSL: The workspace must contain the certificate keystore (JKS) files that are required for single or double
authentication.

+ Java™ Message Service (JMS): The Web Services Description Language (WSDL) syntax must be compatible
with the requirements of the product. Refer to Verifying WSDL syntax compliance for JMS services on

page 213.
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Test generation

When the test is generated, message call envelopes are created according to the XML schema definition (XSD).
During this process, mandatory fields are created, and default choices are assumed. You can modify these elements

in the test editor.

Note: During recording, you might supply authentication details which are not relevant for the actual
application under test. To exclude such actions from the generated test, in Window > Preferences > Test >
Test editor > Service test ensure that the Display the 'Skip if Empty' column in XML tree viewer check box is
selected. To select the empty XML elements that you want to skip, in the test editor, select the elements in the
Skip if empty column.

Encryption and security

The Java™ Runtime Environment (JRE) that the product uses must support the level of encryption required by the
digital certificate that you select. For example, you cannot use a digital certificate that requires 256-bit encryption with
a JRE that supports only 128-bit encryption. By default, the product is configured with restricted or limited strength
ciphers. To use less restricted encryption algorithms, you must download and apply the unlimited jurisdiction policy

files (| ocal _policy.jar and US_export _policy.jar).

For Oracle Java, download the files from this site:http://www.oracle.com/technetwork/java/javase/downloads/jce8-
download-2133166.html.

Before installing these policy files, back up the existing policy files in case you want to restore the original files later.

Then overwrite the filesin/j re/ i b/ security/ directory with the unlimited jurisdiction policy files.

SSL Authentication

Service tests support simple or double SSL authentication mechanisms:

- Simple authentication (server authentication): In this case, the test client needs to determine whether the
service can be trusted. You do not need to setup a key store. If you select the Always trust option, you do not

need to provide a server certificat key store.

If you want to really authenticate the service, you can configure an certificate trust store, which contains the

certificates of trusted services. In this case, the test will expect to receive a valid certificate.

« Double authentication (client and server authentication): In this case, the service needs to authenticate the
test client according to its root authority. You must provide the client certificate keystore that needs to be

produced to authenticate the test as a certified client.

When recording a service test through a proxy, the recording proxy sits between the service and the client. In this
case, you must configure the SSL settings of the recording proxy to authenticate itself as the actual service to the
client (for simple authentication), and as the client to the service (for double authentication). This means that you

must supply the recording proxy with the adequate certificates.
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When using stub services, you can also configure the SSL settings of the stub service to authenticate itself as the

actual server. This means that you must supply the service stub with the adequate certificate.

NTLM and Kerberos Authentication

The product supports Microsoft™ NT LAN Manager (NTLMv1 and NTLMv2) and Kerberos authentication. The
authentication information is recorded as part of the test during the recording phase.

To enable NTLMv2 support, you must add a third party library to the workbench. For more information, see
Configuring the workbench for NTLMv2 authentication on page 485.

Digital certificates

You can test services with digital certificates for both SSL and SOAP security protocol. Digital certificates must be
contained in Java™ Key Store (JKS) keystore resources that are accessible in the workspace. When dealing with
keystore files, you must set the password required to access the keys both in the security editor and the test editor.
For SOAP security you might have to provide an explicit name for the key and provide a password to access the
private keys in the keystore.

Limitations
Arrays are not supported.

Because of a lack of specification, attachments are not supported with the Java™ Message Service (JMS) transport.

The envelope is directly sent using UTF-8 encoding.

All security algorithms are not always available for every Java™ Runtime Environment (JRE) implementation. If a
particular security implementation is not available, add the required libraries to the class path of the JRE that this

product uses.

The generic service tester displays the envelope as reflected in the XML document. However, security algorithms
consider the envelope as a binary. Therefore, you must set up the SOAP security configuration so that incoming and

outgoing messages are correctly encrypted but remain decrypted inside the test.

Performance

Virtual user performance depends on the implementation of the container application. For an HTTP transport, the
product has been tested with a maximum of 900 concurrent virtual users under Windows™ and 600 under Linux™.
For JMS, the maximum is 100 concurrent virtual users, although this number can vary due to the asynchronous

implementation of JMS. Beyond these values, connection errors might occur and the transaction rate will decrease.

Verifying WSDL syntax compliance for JMS services

Various Java™ Message Service (JMS) providers vary in the syntax used for describing services. Before testing JMS
services, you must ensure that Web Services Description Language (WSDL) files comply with the requirements of the
tool.
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1. In the project explorer or test explorer, locate and open the WSDL file for the JMS service that you want to test.
If necessary, you can import a WSDL file from the file system by clicking File > Import > File System.
2. Ensure that the following criteria are met in the syntax of the WSDL file that you use.

o Namespace: xn ns: j ms="ht t p: / / schermas. xni soap. or g/ wsdl / j ms/ "
> SOAP bindings are set to: t ransport="htt p: / / schemas. xn soap. or g/ soap/ j ms"
> JMS transports are defined either as a URL or as j ns: addr ess element

3. If the WSDL file is not compliant, edit the file so that it meets the criteria, and then save and close the file.

Exemple

For example, a JMS defined as a URL looks like this:

<soap:address location="jms:/queue?jndiConnectionFactoryName=UIL2ConnectionFactory;
jndiDestinationName=queue/testQueue;
initialContextFactory=org.jnp.interfaces.NamingContextFactory;
jndiProviderURL=9.143.104.47"/>

A JMS defined as an address looks like this:

<jms:address destinationStyle="queue"
jndiConnectionFactoryName="myQCF"
jndiDestinationName="myQ"
initialContextFactory="com.ibm.NamingFactory"
jndiProviderURL="11iop://something:9600/">
</jms:address>

Configuring the environment for SOAP security

SOAP security profiles require access to the libraries that implement encryption, signature, and other security
algorithms that transform the XML messages before sending and after receiving them. You must prepare an
environment with these libraries to use SOAP security, set the class path of the Java™ Runtime Environment (JRE)

that Eclipse uses, and set the class path of the virtual machine that the Agent Controller uses.
Before you begin

Before you can test SOAP-based services that use security algorithms, you must obtain a set of security libraries and
configuration files for SOAP.

BouncyCastle (http://www.bouncycastle.org) is a provider of such security libraries. Use of these security libraries is
optional for the Rational® test product.

1. Copy the library files into the j re/ | i b/ ext of the JRE installation.

By default, this is the following directory: C: \ Progr am Fi | es\ HCL\ HCLOneTest \j dk\j re\l i b\ ext

2. Add the following VM argument either to the Eclipse launch command line or to the ecl i pse. i ni file:

-vmar gs- Dosgi . par ent C assl oader =ext

The ecl i pse.ini fileis located in the same directory as the ecl i pse. exe launcher binary that is used to
run the product.
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What to do next

To configure a remote computer that uses only the Agent Controller and does not require access to the workbench,

perform only step 1 and restart the Agent Controller service.

After configuring the environment, you must import a Web Services Description Language (WSDL) file and use the
WSDL security editor to set up a security profile for the WSDL file.

Recording a service test with the generic service client

You can record a service test by invoking service requests with the generic service client. After you have sent the
requests and received the responses from the service, select the results in the History section of the generic service
client to generate a test. If you do not have access to a dedicated client for the service calls, the generic service client
is the easiest way to generate the calls and to record a test.

Before you begin

If you are testing a SOAP-based web service, ensure that you have access to a valid Web Services Description
Language (WSDL) file. The wizard can import WSDL files from the workspace, the file system, a remote repository,
or from a URL. Ensure that the WSDL files use the correct syntax for the test environment. The generic service client
might not work with some WSDL files.

If you are using Secure Sockets Layer (SSL) authentication, ensure that you have the required key files in your
workspace.

If you are using SOAP security, ensure that you have configured the environment with the correct libraries and
configuration files.

If the response in a recording or test generation is in XML and the size of the XML data is higher than the value

set in the XML Message Received maximum length field, the response is automatically converted to text to avoid
any memory issues. To convert the full response to text, the tool checks the value set for Text Message Received
maximum length. If the value is lesser than the size of the response, the response is truncated. If you want the
response to be in XML when the response size exceeds the value set in XML Message Received maximum length,
you can manually increase the value for both recording and test generation. To change the value for recording, click
Window > Preferences > Generic Service Client > Message Edition. To change the value for test generation, click

Window > Preferences > Test > Test Generation > Service Test Generation.
About this task

You can also record and generate a test by using REST APIs. The APl documentation to record a test

is located at C: \ Program Fi | es\ __VENDOR _NAME__\ __ VENDOR_NAME__ | MSHARED!\ pl ugi ns
\comibmrational.test.lt.server.recorder.jar.The APl documentation to generate a test after the
recording completes is located at C: \ Program Fi | es\ __ VENDOR_NAME__\ _ VENDOR_NAME__ | MSHARED
\plugins\comibmrational.test.|lt.server.testgen.jar.
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To use a WS-SecurityPolicy that is included in a WSDL or an external XML file, you need to configure the security
policy as described in Using a security policy on page . If a recording contains the Security Assertion Markup
Language (SAML) token, the WS Security policy file must rely on the Service Token Service (STS) that produces the

token. This token can then be used for encryption or other purposes as was designed.
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Sample policy file that relies on SAML token:

<sp:SupportingTokens xmlns:sp="http://schemas.xmlsoap.org/ws/2005/07/securitypolicy">
<wsp:Policy>
<sp:IssuedToken
sp:IncludeToken="http://schemas.xmlsoap.org/ws/2005/07/securitypolicy/IncludeToken/AlwaysToRecipient">
<sp:Issuer>
<Address
xmlns="http://www.w3.0rg/2005/08/addressing">http://9.143.105.204:8080/axis2/services/STS</Address>
</sp:Issuer>
<sp:RequestSecurityTokenTemplate>
<t:TokenType
xmlns:t="http://schemas.xmlsoap.org/ws/2005/02/trust">http://
docs.oasis-open.org/wss/oasis-wss-saml-token-profile-1.1#SAMLV2.0</t:TokenType>
<t:KeyType
xmlns:t="http://schemas.xmlsoap.org/ws/2005/02/trust">http://
schemas.xmlsoap.org/ws/2005/02/trust/SymmetricKey</t:KeyType>
<t:KeySize xmlns:t="http://schemas.xmlsoap.org/ws/2005/02/trust">256</t:KeySize>
</sp:RequestSecurityTokenTemplate>
<wsp:Policy>
<sp:RequireInternalReference/>
</wsp:Policy>
</sp:IssuedToken>
</wsp:Policy>
</sp:SupportingTokens>

1. In the Performance Test perspective, click the New Test from Recording toolbar button “% or click File > New
> Test from Recording.

2. In the New Test from Recording wizard, click Create a test from a new recording, select Service Test, and
click Next.
If you are recording sensitive data, you can select a Recording encryption level.

3. On the Select Location page, select the project and folder where you want to create the test, type a name for
the test, and click Next.
If necessary, click Create Parent Folder [ | to create a project or folder

4. On the Select Location page, select Generic Service Client.
This option uses the generic service client if you do not have access to a dedicated client for the service calls.
See Recording a service test through a client program on page 217 for information about using other client
programs to record the test.

5. Click Next. If this is the first time you are recording a web service test, read the Privacy Warning, select Accept,
and click Finish to proceed.
Result
The generic service client opens.
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. If your service uses a transport or authentication protocol that requires overriding the default settings, then

click the Transport tab and create an HTTP, Java™ Message Service (JMS), IBM® WebSphere® MQ, IBM®
WebSphere® Java MQ, or Java MQ transport.

. Click the Requests tab.

Choose from:
> Right-click WSDLs &% and select one of the options to get the WSDL file.
o Right-click WADLs & and select one of the options to get the WADL file.
o Right-click Endpoints ¥ and select one of the options to send the request.

See Sending service requests with the generic service client on page 481 for more information about using

the generic service client.

8. After creating the call, click the Edit Data arrow to change the details of the call if necessary.

9. Click the Invoke arrow to invoke the service call.

10.
11.

12.

Result
If the call was successful, the response is displayed under the View Response arrow.
To record a test with multiple calls, repeat steps 6 through 9.

When you have finished sending service requests, stop the recorder. You can do this by closing the generic

service client or by clicking the Stop push button = in the Recorder Control view.

If you changed the network settings of the client program as described in step 8, you can revert to the default
settings before closing the program.

Result

The Generate Service Test wizard opens.

Click Finish.

What to do next
Alternatively, you can use the generic service client to create, edit, and invoke the calls without recording. Successful

responses are added to the Request History list. You can select calls in the Request History list, and click the

Generate Test Suite icon “L".

Related information

Sending service requests with the generic service client on page 481
Recording a service test through a client program on page 217
Recording sensitive session data on page 258

Sending service requests with WSDL files on page 494

Recording a service test through a client program

You can record tests for SOAP-based, XML, plain text, or binary services with any client program that uses the HTTP

protocol. To record the test, the recorder intercepts the service calls and message returns between the client and the

service. You can choose between an HTTP or SOCKS proxy recorder or a low-level socket recorder, depending on the

capabilities of the client program.
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Before you begin

The following recorders are available for recording traffic from an application:

» SOCKS proxy recorder: Use this recorder when no proxy connections are required.

« HTTP proxy recorder: Use this recorder when a proxy connections is required to connect to the network or
when the client program does not support SOCKS.

« Socket recorder: Use this recorder for low-level network traffic when the client does not support proxies.
This recorder does not support SSL authentication or encryption of any kind and is only available if the HCL

OneTest™ Performance Extension for Socket Protocols is installed.

™

Regardless of the recorder that you use, the client program must use the HTTP network protocol. For recording Java
Message Service (JMS) or IBM® WebSphere® MQ tests, see Recording a service test with the generic service client

on page 215.

If you are using Secure Sockets Layer (SSL), the HTTP or SOCKS proxy can cause authentication problems because
the proxy recorder relays traffic between the client and the server. Depending on the authentication method in place,
the client might require that the proxy recorder authenticate itself as the server and the server might require that

the proxy recorder authenticate as the client. If the client program requires an authenticated server, you must either
have access to the server certificate keystore and provide it to the proxy recorder or configure the client to accept the

default certificate from the proxy recorder instead of the certificate from the actual server.

If you are testing a SOAP-based web service, ensure that you have access to a valid Web Services Description
Language (WSDL) file. The wizard can import WSDL files from the workspace, the file system, a remote repository,
or from a URL. Ensure that the WSDL files use the correct syntax for the test environment. The generic service client
might not work with some WSDL files.

If you are using SOAP security, ensure that you have configured the environment with the correct libraries and
configuration files.

To record a service test with a client program:

1. In the Performance Test perspective, click the New Test from Recording toolbar button & or click File > New
> Test from Recording.

2. In the New Test from Recording wizard, click Create a test from a new recording, select Service Test, and
click Next.
If you are recording sensitive data, you can select a Recording encryption level.

3. On the Select Location page, select the project and folder to create the test in, type a name for the test, and
click Next.
If necessary, click Create Parent Folder Fto create a project or folder

4. On the Select Client Application page, select the type of client program to use.
The program type defines the recorder that can be used. The following client program types are supported for
recording a service test:

Choose from:
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- Managed Application: This option starts a specified program and uses a proxy or socket recorder to

record the traffic.

On the Managed Application Options page, click Browse to specify the Program path. If necessary,
specify the Working directory, and type the command line Arguments that the program requires.

If the program requires user input from a command-line interface, select Open console for user input.

> Choose a web browser to record traffic that is sent and received with the web browser.

- Unmanaged Application: This option enables you to record traffic from one or multiple client programs
that use a proxy. You must manually start the client programs and the proxy recorder records all traffic
that is sent and received through the specified network port.

- Generic Service Client: This option uses the generic service client if you do not have access to a
dedicated client for the service calls. See Recording a service test with the generic service client on
page 215 for using the generic service client to record service tests.

5. On the Recorder Settings page, depending on the type of client program you selected, specify these details:

a. If you selected Managed Application, specify the recording method.
= Select Record traffic with the proxy recorder to record HTTP or SOCKS traffic through a proxy.
= Select Record traffic with the socket recorder to record low-level network traffic for
applications where a proxy cannot be used. This recorder does not support SSL authentication

or encryption.

Note: When using proxy recording, you can filter out HTTP or HTTPS requests to a specific
endpoints so that any requests to those endpoints are not recorded. See Proxy recording

preferences on page 1162

b. If you selected Record traffic with the proxy recorder, specify whether the proxy recorder uses HTTP
or SOCKS. Select HTTP if a connection to proxy is required or if your application does not support
SOCKS.

c. If you are using SSL authentication, specify the authentication settings for the proxy recorder.
During the recording, the proxy recorder is between the client and the server.
= If the server requires client SSL authentication, provide the client certificate for the proxy
recorder to be authenticated by the server as though the proxy recorder were the client. Select

The server requires a specific client certificate.

To provide single certificate keystore, specify the file name and password of the server
certificate keystore. If multiple certificates are required, click Multiple certificates, and click

Add to specify a certificate keystore file name and password for each host name and port.

= To record a secured site using Internet Explorer or Google Chrome on Windows, install the
recorder certificate by selecting Register the recorder root certificate authority. Before the

recording starts, the browser prompts you to install the certificate. After the recording is
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stopped, the browser prompts you to uninstall the certificate. To avoid multiple prompts for

each recording, select Keep the recorder root certificate authority after recording.

Note: If you already had the certificate from a version prior to 9.2.1 and then install the

latest version of the product, you might have to install the certificate again.

This option is not available when you record by using the Firefox or Safari

browser. To record a secured site on these browsers, manually import the

certificate in the browser from the default location C. \ Pr ogram Fi | es

(x86)\ __VENDOR _NAME__\ __ VENDOR_NAME__ | Mshar ed\ pl ugi ns
\comibmrational.test.|t.recorder.proxy_version\SSLCertificate.For
information about how to import the certificates, see the browser's documentation.

If the client requires server authentication, you must provide the server certificate keystore
for the proxy recorder to be authenticated by the client as though the proxy recorder were
the server. Select The client requires a specific server certificate, and click Add to specify a
certificate keystore filename and password for each hostname and port. If you do not select

this option, the proxy recorder provides its own default certificate.

Note: The keystore must contain the private certificate of the server.

d. If you selected to use the HTTP proxy recorder, specify how to connect to the network. If necessary,

specify an HTTP or SOCKS proxy or point to a proxy auto-configuration (PAC) file.

Use this option if you are connecting to the service through a corporate proxy or firewall.

6. Click Next. If this is the first time you record a service test and you did not select a web browser for the client

application, read the Privacy Warning, select Accept, and click Finish to proceed.

7. If you selected a proxy recorder with a managed or unmanaged application, change the network settings of

the client program to use the proxy recorder.

The method for changing the network settings depends on the client program. However, you must be able to

set the following proxy settings in the program:

> SOCKS or HTTP proxy: Specify the protocol that you selected for the proxy recorder in the wizard.

o Host name: Set to | ocal host .

o Port: Specify the port number that you selected for the proxy recorder in the wizard.

To avoid unexpected results, revert to the previous proxy settings before you stop the recording.

8. Use the client program to perform the actions to test.

You can use the Recorder Test Annotations toolbar to add comments, record synchronizations, or take screen

captures during the recording.

> To add a comment to the recorded test, click the Insert comment icon :E.J.

> To add a screen capture to the recorded test, click the Capture screen icon iZ0. Screen and window

captures make your tests easier to read and help you visualize the recorded test. You can change the

settings for screen captures and add a comment to the image.

> To manually add a synchronization point to the recording, click the Insert synchronization icon =N
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> To manually add a transaction folder to the recording, click the Start Transaction icon ¥~ and Stop
Transaction £ icon to start and stop the transaction.

> To insert a split point into the recorded test, click the Split point icon *-. With split points, you can
generate multiple tests from a single recording, which you can replay in a different order with a
schedule.

9. After you finish the user tasks in the client program, stop the recorder. You can do this by closing the client

program or by clicking the button Stop B in the Recorder Control view.

If you changed the network settings of the client program as described in step 8, you can revert to the default
settings before closing the program.

Result

The Generate Service Test wizard opens.

10. If you inserted a split point during the recording, on the Destination page, specify the location for the split test
or merge the split recordings together.

See Splitting an HTTP test during recording on page 167 for more information about splitting tests.

11. On the Service Test Generation Options page, if you are testing a SOAP-based web service, specify a Web
Services Description Language (WSDL) file from the workspace or click Add to import a WSDL or to link to a
remote WSDL file and click Next.

12. Select the domains to include in the test and click Finish. The domains that are not selected are not included
in the test. You can add them back by generating the test again from the recording.

To include all the domains for all of the recordings, click the Select all and remember my decision check box.
To enable the filter again for HTTP tests, click Window > Preferences > Test > Test Generation > HTTP Test
Generation, and, for Service tests, click Service Test Generation and then click the Enable domain review
before test generation check box.

13. Click Finish.

Results
A progress window opens while the test is generated. On completion, the Recorder Control view displays the Test

generation conpl et ed message, the test navigator lists your test, and the test opens in the test editor.

Related information

Recording a service test with the generic service client on page 215
Sending service requests with the generic service client on page 481
Recording sensitive session data on page 258

Sending service requests with WSDL files on page 494

Preparing to record a test for the HTTP/2 service

To test a web service that is based on the HTTP/2 protocol, record a test by using the SOA extension of HCL
OneTest™ Performance. Before recording the HTTP/2 service, follow the procedure in this topic to configure your

computer.
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About this task
This configuration is required because this feature is released as Beta and is intended for use in a non-production
environment only.

Use Mozilla Firefox or Google Chrome when recording on servers that support the HTTP/2 service.

1. Download the following Application Layer Protocol Negotiation (ALPN) boot jar file https://
mvnrepository.com/artifact/org.mortbay.jetty.alpn/alpn-boot/8.1.8.v20160420

2. Create or rename the pr oduct I nstal | Di r\j dk folderto. . \j dk. i bm You can rename the folder back to
j dk later to test with the IBM JDK.

3. Download Oracle Java 1.8.0u92 from http://www.oracle.com/technetwork/java/javase/downloads/
jdk8-downloads-2133151.html. You can then either extract the compressed file or install Java at
productlnstal | Dir\jdk.

4. Copy the ALPN jar file to pr oduct I nst al | Di r\ maj or dono\ | i b.

5. From product I nstal | Di r,openecl i pse.ini and add the following flags:

-Xbootclasspath/p:<productinstallDir>\majordomo\lib\alpn-boot-8.1.8.v20160420.jar
Note: If there are any other flags starting with -X, delete those flags.

6. Configure HCL OneTest™ Performance Agent to use Oracle Java.
a. Stop the Majordomo process.

On Windows systems, run the following command: cd “ci\program files\hcl\hcl onet est \Majordomo?
ngast op

On Linux systems, run the following command: cd / opt / HCL/ HCLOneTest / Maj or dono . / MDSt op. sh
b. Set the environment variable RPT_JAVA to the Oracle Java binary or executable file.

On Windows systems, run the following command: set RPT_JAVA=c:\program fil es\j ava

\jdk1l.8.0_92\bin\java. exe
On Linux systems, run the following command: export RPT_JAVA=/root/j dk1.8.0_92/jre/bin/java
c. Start the Majordomo process.

7. When you record a service by using a web browser against an HTTP/2 client, the HTTP/2 traffic is
automatically captured. But, to record an HTTP/2 service by using the GSC client, in the HTTP transport

protocol configuration dialog box, you must select the Activate check box.


https://mvnrepository.com/artifact/org.mortbay.jetty.alpn/alpn-boot/8.1.8.v20160420
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i ™
@ Create HTTP Protocel configuration - ve w "* ﬁ

Create HTTP Protocol configuration "?}
.
Create a new HTTP Protoecel configuration //
LR K
Marme: Test
HTTR/2
Activate

+* Time outs

http/2 client connection time out (ms) 300000
Time out for the http/2 session creation (ms) 120000

» Client values

Use HTTP Keep Alive

Server Mame Indication

Use 550 [New 55L configuration v] [ Configure S5L

Platform Authentication

@ Mone

(7 Basic HTTP Authentication
MTLM

Kerberos

Configure proxy

Custom class: B

i ?\ [ 0] 4 ] [ Cancel

8. Specify the following configuration options for HTTP/2:
HTTP/2

Note: Testing HTTP/2 service is in the Beta mode. For more information, see Preparing
to record a HTTP/2 service on page 221.

To test a service that uses the HTTP/2 protocol, select the Activate check box. This check box

is automatically selected when you record a service by using a browser. If you use the Generic

Service Client component to create a HTTP/2 test, you have to manually select the check box.
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HTTP/2 client connection timeout
Specifies the time limit for the HTTP/2 client to connect to the HTTP/2 server.
Time out for the HTTP/2 session creations

Specifies the time limit to create the HTTP/2 session. This time starts after the connection is
established.

Enable HTTP/2 Push

The Push functionality of HTTP/2 automatically identifies and passes the related objects or
requests to the client when a request is sent to the server. Clear the check box to not use the

functionality.
Initial session window
Specifies the buffer size on the sessions.
Initial stream window
Specifies the window size for buffer on each stream after the connection is established.
HTTP/2 Client Input Buffer Size
Specifies the buffer size that is used to read the network traffic.
Maximum Quantity of Messages that can be queued

Specifies the maximum number of messages that can be queued for the HTTP/2 client on a
thread.

Maximum Quantity of HTTP/2 thread pool

Specifies the maximum number of thread pools that will be used by the HTTP/2 client to
distribute the workload.

Minimum Quantity of HTTP/2 thread pool

Specifies the minimum number of thread pools that will be used by the HTTP/2 client to

distribute the workload.
HTTP/2 client bytebuffer pool size
Specifies the buffer size to receive the unciphered values.

Server Name Indication
Note: Not applicable for HTTP/2.
Clear this check box if you do not want to connect to the host computer by using the Server

Name Indication protocol. If the host computer is already configured with Server Name

Indication protocol, you should keep this check box selected.
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Use HTTP Keep Alive

Select this option to keep the HTTP connection open after the request. This option is not
available if you are using IBM® Rational® AppScan®.

Use SSL

Select this option to use an SSL configuration. Click Configure SSL to create an SSL
configuration or select an existing configuration.

Platform Authentication

In this section, specify the type of authentication that is required to access the service. Select
None if no authentication is required.

Basic HTTP authentication

Select this option to specify the User Name and Password that are used for basic
authentication.

NTLM authentication
Note: Not applicable for HTTP/2.

Select this option to use the Microsoft™ NT LAN Manager (NTLM) authentication
protocol. NTLM uses challenge-response authentication. This view lists what

is negotiated (supported by the client and requested of the server) and what is
authenticated (the client reply to the challenge from the server).

Kerberos authentication

Note: Not applicable for HTTP/2.

Select this option to use the Kerberos authentication protocol between the client
and server.

Connect through proxy server
Note: Not applicable for HTTP/2.

If the HTTP connection needs to go through a proxy server or a corporate firewall, specify the
Address and Port of the proxy server. If the proxy requires authentication, select either Basic
proxy authentication or NTLM proxy authentication.

Proxy authentication

In this section, specify the type of authentication that is required to access the
proxy. Select None if no authentication is required.
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Basic proxy authentication

Select this option to specify the User Name and Password that are
used for basic authentication.

NTLM proxy authentication

Select this option to use the Microsoft™ NT LAN Manager

(NTLM) authentication protocol. NTLM uses challenge-response
authentication. This view lists what is negotiated (supported by the
client and requested of the server) and what is authenticated (the
client reply to the challenge from the server).

Custom class
Note: Not applicable for HTTP/2.

Select this option if the communication protocol requires complex, low-level processing with
a custom Java™ code to transform incoming or outgoing messages. Click Browse to select
a Java™ class that uses the corresponding API. This option is not available in IBM® Security
AppScan®.

9. Click OK. You have configured the workbench to test an HTTP/2 service.

What to do next

You can now record a regular SOA test for the HTTP/2 service. After the recording, in the Version field of request
details, the requests are marked with HTTP/2 indicating that the HTTP/2 traffic is captured. If the test playback fails,
check if all the steps are correctly followed.

Optimizing HTTP/2 tests for SOA

HTTP/2 tests require a lot of CPU and memory resources. When you apply load on HTTP/2 tests using computers
that do not have enough resources, the tests might fail. You might want to configure or tune the computers that run
HTTP/2 tests.

CPU Usage

Ensure that the HTTP/2 tests get adequate CPU resources to run. If there are other processes running on the
computer and they are not required, you can stop them. For example, the CPU usage statistic in the image below
indicates that the other processes (shown in red) on the computer are consuming a lot of resources whereas the test
execution process (shown in green) is getting less resources.
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CPU Usage

8327

Memory usage and garbage collection

Ensure that enough memory is available for the test execution. You can configure the garbage collector and adjust the

memory heap size.

Garbage Collection - Consider using the following values so that the garbage collector does not allocate large
amount of temporary memory. By doing so, you are tuning the number of threads allocated for the garbage collector
according to the capability of the computer. You apply the values for each location asset of the schedule.

RPT_VMARGS
-XX:MaxGCPauseMillis=250 -XX:ParallelGCThreads=6 -XX:ConcGCThreads=3 -XX:GCTimeRatio=19

~ General Properties

ROOTDIR = JStmp/cloud_agent
OPERATING_SYSTEM = LIMUX

_CLouD ROLE = CLOUD AGEMT
RPT_VMARGS = -}:MaxGCPauseMillis=250..
LOCATIOM_TEMPLATE = SmyProj/Cloud-5L.loctemp...
RPT_EMABLE_IP_ALIASIMG = FALSE
RPT_IPA_EMABLE ALL IMTE.. = TRUE

Memory heap - Consider using the following values for memory heap:
RPT_VMARGS
-Xms11024m
RPT_DEFAULT_MEMORY

22412m
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General Properties

ROOTDIR = ftmp/cloud_agent
OPERATING_SYSTEM - LINUX
CLOUD_ROLE - CLOUD_AGENT

| RPT_VMARGS - -Xms11024m |
LOCATIOM_TEMPLATE = SmyProj/Cloud-5L1octemp...
RPT_ENABLE IP_ALIASING = FALSE
RPT_IPA_ENABLE_ALL INTE.. = TRUE

| RPT_DEFAULT_MEMORY - 22412m |

Thread Usage

Ensure that you start load testing with fewer virtual testers and gradually ramp up the workload. This practice helps
in observing the changes in the workload, that is, the number of calls per second. In the graph, when the number of
calls per second is flat, it indicates that the maximum capacity of the computer is reached and there is no need to add

more virtual testers.

Platform tuning

Configure the TCP/Socket capabilities of your system by following these two links:
https://wiki.eclipse.org/Jetty/Howto/High_Load
https://msdn.microsoft.com/en-us/library/aa560610%28v=bts.20%29.aspx

Creating a service test from a BPEL model

You can use Business Process Execution Language (BPEL) resources from your workspace to automatically generate
a set of service tests that corresponds to the paths that are run in a synchronous BPEL model.

Before you begin

Tests are stored in test projects. If your workspace does not contain a test project, the test creation wizard creates
one, enabling you to change its name. To store a test in a specific project, verify that the project exists before you
record the test.

If you are using Secure Sockets Layer (SSL) authentication, ensure that you have any required key files in your
workspace.

If you are using Java™ Message Service (JMS), ensure that you have configured the environment with the correct
libraries and configuration files. Ensure that the WSDL files use the correct syntax for the test environment.

If you are using SOAP security, ensure that you have configured the environment with the correct libraries and
configuration files.

BPEL models must be synchronous. Asynchronous BPEL models are not supported.


https://wiki.eclipse.org/Jetty/Howto/High_Load
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Ensure that the BPEL models refer to the WSDL files in a valid import statement, for example:

<bpws:import importType="http://www.w3.0rg/2001/XMLSchema" location="foo.wsdl" namespace="http://foo"/>

Relative file paths, such as: "../../foo.wsdl" are not supported.

Ensure that you have one or more valid Web Services Description Language (WSDL) files and the associated BPEL
model in your workspace. Only the calls to services with a valid web service binding are taken into account. For
example, if the BPEL model was produced in IBM® Websphere Integration Developer, then services must be exported

with the following web service bindings:

<bpws:invoke name="myOperation" operation="myOperation" partnerLink="IServicePartner"
portType="ns3:IService" wpc:displayName="myOperation" wpc:id="20">

Only BPEL invoke activities are considered for generating tests. Any BPEL receive and reply activities are ignored.

Websphere Integration Developer does not generate the required soapAct i on attributes for the soap operations in the

WSDL files. Please edit the generated WSDL files, as follows for every operation: <soap: operati on soapAction=""/>.

To create a service test from a BPEL model:

1. In the Performance Test perspective, click File > New > Other > Test > Test Assets > BPEL to Web service test,
and then click Next.

2. Click Browse to select a BPEL file from the workspace, and click Next.

3. On the Web service test generation page, change the number of paths by specifying how activities and
sequences from the flow of the BPEL model are processed. Each path generates one test.

a. In the Flow section, select how any concurrent sequences that are found in the flow will be converted
into paths.

. In the Switch section, select whether to test otherwise activities from the flow.

. Inthe Throw section, select how throw activities from the flow are converted into paths.

. In the Invoke section, select whether to test inline catches inside invoke activities from the flow.

™ QO o T

. Select Enable data correlation in generated tests to automatically create references in the generated
test elements by propagating variables to the parameters of the web service call and message return
elements.

4. Click Recount paths to update the number of paths to test, and click Next.

One test is generated for each path.
5. For WSDL operations that are bound to multiple ports, you must select one port that is to be used for the test.

Under each test that will be generated, the Operations list displays the WSDL operations that are bound to

multiple ports.

If no WSDL operations are displayed under the tests, this means that all operations are bound to a single port.
In this case, skip step 6.

a. In the Operations list, expand a test and select a WSDL operation that requires binding.
b. In the Binding ports list, select the port that you want to use to test the selected WSDL operation.
c. Repeat steps a and b for each WSDL operation that requires binding.
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6. Click Next.
7. Select a location and a name for the new folder where the tests generated from the BPEL model are created,
and click Finish.

Results
A new folder is created in the Test Navigator containing the generated service tests. These tests are generated with

default message content and must be edited with valid input values.

Creating a service test manually

You can create a service test without recording by simply adding the test elements as required and manually editing
the test element details in the test editor.

Before you begin

Tests are stored in test projects, which are test projects that include a source folder. You must create a test project

before creating a test.

Ensure that you have a valid WSDL file in your workspace. Ensure that the WSDL files use the proper syntax for the

test environment.

If you are using Secure Sockets Layer (SSL) authentication, ensure that you have any required key files in your

workspace.

If you are using SOAP security, ensure that you have configured the environment with the proper libraries and

configuration files.

1. In the workbench, click File > New > Other > Test > Test Assets > Web service test or click the New Service

Test 2 toolbar button.

2. Select a project and, in Name, type a name for the test, and then, click Next.
The name that you type is the base name for the recording, test, and other required files. You see these files
in standard Navigator or the Java™ Package Explorer with their distinguishing suffixes, but you see only the
simple (test) name in the Test Navigator.

3. Select a web service request to create the test for.
If you select Web service request or one of the options in Specification-based structure, specify a WSDL port
and then configuration properties for the HTTP protocol. If you select, XML request and Text request, specify
the configuration properties for the HTTP, JMS, WebSphere MQ, WebSphere Java MQ, and Microsoft.Net
protocols.

For information about the configuration properties of each protocol, see the topics in Sending service
requests with the generic service client on page

4. Click Finish. The service test is created.
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Creating a service test for WebSphere® MQ

You can create an IBM® WebSphere® MQ test by adding the test elements as required and editing the test element
details in the test editor.

Before you begin

Tests are stored in test projects, which are Java™ projects that include a source folder. You must create a test project

before creating a test.

Ensure that you have a valid Web Services Description Language (WSDL) file for a WebSphere® MQ service in your

workspace.

If you are using Secure Sockets Layer (SSL) authentication, ensure that you have any required key files in your

workspace.

If you are using SOAP security, ensure that you have configured the environment with the correct libraries and

configuration files.

1. In the workbench, click File > New > Other > Test > Test Assets > Web service test or click the New Service

Test & toolbar button.
2. Select a project, and then, in Test file name, type a name for the test and click Next.
The name that you type is the base name for the recording, test, and other required files. You see these files in
the standard Navigator or the Java™ Package Explorer with their distinguishing suffixes, but you see only the
simple (test) name in the Test Navigator.
3. In the Select a service request interface page, complete one of the following steps:
a. To test a service that use a WSDL file, select Web service request or Specification-based structure,
click Next, and select a WSDL file.
b. To test a service that does not use a WSDL file, select XML Request, Text Request, Binary Request or
an Empty test.
4. Click Next and select the WebSphere MQ protocol.
5. In SOAP Action, specify the SOAP action to be used to invoke the MQ request.
6. To override the message header and descriptor that was specified in WebSphere MQ transport configuration,
click Override MQ Protocol Configuration values and specify the customize header and message descriptor.
7. Click Finish. The service test is created.
8. On the web service call, click Update Response.
This opens the Response Preview window, displaying the data that will be used to perform the call.
9. Click Update Test.
This action calls the web service and creates a message return element with the return data. If a message
return element already exists, then it is updated with latest return data. With the message return test element,

you can implement data correlation and content-based verification points.
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Creating a service test for WebSphere Java MQ

To test Java-based applications, create a service test and add the WebSphere Java MQ messages. You can create a

service test by using Generic Service Client option [ or the New Service Test wizard 2.
Before you begin
Connect to a WebSphere MQ server.

If you are using Secure Sockets Layer (SSL) authentication, ensure that you have any required key files in your

workspace.

If you are using SOAP security, ensure that you have configured the environment with the correct libraries and

configuration files.

1. In the workbench, click File > New > Other > Test > Test Assets > Web Service Test or click Create a Service

Test .
2. Select a project, and then, in Test file name, type a name for the test.
The name that you type is the base name for the recording, test, and other required files. You see these files in
the standard Navigator or the Java™ Package Explorer with their distinguishing suffixes, but you see only the
simple test name in the Test Navigator.
3. In the Select a service request interface page, complete one of the following steps:
a. To test a service that use a WSDL file, select Web service request or Specification-based structure,
click Next, and select a WSDL file.
b. To test a service that does not use a WSDL file, select XML Request, Text Request, Binary Request or
an Empty test.
4. Click Next, select the WebSphere Java MQ protocol, and specify a transport configuration. If necessary,
click New to create the transport configuration for the call. See Creating a WebSphere Java MQ transport
configuration on page 488.

5. Complete the following information in the General tab:

Learn more about the Ul elements in the General tab:
Queue
Name of the queue as defined on the WebSphere MQ server.

Message type

The types of messages are these:
o Datagram means that the message does not require a reply.
> Request means that the message requires a reply.
> Reply means that the message is a reply to an earlier request message.
> Report means that the message is reporting on some expected or unexpected
occurrence, usually related to some other message. An example is a request

message that contained data that was not valid.
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Message Persistence

This value indicates whether the message is persistent or not. If the message is
persistent, it survives the system failures and restarts of the queue manager. If the
message is not persistent, it survives a restart if it is present on a queue having the
NPMCLASS(HIGH) attribute. However, even with the NPMCLASS(HIGH) attribute a
message does not survive a QMGR class. Nonpersistent messages on queues having
the NPMCLASS(NORMAL) attribute are discarded at queue manager restart, even if the
message is found on the auxiliary storage during the restart procedure.

Dynamic Reply

Select this check box for the WebSphere MQ server to dynamically create a temporary
queue as a reply. If this check box is not selected, the message in Reply Queue is used.

Reply Queue
This is the name of the message queue to which the application that issued the get
request for the message should send the reply and report messages.

Reply Manager

This is the name of the queue manager on which the reply-to queue is defined.
Additional properties

Specify the additional properties for the queues.

6. Optional: If necessary, complete the following information on the Config tab:

Learn more about the Ul elements in the Config tab:

Message Priority

This is the priority of the message. The lowest priority is 0.
Encoding
This is the numeric encoding of numeric data in the message. This value does not apply
to numeric data in the MQMD structure itself.
Expiry Interval
This is the period of time, in tenths of a second, after which the message becomes

eligible to be discarded if it has not already been removed from the target queue. The

expiry interval is set by the application that put the message.
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Character set

This is the character set identifier of the character data in the application message data.

7. Optional: In the Report tab, select the report messages to receive.

8. Optional: If necessary, complete the following information in the Context tab:

Learn more about the Ul elements in the Context tab:

Application Identity Data
This information is defined by the application suite. Use it to provide information about
the message or its originator.

Application Origin Data
This information is defined by the application suite. Use it to provide additional
information about the origin of the message.

Accounting Token
This information is needed by the application to appropriately charge for the work that is
done as a result of the message.

User ID

This is the user identifier of the application that originated the message.

9. Optional: In the Identifiers tab, for the messages that require binary input, specify the ID in the string format
in the second column. The first column is filled automatically in the hexadecimal format.
10. Optional: In the Segmentation tab, select the segment of the message and click Next.
11. If you had selected XML Request, click Next, select a XSD file and click Finish.
Result

The new service test is created.

What to do next

You can now enhance the test and run it.

Creating a service test for a plain XML call

You can create a test for a plain XML call over HTTP, JMS, or IBM® WebSphere® MQ, by simply adding the test

elements as required and editing the test element details in the test editor.
Before you begin

Tests are stored in test projects, which are Java™ projects that include a source folder. You must create a test project
before creating a test.
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If you are using Secure Sockets Layer (SSL) authentication, ensure that you have any required key files in your

workspace.

If you are using SOAP security, ensure that you have configured the environment with the correct libraries and

configuration files.

1. In the workbench, click File > New > Other > Test > Test Assets > Service Test or click the New Service Test

2 toolbar button.

2. Select a project, and then, in Test file name, type a name for the test and click Next.
The name that you type is the base name for the recording, test, and other required files. You see these files in
the standard Navigator or the Java™ Package Explorer with their distinguishing suffixes, but you see only the
simple (test) name in the Test Navigator.

3. On the Select Service Call Interface page, select whether you want to create a test using a plain XML call
interface or a Web service call interface.
If you select web service call interface, select or add a WSDL file and then, select port to which the call will be
binded. Click Next.

4. On the Configure Protocol page, select either HTTP, JMS or WebSphere® MQ as the protocol and then,
specify the options for the selected Protocol configuration.

5. On the Select Root Element page, you can select an XSD and then, select a root element for the call.

6. Click Finish.

Changing service test generation preferences

You can change default test generation values by changing the preference settings. The default settings, however, are

appropriate for recording in most cases.

1. Click Window > Preferences > Test > Web Services Test Generation

2. Select the setting to change.
Time out delay used for call

This is the default time out for web service calls. If the web service does not respond within this

period, an error is produced.
Think time default value
This is the default think time for generated tests.

3. After changing a setting, click Apply.

Recording socket and TN3270 tests

When you record a test, the test creation wizard records your interactions with the application under test, generates a

test from the recording, and opens the test for editing.
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Socket performance testing guidelines

Before you can test the performance of TCP/IP socket-based applications, set up your test environment and

incorporate these guidelines to produce reliable performance tests.

Limitations

You can use this extension to test applications that run in a client-server model, where the test simulates multiple
clients that connect to one or several servers. Other models, such as peer-to-peer networks, are not supported.

HCL OneTest™ Performance does not support socket recording in the 64 bit versions of Microsoft Windows 2003 and
Windows XP. Also, you cannot record 64 bit applications on 64 bit Windows 10 and Windows 2016 systems.

Performance

When you deploy performance tests, use a relevant number of virtual users on a given computer is important. For
example, if you deploy too many virtual users on a single computer, the results will reflect more the load of the test

computer than the load of the server.

For best results with performance tests on an average test computer with a 1 GHz processor and 1 GB of RAM, do not

exceed 1000 concurrent virtual users.

If you exceed the number of virtual users that a single test computer can run, the measured performance of the server

will be affected by the performance of the test computer, which will invalidate the final results.

When editing a schedule for long performance tests, use these guidelines:

« In the schedule editor, reduce the Test log level to None.

« In the schedule editor, set the Statistics sample interval to approximately 1/60 of the run time, for example 12
minutes for an estimated 12-hour session.

» When possible, use loops inside test suites rather than loops in the schedule. Using loops inside test suites
avoids connection problems that might occur over long duration tests and emphasizes measurement of the
send and receive activity rather than connection and close activity.

SSL/TLS Authentication

Socket tests support simple or strong Secure Sockets Layer (SSL) or Transport Layer Security (TLS) authentication

mechanisms, also called server authentication and client authentication.

For server authentication, the client must determine whether the server can be trusted. When you are recording or
running a socket test with a proxy recorder, the proxy recorder sits between the server and the client. Therefore, you
must "trick" the client application into behaving as though the proxy recorder is the certified server by performing
either one of the following actions:
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- Configure the SSL or TLS settings of the recorder proxy to authenticate itself as the actual server to the client
and as the client to the service. This means that you must supply the recording proxy with the adequate
certificates.

« Configure a managed client (an external client application) to accept the proxy recorder as though it
were the certified server. The recording wizard provides a link to download and import an HCL OneTest™

Performancecertificate into the client application.

For client authentication, the server must authenticate the test client according to its root authority. Therefore, you
must provide the client certificate that is expected by the server to authenticate the proxy recorder or the test agent

as a certified client.
See Digital certificates overview on page 244 for more information about managing digital certificates.

TN3270 performance testing guidelines

Before you can test the performance of TN3270 terminal applications, set up your test environment and incorporate

these guidelines to produce reliable performance tests.

Limitations

You can use this extension to test applications that run on a TN3270 terminal emulation client, where the test

simulates multiple terminals that connect to one or several servers.

These TN3270 terminal emulation packages are supported:

» IBM® Personal Communications
» Attachmate EXTRA! X-treme

Performance

When deploying your performance tests, use a relevant number of virtual users on a given computer. For example, if
you deploy too many virtual users on a single computer, the results reflect more the load of the test computer than

the load of the server.

For best results with performance tests on an average test computer with a 1 GHz processor and 1 GB of RAM, do not

exceed 1000 concurrent virtual users.

If you exceed the number of virtual users that a single test computer can run, the measured performance of the server

is affected by the performance of the test computer, which invalidates the final results.

When editing a schedule for long performance tests, use these recommendations:
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« In the schedule editor, reduce the Test log level setting to None.

- In the schedule editor, set the Statistics sample interval value to approximately 1/60 of the run time, for
example 12 minutes for an estimated 12-hour session.

« When possible, use loops inside test suites rather than loops in the schedule. Using loops inside test suites
avoids connection problems that might occur over long-duration tests and emphasizes measurement of the

send and receive activity rather than connection and close activity.

Recording a socket API performance test

You can record a socket API test from any client program on your computer. When you record, the recording wizard

automatically starts the client program and records all the data that transits through the socket API.
Before you begin

Tests are stored in performance test projects. If your workspace does not contain a performance test project, the
test creation wizard creates one with a name that you can change. To store a test in a specific project, verify that the

project exists before you record the test.
Ensure that you have a working client program and that you can connect to the server.

Ensure that the session that you are recording is reproducible. This means that when the recorded actions are

replayed by the test, the same responses from the server will be received.

HCL OneTest™ Performance does not support socket recording in the 64 bit versions of Microsoft Windows 2003 and
Windows XP. Also, you cannot record 64 bit applications on 64 bit Windows 10 and Windows 2016 systems.

To record a socket test:

1. In the Performance Test perspective, click the New Test from Recording toolbar button “& or click File > New
> Test from Recording.

2. In the New Test from Recording wizard, click Create a test from a new recording, select Socket Test, and click
Next.
If you are recording sensitive data, you can make a selection in Recording encryption level.

3. On the Select Location page, select the project and folder to create the test in, type a name for the test, and
click Next.
If necessary, click Create Parent Folder [ to create a new project or folder.

4. On the Select Client Application page, select the type of client program to use to record the test:
Choose from:

> To specify any client program that is located on your computer, select Managed Application, and click
Next.

On the Managed Application Options page, click Browse to specify the Program path. If necessary,
specify the Working directory, and inArguments type the command-line arguments that the program

requires.

If the program requires user input from a command-line interface, select Open console for user input.
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o To record a TN3270 terminal emulation session, select IBM Personal Communication or Attachmate

EXTRA! X-treme if these programs are installed, and click Next.

If required, specify a session file to start the TN3270 session.

Note: Using this method to record a TN3270 session produces a low-level socket API
performance test that is based on the TN3270 protocol traffic. To record a TN3270 test, see
Recording a TN3270 performance test on page 240.

> To record an HTTP session, select Microsoft Internet Explorer or Mozilla Firefox, and click Next.

If you choose Mozilla Firefox, you can specify a Firefox profile.

Note: Using this method to record an HTTP session produces a socket APl performance test
that is based on the HTTP traffic. To record an HTTP test, see Recording an HTTP test on
page 156.

5. If the application uses Secure Sockets Layer (SSL) and Transport Layer Security (TLS) authentication to
authenticate the server or the client application, specify the following options, and click Next:
Choose from:
- Select The server requires a specific client certificate if you are using client authentication. Specify
a certificate keystore file name and password. If multiple certificates are required, click Multiple
certificates and specify a certificate keystore file name and password for each host name and port.
> Select The client requires a specific server certificate to provide the certificate keystore file name of

the server and a password for each host name and port.

If you do not provide the server certificate, you must configure the client application to authenticate
the certificate of the proxy recorder as though the proxy recorder were the actual server. Click Save
this certificate to save the certificate that is generated by HCL OneTest™ Performance, and import the
. cer file into the client application.

If necessary, select whether to use SSL 3.0 and TLS 1.0 encryption. See Socket performance testing
guidelines on page 236 for more information about SSL and TLS authentication.

6. If this is the first time that you record a socket API performance test, read the Privacy Warning, and select
Accept to proceed.

7. Click Finish to start recording.
Result
A progress window opens while the client program starts.

8. Use the client program to perform the actions to test.
You can use the Recorder Test Annotations toolbar to add comments, record synchronizations, or take screen

captures during the recording.
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> To add a comment to the recorded test, click the Insert commenticon :E.J.

> To add a screen capture to the recorded test, click the Capture screen icon iZ0. Screen and window
captures make your tests easier to read and help you visualize the recorded test. You can change the
settings for screen captures and add comments to images.

> To manually add a test synchronization to the recording, click the Insert synchronization icon El

> To manually add a transaction folder to the recording, click the Start Transaction icon ﬁi} and Stop
Transaction icon EE' to start and stop the transaction.

> To insert a split point into the recorded test, click the Split point icon #-. With split points, you can
generate multiple tests from a single recording, which you can replay in a different order with a
schedule. See Splitting a test during recording on page 167 for more information about splitting a
test.
9. When you have finished test actions in the program, stop the recorder. You can do this by closing the client

program or by clicking the Stop = push button in the Recorder Control view.
Result
A progress window opens while the test is generated. On completion, the Recorder Control view displays the

Test generation conpl et ed message, the Test Navigator lists your test, and the test opens in the test editor.

Related information

Socket performance testing guidelines on page 236
Recording a TN3270 performance test on page 240
Recording sensitive session data on page 258
Recording an HTTP test on page 156

Recording service tests on page 211

Recording a TN3270 performance test

You can record a TN3270 test from a terminal emulation client. When you record, the recording wizard automatically

starts the terminal emulation client and records all the screen and input activity that transits the socket connection.
Before you begin
Ensure that you have a TN3270 terminal emulation program installed on the local computer.

Tests are stored in performance test projects. If your workspace does not contain a performance test project, the
test-creation wizard creates one with a name that you can change. To store a test in a specific project, verify that the

project exists before you record the test.

Ensure that the session that you are recording is reproducible. This means that when the recorded actions are

replayed by the test, the same responses from the server will be received.

To record a socket test:
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. In the Performance Test perspective, click the New Test from Recording toolbar button “& or click File > New
> Test from Recording.

. In the New Test from Recording wizard, click Create a test from a new recording, select TN3270 Test, and
click Next.
If you are recording sensitive data, you can select a Recording encryption level.

. On the Select Location page, select the project and folder where to save the new test, type a name for the test,
and click Next.
If necessary, click Create Parent Folder [ to create a new project or folder

. On the Select Client Application page, select the type of client program to use to record the test:
Choose from:

o In most cases, select IBM Personal Communication or Attachmate EXTRA! X-treme, and click Next.

If required, specify a session file to start the TN3270 session.

- If you are using other TN3270 terminal emulation software, select Managed Application, and click
Next.

On the Managed Application Options page, click Browse to specify the program path. If necessary,
specify the Working directory, and in Arguments, type the command-line arguments that the program
requires.

If the program requires user input from a command-line interface, select Open console for user input.

. If this is the first time you record a socket API performance test, read the Privacy Warning, and select Accept
to proceed.
. Click Finish to start recording.
Result
A progress window opens while the TN3270 terminal program starts.
. Use the TN3270 terminal program to perform the actions to test.
You can use the Recorder Test Annotations toolbar to add comments, record synchronizations, or take screen
captures during the recording.
> To add a comment to the recorded test, click the Insert commenticon :'2).
> To add a screen capture to the recorded test, click the icon = Capture screen. Screen and window
captures make your tests easier to read and help you visualize the recorded test. You can change the
settings for screen captures and add a comment to the image.
> To manually add a test synchronization to the recording, click the Insert synchronization icon Izl
> To manually add a transaction folder to the recording, click the Start Transaction icon rﬁ} and Stop
Transaction icon E'E} to start and stop the transaction.
> To insert a split point into the recorded test, click the Split point icon -. With split points, you can
generate multiple tests from a single recording, which you can replay in a different order with a
schedule. See Splitting a test during recording on page 167 for more information about splitting a
test.
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8. When you have finished test actions in the program, stop the recorder. You can do this by closing the TN3270

terminal program or by clicking the Stop push button [ in the Recorder Control view.

Result

A progress window opens while the test is generated. On completion, the Recorder Control view displays the
Test generation conpl et ed message, the Test Navigator lists your test, and the test opens in the test editor.

Related information

TN3270 performance testing guidelines on page 237
Recording a socket API performance test on page 238

Recording sensitive session data on page 258

Changing test generation preferences

You can change the way that the test recorder organizes multiple send and receive elements in a new socket test by

changing test generation preferences. To improve the readability of your test, you can merge consecutive send or

receive elements that use the same connection.

Before you begin

To change the way that test elements are organized by default in a new test, you can change the test generation

preferences before recording the test.

To merge or reorganize elements in an existing test, you can use the Organize wizard. See Merging socket send and

receive elements on page 3671 for more information.

To merge send or receive elements in a new socket test:
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. Click Window > Preferences > Test > Test Generation > Socket Test Generation.

Result
The Socket Test Generation preferences window opens.

. Select Strategies.

You can create multiple organization strategies for handling different applications. Only one strategy is active

during the recording.

3. Select Default Strategy or click New to create an organization strategy.
4. Click Settings.
5. In Edit Socket Strategy Settings, specify how you want the test recorder to generate multiple send and receive

elements:
Send elements
Merge consecutive send elements

Select this option to merge together all the consecutive socket send elements that

use the same connection.
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Manipulate data with custom code

Select this option to force all the selected send elements to enable the Manipulate
data with custom code setting with the specified Class name of a custom Java™

class that uses the API to process data in the socket send element.
Receive Actions
Do not merge

Select this option to keep receive elements unmodified as they are initially
recorded.

Merge consecutive receive elements

Select this option to merge together all the consecutive socket receive elements

that use the same connection.
Keep only last receive element

Select this option to discard all multiple consecutive receive elements except the

last one recorded.
Response timeout

The maximum delay (in seconds) to receive the first byte of the response. If no
data is received before the end of the response timeout delay, the receive action
produces an error in the test log. The response timeout counter starts when the
receive action starts after the think time; the counter is interrupted when the first

byte is received.
End policy

This option specifies when to stop receiving data and to move to the next test
element.
> Receives exact number of bytes: The receive action stops when the

recorded number of bytes is received. Specify a Timeout (in seconds) after
which the receive action produces an error in the test log, if the correct
number of bytes is not received. If Link data size is enabled, the receive
action expects the number of bytes displayed in the Data area. If Link data
size is disabled, the receive action expects the number of bytes displayed
in Bytes. This is the default setting

o

Receives until end of stream: The receive action stops when the
connection is closed by the remote computer. If Accepts empty response
is selected, then the reception of a single byte is not required and the
Response Timeout is ignored. Specify a Timeout (in seconds) after which
the receive action produces an error in the test log, if the correct number of
bytes is not received.

- Matches a string: The receive action stops when a specified sequence of

bytes is received. Specify a Timeout (in seconds) after which the receive
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action produces an error in the test log, if the correct number of bytes is not

received.

o

Recognizes a regular expression: The receive action stops when a
sequence of bytes that matches a regular expression is received. Specify
a Timeout (in seconds) after which the receive action produces an error in

the test log, if the correct number of bytes is not received.

o

Delegated to custom code: The receive action stops when a condition

is met in a custom Java™ class. This setting allows great flexibility, but
requires coding of a custom Java™ class following the HCL OneTest™
Performance extension API. Click Generate Code to generate a template
based on the API or View Code to open the specified class in the Java™
editor.

Except when the Receives until end of stream policy is in force, receive actions
produce an error in the test log when the connection is closed by the remote

computer.
Timeout

For end policies that have a Timeout setting, this setting specifies a delay (in
seconds) after which the receive action produces an error in the test log if the end
policy criteria is not met. The timeout counter starts when the first byte is received.

6. Click OK to apply the changes, and close the Preferences window.

Digital certificates overview

The digital certificates feature enables you to run tests against servers that use Secure Sockets Layer (SSL) for

applications that require client-side digital certificates to authenticate users.

A digital certificate is a file that binds a public cryptographic key with an identity (a user or an organization). Trusted
certificate authorities issue digital certificates, which are then used to authenticate users and organizations for
access to websites, email servers, and other secure systems. A certificate store is an archive file that contains almost
any number of digital certificates, possibly certificates that are issued from different certificate authorities.

To use digital certificates in tests:

1. Create a digital certificate store. For more information about this subject, see Digital certificate creation
overview on page 245 and Creating a digital certificate store on page 249.

2. Record a test that requires that you use a digital certificate.

3. Associate a digital certificate with a test for playback. For more information about this subject, see Playing
back a test with a digital certificate on page 252.

4. Optionally, you can associate the digital certificates in one or more digital certificate stores with a dataset. For

more information about this subject, see Using a digital certificate store with a dataset on page
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Create a certificate store by running the supplied KeyTool command-line program. The program creates a certificate

store that contains digital certificates.

Record a test that requires using a digital certificate. Specify the certificate and password that to use, and then begin

recording the test. Browse the website as you typically would to record a test.

After you have finished recording, open the test for editing. On the Common Options page, under Digital Certificates,
click Add. Type the name of the certificate store that you created previously; then select the certificate that you want
to use. Save the test. When you run this test, the digital certificate from the certificate store is submitted to the server.

If you have recorded a test that does not use SSL, you can convert that test to be secure by adding an SSL object to
the corresponding Server Access Configuration in the test.
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To use a certificate store with a dataset, open the test for editing. On the Common Options page, click Add Dataset.
Create a dataset with two columns that contains a list of the certificates in the certificate store and a list of
passphrases for the certificates. Select Fetch only once per user. Save the dataset. On the Common Options page,
under Digital Certificates, click Add. Select the certificate store that you created previously from the Certificate Store
column. Insert a Certificate Name for the digital certificate. Highlight this name, and then select Substitute from
dataset. Choose the dataset added previously, and then choose the column with the certificate name. Repeat this
process to substitute passphrases from the dataset column containing passphrases. Save the test. Add the test to a

schedule. When you run this schedule, the certificates from the certificate store are submitted to the server.

Digital certificate creation overview

If you want to use digital certificates to run tests against applications that require client-side digital certificates to
authenticate users, work with the appropriate server administrators to determine the types of certificates that you

need to create.

In cryptography, a public key certificate is a document that uses a digital signature to bind a public key with a physical
identity. These certificates are often referred to generically as digital certificates or client digital certificates. The most
common standard for digital certificates is the X.509 standard.
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In public key cryptography, each certificate has two associated keys: a public key and a private key. The public key is
incorporated into the X.509 certificate and is always available with the certificate itself. The private key is always kept
private (meaning, it is never transmitted). For ease of portability, the two keys (and the certificate) can be included in
one, encrypted and passphrase-protected, format known as PKCS#12.

In order to verify the authenticity of a certificate, it is digitally signed by another certificate, known as a Certificate
Authority (CA). This CA certificate may be one created (and kept secure) by a company hosting a secure application,

or it could be created by a company such as Verisign.

When a web application requires digital certificates, an administrator typically creates digital certificates for each
authorized user. The administrator digitally signs each certificate using the system CA certificate. These certificates,
along with the public and private keys, are distributed to users. Often these keys will be distributed in the PKCS#12
format. Users then import these certificates into their web browsers. When the browser is challenged by the server, it
will produce its certificate.

When importing certificates for web applications, select the check box that indicates that the keys be exportable.
With this indication, the certificate can be exported to a PKCS#12 formatted file for later use by other programs.

Do not use certificates that are assigned to actual users for performance testing purposes. Use test certificates that
do not correspond to actual users.

There are four types of certificates that can be used in testing:

« Self-signed certificates

- Signed certificates

« Certificate authority (CA) certificates
« Unsigned certificates (rarely used)

Self-signed certificates are used when no entity needs to vouch for the authenticity of the certificate. These are the

simplest certificates to create and use. Typically, however, a signed certificate is used to represent a particular user.

Signed certificates are used when a certificate needs to be created for and issued to one, and only one, user. Signed

certificates are signed by a certificate authority (CA).
Certificate authority (CA) certificates are self-signed certificates used to sign (certify) certificates.

Unsigned certificates are certificates that are neither signed by a CA nor self-signed. Most web applications do not

use unsigned certificates.

When you create a self-signed or signed certificate (including CA certificates) you can specify a subject. The subject
of a certificate is the set of attributes of an X.500 Distinguished Name that is encoded in the certificate. The subject
enables the recipient of a certificate to see information about the owner of the certificate. The subject describes the
certificate owner, but is not necessarily unique. Think of subjects as entries in a telephone book; there can be multiple
entries for Patel Agrawal, but each entry refers to a different person.

The subject can contain many different types of identifying data. Typically, the subject includes the following:
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Example

COMMON NAME (CN)

CN=Pat el Agrawal

ORGANIZATION (0)

O=XYZ Cor poration

ORGANIZATIONAL UNIT (OU)

OU=XYZ Sof tware G oup

COUNTRY (C)

C=IN

LOCALITY (L)

L=Bangal or e

STATE or PROVINCE (ST)

ST=Kanat aka

E-MAIL ADDRESS (emailAddress)

emai | Addr ess=agr awal @yz. com

This information can be typed as one string, using forward slashes to separate the data.
For example, the above subject would be typed as follows:

/ CN=Pat el Agrawal / O=XYZ Cor por ati on/ QU=XYZ Sof tware G oup/ C=I N L=Bangal or e/ ST=Kar nat aka/

emai | Addr ess=agr awal @yz. com

To learn more about using the supplied command-line program to create certificates, see Creating a digital certificate

store on page 249.

Creating a digital certificate with OpenSSL

You can use the OpenSSL program to create digital certificates for use with tests.

Before you begin
OpenSSL is available from the OpenSSL Project at http:/www.openssl.org/.

1. Create a certificate authority (CA).
For the purposes of testing, this CA takes the place of a recognized CA on the Internet, such as VeriSign. You
use this CA to digitally sign each certificate that you plan to use for testing.

a. Create a certificate request (CSR) file. The "subject” (-subj) describes the user of the certificate. Enter
dummy values as shown. The following command line sets the password for the certificate to abcdef g.
Example

openssl req -passout pass:abcdefg -subj "/C=US/ ST=IL/L=Chi cago/ O=HCL Technol ogi es/ OU=HCL Sof t war e

Group/ CN=Rat i onal Performance Tester CA/ email Address=hop@.cl.con -new > wai pio.ca.cert.csr

b. Create a key file, wai pi 0. ca. key, to store the private key.
This removes the password protection from the certificate request file so that you do not have to type
the password every time you sign a certificate. Because the password protection has been removed,
use the certificate request file for testing purposes only.
Example
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openssl rsa -passin pass:abcdefg -in privkey.pem -out waipio.ca. key

c. Create an X.509 digital certificate from the certificate request. The following command line creates a
certificate signed with the CA private key. The certificate is valid for 365 days.
Example

openssl x509 -in waipio.ca.cert.csr -out waipio.ca.cert -req -signkey waipio.ca.key -days 365

d. Create a PKCS#12-encoded file containing the certificate and private key. The following command line
sets the password on the P12 file to def aul t . HCL OneTest™ Performance uses password of def aul t
for all PKCS#12 files by default.

Example

openssl pkcsl2 -passout pass:default -export -nokeys -cacerts -in waipio.ca.cert -out

wai pi 0. ca.cert.pl2 -inkey waipio.ca. key

Result
You now have a CA certificate (wai pi 0. ca. cert), which can be installed into the web server under test and
a private key file (wai pi 0. ca. key) that you can use to sign user certificates.

2. Create a digital certificate for a user.

a. Create a CSR file for the user. Set the initial password to abc. Optionally, provide an appropriate subject.

Example

openssl req -passout pass:abc -subj "/ C=US/ ST=I L/ L=Chi cago/ O=HCL Technol ogi es/ OU=HCL Sof t war e

G oup/ CN=John Sni t h/ emai | Address=sni th@cl .conl' -new > johnsmth.cert.csr

b. Create a private key file without a password.

Example
openssl rsa -passin pass:abc -in privkey.pem -out johnsmth. key

c. Create a new X.509 certificate for the new user, digitally sign it using the user's private key, and certify
it using the CA private key. The following command line creates a certificate which is valid for 365
days.

Example

openssl x509 -req -in johnsmith.cert.csr -out johnsmith.cert -signkey johnsnith.key -CA

wai pi 0. ca.cert -CAkey wai pi 0. ca. key -CAcreateserial -days 365

d. Optional: Create a DER-encoded version of the public key. This file contains only the public key, not
the private key. Because it does not contain the private key, it can be shared, and does not need to be
password protected.

Example

openssl x509 -in johnsmith.cert -out johnsmth.cert.der -outform DER
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e. Create a PKCS#12-encoded file. The following command line sets the password on the P12 file to
defaul t.

Example

openssl pkcsl2 -passout pass:default -export -in johnsmith.cert -out johnsmith.cert.pl2 -inkey

j ohnsmi t h. key

Repeat this step to create as many digital certificates as needed for testing. Keep the key files secure, and
delete them when they are no longer needed. Do not delete the CA private key file. You need the CA private key
file to sign certificates.

Results

Now you can install the CA certificate (wai pi 0. ca. cert) into WebSphere®. Optionally, create a user certificate

specifically for your web server, and install it into WebSphere®.

You can use user certificates individually to record tests. To use the user certificates (j ohnsnit h. cert. p12)
during test editing and playback, compress them in ZIP format to a file with the .rcs extension. This creates a digital
certificate store. To learn more digital certificate stores, see Creating a digital certificate store on page 249. You can

also import user certificates into your web browser to interactively test them in your environment.

Creating a digital certificate store

The KeyTool command-line program enables you to create a Rational® Certificate Store (RCS) file that contains
digital certificates for use with tests. A Rational® Certificate Store (RCS) file is a compressed archive file that
contains one or more PKCS#12 certificates. You can also use the KeyTool program to remove certificates from a

certificate store.
About this task

HCL OneTest™ Performance acts as a proxy between the browser and the server application to record the data
exchange. When a secured page is recorded using HCL OneTest™ Performance, the proxy certificate of the product is

presented to the browser.

1. In the command line tool, navigate to the directory that contains the Keytool utility. By default, the utility is
located at C: \ Progr am Fi | es\ HCL\ HCLOneTest\j dk\j r e\ bi n.
2. Type the following command:

Example

keyt ool . exe -genkeypair -alias certificateNane -keystore keystoreNane -storepass password -validity 365

-keyal g RSA -keysize 2048 -storetype pkcsl2

For additional information about parameters by certificate generation, review the official keytool

documentation.
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Option Description
- genkeypai r Generate public and private keys for key pair.

-alias Alias for your certificate in the key store. You may
never use it, but every new certificate in your key
store must have its own alias.

-keystore Name of the key store file, which will be generated as
the result of the command. It holds your certificate
and a corresponding private key. You can reuse this
key store for next certificates that you might gener-
ate. One key store can contain many certificates.

- st orepass
Password that protects your key store file. You will
have to enter it every time you want to sign a docu-
ment.

-validity Number of days the certificate is valid. You can enter
more than 365.

-keyal g Algorithm to generate the cryptographic keys that is
corresponding to your certificate. You can use RSA or
DSA.

-keysi ze Length of the cryptographic keys. The more the
length the stronger the signature.

-storetype Format of the key store file. PKCS#12 (a.k.a PFX) key

stores can be understood by a lot of different pro-
grams and you can also import a PKCS#12 file in
your Windows key store (just double click it and fol-
low the instructions).

3. The certificate generation process prompts you to enter some information about you. Enter the information as

prompted.
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Microsoft Windows [Uersion 6.1.76811 -
Copyright <c?> 200% Microsoft Corporation. All rights reserved.

C:xUszsers~Administrator>cd GC:“Program Files“HCL~5DP>jdk“jre~bin

C:“Program Files~HCL~5DP~jdk~jre~hin>keytool.exe —genkeypair —alias my_certifica
te —keystore my—keystore.pfx —storepass my_password —wvalidity 365 —keyalg RSA —k[=
eyzize 2048 —storetype pkcsl2 T
hat iz your first and last name?

[Unknownl: Syed Attaullah
Illhat is the name of your organizational wnit?

[Unknown 1:

organization?

[Unknown 1:
llhat is the name of ywour City or Locality?

[Unknownl: Chennai

llhat is the name of your State or Province?
[Unknownl: TamilHadu
What is the two—letter country code for this unit?
[Unknownl: 1IN
Iz CH=Syed Attaullah, OU=HCL, 0=HCL, L=Chennai, ST=TamilMadu, C=IN correct? C(tup
e Ilyesll or Ilnull)
[nol: wyes_

4. If prompted for a password when using the keystore, enter the same password as provided on the command
line.
Result

The key store file (.pfx) is stored in your current directory.

Results

You now have a digital certificate store that you can use with tests. Because the KeyTool program has many options,
you might want to create an alias or script file to use to invoke KeyTool. Use KeyTool to create and add as many
digital certificates as you want. If you want to create a dataset of the names of certificates in the certificate store, run

KeyTool again with the -1i st option. This option writes a list of names that can then be imported to a dataset.

What to do next
Before you start recording the application that requires client certification, import the certificate to the HCL OneTest™
Performance project. For information about how to import the certificate and record a test, see the Recording a test

on page topic.

You do not have to use the KeyTool command-line program to create a certificate store. It is possible to use existing
PKCS#12 certificates with HCL OneTest™ Performance. PKCS#12 certificates can be exported from a web browser.
PKCS#12 certificates encode the private key within the certificate by means of a password.

Note: Do not use certificates associated with real users. Certificates associated with real users contain
private keys that should not become known by or available to anyone other than the owner of the certificate.

An intruder who gained access to the certificate store would have access to the private keys of all certificates
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in the store. For this reason, you must create, or have created for you, certificates that are signed by the

correct certificate authority (CA) but that are not associated with real users.

Playing back a test with a digital certificate

After you create a digital certificate store and record a test using a digital certificate, you must associate the digital

certificate with the test for playback.

Before you begin
You need to record a test using a digital certificate, and you need a digital certificate store file containing one or more
PKCS#12 certificates.

If your certificate extension is not .rcs, then you need to zip the certificate, rename the extension to .rcs, and copy it to

the root directory of the project.

To associate a digital certificate with a test for playback:

1. Open the test for editing.

2. On the Security tab, under Digital Certificates, click Add.

3. Select or type the name of the certificate store file that you created previously.
You must type or select the file name. You cannot browse to locate the file. The certificate store must be
a Rational® Certificate Store (RCS) file. A Rational® Certificate Store file is a compressed archive file that
contains one or more PKCS#12 certificates.

4. Select the digital certificate that you want to use, and then click Select.

5. When prompted to place the digital certificate in a dataset, click No. To learn more about substituting digital
certificates, see Using a digital certificate store with a dataset on page

Result

Note: If you add multiple certificates to the Digital Certificates list on the Common Options page, the
first certificate that satisfies the request from the server (in the order by which the certificates were

entered) is used during playback.

6. Save the test.

Results

When you run this test, the digital certificate from the certificate store is submitted to the server.

Entrust TruePass authentication overview

Entrust provides digital identity and encryption technologies to governments and private industry. With Entrust
TruePass software users can authenticate with secure web applications without installing a digital certificate in their

browsers. This makes it convenient for use in kiosks and other public user environments.
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You can now run tests against servers that require Entrust TruePass authentication. Roaming mode with TruePass
applet version 7.0 and later are supported. Local mode, and versions of the TruePass applet prior to 7.0, are not
supported. Recording tests with Entrust TruePass applications works just as regular HTTP recording does.

The Entrust TruePass Authentication object is displayed in the test editor for tests that you record with Entrust
TruePass applications. The Version field displays the recorded version number of the Entrust TruePass applet. The
Server Name and Port are correlated fields. Click Substitute to use the Data Sources view to change the server

or port number for playback. The Application Context displays where the Entrust application is mapped to in the

application server. The User Name and Passphrase fields can be substituted with values from a dataset.

Test Contents Test Element Details
This section shows the test contents Entrust Authentication (Mode: Roaming)
=Ll Entrust Technology Portals -~ Version:
=% wanw.entrust.com:443 [ Authenticat Connection Information
+ j_;,,‘ www, entrust.com:443/new_stylesheet ) Server Name: \www.entrust. com |
H- " wwew, entrust, com: 443fimages/navigatior Port: @

@
2 veww, entrust, com: 443/secured,/main.hat
’7.;.,' www, entrust.com:443/fimages /navigatior
2 woww, entrust, com: 443 /new_stylesheet_y Down
s www,entrust.com: 443 /extranet/ —
i veww, entrust, com:443/css/global 2. css
:,,, www.entrust.com:%Sﬁcssm?mEj“ms":s’ Passphrase: |testPassphraseas
i www, entrust. com:443/css print.css

s WWWw. entrust.com: 443/css/menu’5.css
“; wow,entrust,com: 443 fincdudes/starttabs
2 woww, entrust, com: 443fincludes ieupdate
s www, entrust. com: 443 findudes/cookielibe
“% v, entrust,com: 443 fincdudes/new-tab:

s www, entrust.com: 443 fncdudeshome -dr ¥

Application Context: |ﬁruePass.ﬁ.ppIicaﬁun |

up

IH

Authentication Information

User Mame: |testuser

] R O O [ o

<

Comrnon properties

Kerberos overview

You can run HTTP tests against servers that use the Kerberos protocol for authentication.

Introduction

Kerberos is a security authentication protocol that requires users and services to provide proof of identity.

Note: Kerberos is supported only for HTTP tests on HCL OneTest™ Performance.

Supported environments

Kerberos is supported on HTTP for web servers running Internet Information Server (11S) or WebSphere® with the
Simple and Protected GSS-API Negotiation Mechanism (SPNEGO) trust association interceptor (TAI). Additionally,
the Key Distribution Center (KDC) must be part of the Windows™ Domain Controller Active Directory. Internet Explorer,
Mozilla Firefox, Opera, Apple Safari, and Google Chrome browsers are supported for recording tests. Kerberos is not

supported on other protocols, environments, or browsers. For example, a KDC running on Linux™ is not supported.
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Tips

For best results when you record tests that use Kerberos authentication, specify the host by name, not by numeric
IP address. Also, note that user information is case-sensitive. Specify user information using the exact logon name
from the user account in Active Directory. The User logon name field in the properties for the user in Active Directory
displays the correct user name in the correct case. To the right of the user name the realm or domain name is
displayed in the correct case. For example:

» User ID: kerberostester
» Password: secret
» Realm: ABC.IBM.COM

User logon names of the form ABC\kerberostester are not supported.

Troubleshooting

Kerberos authentication is a complex process. If you encounter problems when you attempt to record and play back
tests that use Kerberos authentication, change the problem determination log level toAll and run the tests again with
only one virtual user. To learn more about the problem determination log, see the help topic on changing the problem
determination level. After running a test, the CommonBaseEvent s00. | og file on the agent computer contains

information that can help you determine why Kerberos authentication failed.

Terms
Active Directory

Active Directory is an implementation of Lightweight Directory Access Protocol directory services
created by Microsoft™ for use primarily in Windows™ environments. The main purpose of Active
Directory is to provide central authentication and authorization services for Windows™ computers. With
Active Directory, administrators can assign policies, deploy software, and apply critical updates to an
organization.

Directory service

A directory service is a software application or set of applications that store and organize information
about the users and resources of a computer network.

Generic Security Services Application Program Interface (GSS-API)

The GSS-API enables programs to access security services. The GSS-API alone does not provide any
security. Instead, security service providers provide GSS-API implementations, typically in the form of
libraries that are installed with their security software. Sensitive application messages can be wrapped,
or encrypted, by the GSS-API to provide secure communication between client and server. Typical
protections that GSS-API wrapping provides include confidentiality (secrecy) and integrity (authenticity).

The GSS-API can also provide local authentication about the identity of a remote user or remote host.
Key Distribution Center (KDC)

The authentication server in a Kerberos environment is called the Key Distribution Center.

254



Chapter 6. Test Author Guide

Lightweight Directory Access Protocol (LDAP)

LDAP is an application protocol for querying and modifying directory services running over TCP/IP.

An LDAP directory tree typically reflects political, geographic, or organizational boundaries. LDAP
deployments typically use Domain Name System (DNS) names for structuring the highest levels of the
hierarchy. LDAP entries can represent many different types of objects including people, organizational
units, printers, documents, or groups of people.

Simple and Protected GSS-API Negotiation Mechanism (SPNEGO)

SPNEGO is used when a client application attempts to authenticate to a remote server, but the
authentication protocols supported by the remote server are unknown. SNPEGO is a standard GSS-API
pseudo-mechanism. The pseudo-mechanism uses a protocol to determine which common GSS-API
mechanisms are available, then SPNEGO selects one GSS-API mechanism to use for all future security
operations.

Trust Association Interceptor (TAI)

The TAl is a mechanism that establishes a secure connection between WebSphere® and other
application software.

Recording Kerberos applications with Internet Explorer

You must configure your browser before you attempt to record Kerberos applications.

Before you begin

The client computer must be a member of the domain for which single sign-on (SSO) has been defined.

To configure Internet Explorer to use Simple and Protected GSS-API Negotiation Mechanism (SPNEGO):

a A W N =

O OV 00 N o

. Log on to Windows™ with a user ID for the domain for which SSO has been defined.

. Start Internet Explorer.

. Click Tools > Options.

. Click the Security tab.

. Define the site to authenticate to using Integrated Windows™ Authentication. Depending on your enterprise

policy, you define the site in either the Local intranet zone or the Trusted sites zone.
Choose from:
o To define the site in the Local intranet zone, select Local intranet. The instructions that follow assume
that you are defining the site in the Local intranet zone.
> To define the site in the Trusted sites zone, select Trusted sites. In the Security Settings for the
Trusted sites, click Automatic logon with current username and password, not Automatic logon only

in Intranet zone.

. Click Sites.

. Click Advanced.

. Type the URL for the hostname for which you want to enable SSO. For example, type http: // abc. i bm com
. Click Add.

. Click OK.

255



HCL OneTest Performance

11. Click OK again.

12. Click the Advanced tab.

13. Scroll down to Security, and select Enable Integrated Windows Authentication (requires restart).
This option is not available on Internet Explorer 5.5. Integrated Windows™ Authentication is always enabled on
Internet Explorer 5.5.

14. Click OK.

15. Restart Internet Explorer.

Recording Kerberos applications with Mozilla Firefox

You must configure your browser before recording Kerberos applications.

Before you begin
The client computer must be a member of the domain for which single sign-on (SSO) has been defined.

To configure Mozilla Firefox to use Simple and Protected GSS-API Negotiation Mechanism (SPNEGO):

1. Start Mozilla Firefox.

2. In the location bar, type about : confi g.

3. In the Filter field, type net wor k. n.

4. Double-click the network.negotiate-auth.trusted-uris preference.

The network.negotiate-auth.trusted-uris preference lists the sites that are permitted to engage in SPNEGO
authentication with the browser.

5. In the Enter string value window, type a comma-delimited list of URLs of trusted domains.

6. Click OK.

7. Optional: If the application under test uses the advanced Kerberos feature called Credential Delegation,
double-click the network.negotiate-auth.delegation-uris preference. Type a comma-delimited list of URLs of
trusted domains.

The network.negotiate-auth.delegation-uris preference lists the sites to which the browser may delegate user

authentication.

Generating tests that use Kerberos

You must supply your Kerberos user name and password when generating tests that use Kerberos.

About this task

The test generation process attempts to detect if Kerberos was used when a test was recorded. If the test generation
process detects that Kerberos was used when a test was recorded, you are prompted for the Kerberos credentials.
The test generation process might not differentiate between Kerberos authentication and NT LAN Manager (NTLM)

authentication. In that case, you are prompted for the authentication type and credentials.
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1. In the Kerberos window, type in the Kerberos Realm name field the Kerberos realm name that you used during
recording.
If the test generation process cannot determine which type of authentication was used, the Authorization
window is displayed, not the Kerberos window. In that case, click the Kerberos radio button before typing the
Kerberos realm name.

2. In the User name field, type the user name that you used during recording.

3. In the Password field, type the password that you used during recording.

Results

The test generation process creates a Kerberos configuration file. The file is kr b5. i ni and it is stored in the root

of the project workspace. This file is required to play back Kerberos tests. Typically, you need to ensure that the
workbench computer that you use to record the test is in the same Kerberos realm as the agent computers that you
use to play back the test. Advanced users and security administrators can edit this file with a text editor to tailor it to a

specific test environment.

Annotating a test during recording

You can add comments, add transactions, or change a page name while you record a test. The advantage of adding
these elements during (rather than after) recording is that you can place the annotations in the test exactly where you
want. In addition, because annotations are part of the recorded test, they are regenerated when you regenerate the
test. You can also insert split points into a test during record.

1. Start recording the test. The Recorder Test Annotations toolbar opens near the top of the screen.

2. Click the appropriate icon.

You can use the Recorder Test Annotations toolbar to add comments, record synchronizations, or take screen
captures during the recording.
> To add a comment to the recorded test, click the Insert comment icon E.J You are prompted for a
comment.
> To add a screen capture to the recorded test, click the Capture screen icon 20, Screen and window
captures make your tests easier to read and help you visualize the recorded test. You can change the
settings for screen captures and add a comment to the image.
> To manually add a synchronization point to the recording, click the Insert synchronization icon =l
> To manually add a transaction folder to the recording, click the Start Transaction icon Eii\" and Stop
Transaction icon E'iE' to start and stop the transaction. Transactions can be nested.
> To insert a split point into the recorded test, click the Split point icon #-. With split points, you can
generate multiple tests from a single recording, which you can replay in a different order with a
schedule. See Splitting a test during recording on page 167 for more information about splitting a

test.
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> When recording an HTTP test, to change the page name, click the Change page name icon T_. In
the resulting test, the page element in the test editor uses the new name, however the original name
is preserved in the Page Title Verification Point area so that page title verification points still work
correctly.

3. Close the client program to stop the recording.

4. If you inserted a split point during the recording, on the Destination page, in the Test Generation wizard,

specify the location for the split test or merge the split recordings together.

Results

The test is generated with the comments, transactions, and page names that you added.

Recording sensitive session data

You can keep recording session (. r ecsessi on) files to view the contents of a recording or to regenerate tests.
However, if a recorded test contains sensitive information, you can choose to obfuscate, or encrypt, text strings in the
recsession file.

To protect test data in a recording session file:

1. In the Performance Test perspective, click the New Test from Recording toolbar button “& or click File > New

> Test from Recording.

. In the New Test from Recording window, select Create a Test from a New Recording, and select the type of

test to create.

. In Recording encryption level, select one of these options:

Choose from:

- Obfuscated: This setting hides text strings to prevent viewing the raw data in recsession files with a
text editor outside of the workbench. You can still use recsession file to generate tests and to view
recording information.

- Passphrase: This setting uses an AES-128-bit algorithm to encrypt text strings in the recsession
files. The encryption strength depends on the length of the passphrase. The recording session file is
unrecoverable if the passphrase is lost.

. On the Select Location page, select the project and folder locations to contain the new test, type a name for

the test, and click Next.

. If you selected Passphrase, on the Passphrase Protection page, type the passphrase twice in Passphrase and

Confirm passphrase.
For solid protection, make the passphrase longer than 24 characters if using English words or at least 12
random characters.

6. Click Next, and continue the recording session for the type of test that you selected.

Related information

Creating tests on page 153
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Splitting a test during recording

You can insert split points when you record a test. Split points allow you to generate multiple tests from a single

recording that you can replay in a different order with a schedule.

To split a test during recording:

1. Start recording the test. The Recorder Test Annotations toolbar opens near the top of the screen.

2. To insert a split point into the recorded test, click the 5 Split point button. . The Insert Split Point window is
displayed.

3. Type a name for this section of the test and click OK. You are naming the previous section of the test, not the
upcoming section of the test.
Repeat this step between recorded user actions as needed to split tests.

4. After you finish performing the user tasks in the client program, stop the recorder. You can do this by closing

the client program or by clicking the Stop B button in the Recorder Control view.
If you changed the network settings of the client program as described in step 8, you can revert them to the
default settings before closing the program.
Result
The Generate Service Test wizard opens.
5. On the Destination page, specify the location for the split test or merge the split recordings together:
- In Location, click Browse to specify the folder where the split tests are generated.
> Type a Test prefix that will be appended to the name of each split test. Leave blank if you do not want
the split test names to have a prefix.
> In the split test list, mark the split tests that you want to generate. Click Select All to generate all split
tests or Unselect All to clear the list.
> To merge several split tests into a single test, multi-select the tests that you want to merge by holding
the Shift key and click the Merge button.
6. Click Finish.

Results

The tests are generated using the test names that you specified.

Generating a new test from a recorded session

You can generate a new test from a recorded session. For example, if you accidentally damage a test during editing,
or if you want to change a test preference, you can regenerate the test instead of re-recording it. If split points were

inserted in the recording, you can choose to generate a single test without split points.

To regenerate a complete test from a recording that contains split points:

1. In the test navigator, select the .recsession file of the test recording to regenerate.
2. Right-click, and then select Generate Test.

Result

The Generation Test wizard is displayed.
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3. If the .recsession file is compatible with multiple test types, select the type of test that you want to generate
and click Next.
Example
For example, select HTTP Test to generate an HTTP performance test.

4. On the Select Location page, select the project and folder where you want to create the test, type a name for
the test, and click Next.
If necessary, click [ “Icreate the parent folder to create a new performance test project or a folder

5. If the .recsession file contains split points, on the Options page, select Generate test without split points if
you want to regenerate the test as a single test.

6. Click Finish.

Results
The test is regenerated and opened in the test editor.

Organizing test assets by type

By clicking an icon, you can view your test assets in a logical order, in separate folders for tests, schedules, results,
locations, and datasets.

About this task
In the Test Navigator view, you can click Show Java Content to see custom code that you created, click Show Missing

Resources to view unresolved references, and click Show File Extenstions to view file extensions of test assets.

1. On the Test Navigator toolbar, click the Show the logical test navigator “E jcon.
To see the Test Navigator view, click Windows > Show view and click Test Navigator.

2. Your assets are now grouped logically. To see them, open the appropriate folder.

Test Data Sources F lﬂl!Mm =0

(elim| =R
= TD"I- kestproj

[#-[= Performance Tesk
[,:“'5- Performance Schedule
[g Performance Resulks
L5 Locations

[5 Datapools

Note: In the Logical view, only if the asset is available the appropriate folder is displayed. For example,
if the Results folder is displayed only after you have executed a test.

Editing tests

After you record a test, you can edit it to include datasets (to provide variable data rather than the data that you

recorded), verification points (to confirm that the test runs as expected), and data correlation (to ensure that returned
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data is appropriate for the corresponding request). You can also add protocol-specific elements to a test. When you

edit a test, the modified items appear in italic type. The italic type changes to regular type after you save the test.

Editing HTTP tests

After you record a test, you can edit it to include variable data rather than the data that you recorded and can include
verification points to confirm that the test runs as expected. You can also edit the test to include [NB1] transactions,
conditional processing, custom code, and standard header or custom header to a request or response.

Redirection support for HTTP tests

When you run HTTP tests, redirect requests are followed automatically, which supports common usage patterns,
such as load balancing.

HTTP redirect responses are responses to requests with status codes in the 300 family, which indicate that the
requested content is found at a different location. Redirect responses include HTTP status codes such as 301 mved
Per manent | y and 302 Found. Some HTTP applications redirect clients to a specific URL, but the ultimate response to
the client request can be handled by one of several servers to balance the load that each server handles. For example,
a request that is sent to http://www.example.com/ might be redirected to http://www-1.example.com or http://
www-2.example.com, depending on traffic and load conditions.

Both expected redirect and unexpected redirect responses are supported when you run tests. Expected redirect
responses occur when you record tests. Unexpected redirect responses are received from the server when you run
tests, but the responses are not present in the recorded test.

Expected redirect responses are handled by automatic data correlation. To automatically correlate host names and
port numbers, click Window > Preferences > Test > Test Generation > HTTP Test Generation > Data Correlation, and
then select the Automatically correlate URL pathname if redirected by response check box. This option is selected by
default.

Unexpected redirect requests are followed until an HTTP status code that is not a redirect response, such as 200

o, is returned by the server, or until the maximum number of redirect responses has been reached. By default, the
maximum number of redirect responses to follow is 10. When a 200 oK response is received, references that use the
data in the final response are created.

Server access configurations are updated dynamically for unexpected redirect responses. For example, for a config_1
server access configuration, where the host is abc.example.com and the port is 80, if a request that uses that
configuration is redirected to port 8080 on the xyz.example.com host, all subsequent requests in the test that use the

same configuration use port 8080 on the xyz.example.com host.

Verification points in a request are applied to the final destination. You can set a ResponseCode verification point

in a request so that an unexpected redirection can be handled appropriately. If you set an exact ResponseCode
verification point, it fails when a redirection occurs. A relaxed verification point also fails if the status codes in the 300
family are not part of the relaxed code list.
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Creating secondary HTTP requests

A recording creates multiple HTTP requests and responses. In some cases, a response from the server can be
dynamic, because of which the subsequent requests might need to be modified. While playing back the test, some
of these dynamic requests might fail. For example, recording and playback might involve a different set of users with
different permission settings or the Ul elements might have changed since the time you recorded the test. To ensure
that the test is played back without the need to record it again, you can create secondary requests which, based on

the response received from the server, fetch the exact values that the test requires .

About this task

You identify the HTTP request for which to create a secondary request, and then create a reference for all the
occurrences to dynamically generate the request. If you do not want to create a reference, you can define an array
variable that lists the HTTP requests to use from playback. You can use the array variable from custom code.

From version 9.1.0.1 or later, you can also specify the number of requests to be send to the server in the Test Editor
itself. After creating the secondary HTTP request, in the HTTP Secondary Request Generator Details area, specify the
total number of requests. If the number of requests is greater than 0, the number that you specify in Total number of
requests takes precedence over the array variable.

Test Contents HTTP Secondary Request Generator Details
Enter filter text View ¥ Options ¥ pegyect Attributes
4 7. Home o Add Wersion: 11 = | Method: | GET -
| -
- g wWww o L Torgf F—
s A0 e, _Lorgfsite.csshes Insert Connection template: Conn_2 Change...

> :E fonts.googIeap?s.comfcss?fam?ly:Fredericka+the+Great|A|IL = m
| fonts.googleapis.carn/css armily=Ral eway

Max, simultanecus connections: 2 +| Total number of requests: |0

e - ) Lo . -
- /g sT.addthis.com/js/300/addthis_widgets CR—— LIRL: FarhalhAReThFAATA TR 17 ATRF T raf?arrecsKemdd —ANAATI7E
. “ imglwsimg.com/tee/tec_l.combined.1.0.5.min js

m

, “8 imgdusirng.corm/starfield/duelAv2.5.8/duel jsfappid=038kL T Data:
. 8 nebulaasimg,com/4eaafSaThi5137a79245hhe A0 76072 20c &J Add
- 8 nebulawsimg.corn/$2afd60944F8e 0956617 cBF38c e e3P Down Modify
3 % nebulawsimg, corriflaeselbhbel1bf81d 76232 010F7 cefitic
. “hs finebulawsimg.comfaeSelbi5el1bffs1d76232018fT cef7a Prew Rermowe
. “E nebulawsimg.com/aTdbecddllcefodfbdbafieldabe2alinie ~
. B nebulawsimg.com/1fode320f58bb 013422 d6 42 4d9deedatic Mext:
A £ inl D hekt e e el 6 A TR VR L ToAL 1

You can also use the delays to control the flow of the requests to the server. In the Advanced tab, go to the Delay
Between Requests section and select the parameters for the flow of the requests. In Release When, select when
exactly to release the request. For instance, First Character Sent indicates to release the second request after the first

character in the first request is sent.

To create a secondary HTTP request:

1. Create a reference. See the Creating a reference on page topic.

2. Right-click the HTTP request for which to create the secondary request and click Create Secondary HTTP
Request Generator. You can also select multiple HTTP requests that have common headers or connection
attributes. If multiple requests do not have common attributes, you are prompted to select one request as
template.

Result
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The original HTTP requests are disabled, indicating that the playback will now use only the secondary HTTP
request.
3. Run the test.

HTTP test editor overview
With the test editor, you can inspect or customize a test that you recorded.

The test editor lists the HTTP pages for a test, by title. The following example shows the visitIBM test, which was
generated from a recording of these tester actions: type ht t p: / / www. i bm com under Shop for select Software, stop

recording.
PE yisitlEM 57 =0
Test - visitIBM
Test Contents Test Element Details
This section shows the test contents visitIBM

Enter filter text Options Security | Performance Requirements | HTTP Options

= G5 visiteM SEEIILS

k= EL: Test Variables MName Usage Location
l#. IBM - United States

+

+ L. IBM Shop for software
= Select
Add Datapool
[Shuw Datapool Candidates. .. ]
] Enable response time breakdown  [define locations]
4 b4 Wﬁdvanced

The test editor window contains two main areas. The area on the left, Test Contents, displays the hierarchy of
the HTTP pages for the test. The area on the right, Test Element Details, displays common options and specific

information about the HTTP protocol. The HTTP options apply to every page an HTTP test.

The Test Variables are listed at the top of the Test Contents area. These variables, which are the host names and
ports in the test, are automatically created when the test is generated. Click a variable name to see where it is used in
the test. By changing these variables, you can share or reuse the test for different configurations and web hosts. User-
defined variables are also listed at the top of the Test Contents area. For more information on this subject, see related

topics.
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When you expand a test page, you see a list of the requests for the page, in separate folders, with names that are full
web addresses minus the initial htt p: /7. The following example shows the expanded first page of the visitIBM test
with the page selected in the Test Contents area. In this example, the settings that are displayed in the Test Element

Details apply to the selected page.

PE yisitEM 52 =8
Test - visitIBM

Test Contents Test Element Details

This section shows the test contents IEM - United States

rET—— Options ~  Page title: [;EM - United States &

Primary request: 43,; vevuwe.ibm. com fus fen/

+- [l Test variables Think time: 0 Miliseconds |
-l 1BM - United States
H-Lgd. IBM Shop for software Test Data Opti =
= Select panns
Mame Value Substituted with -

s

Preview is not available,

E‘/ Page Title Verification Point

hd > [T Enable verification point i

The primary request, which is listed in bold, is the basis of the page title. The primary request can be the web
address that the tester typed into the browser, a hyperlink that was clicked, or a web address to which the tester was
redirected from another page request. In the example, the primary request shows that the tester was redirected to
www.ibm.com/us/ from the initial page request (www.ibm.com). If the primary request does not return a page title,
the test generator creates a unique name for it from the first node of the web address.

Some requests are highlighted in yellow. This highlighting indicates that these requests contain one or both of the

following types of information:

- A dataset candidate: This is a value, usually one specified by the tester during recording, that the test
generator determined is likely to be replaced by values in a dataset. An example of a dataset candidate
is a string that you search for in a recorded test. The string is highlighted as a dataset candidate on the
assumption that, before playback, you might want to associate the string with a dataset column that contains

appropriate substitute values. For more information on this subject, see related topics.
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- Correlated data: These are values in a test, usually one of them in a response and the other in a subsequent
request, that the test generator determined needed to be associated in order to ensure correct test playback.
An example is a photograph that is returned to the browser by a test that searches an employee database.
The test generator automatically correlates employee names with photographs. Suppose that, before running
the test with many virtual users, you replace the employee name searched for in the recorded test with names
in a dataset. Because the test correlates the data, each virtual user searches for a different employee, and the
server returns an appropriate photograph. For more information on this subject, see related topics.

Note: To see an illustration of color coding in performance tests, click Window > Preferences > Test > Test
Editor, and then click the Colors and Fonts tab.

When you expand a request, you see the Response data for the request. As shown in the following example, requests
can also contain Connection data. Because the response is selected in the Test Contents area, the Test Element

Details area displays the response data for this request.

T yisitlBM 53 =g
Test - visitIBM
Test Contents Test Element Details
This section shows the test contents Response: 302 - Found
Enter filtter te Options ™ Response Data
I Status: (302 Version: |1.1
= ~Uni A
L. Eiﬂ United State_ Add Ressonc|[Eound |
=g wvewyibm. com/
) )
2 Connection Response Headers
£ Response:
o o u:rum.v.ihpm.cor Header Mame Value G Add
b i | Date Tue, 28 Sep 2010 13:57:54 GMT
B .|bm.c0m,-'_| Server IBM_HTTP Server
+ Jibm.com/i Content-Type text/html
+ Jibm. comji Expires Fri, 01 Jan 1990 00:00:00 GMT
¥ Jibm.com/l F'_ragma_ o nu:u-cau:!ﬂe _ o v
+ w.ibm.comji < ¥
+ Jibm.comji
+ Jibm. comj Content:
+ w.ibm,comyi <'DOCTYPE HTIML PUBLIC "-//IETF//DID HIML 2.0//EN">
+ Jibm.comji <html><head>
+ Jibm.comji <title>»302 Found</title>
+ Jibm.comji </head><body>
+ Jibm.comji <hl»Found<,/hl>
+ w.ibm, comyi <p>The document has moved <a href="http://www.ibm.com/us/
+ Jdbm.comyi </body></html>
£ Jdbm.com)i
£ we.ibm. camy
£ Jdbm.com)fi
£ I Jdbm,com)fi
s _ >

¥

war ibem s i

b

WAdvanced

The Response data inside each request shows the data that the web server returned to the browser based on that

request. Collectively, the requests listed inside a page are responsible for everything that was returned by the web

server for that page.
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Select multiple responses to display a table under Test Element Details that shows the following elements for the

selected responses:

» Response code

» Response reason

» Response size

- Binary indicator

» Parent request

« Content verification point

» Response code verification point

» Response size verification point

Click Add to add child elements to the selected test element. Alternatively, you can right-click a test element and
select an action from a menu. The choices that you see depend on what you have selected. For example, after you
select a test, you can add a new page, a block of custom code, or an IF condition. After you select a page, you can add
a request or an IF condition.

The Insert push button works similarly. Use it to insert a sibling element before the selected element.

The Remove, Up, Down push buttons, and some Add choices (HTTP Page, HTTP Request, Basic Authentication)
are primarily for use with tests that you write by hand; these actions or choices are likely to break a generated test.
The types of structures that are commonly used in generated tests are explained in Verifying expected behavior on
page 276 and Adding test elements on page

If you test Siebel applications, see Testing Siebel applications on page 294 for prerequisites and details about the
differences between standard HTTP tests and Siebel tests.

A portion of the test editor can occasionally be obscured. To see the obscured area, move the cursor over one of the

blue lines until it changes to I and drag up or down while holding the left mouse button.

To resize the Test Editor window, do one of the following:
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« Click Ctrl+Alt+> or Ctrl+Alt+< to enlarge or reduce the window.
- Hover at the left side of the Test Element Details area. When you see a vertical blue line, right click the line
and select a size ratio from the menu.

Test Element Details

WisitIBM

s
20/20
S
4080 :
ariat
50/50
ofa0
o 70730
a0/z0
P
oft  Cival,
Right  Ckrl+al+.

;:*3':-5 Rlurm |

The new size remains the next time you open the window. Double click the blue line to return to a 50/50 ratio.

Related information

Reusing tests on different hosts: Server connection variables on page 291
Providing tests with variable data (datasets) on page

Correlating response and request data on page

Specifying the number of allowable URL redirects during test runs

When you run a test in a load-sharing environment, an unexpected redirection loop might occur during HTTP
processing. An unexpected redirect response occurs when an HTTP request that normally returns a specific

document redirects the browser to another location.
About this task

When the system detects an infinite loop of redirects, the infinite loop is broken, an error verdict for the request is
issued, and the following message is displayed:

Infinite redirection | oop detected getting URL n. If this is expected and understood, increase RPT_VMARGS

r pt MaxRedi recti on paraneter. Redirected history (fromthe first URL to the current one).

The default number of redirects is set at 10; however, you can edit the maximum number of redirects by updating the
RPT_VMARGS argument in the —Dr pt MaxRedi r ect i on setting.
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To modify the number of allowable redirects before an error is reported, complete these steps on the workbench.

1. In the Test Navigator, expand the project until you find the agent computer at the deployment location to
change.

Agent computers are represented by the £ icon.
2. Right-click the agent computer, and then click Open.
3. Under Property Groups, click General Properties, and then click Add.
4. In the New Property window complete these steps:
a. In the Property Name field, type RPT_VMARGS.
b. In the Operator field, confirm that the operator is =.
c. In the Property Value field, type -Dr pt MaxRedi r ect i on=n, where n is the maximum number of redirects
that can occur before the error message is displayed, and then click OK.
d. Only one RPT_VMARGS argument is allowed for each agent computer location. If multiple RPT_vvARGS
style properties are required, you must separate- bnane=Vval ue with a space. For example,
- Dr pt MaxRedi recti on=15 - Danot her Property=Val ue.
Result

The following New Property window sets the maximum number of redirects to 15:

-
(4} New Property

Property Name: Operator: Property Value;

RPT_VMARGS sl | =  |a| | -DrptMaxRedirection=15 [

o4 ] [ Cancel

Cutting and pasting in tests

You can cut, copy, and paste in HTTP tests.

The test editor supports the standard cutting, pasting, and copying of test elements by using the Edit menu or
keyboard shortcuts. Test elements include HTTP pages, HTTP page elements, and requests. If you cut a test element,
that element is not actually removed from the test until you next cut or paste.

If you copy a test element, that element is not actually copied until you next paste. For this reason, do not close the
test from which you copy a test element until you have pasted the test element into another test. If you copy a test
element from a test, and then close the test, nothing is pasted when you attempt to paste the test element. When you
cut an element, it becomes unavailable (gray) and is displayed in italics. When you paste an element, it is displayed in
italics until you save the test.

If you copy a request from one test to another and the connection details are same, the connections are copied. If the
server URL in the another test is different, the connection detail is not copied. Click Change to add a new connection.
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Request Attributes

Wersion: 11 = | Methad: | GET - - Prirnary request for page
Connection: Conn_2: api.bing.corm 80
URL:

Note: Cutting and pasting can break correlations between test elements. For example, it is possible to cut a
test element that contains a reference that a later portion of the test requires. When you cut, copy, or paste
HTTP test elements, you are not warned of potential data correlation problems. You must ensure that the

editing operation does not cause a data correlation error.

Defining requirements in tests

You can define requirements for elements in a test. These requirements specify acceptable thresholds of
performance and validate service level agreements. Starting from version 9.2.0.1, you can define both performance
and functional requirements in the tests. The verdict of the test is computed based on the requirements defined in the

schedule. You can view the verdict in the Requirements report.
About this task

You can set requirements on protocol-specific test elements, on schedule elements, on data created by custom code,
and on collected resource usage data. You define a requirement as standard or supplemental. A standard requirement
determines that the requirement is significant enough to cause the entire run to be declared a failure if it fails. A
supplemental requirement, although important, is not significant enough to cause the run to fail. For example, a
supplemental requirement might be a request from development to validate a very specific data item provided by
WebSphere® PMI monitoring.

To define a requirement for the elements in a test:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. In the Test Contents area, select the page or the request that will have the requirement.
You can select multiple pages or multiple requests.

3. In the Test Element Details area, click the Advanced tab, and select Enable Requirements.
Result
A table of requirements that apply to the page or to the request is displayed.

4. Click the requirement to define, and add a definition, as follows:
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Option Description
Name You can change the name of a requirement to im-
prove readability. However, changing a requirement
name causes a mismatch between the Requirements
report, which uses the changed name, and the oth-
er reports, which use the default name. Therefore,
when you change a requirement name, be sure to
keep track of the original name.
Operator Select an operator.
Value Type a value.
Standard Select to make the requirement standard. A standard

requirement can cause a test to have a verdict of fail.
Clear to make the requirement supplemental. In gen-
eral, supplemental requirements are used for require-
ments that are tracked internally. A supplemental re-
quirement cannot cause a run to fail, and supplemen-
tal results are restricted to two pages of the Perfor-

mance Requirements report.

5. Optionally, apply the defined requirement to other test elements:

a. In the Test Contents area, select the test elements that will have the requirement.

The elements must be of the same type, for example, all page elements.

b. In the Requirements table, right-click the requirement row, and select Copy Requirements.

6. Optionally, select Hide Undefined Requirements to hide the shaded rows, which indicate that a requirement is

not defined, and improve readability.

7. Select a requirement and click Clear to remove its definition. The requirement is still available and can be

redefined.

8. After you have defined a number of requirements on test elements, you might want to see all of the

requirements defined for the test. To do so:

a. In the Test Contents area, click the name (root) of the test.

b. In the Test Element Details area, sekect the Requirements category.

Result

The Requirements page displays a summary of the performance and functional requirements defined

in the test.

c. To navigate to the original requirement definition, double-click the requirement row.
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Exemple

You can define requirements in a test or in a schedule. When you define a requirement in a test, the requirement is
defined individually for each test element—even if you select multiple test elements and apply the requirement to all
of them at the same time. When you define a requirement in a schedule, the requirement is applied to the aggregate

of test elements.

For example, assume that you select every page in a test and define this requirement: Aver age response tine for
page [ms] [For Run] must be less than 5 seconds. This means that if one page in the test has a response time of 6
seconds, the requirement on that page fails. The other pages, which have a response time of less than 5 seconds,
pass.

Assume that you open a schedule and define this requirement: Aver age response time for all pages [ms] [For Run]
must be less than 5 seconds. This measures the average response time for all of the pages. One page can have a
response time of 30 seconds, but if enough pages have a response time low enough to counter the negative effect of

that one page, the requirement passes.

For information on defining requirements in schedules, see Defining requirements in schedules on page 544.

Adding an authentication folder

Web application servers can include an option to force a login. You might have recorded a test with this option
disabled but want to run the test with the option enabled. Adding an authentication folder to the appropriate test

request lets you do this without recording the test again.

To add an authentication folder to a request:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
2. Click the request that will contain the authentication folder.
3. Click Add and select Basic Authentication.
Result
A folder named Authentication is added to the request, and the Test Element Details area displays the Userid,

Password, and Realm fields.

Adding or removing header in batches

You can add or remove HTTP header from multiple HTTP requests or responses in batches to improve the script
efficiency. For example, during the development process, there might be HTTP headers change or addition of new

HTTP headers to the requests. These changes in the HTTP headers will result in the test script failure.

Adding HTTP header to multiple HTTP requests

During the development process, there might be a change in HTTP headers. To modify the test script in a faster and

easier way, you can add the HTTP headers in batches to the requests.
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About this task

To add HTTP headers to multiple HTTP requests at once:

1. Open the test.
2. In the test hierarchy, select a request (press Ctrl key to choose multiple requests).
3. From the Options drop-down list, select Add > HTTP Header. The Add/Edit Headers window opens.

(@ Tast Editor X

Add/Edit Headers ik

Use this dialog to add or remove headers. Select "Custom type” to enable new custom headers. |—

Quick 9earch:i

Ayailable headers
Accept A

| Header types: All

Selected headers

Header value

Accept-Charset
Accept-Encoding
Accept-Language
Allow
Authorization
Cache-Control
Connection
Content-Encoding
Content-Language
Content-Length
Content-Location
Content-MD5
Content-Range
Content-Type
Date

Expect

Expires

From

Host

If-Match
If-Modified-Since
If-Nane-Match
If-Range
If-Unmodified-Since
Last-Modified
Max-Forwards

New custom header

Mame: Value: Insert

@ oK Cancel

4. To add a standard header:

a. In the Available Headers list, locate the header to add and click it. Type the name of the header in the
Quick search field and select the type of header that you are looking for in Header types list to quickly

locate a header in the Available Headers list.

b. Click the right-angle bracket (>). The selected header moves into the Selected headers list and your

cursor is placed in the value column.

c. Type the value for the header.

5. To add a custom header:
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a. In the Header types list, select Custom.

b. At the bottom of the window, in the New custom header area, type the header information in the Name
field and the Value field, and then click Insert. The custom header is added to the Selected headers

list.
¢. When you have finished adding headers, click OK.

Removing HTTP header from multiple HTTP requests

During the development process, there might be addition of new HTTP headers. To modify the test script in a faster

and easier way, you can remove the HTTP headers in batches from the requests.
About this task

To remove HTTP headers from multiple HTTP requests at once:

1. In the Test Navigator, browse to the test and double-click it. The test opens.

2. Right-click the test name, and then select Test Search.
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3. In Search for text, type the header name to locate.

4. In the Elements to search list, select the HTTP Requests check box.

5. On the right-hand side, where you can define how to search a selected element. Select the Headers Names or

Header Value check box depending on the input provided in the Search for text field.
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@ Search O X

57 File Search 5 Test Search %7 Data Correlation Rules % Java Search % Plug-in Search ’ Test Log Search

Search for text: ‘ testname V‘
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[ ] Limit search to primary requests only

® Customize... Replace... Cancel

6. Click Search. The Test Editor window displays with the number of matches found.

() Test Editor »

@ Number of matches found: 5

7. In the Search view, select a result (press Ctrl key to choose multiple results).
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8. Right-click the selected results and click Delete Header.
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Verifying expected behavior

To check whether an expected behavior occurred during a run, you add verification points. When you run a test that
contains a verification point, an error is reported if the expected behavior did not occur. When global verification
points are disabled (the default), you can enable verification points for a specific test.

Enable verification points globally. Click Window > Preferences > Test > Test Generation > HTTP Test Generation.

Specifying the expected page title

Page title verification points verify that the primary request for a page returns the expected page title. If the returned
title is unexpected, the test log reports a failed verdict event. Although the comparison is case-sensitive, it ignores
multiple white-space characters (such as spaces, tabs, and carriage returns).

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
2. Right-click the test name or a page, and select Enable Page Title VPs.
Your choice determines whether the verification point is added to all pages in the test or to one page.

3. Click the page title to display the editing fields in the Test Element Details area.

r__=,,|z Page Title ¥erification Point

Enable verification point

Expected page title; |iBM IJnited States
Recorded kitle: IBM United States

4. Ensure that the Expected page title field shows the string that you expect to be included in the response.
Although you can change the string, the value listed is what was returned between the <title></title> tags
during recording.
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What to do next
You can also change the preferences so that Page Title verification points are set automatically. To do this:

1. Change the HTML page title. Click Window > Preferences > Test > Test Generation > HTTP Test Generation
> Verification Points, and select HTML Page Title. This changes subsequent tests that you record.
2. Optionally, regenerate existing tests with the changed preference, as shown in Generating a new test from a

recorded session on page 259.

Specifying the expected response code

Response code verification points verify that the response code matches an expected value. If the returned code is
does not match, the test log reports a failed verdict event. You can specify an exact response code or verify that the

code is within the same category.

About this task
You can either change the preferences so that Response Code verification points are set automatically for all the

tests or you can configure each test setting. To set response code in the preferences:

1. Change subsequent tests that you record. Click Window > Preferences > Test > Test Generation > HTTP
Test Generation > Automatically include verification point of, select HTTP Return Code and click Relaxed or
Exact. This changes subsequent tests that you record.

2. Optionally, regenerate existing tests with the changed preference, as shown in Generating a new test from a

recorded session on page 259.
To set response code setting for a test:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
2. Right-click the test name, a test page, or a request, and select Enable Response Code VPs.
Your choice determines whether a verification point is added to every request in the test, to every request in a

page, or to a particular request. The following figure shows a response code verification point within a test:

-l S84 Lindfed States
B s dm.comy
2% Connection
- 4% Response: 302 - Found
1l Response Code Verifiration Foint

Note: When you modify a test, the modified items appear in italic type. The italic type changes to
regular type after you save the test.

3. Click the verification point to display the response code editing fields in the Test Element Details area.
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Test Flement Details
Response Code Yerification Poink
Record response code is 302,

el Enable werification poink

Select makching method

{0 Exact

2 Relaxed

4. To disable an individual response code verification point, clear the Enable verification point field.
5. From the Select matching method list, click an option to indicate how closely the returned response code

must match the recorded value.

Option Description

Relaxed If the recorded response code is 200, 201, 202, 204,
206, 301, 302, or 304, then a returned response code
of any of those values causes the verification point
to pass. If the recorded response code is any other
value, it is the same as if you had specified an exact
match.

Exact An error is reported if the returned response code

does not match the recorded value.

Specifying the expected response size

Response size verification points verify that the number of bytes returned in a response is what you expected. If the
byte count does not match, the test log reports a failed verdict event. You can specify an exact response size or verify

that the byte count is within a range.

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
2. Right-click the test name, a test page, or a request, and select Enable Response Size VPs
Your choice determines whether the verification point is added to all test pages, to a page in the test, orto a
particular request. The following figure shows a response size verification point within a test:

Led . 1B Lhnitad Stakas
- s bm. com/

@ Connection

=47 Response: 302 - Found
LGy, Response Size Verification Poink
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Note: When you modify a test, the modified items appear in italic type. The italic type changes to

regular type after you save the test.

3. Click the verification point to display the response size editing fields in the Test Element Details area.
Test Element Details
Response Size Werification Poink
Recorded response size is 206 bytes,

Sy Enable verification paink

—Select makching rmethod

® Exart: bytes

O At least:
O ak most:
O Range (bytes):

O Range (%)

Werify that the response size is exackly 206 bykes,

Responses to HEAD requests, by definition, have no contents; the size is always 0.

4. To disable an individual response size verification point, clear the Enable verification point field.
5. From the Select matching method list, click an option to indicate how closely the response size that is
returned in the page request must match the recorded response size.
o The default matching method for a primary request is Range, with a percentage adjustment based
on the value in the field on the right. (You can change the percentage basis as well as the matching
method.) When the test is run, an error is reported if the actual response size falls outside the adjusted
range.
» For other requests, the default matching method is Exact. When the test is run, an error is reported if

the response size does not exactly match the expected size.

What to do next
You can also change the preferences so that Response Size verification points are set automatically. To do this:

1. Change subsequent tests that you record. Click Window > Preferences > Test > Test Generation > HTTP
Test Generation > Verification Points, and select HTTP Response Size. This changes subsequent tests that
you record.

2. Optionally, regenerate existing tests with the changed preference, as shown in Generating a new test from a

recorded session on page 259.
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Specifying the expected content

Content verification points verify that the response contains—or does not contain—an expected string. If the content
returned is unexpected, the test log returns a failed verdict event. You can create a content verification point from
specific response text.

To create a content verification point from a response or a portion of a response:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. Click the response that contains the contents that you want to use for the verification point. If you do not see
the contents, press Ctrl+Shift+Spacebar in the Test Element Details area, under Content.

3. Select the content for the verification point, right-click, and select Add to Content Verification Point.

Result
The content verification point and the selected string are displayed in the Test Contents area.

4. Edit the new content verification point as needed. You can use the Add, Insert, and Remove buttons to
manipulate content verification points and content verification point strings. After you select a content
verification point or content verification point string in the editor, you can also edit the verification points and
strings by using the controls in the Test Element Details area. For example, you might want to change part of
the hard-coded response contents to a regular expression. To substitute from any data source that exists in
the test, select the entire string or a portion of the text string, and then right-click, and select Substitute.

Note: Responses to HEAD requests, by definition, have no content. Therefore, a content verification
point that attempts to match a string in a response to a HEAD request will fail.

Specifying the expected content for multiple requests

Content verification points verify that the response contains—or does not contain—an expected string. If the content
returned is unexpected, the test log returns a failed verdict event. You can advance through a test and create content
verification points in multiple requests, or in the entire test.

To create content verification points in multiple requests:

1. Adjust the verification point scope. The default is to create content verification points in primary requests only
and to skip responses with binary contents. Click Window > Preferences > Test > Test Editor > HTTP Test.
Select or clear Skip responses with binary content and Create only in primary responses as needed.

2. In the Test Navigator, browse to the test and double-click it.

Result
The test opens.

3. Right-click the test name, a test page, or a request, and select Verification Points > Enable Content VPs.

Your choice determines whether the verification point is added to all test pages, to a page in the test, orto a
particular request. Confirm that you want to modify the test elements, and click OK.
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4. In the Create/Enable Content Verification Point window, set Verification fails if to either At least one of the
checked strings is found or to None of the checked strings are found.

5. In the list of strings in the Text column, select the strings that the content verification point should search for.

o If you are editing an HTTP test, the window lists user-defined strings.
> If you are editing a Siebel HTTP test, the window also lists strings of interest in Siebel applications.

6. To create a new string from scratch, click New String. To create a new string by editing another string, click it
and click Duplicate. To edit an existing string, click Edit. To remove a string, click Remove.

7. Optionally, insert a regular expression into the verification point. The most common regular expressions are
« for any number of characters, 2 for any single character, and\ for an escape to enter literals. For detailed
information on Java™ regular expressions, see the Java™ documentation.

8. The Create/Enable Content Verification Point window advances through the requests. The preference
settings that you selected in the first step determine whether secondary requests and requests containing

binary data are affected. Select one of the following:

Option Description

Skip Advances to the next request without inserting a veri-

fication point in the current request.

Enable Inserts a verification point into the current request

and advances to the next request.

Enable All Inserts a verification point into every test request (if

the scope is the test) or every page request (if the

scope is a page).

By default, a string that you set for a content verification point is available to all tests. To make the string
available only to a specific test, or to clear the list of strings displayed when you create a verification point,
change the preferences in the Content Verification Points section of Window > Preferences > Test > Test
Editor > General.

Specifying error-handling behavior

You can specify how error conditions are handled when running a test or schedule. Error conditions include
verification point failures, connection failures, server timeouts, custom code alerts, and problems with data

correlation.

About this task

You can specify error-handling behavior for the workbench, schedules, tests, and test elements/steps. The Errors
report displays the error conditions and error behavior that occurred in a test or schedule. When you set the error-
handling behavior for the workbench, it is applied to all the tests in the workbench. To apply it for the workbench, click
Window > Preferences > Test > Test Execution > Error handling.

Starting from 9.2, there is a new Error handling preference - Mobile or Web Ul Fatal Error - to allow text execution for
a compound test to continue even after a fatal exception in one of the tests in a compound test.
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1. In the Test Navigator, browse to a test, and double-click it.

Result
The test opens.

. In the Test editor, complete one of the following steps:

a. To specify error-handling behavior for a request/step or other elements in the test hierarchy, in the Test
Contents section, select the element and in the Test Details section, click the Advanced tab.

b. To specify error-handling behavior for an element such as a connection, verification point, substitution,
or reference, select the element, and then click Change. Skip to step 5.

c. To specify error-handling behavior for a dataset that is associated with a test, on the Common Options

page, select the dataset, and then click Dataset Properties. Click Change. Skip to step 5.

. Under Error Handling, expand Click to show conditions.

Result
The error condition table is displayed. The error condition table shows all possible conditions that can be
handled in the test.

. Select the check box next to the condition for which to specify behavior.

Result

A window opens where you can specify the action to take and the message to log when the condition occurs.

5. To apply an action when the specified condition occurs, select the Override action upon error check box .

Option Description
Continue Click to continue running the test.
Exit transaction Click to exit a transaction when the specified condi-

tion occurs. Select the Innermost or Outermost trans-
action, or type the name of a transaction.

Exit loop Click to exit a loop when the specified condition oc-
curs. Select the Innermost or Outermost loop, or type
the name of a loop.

Continue to next iteration of loop Click to continue to the next iteration of a loop when
the specified condition occurs. Select the Innermost
or Outermost loop, or type the name of a loop.

Exit test Click to exit the test when the specified condition oc-
curs.
Exit user Click to stop the virtual user that encounters the

specified condition.

For a Web Ul test, this action will stop the test execu-

tion.

Terminate run Click to stop the run when the specified condition oc-

curs.




Chapter 6. Test Author Guide

6. To contribute to the health of the page, transaction, or loop, select the Override contribution to health status
check box and select Yes. The respective reports display the health of the page, transaction, or loop.

7. Optional: To write a message to the test log when the specified condition occurs, select the Override log
message upon error check box and type a message.

8. Click OK.

Exemple

To stop running a test when a substitution failure occurs in data correlation, select the Substitution Failure check
box. Click Exit Test, and then click OK. The error-handling behavior that is specified closest to where an error occurs
takes precedence. If a specific request is set to continue if a substitution fails, and the schedule is set to stop if a

substitution fails, then the schedule will continue running if the substitution fails in that request.

Related reference

Error conditions on page 1141

How loops affect the state of virtual users

If verification points fail unexpectedly during a run, the cause might be that virtual users in loops do not maintain
their original state. To enable each virtual user to enter the loop in the original state, you can modify the test's HTTP

options or add custom code.

About this task
By default, the cookie cache for a virtual user is not reset during a test run. This is consistent with a browser's
behavior. If a test or schedule contains loops, and a web server sets a cookie during the first iteration of the loop, that

cookie is "remembered" on subsequent iterations.

However, in certain instances, you might want to clear all cookies cached for a particular virtual user. For example, if
you want each iteration of a loop to appear as a new user, you must reset the cache. If you do not, although the test
completes, verification points that you have set within the test may fail.

There are two ways to reset the cookie cache, and each way has different effects.

To reset the cookie cache when looping in the schedule, or when the test follows another test in the schedule, use the
following method. This resets the cache whenever the test is entered. Even if your tests do not loop, use this method
if you are running back-to-back tests or Siebel tests.

1. In the Test Navigator, browse to the test and double-click it. The test opens.

2. On the HTTP options page, select Clear cookie cache when the test starts.

To reset the cookie cache from one loop iteration to the next when you have put a loop around the entire contents of

the test, and the loop is inside the test, add custom code to the test and call an API, as follows:
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1. Run the test or schedule to add the current Java™ libraries to the class path.

2. Open the test and select the test element located at the point where you want the cookie cache to be reset.
Typically, this is at the end of the loop.

3. Click Add or Insert and select Custom Code.
Add appends the custom code to the bottom of the selected element (test or test page). Insert adds the
custom code above the selected page or page request.

4. Add the following Java™ import statement: | nport
comibmrational.test.lt.execution.http.util.CookieCacheUtil

5. Add the following Java™ code inside the exec method: Cooki eCachelt i | . cl ear Cooki eCache(t es);

Exemple
The following example shows a custom code addition that resets the cookie cache. The lines that you add to the

generated custom code template are shown in bold:

Note: For another example of custom code that sets and clears cookies, see Setting and clearing cookies for

a virtual user on page

package test;

import com.ibm.rational.test.lt.execution.http.util.CookieCacheUtil;
import com.ibm.rational.test.lt.kernel.services.ITestExecutionServices;

public class Class1131739398417 +implements
com.ibm.rational.test.lt.kernel.custom.ICustomCode2 {

public Class1131739398417() {
}
public String exec(ITestExecutionServices tes, String[] args) {
CookieCacheUtil.clearCookieCache(tes);
return null;
}
}

Splitting a test

After you record a test, you can split it into smaller tests. By splitting a test, you can create modular building blocks of

smaller tests and combine them to make bigger tests. The original test is unchanged.

About this task

With the test-splitting capability, you can record a relatively long scenario with many functional steps against an
application and then, in the editor, dissect the test into many smaller test segments, which you can run in various
orders in a schedule. The wizard determines which variables need to persist among the split tests and creates the
linkage so that you do not have to write custom code.

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
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2. Select one or more elements in the test for splitting into a new test.
You must select contiguous elements. You can select elements, except for variable containers, that are
immediate children of the root node of the test.

3. Right-click the selected elements, and then select Save Selection As New Test.

4. In the Save Selection as New Test window, type a file name for the new test, and optionally provide a
description or comment for the split test.

a. Select Also use description text for comment at beginning of each test to add the Description/
comment field as a comment at the beginning of the split test.

b. Select Mark the selection in the editor to mark the selection in the original test with marks of the form
[N->where N is a positive integer that corresponds to the number of saved selections. For example,
the first time you save a selection as a new test, the selection in the original test is marked with this
identifier:[ 1- >. If you save three selections, the original test is marked with these identifiers: [ 1->, [ 2- >,
and [3->.

c. Click Next.

Selecting Mark the selection in the editor makes it easier to split a test into multiple parts. The marks in the
editor are removed when you close the test. You cannot save marked test elements. Right-click and select
Clear Range to remove the marks if you want to save the selected test elements again.

5. Optional: On the next page of the Save Selection as New Test wizard, examine the changes to be performed
as a result of the split.
Typically, you leave Link tests through variables and HTTP Specific Changes selected; clearing these options
might make a split test unusable or produce unpredictable results. However, you can clear specific Link tests

through variables boxes if you do not want certain data to be correlated between the tests.

285



HCL OneTest Performance

€9 Save Selection as New Test

Required Changes

Review changes to be performed. l::ﬁ
Changes to be performed 4o -

= ff->:_b'| Create new test: /newproj/tsplittest_join_a. testsuite

fi?‘:_fl Link tests through variables

@3 HTTP Spedific Changes

Mo preview available

':':’:' Einish ] [ Cancel

6. Click Finish.

Results

The new test is created from the selected elements. The test variables that are created by splitting a test are listed

in the Variables Created by Split Test container in the new test. For best results, open the Variables Created by Split
Test container in the new test and make sure that the variables are created and assigned with values by a test that is
executed before the newly split test. For more information on test variables, see About test variables on page

and Declaring and assigning test variables on page

The original test is marked if you select the Mark the selection in the editor option. To remove the marks, right-click
the selected elements in the original test and select Clear Range. You are also prompted to delete the new test. Click
Yes to delete the new test or No to preserve it.

Exemple
Be aware of the choices that you make when you split a test and rearrange the split tests in a schedule. Assume that
the visitIBM recorded test contains the following actions:

» Logging on to a server.
- Creating an entry on the server and removing the entry.
« Editing an entry, validating that the change occurred, and restoring the entry.

- Logging off of the server.

You want to split the test into four parts: Logon, Create, Edit, and Logoff. You need to split the test four times.
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« Open visitIBM and select the logon actions. Name the new test Logon, which contains the Logon actions.
« Select the create actions. Name the new test Create.

« Select the edit actions. Name the new test Edit.

« Select the logoff actions. Name the new test Logoff.

You then create a schedule that runs virtual users selected from a dataset. Each virtual user runs the Logon test,

performs various combinations of the Create and Edit tests, and finally runs the Logoff test.

Be aware, however, that when you split the tests, the Create test might have initialized variables that the Edit test
uses. Therefore, if you reverse the order during the run (that is, run the Edit test before the Create test), make sure that
the variables that the tests share are initialized and set correctly.

Splitting a test page

You can split an HTTP page into two contiguous pages. The page title, think times, primary request, and delay are
automatically recalculated for the affected pages. Customized page titles, think times, primary requests, and delays
revert to the default values.

Before you begin

When you inspect a test, you might notice that some page boundaries are not at the correct place. A common cause
is that, during recording, you did not wait for the page to fully load. Although you can rerecord a test, if your test is
long or compley, it is often easier to split the incorrect page when you edit the test, rather than to rerecord the entire
test.

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. In the test, expand the page that you want to split.

3. Right-click on the request where you want the split to occur, and select Split page here.

4. In the Split HTTP Page window, you can change the location of the split by clicking on another page element.
You can also create a new page, combine the elements above the insertion point with the previous page, or
combine the elements below the insertion point with the next page.
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5. To split the page, click Finish.

What to do next
You can also set preferences so that new pages are generated when the delay exceeds a specified value. Click
Window > Preferences > Test > Test Generation > HTTP Test Generation, and click the Protocol tab. Enter a value

for Generate new page if delay between requests is >.

Merging test pages

You can two or more contiguous HTTP pages into one page. The page title, think times, primary request, and delay
are automatically recalculated for the affected pages. Customized page titles, think times, primary requests, and
delays revert to the default values.

About this task
When you inspect a test, you might notice that some page boundaries are not at the correct place. These extra pages

are caused by a variety of reasons. For example, during recording you might hover over a "hotspot" that fetches
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images as you move on and off of the spot. In this case, some pages in the test, which properly belong to the previous
page, contain only .gif files. Although you can rerecord a test in the hope of fixing this problem, if your test is long or
complex, it is often easier to merge the incorrect page when you edit the test, rather than to rerecord the entire test.

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. Select the pages to merge (the pages must be contiguous) and select Merge Selected Pages

3. The Merge Pages window lists the pages that you are merging. From this list, select the page that will contain
the other pages.

4. Optionally, click Keep empty pages to keep the same number of pages in the test. For example, if you select
this option and merge two pages, one page will contain all of the requests and the other page will be empty.

What to do next
You can also set preferences so that new pages are not generated when the think time is less than specified value.
Click Window > Preferences > Test > Test Generation > HTTP Test Generation, and click the Protocol tab. Enter a

value for Do not generate new page if think time is <.

Disabling and enabling secondary HTTP requests

You can disable all secondary requests within an HTTP performance test or a subset of requests in the test.
Secondary requests are all requests within a page other than the primary request.

About this task
To disable other elements in tests or schedules (for any protocol), see Disabling portions of a test or schedule on

page

1. In the Test Navigator, browse to the test, and double-click it.
Result
The test opens.
2. In the Test Element Details area, click the HTTP Options tab.
3. At Secondary request behavior, click Modify.
4. In the Enable or Disable Secondary Requests box, select one or more of the following options:

Option Description
All secondary Selects all secondary requests.
Images Selects all secondary requests that are image-relat-

ed. This selection includes all secondary requests
where the Content-type header of the response con-
tains image or the path of the URI of the request con-

tains a .gif, .png, .jpg, .bmp. or .tif extension.
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Option Description

Host/Port based Selects all secondary requests that use the speci-
fied host:port pair for connections. A list of host:port

pairs in the test is displayed.

User-defined Selects all secondary requests where the user-speci-
fied string, or a string matching a user-specified regu-

lar expression, is in the request URL.

5. You typically keep the boxes under Do not disable secondary requests selected, which leaves them enabled.
However, if you have extensive knowledge of the system under test and have already done some
troubleshooting, you might clear these boxes in the following cases:

> With responses containing set-cookie headers: If the cookies set in a particular request are not
important to the remaining requests, you may disable them. This decision requires you to know how
the system under test uses cookies.

> With data sources used by enabled requests: If a test contains superfluous data correlation, you may
disable it. This decision requires you to know how the system under test uses data correlation.

6. Select Disable or Enable to modify the secondary requests.

Result

The requests are now enabled or disabled.

Adding custom actions to requests

After an HTTP test is generated, you might want to add a few actions before or after a particular request is
processed. For instance, for preprocessors, you can modify the headers before sending them to the server. Similarly,

for postprocessors, you can extract data from the response and set it to a variable.
About this task

The actions to be processed must be coded in Java. Note that the pre processor is the last thing to be sent to the
server after all the processing (data substitution) for the request is complete. Also, a postprocessor is the last thing

to be received after all response processing is complete from the server.

You can add preprocessors and postprocessors at the test level and at the request level. When they are added at both

the levels, the ones at the request level takes precedence.

The preprocessors and postprocessors for the HTTP extension uses the following interfaces and methods:

- IHTTPRequestInterface: Use this interface to process an action before the request is processed.
> setURI: Use this method to set or change the URL that is sent to the server.
- getHeader: Use this method to get the name of the header that requires a value. If there are more than

one header with the same name, only the first value is returned.

290



Chapter 6. Test Author Guide

- removeHeader: Use this method to remove the name of the header.

- setHeader: Use this method to set the name and value for the header. If the header does not exist, it
is created. If the header exists, the value is changed. If there is more than one header with the same
name, only the first header is changed.

- IHTTPResponselnterface: Use this interface to process an action after the request is processed.

- getResponseContent: Use this method to view the content of the response. If the response content
exceeds the specified limit, the content is truncated.

- getResponseHeader: Use this method to view the name of the header. If there are more than one
header with the same name in the response, only the first header is returned.

- getReturnCode: Use this method to view the return code of the current response.

- IHTTPRequestCommonlnterface: Use this interface for both request and response interfaces.
> getURI: Use this method to view the current URI of the request.
- getHeaders: Use this method to view all of the headers associated with the request for pre processing

or all of the headers associated with the response for post processing.
To add a preprocessor or postprocessor:

1. In the Test Content area of the Test editor, select a request.
2. In the Test Details area of the Test editor, click the Advanced tab.
3. To add a custom action before a request is processed, in Preprocessor, click Create.
4. Specify a name for the Java file and click Finish.
Result
A new Java file opens. Add the custom actions to be processed before the request and save the file.
5. To add a custom action after a request is processed, in Postprocessor, click Create and follow step 4.

What to do next

You can now run the test to verify if the actions specified in preprocessors or postprocessors returned expected
results.

Reusing tests on different hosts: Server connection variables

Your tests represent a significant investment in time and effort. You can share or reuse them for different

configurations and web hosts by changing the variables for the host name and port.

Before you begin
Before you begin, confirm that test generation preferences are set to support data correlation. Click Window >
Preferences > Test > Performance Test Generation > HTTP Test Generation, click the Data Correlation tab, and

verify that Automatically correlate host and port data is selected. If not, select that option and regenerate the test.

About this task

Perhaps you develop the tests on a lab computer and then they want to run them on a production server. If the
application that you are testing is identical on both computers, you can change the host name and reuse the tests on
the production server.
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To change the name of the host or proxy server on all requests in a test:

1. In the Test Navigator, browse to the test and double-click it. The test opens.
2. Expand the Test Variable section at the top of the test, and click the Server Connection variable that contains
the hostname that you want to change.
3. In the Test Element Details area, perform the following steps:
a. Type the new host name in the Host field.
b. Optional: Type a new port number in the Port field.
Result
The new hostname and port combination is correlated to the test variable, which contains the value currently

being used.

Results

Note: To change the host names and ports of many tests, put the server connection variable in a dataset
and associate the dataset with the tests. When you change the name and port in the dataset, that change is
propagated throughout the tests in the dataset. For more information, see Creating a dataset associated with

atest on page

Converting tests to use SSL connections

You can convert a test that was recorded without Secure Sockets Layer (SSL) connections to use SSL connections.

About this task
If you develop performance tests on a lab computer that does not use secure connections, and then you must run the
tests against a production server that requires SSL connections, you can add SSL to the server access configurations

and reuse the tests.

To convert a server access configuration to use SSL for all associated connections:

1. In the Test Navigator, browse to the test, and double-click it. The test opens.

2. Expand the Test Resources section at the top of the test.

3. Right-click the server access configuration that corresponds to the server where you want to add SSL, and
then click Add > SSL.

Result
An SSL element is added as a child of the server access configuration.

4. In the Test Element Details area for the server access configuration, type a new number in Port if the server
uses a different port for SSL communication. If the port number is correlated with a server connection
variable, select the port number, right-click, and select Go To > Variable: variable_name to navigate to the
variable. Change the port number in the server connection variable.

5. In the Test Element Details area for the SSL element, make a selection in Protocol, and type or select a name
in Cipher.

6. Repeat the same steps for all server access configurations to convert to use SSL.
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Results
When you run the test, the connections that are associated with the server access configurations use SSL.

Working with Server Name Indication (SNI) recordings

If you have recorded against a server that supports Server Name Indication (SNI), an extension of the TLS protocol,
the recording session file displays t r ue for the SNI Extension field. There might be a need for you to access both
SNI and non-SNI applications from the same server. To run the same test without using the SNI extension, you can
manually change the value to f al se.

About this task
Packets }:9 — 'L:k::' Packet Details
Packet StatTime  EndTime  ~| Proxy Open Secured
2 Proxy connection type 0 00:00069  00:00069 5| Recorder ® HTTP Proxy Recorder
IEuaLocal addresses 00:00.308 00:00.308 .
& Proxy starts 00:00.210 00:00.210 Connection Id: z
4 Proxy initiates connection 1 00:06.271 00:06.271 Parent ConnectionId: 1
L?Proxy opens connection 1 00:06.271 00:06.611 Connection TypeId: ]
5_?Pr0xy opens secured connection 2 based on 1 00:06.758 00:07.357 Server Host: tiles.cervices.mozilla.cam
|§Prm<}r close connection 2 00:07.551 00:07.551
= Proxy close connection 1 00:07.551 00:07.551 Server Port: 443
4 Proxy initiates connection 3 00:10195 00:10.195 Client Host: 127001
9 Proxy opens connection 3 00:10.195 00:10.259 Client Port: 54790
9 Proxy opens securec! connection 4 based on 3 00:10.268 00:10.408 Cipher Suites: 55L_ECDHE_RSA_WITH_AES 128 GCM_SHAZ56
& Proxy close connection 4 00:10.703 00:10.703
P Proxy close connection 3 0010703 00:10.703 55L Pratocols: TL5v1.2
Elg.aproxy initiates connection 5 00:10.788 00:10.788 HTTP Version Protocol: |http/1.1
9 Proxy opens connection 5 00:10.788 00:11.066 - | | SMI Extension: true

Overview | Content

The Server Access Configurations resource of the test script also have SSL entries. Each SSL entry displays which
TLS version and Cipher value was used. To edit multiple SSL entries, select them and in the Detail area, right-click the

entries and click Edit multiple SSLs.

Viewing a test in the Protocol Data view

The Protocol Data view enables you to inspect the actual test data. You can see requests, response headers, and
response contents, as well as the rendered images that you see through your browser. Use this view to obtain the
information you need to add custom code or to manually correlate data. This view also lets you compare the recorded

data with the data retrieved during a run.

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. Click the Protocol Data tab to open the view.
Result
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0 Tip: If you cannot locate the Protocol Data tab, click Window > Show View > Protocol Data.

3. In the test, click the line that corresponds to the page, request, or response that you want to view.
4. In the Protocol Data view, click the tab that corresponds to the type of data or view of interest.
Result

The selected data is displayed in the Protocol Data view.
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What to do next

If you have problems during playback, you can compare the data that was recorded with the data that was retrieved
during the run. For information on displaying the data retrieved during the run, see Inspecting HTTP test logs in the
Protocol Data view on page 625.

Testing Siebel applications

When you record a Siebel application, a Siebel-specific test is automatically generated. However, before you run this
test, install the Siebel Test Automation library and edit the test to use built-in Siebel variables.
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Note: HCL OneTest™ Performance 64-bit workbench does not support testing Siebel applications.

Prerequisites for Siebel testing

To test Siebel applications, the Siebel Test Automation and the Microsoft™ C++ runtime libraries must be installed on
the workbench computer.

About this task

Siebel applications run only on Windows™ operating system, therefore you must run the Siebel tests only on
Windows™. You must not add a Siebel test to a schedule that you deploy to run on operating systems other than
Windows™.

Note: HCL OneTest™ Performance 64-bit workbench does not support testing Siebel applications.

To install the prerequisites for testing Siebel applications:

1. Obtain the Siebel Test Automation library, ssdt corr. di I, from Siebel.

2. Copy the ssdtcorr. di| file to the workbench computer in this path:. . . \'i bm sdp\rpt\external _files
\ depl oyabl e\ si ebel \ ...\ hcl\hcl onet est\ hot - perf\external fil es\depl oyabl e\si ebel\,
where. .. \ibm sdp\rpt\...\hcl\hclonetest\hot-perf\ isthe product installation directory.

If the Siebel Test Automation library is not installed, Siebel tests will fail, and a warning message will display
when you edit a Siebel test. After the library is installed on the workbench computer, it is automatically

deployed as needed to any remote location. The library must be on any computer that runs a Siebel test.

You can use the rptExternal variable in the confi g. i ni file to control where external files must be installed.
By default, the rptExternal variable is set to the product installation directory. Edit the rptExternal variable if you
want to install the .dll files to a different location.

Example
For example, if you set the rptExternal variable to e\ :\\i bm\ sdp\\ rpte\:\\hcl\\ hcl onet est\\ hot - perf then you
would install the Siebel Test Automation library in e: \ hcl \ hcl onet est\ hot - perf\external _files
\ depl oyabl e\ si ebel \ . Note that you must use an extra backslash before the colon and backslashes in the
path.

3. Copy the appropriate Microsoft™ C++ runtime library to the workbench computer in the same directory as the
ssdtcorr.dl | file. Recent version of ssdtcorr.dl | (Version 8.1.1.14 for example) require msvcr 110. di | . Older

versions of ssdt corr. dl | (like Version 7.7.0.0) need nsvcr70.di | .

To download the appropriate Visual C++ runtime library from the Microsoft™ web site, download the Windows
Server 2003 Resource Kit Tools for msver 70. di | or the Visual C++ Redistributable for Visual Studio 2012
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to get msvcr 110. di | . The file name is case-sensitive, and must be all lower-case. The file must be named

msver 70. dl |, Not MSVCR70. DLL

Once installed in the correct directory on the workbench computer, the Microsoft™ C++ runtime library is

automatically deployed as needed to any remote location.

Differences between Siebel tests and HTTP tests

Siebel tests precisely designate dataset candidates, include an additional type of data source, and store variables
in a proprietary data structure. In addition, page names are created during test generation to help you find pages of

interest.

The primary difference between a Siebel test and a standard HTTP test is in how dynamic data is stored and

substituted during a test run:

« In a standard HTTP test, a data source (dataset variable, custom code, or a reference) is linked to a test value
that is replaced at run time. Siebel tests support standard HTTP data sources and substitution. Datasets,
which are explained in Providing tests with variable data on page , work the same way in Siebel tests
as in standard HTTP tests, but the dataset candidates in Siebel tests are more precisely designated than in
standard HTTP tests. In many cases, dataset substitutions are the only changes that you need to make to a
Siebel test.

- In a Siebel test, an additional type of data source, which is called a built-in data source, contains variables that

you can use to replace a test value.

These variables can be substituted for dates (in defined formats), time stamps, and counters throughout
tests. In some cases, SWE Unique Value can be used as an alternative to a dataset; for example, to supply
variable account names. For detailed instructions, see Correlating a request value with a built-in Siebel

variable on page 297.

Siebel variables are stored in a proprietary data structure called a star array. A star array stores both strings and their
length in hexadecimal format (length_string) or integer format (length*string). Siebel substituters have a method for
substituting data and recomputing the length. You can substitute from a value in a star array (highlight a length_string
or length*string format value, right-click, and then click Substitute). You are then asked whether you want a Siebel

substitution or a standard HTTP substitution. You typically select Siebel data correlation.

Siebel tests are organized inside the test editor much like standard HTTP tests, but with some differences for pages:

« The first page of a Siebel test is named Message Bar, which emulates the ticker-tape message that Siebel
application pages display.

» Page names are created during test generation to help you find pages of interest. For example, a typical
change to make to a test before running it is to replace the user name and password that you typed during
recording with values in a dataset. As shown in the example, the page from which you logged into the Siebel
server is named Login - Send UserName/Password, to help you find this page quickly.
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Correlating a request value with a built-in Siebel variable
If you are editing a Siebel test, you can correlate request values with built-in Siebel variables.

To correlate a request value with a built-in variable:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
2. Locate the value that should be replaced by a built-in variable.
3. Highlight the value: with the left mouse button pressed, drag your mouse over it.
4. Right-click the highlighted value and click Substitute from > Built-in data sources.
Result
The Built-in Datasource Selection wizard displays the types of variables that can be substituted.
5. Select the type of variable and click either Next or Finish.
Choose from:
o If you select Current Date, click Next, select the date format, and then click Finish.
o If you select SWE Counter, click Next, type values for the counter in the Current Value and Maximum

Value fields, and then click Finish.

Editing SAP tests

After you record a test, you can edit it to include variable data (rather than the data that you recorded) and verification

points (to confirm that the test runs as expected).
SAP test editor overview
You use the test editor to inspect or customize a SAP performance test that you recorded.

The test editor lists the SAP transactions for a test, by title. The following example shows the test MySAPTest,
which was generated from a recording of these tester actions: logon to the server, launch a Material Master Display

transaction (mmO03), view the Basic Data screen for the item SCREW, and stop recording.
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Test Contents Test Element Details
This section shows the test contents MySaPTest
SR 15 AP et
ﬂ;} J5AP_CODEPAGE=1100 [FULLMENU 9.143.105.5
+)- (% Transaction: 0} 5000

+- (B Transaction: 1] MM
e .
(% Transaction: 2

el SAP Options

Datapools

Marng | Usage | Location

L L

Common properties Add Datapocl ‘ ‘

There are two main areas in the test editor window. The area on the left, Test Contents, displays the hierarchy of the
SAP transactions for the test. The area on the right, Test Element Details, displays details about the currently selected
item (transaction or event) in the test hierarchy. In the preceding example, Test Element Details displays information

about the test because the name of the test, MySAPTest, is selected in the Test Contents area.

When you expand a test transaction, you see a list of SAP screens. Each SAP screen corresponds to a new page or

window in SAP GUI and is reflected by the screen capture in the SAP Protocol Data view.

When you expand a SAP screen, you see the SAPGUI events for the screen, with names that describe the action.
The following example shows the Material Master Display (mm03) transaction expanded with the SAP Easy Access
screen. The set event that described the mmO03 text input in the SAP GUI is selected in the Test Contents area.
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Test Contents Test Element Details
This section shows the test contents SAP Set Event
- %E MySARTest Information
ﬂ;} J5AP_CODEPAGE=1100 [FULLMENU 9.143.105.5 Name: oked

+ éj, Transaction: 0 5000 —— Typer | GUiOkCodsField

-y .
= (& Transaction: 1/ MMD3 Tdentifier: | fappjcon]0]jses[o]wnd[a]thar0]/cked

--[E] 5AP Easy dccess Remave

eField" text ko "mm03"

ﬁ{E Press enter in "SAP Easy Access”
= Server Request
+-[Z] Display Material {Initial Screen)

Thirk Time: | 3355 miliseconds - |

Dawn

HEJHUS

+ E Restrict Yalue Range Event Attributes
4B Hit List : :
+-[Z] Display Material {Initial Screen) hlame: |GU|OkCDdEF|E|d
+-[2 Select Yiew(s) Velue: fms

+-[Z] Display Material 522200 (Semi-finished product
+ éj, Transaction: 2

Common properties

Values can sometimes be highlighted in green. This highlighting indicates that these requests contain one or both of

the following types of information:

- A dataset candidate: This is a value, usually one specified by the tester during recording, that the test
generator determined is likely to be replaced by values in a dataset. An example of a dataset candidate
is a string that you search for in a recorded test. The string is highlighted as a dataset candidate on the

assumption that, before playback, you might want to associate the string with a dataset column containing

appropriate substitute values..

request, that the test generator determined needed to be associated in order to ensure correct test playback.
An example is a material price returned to the browser by a test that searches a material database. The test
generator automatically correlates material names with prices. Suppose that, before running the test with
many virtual users, you replace the material name searched for in the recorded test with names in a dataset.
Because the test correlates the data, each virtual user searches for a different material, and the server returns

an appropriate price.

To see an illustration of color coding in performance tests or to change the color settings, click Window >

Preferences > Test > Performance Test Editor, and then click the Fonts and Colors tab.

The Response data inside each request shows the data that the SAP server returned to the browser based on that

request.

Correlated data: These are values in a test, usually one of them in a response and the other in a subsequent
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Click Add to add elements to the selected test element. Alternatively, you can right-click a test element and select an
action from a menu. The choices that you see depend on what you have selected. For example, after you select a test,

you can add a new event.
The Insert button works similarly. Use it to insert an element before the selected element.

The other buttons (Remove, Up, Down), are primarily for use when substantially modifying a test; these actions
or choices are likely to break a recorded test. The types of structures that are commonly used in recorded tests
are explained in Adding verification points to a SAP test on page 301 and Adding elements to a SAP test on
page 303.

The test editor synchronizes with the SAP Protocol Data view. When you select a test element in the test editor, the

corresponding screen is displayed as a screen capture in the SAP Protocol Data view. If a specific SAP GUI object is
related to the test element, the object is highlighted in the SAP Protocol Data view. You can also right-click SAP GUI
objects in the SAP Protocol Data view to add associated events or verification points to your test.

Tasks | Recorder Control | Protocol Data | Error Log -"EE:ESP.F' Protocol Data &3 =0

:Q: Screen Capture l :':‘T:: Chject Data l

™ SAP Easy Access —

Menu Edit Favorites Extras System Help

@[ -] @ G
l__ﬂ B ﬁ ﬁaﬁDthermenu E P v . Bﬂreatemle

..... G OHice

+I B (7 Logistics

----- (7 tccourting

----- (] Human Resources
----- (7 Information Systems
----- (7 Tools

Sometimes, the area of the editor where you need to work is obscured. To enlarge an area, move your cursor over one
of the blue lines until your cursor changes shape (to a vertical line with an up arrow at the top and a down arrow at the
bottom) and drag up or down while holding the left mouse button.

Verifying expected behavior

To check whether an expected behavior occurred during a run, you can add verification points. When you run a test
that contains a verification point, an error is reported if the expected behavior did not occur.

300



Chapter 6. Test Author Guide

Adding an SAP verification point

With SAP get and SAP call elements, you can retrieve a value from the SAP GUI to create verification points on an SAP

screen element.
Before you begin

When you add SAP verification points, SAP get elements, and some SAP calls, retrieve the data from objects in the
SAP GUI, such as windows or text fields. SAP get and SAP call elements are contained in SAP screens in the test

suite. SAP screens can be windows, dialog boxes, or transaction screens that are part of a recorded transaction.

You can use either the test editor or the SAP Protocol Data view to create or edit SAP get and SAP call elements

and place verification points on them. When using the SAP Protocol Data view, you can select SAP screen elements
from the screen capture to specify the SAP GUI identifier for the get event. Using this method to create or edit an SAP
verification point is easier than adding it manually from the test editor.

The SAP Protocol Data view contains two pages that are synchronized with each other and with the test editor:

« Screen Capture displays a graphical screen capture of the SAP GUI. You can select all GUI objects such as
windows, buttons, fields or areas.

- Object Data provides information about the selected GUI object: identifier, type, name, text, tooltip, and
subtype.

1. Open the test editor and the SAP Protocol Data view.
If the SAP Protocol Data view is not open, click Window > Show View > Other > Test > SAP Protocol Data.

2. In the Test Contents area of the test editor, expand a transaction and an SAP screen.
The SAP Protocol Data view displays a screen capture of the selected transaction.

3. Inside the transaction, select the item for which you want to enter a new value.
Result
The Screen Capture page of the SAP Protocol Data view displays the screen capture of the SAP GUI with the
corresponding GUI object highlighted in red.

4. In the SAP Protocol Data view, right-click the GUI field that you want to verify, and then select Create
Verification Point.
If you want to create an advanced verification point using an SAP GUI call method, then you can select Create
Element instead.

5. In the Create Verification Point or Create Element window, specify the expected value for the verification
point.
Choose from:
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- If you want to verify a text value in the SAP GUI object, ensure that Verify text is selected, and type the
Expected value that you want to verify; then click Finish.

o If you want to verify advanced properties of the SAP GUI object, you can select Advanced, and
then specify the properties attached to the GUI object as well as the Expected values. Refer to SAP
documentation for information about these properties.

- If you selected Create Element to create a verification point on an SAP call, then select Advanced,
choose an Element type that returns a value, and then specify the properties attached to the GUI
object. Refer to SAP documentation for information about these properties.

What to do next
After creating the event, you can use the test editor to easily change the value. You can also enable and disable SAP
verification points on SAP get and SAP call elements in the test editor.

Specifying an expected screen title

Screen title verification points report an error if the title of an SAP screen is different from what you expected.

1. Select the SAP screen in the test editor and ensure that screen title verification is enabled for the SAP screen.

The Test Element Details area includes a Screen Title Verification Point section.

- If screen title verification was enabled for the entire test, the Enable verification point check box is
selected for all SAP screens in the test.

o If screen title verification was enabled for a specific SAP screen, the Enable verification point check
box is selected for the selected SAP screen.

You can enable or disable screen title verification for a specific SAP screen in the test editor by selecting or
clearing the Enable verification point check box.

2. Ensure that the Expected screen title field shows the string that you expect to be included in the page title that
is returned when this page is loaded.

When the test was recorded, SAP returned a default title for this screen. This value is displayed in the
Recorded title field, and is automatically copied to the Expected page title field when the Enable verification
point check box is selected. You can change the string in the Expected page title field as needed.

Result

Whenever the test runs with page title verification enabled, an error is reported if the title returned for the page
does not contain the expected title. Although the comparison is case-sensitive, it ignores multiple white-space
characters (such as spaces, tabs, and carriage returns).

Verifying response times

SAP request response times measure the delay between the moment the user submits a server request and the
moment the server responds. Response time data is provided by the server. You can set a verification point on a
response time threshold value. If the test encounters a response time above the threshold, the verification point is
failed.
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Before you begin

When the Verification points for SAP request response time threshold option is selected in the SAP Test Generation
preferences, all SAP server request elements contain a response time verification point. The default threshold value
is calculated by applying a multiplier to the recorded response time. You can change the default multiplier in the SAP
Test Generation preferences. The response time measurements are displayed in the SAP server request element,

which is the last element in an SAP screen.

To define a response time verification point:

1. In the test editor Test Content area, select an SAP server request element inside an SAP screen element.
2. In the Test Element Details, select Enable verification point, and then enter the Response time threshold in
milliseconds.

If the test encounters a response time that is higher than the threshold, the verification point is failed.

Adding elements to an SAP test

You can add a variety of elements to an SAP performance test, such as loops, conditions, SAP set, verification point

or sequence elements.

Adding an SAP set, SAP get, or SAP call element

You can use SAP set, SAP get, or SAP call elements in performance tests to add items such as a field selection, a

keyboard entry, a get element for reference use, or any advanced interaction with the SAP client GUI.
Before you begin

SAP set elements represent user interactions with the SAP GUI, such as entering a value into a field. SAP set
elements are contained in SAP screen elements. SAP screen elements can be windows, dialog boxes or transaction

screens that are part of a recorded transaction.

SAP get elements enable you to retrieve information from the SAP GUI, such as field values. SAP get elements
are contained in SAP screen elements. The primary use of an SAP get element is to create a reference field or a

verification point in the test. An SAP verification point is actually an SAP get element with a verification point enabled.

SAP call elements represent all the various user interactions that are neither an SAP set or an SAP get element. For

example, selecting an object, scrolling, or pressing the Enter key generates an SAP call.

You can use either the test editor or the SAP Protocol Data view to create or edit SAP set, get, or call elements.
When using the SAP Protocol Data view, you can select SAP screen objects from the screen capture and copy the
information directly to the new SAP set, get, or call element. Using the SAP Protocol Data view to create or edit an

SAP event is much easier than adding an event manually from the test editor.

The SAP Protocol Data view contains two pages that are synchronized with each other and with the test editor:
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- Screen Capture displays a graphical screen capture of the SAP GUI. You can select all GUI objects, such as
windows, buttons, fields or areas.

- Object Data provides information about the selected GUI object: identifier, type, name, text, tooltip, and
subtype.

To add an SAP set, get, or call element:

1. Open the test in the test editor and the SAP Protocol Data view.
If the SAP Protocol Data view is not open, click Window > Show View > Other > Test > SAP Protocol Data
2. In the Test Contents area of the test editor, expand a transaction and an SAP screen.
The SAP Protocol Data view displays a screen capture of the selected transaction.
3. Inside the transaction, select the item for which you want to enter a new value.
Result
The Screen Capture page of the SAP Protocol Data view displays the screen capture of the SAP GUI with the
corresponding GUI object highlighted.
4. In the SAP Protocol Data view, right-click the GUI object for which you want to create the SAP set, get, or call
element, and then click Create Element.
Result
This opens the window, which already contains the Identifier from the recorded session.
5. In the Create Element window, specify the type of SAP element that you want to create. Enter the value that
you want to add, and then do one of the following procedures, depending on your testing objectives:
Choose from:
o To create a simple SAP set element, select Set text, and then type the text value that you want to input
into the SAP GUI.
> To create an SAP get or an SAP call element, select Advanced, and then select SAP Set, or SAP Call
in the Element type list. Use a SAP set to input a value into the SAP GUI client. Use a SAP call to call
a method for advanced interaction with the SAP GUI. Specify the property to get or the method of the
call. Refer to SAP documentation for information about SAP call methods and properties. SAP call
elements are created with default values that you can change in the test editor. You can use SAP call
methods to define a verification point or for data correlation.
> To create a non-text SAP set element, select Advanced, and then select SAP Set in the Element type
list. Specify the property to set and enter a value if that property requires one.
6. Click Finish.

What to do next
After creating elements, you can use the test editor to change values. You can also replace values with a dataset

variable or a reference.

Adding an SAP sequence element

You can use SAP sequence elements to specify complex interactions with the SAP GUI that involve multiple actions
within a single object.
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Before you begin

SAP sequence elements represent complex user interactions with the SAP GUI, and contain multiple SAP set, get,
or call child elements where each child element of the sequence is an action that relies on the return result of the
preceding child element. In most cases, SAP sequences are recorded when you interact with complex SAP GUI
objects. However, with advanced knowledge of the SAP API, you can use SAP sequences to create complex actions

or verification points.
SAP sequence elements are contained in SAP screen elements.

You can use either the test editor or the SAP Protocol Data view to create or edit SAP sequences. When using the
SAP Protocol Data view, you can select SAP screen objects from the screen capture and copy the information directly
to the new SAP sequence element.

The SAP Protocol Data view contains two pages that are synchronized with each other and with the test editor:

« Screen Capture displays a graphical screen capture of the SAP GUI. You can select all GUI objects such as
windows, buttons, fields or areas.

- Object Data provides information about the selected GUI object: identifier, type, name, text, tooltip, and
subtype.

1. Open the test in the test editor and the SAP Protocol Data view.

If the SAP Protocol Data view is not open, click Window > Show View > Other > Test > SAP Protocol Data

2. In the Test Contents area of the test editor, expand a transaction and a SAP screen.

The SAP Protocol Data view displays a screen capture of the selected transaction.
3. Inside the SAP screen, select where you want to enter the new sequence.
Result
The Screen Capture page of the SAP Protocol Data view displays the screen capture of the current SAP
screen.

4. In the SAP Protocol Data view, right-click the SAP GUI object for which you want to create the SAP sequence

element, and then click Create Element.
Result
This opens the Create Element window, which already contains the Identifier from the recorded session.

5. Select Advanced, select SAP Sequence in the Element type list, and then click Finish.

6. In the Test Contents area of the test editor, select the SAP sequence and click Add > Element to add a SAP
set, get, or call element to the SAP sequence.

7. In the Test Contents area of the test editor, select the SAP sequence, and then click Add or Insert to add
sequence child elements as required. In the Create Element window, use the Cast button to cast the results
of the previous child element to match the expected input type. See the SAP APl documentation for detailed
information on SAP objects and calls.
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Adding a batch input transaction

You can import batch input transactions that were recorded from the SAP GUI into an SAP batch input test. A batch

input test can contain multiple batch input transactions.
Before you begin

You can add batch input transactions only to a batch input test, not to a regular SAP performance test. First create a

new batch input test.

Batch input tests access the SAP server at a low level, bypassing the SAP GUI interface, and therefore cannot contain
any verification points or SAP GUI elements. Their main purpose is to simulate a load on the server when added to a
test schedule that already contains SAP performance tests. Only the SAP performance tests provide accurate SAP

application performance measurement.

To add an SAP batch input transaction to a batch input test:

1. Open the batch input test in the test editor.

2. In the Test Contents area of the test editor, right-click the test node, and click Add > Transaction.
Placing the batch input transaction inside a transaction is not mandatory, but it is a good practice, because
the performance report shows the results for each transaction separately.

3. Right-click the transaction and click Add > SAP Batch Input Transaction.
Result
This opens the SAP Batch Input File Selection window.

4. Select a batch input transaction file that was recorded with the SAP GUI batch input recorder, and then click
Open.

What to do next

After creating elements, you can use the test editor to change values. You can also replace values with a dataset
variable or a reference. You can also place the batch input transaction inside a loop to make it repeat several times
during the test.

Splitting an SAP test

After you record a test, you can split it into smaller tests. Splitting tests enables you to create modular building blocks
of smaller tests and combine them to make bigger tests. The original test is unchanged. You can recombine these

building blocks in a schedule, including loops and conditions.
Before you begin

When reusing split tests in a schedule, you must ensure that the general test structure is consistent including SAP
session logon and logoff details. For example, if split test a contains the session logon details and split test ¢

contains the logoff transaction, you must place them in the correct order in the schedule user group.

SAP tests can be split only at the transaction level. When the test is executed in the schedule, it must start with a SAP

logon transaction and end with a SAP logoff transaction.
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1. In the Test Navigator, browse to the test and double-click it. The test opens.

2. Right-click a SAP transaction in the test, and select Split Test. The page that you click is the first page of the
new test.

3. In the New Test Names window, confirm the location of the split, optionally provide names and descriptions
for the split tests, and click Next.

4. In the Split Test window, examine the changes to be performed as a result of the split, and click Finish.

Exemple

For example, you could record a test that contains the following actions:

» Logging on to a server.
« Creating an entry on the server and removing the entry.
« Editing an entry, validating that the change occurred, and restoring the entry.

- Logging off of the server.

You then split the test into four parts: Logon, Create, Edit, and Logoff. You create a schedule that runs virtual users
selected from a dataset. Each virtual user runs the Logon test, performs various combinations of the Create and Edit

tests, and finally runs the Logoff test.

Viewing GUI data in the SAP Protocol Data view

The SAP Protocol Data view provides a graphical view of screens as they are displayed in the SAP GUI. In addition, it
provides a view of the SAP GUI object data. The data displayed in the SAP Protocol Data view is synchronized with the

test elements selected in the test editor.

To view test contents in the SAP Protocol Data view:

1. Open the test.
2. Click the SAP Protocol Data tab to activate the view.
Result

As shown in the example, the tab color changes to blue and the tabs for the Protocol Data view are displayed.

If you cannot locate the SAP Protocol Data tab, you can open this view by clicking Window > Show View >
Other > Test > SAP Protocol Data.

3. In the test editor, click the line corresponding to the transaction, screen or SAP event that you want to view.
4. In the SAP Protocol Data view, click the tab corresponding to the type of data or view of interest.
o Clicking Screen Capture opens a page that displays the corresponding screen as recorded in the SAP
GUI client. If a SAP event is selected, the corresponding field, button or GUI object is highlighted in red.
o Clicking Object Data opens a page that displays the SAP GUI object data for the corresponding object.
This data can be used to identify the object in a test element.
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Editing Citrix tests

After you record a test, you can edit it to include variable data (rather than the data that you recorded), verification

points (to confirm that the test runs as expected), transactions, conditional processing, and custom code.

Citrix test editor overview

With the test editor, you can inspect or customize a test that you recorded.

The test editor lists the window events for a test, in sequential order. New windows are displayed in bold. The
Windows™ operating system assigns each window an ID number. This number changes on each execution of the test,

but usually remains the same within the test, providing a means of identifying each window object.

Note: In some cases, the operating system recycles destroyed window IDs. The test recorder identifies these

properly by appending an extra number at the end of the window ID if necessary.

There are two main areas in the test editor window. The area on the left, Test Contents, displays the chronological
sequence of events in the test. The area on the right, Test Element Details, displays details about the currently
selected item (window, mouse event, key event, or screen capture) in the test hierarchy. The Common Options and
Citrix Options apply to the entire test.

Under the test is the Citrix session, which contains information about the connection and Citrix XenApp client options,
such as color depth and resolution.

Window events are the primary test elements in a Citrix test and represent graphic objects that are drawn by the Citrix
server, such as actual window, dialog boxes, menus, or tooltips. A Window event is recorded each time a window is
created, destroyed, moved, or resized. The first occurrence of a window, a create window event, is displayed in bold.
Window objects are typically identified by their title. If there is no window title, for example on menus or tooltips, then

the test editor uses the window ID number.

Inside windows, you see a list of events for the window, such as create window events, screen captures, mouse or key

board actions.

Some actions contain data that is highlighted. This highlighting indicates that the data contains one or both of the
following types of information:

- A dataset candidate: This is a value, usually one specified by the tester during recording, that the test
generator determined is likely to be replaced by values in a dataset. An example of a dataset candidate
is a string that you search for in a recorded test. The string is highlighted as a dataset candidate on the
assumption that, before running the test, you might want to associate the string with a dataset column
containing appropriate substitute values.

» References: These are values in a test, usually one of them in a response and the other in a subsequent
request, that the test generator determined needed to be associated in order to ensure correct test execution.
An example is a photograph returned to the browser by a test that searches an employee database. The test
generator automatically correlates employee names with photographs. Suppose that, before running the test
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with many virtual users, you replace the employee name searched for in the recorded test with names in a
dataset. Because the test correlates the data, each virtual user searches for a different employee, and the
server returns an appropriate photograph.

To see an illustration of color coding in performance tests, click Window > Preferences > Test > Test Editor, and then

click the Fonts and Colors tab.

Click Add to add elements to the selected test element. Alternatively, you can right-click a test element and select an

action from a menu.

The choices that you see depend on what you have selected. For example, inside a window, you can add a mouse
action or a text input. The Insert button works similarly. Use it to insert an element before the selected element. The

Remove button allows you to delete an item.

Note: Because Citrix performance tests rely on low level interaction with the server, manually changing test

elements is likely to break a recorded test.

Citrix synchronization overview

During the run of a Citrix session, the test uses window events or image recognition to ensure that the correct user

input actions are maintained on track with the application events coming from the Citrix server.

The synchronization mechanism enables the test to remain synchronized without relying only on the timing, which

could vary with the load on the Citrix server.

Synchronization is different from the function of verification points. Verification points check specified values

of the application, such as window synchronizations, and produce a test status: pass, fail, error, or inconclusive.
Synchronization is used for test execution and produces synchronization timeouts in the test log when the test fails
to recognize the server output.

Synchronization occurs on window events or through the recognition of a screen area that you specify.

» Window event synchronization is produced automatically by the Citrix server. When the test is run, the virtual
users send emulated user actions to the server, such as keyboard or mouse actions and the server responds
with window events such as create, activate, or destroy. The test waits for the expected window events
to occur before sending the next user actions to the server. The test uses window styles, and optionally,
locations, sizes, and window titles, to recognize windows.

- Image synchronization enables you to require additional recognition of screen area contents. The test can
synchronize on either a unique bitmap hashcode that is calculated from the image or on a text string retrieved
from the image through optical character recognition. In some applications, such as web browsers or word
processors, the actual window content changes more frequently then the window objects. In these cases, you
must manually add image synchronization to critical parts of the test during the recording so that the test can

synchronize with the window contents.
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During test execution, the test waits for the window event or the image recognition to synchronize the user actions
independently from the load on the server. If an expected window event fails to occur or an expected image is not
recognized, then the test produces a synchronization timeout that is reported in the test log. The test will attempt to
resume the execution at the next synchronization point.

The base timeout delay is specified in the Citrix test generation preferences; however, the actual delay varies with the

level of synchronization.

There are three levels of synchronization for window events and images that can be specified for each element in the
test editor:

- Conditional: This is the default behavior for main windows and dialog boxes. If the synchronization fails, the
test tries to continue and the synchronization timeout is logged in the Citrix performance report and the test
log.

» Mandatory: If the synchronization fails after a period that is three times the base timeout delay (by default),
the test exits with an error status and the connection with the Citrix server is closed. The test execution
continues to run until test results are finalized.

« Optional: Synchronization is not required but is logged in the test log. A timeout occurs after 1/10th of the

base timeout delay.

The default timeout values can be overridden for each synchronization element in the test editor. The test recorder
automatically sets the recommended synchronization level for window events depending on their nature:

« Main window create events are set to mandatory.
» Other window create events are set to conditional.
« Main window destroy events are set to conditional.
« Other window destroy events are set to optional.

 Image synchronizations are set to conditional.

Verifying application behavior

To check the expected behavior of the application during a Citrix performance test, you can add verification points at
strategic points in the test. You can use window verification points to check that a specific window opens during the

test, regardless of its contents, or you can use image synchronization to verify the displayed contents. During the run,
verification points produce a pass, fail, error, or inconclusive status in the Citrix Verification Point report. You can also

measure response times between two test elements.

Enabling Citrix window verification points

You can use verification points on window titles to check whether a window with a specific caption is created during
the test. Alternatively you can set a verification point on the synchronization criteria of the window to check whether
the window position, size, and style match the expected criteria, regardless of the contents. You can enable window

verification points for a specific test or generate them automatically by setting the test editor preferences.

Before you begin
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During the run, verification points produce a pass, fail, error, or inconclusive status in the Citrix Verification Point

report and in the test log.

Mandatory window synchronization events always have a verification point enabled. This setting causes the test to

have a fail status if the window does not synchronize.
About this task

To automatically enable verification points each time a window title changes during the recording, click Window >
Preferences > Test > Performance Test Generation > Citrix Test Generation, and select Verification point on every

window title change.

When verification points are disabled, you can enable verification points for a specific test:

1. Open the test.

2. In the test editor, select a session or a window event.
Your choice determines whether the verification point that you select is added to all windows in the test or to a
particular window in the test.

3. Right-click, and select Enable Window VPs.

To inspect or set your verification points, see Specifying window verification point criteria on page 312.

Note: Verification points on mandatory window synchronization elements cannot be disabled.

Enabling Citrix image synchronization verification points

You use verification points on image synchronization elements to check whether the contents of a screen area match
either an expected bitmap or a text string. You can add image synchronization verification points to a recorded image

synchronization element.

Before you begin
During the run, verification points produce a pass, fail, error, or inconclusive status in the Citrix Verification Point

report and in the test log.

To add a verification point to a recorded image synchronization element:

1. In the test editor, select an image synchronization test element that you added during the recording.
2. In the Test Element Details area, on the Synchronization page, select the verification method:

Choose from:
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- Select Bitmap hash code to verify the exact contents of the image.

> Select Optical character recognition to verify the recognized text in the captured screen area, and then

click Extract Text to obtain the text that is expected.

If the text extraction is unsuccessful, try changing the text recognition settings on the Options page.
However, accuracy of the recognized text is not essential. It is only important that the recognized text

is consistent each time the test runs for the verification to pass.

3. In the Test Element Details area, on the Settings page, select Enable verification point on synchronized

image.

Related reference

Citrix image synchronization details on page 1194

Citrix test generation preferences on page 1156
Related information

Citrix synchronization overview on page 309
Synchronizing tests with screen areas on page 317

Adding values to an image synchronization on page 319

Specifying window verification point criteria

Window verification points produce a fail status in the test execution report if they differ from the specified expected

criteria.

1. In the test editor, select a window event element.
You can set a verification point on any window event that creates, activates, or destroys a window that
contains a title.
2. Ensure that Enable verification point on synchronized window event is enabled for the selected window event
element.
3. In the test editor, select the window element that contains the window event.
4. Select the event synchronization criteria:
- X position and Y position: Select these options to specify that the top left corners of the window must
be located at the same coordinates.
> Width and Height: Select these options to specify that the window must be the same size.
- Title: Select this option to specify that the window must have the same title.
The window styles are a mandatory criteria and cannot be disabled.
5. If you selected Title, the Window title field shows the expected title.

If necessary, you can change the expected title in the Window title field.

You can use standard regular expressions to specify the expected title by selecting Use regular expressions.
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Results
Whenever the test runs with a verification point enabled on a window create, activate, or destroy event, a fail status
is reported in the test log if the criteria returned by the Citrix server for the window does not contain the expected

criteria.

Measuring response times

A response time measures the delay between a specified start event and a specified stop event. Typically, the start of
the measurement is set to a mouse or keyboard input. Similarly, the stop is set to a window create, window activate,
or window destroy event that is a response to the input event, or an image synchronization element that was recorded
with the test.

Before you begin

Response time measurements require a start element and a stop element. If either of these are missing, the response

time definition is displayed with an error or warning marker.
About this task

When the Response time for main windows option is selected in the Citrix Test Generation preferences, recorded
tests are generated with a response time measurement each time a main window is created. Generated
measurements start on the event that occurred immediately before a main window is created and stop when the main

window is created.

You can view all the response times of a test by selecting the Citrix test element in the test editor. Response times are

listed in the Response Time Definitions table where they can be edited, renamed, or deleted.

1. In the test editor Test Contents area, select a test element to start the response time measurement.

2. Press the Ctrl key, and select another test element to stop the response time measurement.
The two elements are selected in the test. The first element is the start of the response time measurement
and the second is the stop.

3. Right-click either the start or stop element, and click Create Response Time.

4. A Create Response Time window displays information about the new response time measurement. If the new
response time measurement replaces a previous one, click Yes. Otherwise, click OK.

5. Optional: To view all the response times that are defined for the test, click the test element in the test
navigator, and select the Citrix Response Time page.

Note: By default, response time measurements are included in the test results, even when the
synchronization fails with a timeout. To exclude failed synchronizations from the response time
results, clear the State option in the Response Time Definitions list.

Adding elements to a Citrix test

You can add a variety of elements to a test, such as user input actions, comments, loops or conditions.
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Editing a mouse action

You can edit mouse actions to manually specify how the mouse interacts with the Citrix server.
Before you begin

Mouse actions describe low-level user actions using the mouse such as mouse movements, clicks and double-
clicks, or drag-and-drop operations. Mouse actions can be added only inside window events or mouse sequences. For
example, a drag-and-drop operation is described as a mouse down action at a specific location, a sequence of mouse

move actions, and a mouse up action at the destination location.

In most cases, you will rely on the mouse actions that were recorded with the test. However, in some cases, you might
want to manually refactor mouse action sequences that are redundant or poorly recorded. For example, a double-click
event can sometimes be recorded as a mouse down, a mouse up, and a click. The result will be the same as a double

click action but the test will be more difficult to read.

Note: Because Citrix tests contain low level user input and synchronizations, minor changes can prevent the
test from working. When editing these tests, you must ensure that they are functionally identical.

1. Open the test in the test editor.
2. Expand a window action.
Choose from:
o To edit a mouse action, select the event in the Test Contents area.
> To create a new action at a specific location, select an action and click Insert and Citrix Mouse.
3. In the Test Element Details area, specify the type of event.
- Mouse move: This indicates that the mouse is moved from the current coordinates to the coordinates
specified in X Position and Y Position.
- Mouse click: This indicates that the mouse is clicked at the coordinates specified in X Position and Y
Position. In the Buttons area, select the button that is clicked.
- Mouse double click: This indicates that the mouse is double clicked at the coordinates specified in X
Position and Y Position. In the Buttons area, select the button that is double clicked.
> Mouse down: This indicates that a mouse button is pressed at the coordinates specified in X Position
and Y Position. In the Buttons area, select the button that is double clicked.
- Mouse up: This indicates that a mouse button is released at the coordinates specified in X Position
and Y Position. In the Buttons area, select the button that is double clicked.
4. You can specify the think time for the mouse action. This emulates the time spent by a user before initiating

the current event.

Viewing a mouse sequence

You can use mouse sequences to view complex mouse movements on the screen.

Before you begin
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Mouse sequences provide a graphical view of a series of mouse move events. This is particularly useful when a

large number of mouse move events are meaningful to the application. For example, drawing the letter e in a paint
program is represented as a mouse down event, a mouse sequence, and a mouse up. In the test editor, the sequence
graphically displays how the letter e is drawn in the application. If any screen captures were taken during the recorded

session, the sequence will be shown over the screen capture.

In most cases, you will rely on the mouse sequences that were recorded with the test. However, in some cases, you

might want to manually refactor mouse events into sequence.

Note: Because Citrix tests contain low level user input and synchronizations, minor changes can prevent the

test from working. When editing these tests, you must ensure that they are functionally identical.

1. Open the test in the test editor
2. Expand a window event and select the sequence in the Test Contents area.
3. In the Test Element Details area, you can view the following information:

Display mouse sequences for

This option specifies how you want to display previous, current, or all mouse sequences in the

current mouse sequence:
Current® sequence

Only the current mouse sequence is displayed in the test editor. This option is

selected by default.
Previous and current sequences
The current mouse sequence is displayed with any previous mouse sequences.
All sequences
All mouse sequences are displayed simultaneously.
Fit screen to visible area

Select this option to adjust the display of the mouse sequence to the available area in the test
editor. If disabled, the screen capture will be the actual size, which might require scrolling. This
option is enabled by default.

Screen capture area

This area represents the mouse movements on the screen. If a screen capture was recorded, it

is displayed in the background. Mouse sequences are displayed as specified.

Editing a keyboard action

You can edit keyboard actions to manually specify how the keyboard interacts with the Citrix server.

Before you begin
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Keyboard actions describe low level user actions using the keyboard such as text inputs or keyboard shortcuts.

Keyboard actions can be added only inside window events.

In most cases, you will rely on the keyboard actions that were recorded with the test. The recording tries to factor
multiple key presses into text input actions. However, in some cases, you might need to manually factor keyboard
actions that are redundant or poorly recorded. For example, in some cases, a text input string Hel | o can be recorded

as a press on the Shift key, a press on the H key, a release of the Shift key, a stroke of the E key, and finally a text

input of llo. By manually factoring keyboard actions into text inputs, you can handle text from dataset variables and

references.

Note: Because Citrix tests contain low level user input and synchronizations, minor changes can prevent the

test from working. When editing these tests, you must ensure that they are functionally identical.

1. Open the test in the test editor
2. Expand a window event.
Choose from:
o To edit a keyboard action, select the action in the Test Contents area.
o To create a new keyboard action at a specific location, select an action and click Insert and Citrix
Keyboard.

3. In the Test Element Details area, specify the type of action.
o Key Stroke: This indicates that a key is pressed and released.
- Key Down: This indicates that a key is pressed and held down.
> Key Up: This indicates that a pressed key is released.

The Key Code field displays the key code as interpreted by the Windows™ operating system and is translated
in the Character field. Use the modifiers to specify the whether the Control key, Shift key, or Alt key is also
pressed.

. You can manually enter any Unicode character that is not normally available through single keystrokes by

using the Character Edition area. Select the input field and enter the character on your keyboard.

The Key Code and Character fields display the corresponding character.

Note: The workbench uses some key combinations as keyboard shortcuts. Such combinations can be
intercepted and cause undesirable actions instead of displaying a particular character in the Character
field..

5. You can specify the think time for the keyboard event. This emulates the time spent by a user before initiating

the current event.

Editing a text input

You can edit text inputs to replace a sequence of keyboard events with text strings that are easier to handle as

dataset variables or references.

Before you begin
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Text inputs describe a series of low-level keyboard events as a single text string. Text inputs can be added only inside

window events.

In most cases, you will rely on the text inputs that were recorded with the test. The recording attempts to factor
multiple key presses into text input events. However, in some cases, you might need to manually factor keyboard
events that are redundant or poorly recorded. For example, in some cases, a text input string Hel | o can be recorded
as a press on the Shift key, a stroke of the H key, a release of the Shift key, a stroke of the E key, and finally a text
input of llo. By manually factoring keyboard actions into text inputs, you can handle text from dataset variables and
references.

Note: Because Citrix tests contain low level user input and synchronizations, minor changes can prevent the

test from working. When editing these tests, you must ensure that they are functionally identical.

1. Open the test in the test editor
2. Expand a window event.
Choose from:
> To edit a text input, select the action in the Test Contents area.
> To create a new text input at a specific location, select an action and click Insert and Citrix Text.
3. In the Test Element Details area, edit the text string that will be entered during the test.
4. You can specify the think time for the keyboard event. This emulates the time spent by a user before initiating

the current event.

Synchronizing tests with screen areas

Image synchronization enables Citrix performance tests to keep track of the contents of a screen area during replay

instead of focusing only on window events.
Before you begin

You can use image synchronization elements in a test to facilitate the test replay in applications that do not create or

modify many windows, but update the contents of the window regularly.

The contents of an image are processed as a value that is either a calculated bitmap hashcode or a text string
obtained by optical character recognition. During test execution, the test waits for the contents of a screen area to
match the expected image synchronization value before proceeding with the test. If the value is not matched during

the synchronization period, an image synchronization timeout is produced in the test log.

You can also add verification points to image synchronizations in the test editor. The verification point passes if the

synchronization succeeds and fails if a timeout occurs.

You insert image synchronizations during test recording.
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1. Start recording a Citrix performance test and record a sequence of user actions.

2. To add an image synchronization to the recorded test, in the Citrix Recorder Control window, click the Insert

image synchronization += button, select an area of the screen that will be used for synchronization, and then
click the Insert image synchronization button again.

3. Continue the recording. When you have completed the sequence of actions to be tested, end the Citrix session
cleanly and close the Citrix XenApp client.
Result
A progress window opens while the test is generated. On completion, the Recorder Control view displays the
message Test generation conpl et ed, the Test Navigator lists your test, and the test opens in the test editor.

4. In the test editor, select the Image synchronization element.

a. Set the synchronization state to Conditional, Mandatory or Optional. In most cases, because you are
explicitly requesting for a synchronization to occur, you should leave the synchronization state as

Conditional.

b. Specify one of two synchronization methods.

= Select Bitmap hash code if you want the synchronization to occur when the selected area
matches exactly the recorded image. A single pixel of difference will cause a synchronization
timeout.

= Select Optical character recognition if you want the synchronization to occur when a text
string is recognized in the selected area. Click Extract text to test the text recognition on the
recorded image. Note that for synchronization purposes the text recognition results must be
repeatable, not necessarily accurate.

Note: On Windows 2008, it is recommended to use the Bitmap hash code
synchronization method for a Citrix test.

You can click Extract text several times to make sure that the text recognition results are
repeatable. If the recognized text differs, click Options to change the Zoom factor or other
optical character recognition settings. You should not manually correct the recognized text.

You can click Add to specify multiple expected text strings, Use regular expression to specify a
text string as a regular expression, or Factorize to automatically generate a regular expression

from multiple expected text strings.

c. Specify whether you want to enable a verification point on the image synchronization. This enables the

test to produce a pass or fail status in the Citrix Verification Points report.

Manually adding an image synchronization

You can manually add an image synchronization element to an existing test to ensure that the test synchronizes
correctly or to add a verification point. To do this, you must create the image synchronization element, and then

perform a single run of the test to retrieve the image hash code or text detected by optical character recognition
(OCR).
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. Open the test in the test editor.

. Select the location where you want to create the image synchronization and click Insert and Citrix Image
Synchronization.
Result
This creates a new image synchronization element that is set to Conditional and has several values disabled.
This is because the test does not yet contain the image hash code or recognized text.

. In the screen capture area, move and resize the black rectangle to specify the zone of the image that will be
used for the synchronization.
Alternatively, you can specify the pixel values in X position, Y position, Width and Height.

. Select File > Save to save the test, and then, in the test navigator, right-click the test and select Run As >
Performance Test.
Result

This runs the test once to retrieve the image hash code or recognized text.

5. After running the test, right-click the test report, select Display Test Log, and then select the Events page.
6. Click the Events tab.

. Expand the top line of the Events hierarchy and navigate to the Image timeout element that was produced
during the run.

. Select the image timeout to open the Citrix Image Synchronization view.
If necessary, you can open the Citrix Image Synchronization view manually by selecting Window > Show View
> Other > Test > Citrix Image Synchronization. This view shows the actual screen area encountered during the

test and the expected image, as well as the corresponding hash codes or recognized text values.

. To add the actual hash code or recognized text to the image synchronization, click the Add value #=| button.

Adding values to an image synchronization

You can replace or add alternative values in an image synchronization element so that synchronization is not
restricted to the exact recorded image. Alternative values can also be useful in updating the test if the behavior of the

application changes.
Before you begin

If you are using optical character recognition, simply click Add in an image synchronization element in the test editor

to add an alternative value, and enter a new text string in the Expected text field.

If you are using the bitmap hash code synchronization or optical character recognition, you can use the following

method to add an alternative hash code or recognized text value.

To add an alternative value to an image synchronization:

1. After inserting an image synchronization element, run the test from the Run menu.

If possible, arrange for the alternative condition to occur before starting the run. The test should produce an

image synchronization timeout when the alternative condition is encountered.

2. In the Performance Test Runs view, right-click the test log container, and then select Display Test Log.

The test log opens in the editor with the Overview page selected.
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3. Click the Events tab.

4. Expand the top line of the Events hierarchy and navigate to the Image timeout element that was produced
during the run.

5. Select the image timeout to open the Citrix Image Synchronization view.
If necessary, you can open the Citrix Image Synchronization view manually by selecting Window > Show View
> Other > Test > Citrix Image Synchronization. When an image timeout is selected, this view shows the actual
screen area encountered during the test and the expected image, as well as the corresponding hash codes or
recognized text values.

6. You can either add the new hash code or recognized text value to the image synchronization as an alternative
value or you can replace the existing value with the new value.
Choose from:

> To add the actual hash code or recognized text as an alternative value, click the Add value += button.

> To replace the expected value with the new value, click the Replace value <= button.

Using custom code with a Citrix test

You can write custom Java™ code to expand the functions of HCL OneTest™ Performance.

Before you begin
Custom code requires knowledge of Java™ programming and the use of the HCL OneTest™ Performance API. See

Executing test execution with custom code on page for more information.

About this task
To use custom code for test synchronization:

1. In the test navigator, select the test element location to insert the custom code.

2. Click Insert > Custom Code.
Result
A custom code test element is created in the test.

3. On the Test Element Details page, click Generate Code to create a Java™ class based on the HCL OneTest™
Performance API.
You can click View Code to edit an existing class.

4. In the Java™ editor, add the import statement for Citrix tests: i nport
comibmrational.test.|t.execution.citrix.custonctode.*;

5. Complete the exec method to specify the function to create.

6. Save and close the Java™ class.

Exemple

The following example is custom code class that can be used as a starting point to evaluate the results of a
synchronization point. You can use this template to write a class that performs a synchronization when image
synchronization and window-event synchronization are not practical for your test.

import com.ibm.rational.test.lt.kernel.services.ITestExecutionServices;
import org.eclipse.hyades.test.common.event.VerdictEvent;
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import com.ibm.rational.test.lt.execution.citrix.customcode.CitrixCustomCodeImpl2;
import com.ibm.rational.test.lt.execution.citrix.customcode.ICitrixCustomCode2;

public String exec(ITestExecutionServices tes, String[] args) {
ICitrixCustomCode2 thisCode = new CitrixCustomCodeImpl2(tes);

// to get the last VP status
int verdict = thisCode.getlLastVerificationPointVerdict();
if (verdict != VerdictEvent.VERDICT_PASS) {

// this example reports a message but must be adapted to your specific needs
tes.getTestLogManager () .reportMessage("last VP status: " + thisCode.verdictEventToString(verdict));

}

return null;

}

The following example demonstrates how you can record a screen capture during playback for debugging purposes.

The screen capture is recorded in the test log and can be viewed in the Citrix image synchronization view.

import com.ibm.rational.test.lt.kernel.services.ITestExecutionServices;
import com.ibm.rational.test.lt.execution.citrix.customcode.x*;

public String exec(ITestExecutionServices tes, String[] args) {
ICitrixCustomCode2 thisCode = new CitrixCustomCodeImpl2(tes);

// To capture and log the full screen:
thisCode.logFullScreenCapture();

// To capture and log a part of the screen:
// thisCode.logPartialScreenCapture(x, y, width, height);

// To capture and log a part of the screen to a file:
// thisCode.savePartialScreenCapture(filename, x, y, width, height);

return null;

}

What to do next
After creating a custom code test, you can run the test as usual. If you need to debug the test, you can use the

monitoring panel to insert breakpoints or to interact with the Citrix environment during execution.

Related information

Debugging Citrix tests on page 628

Editing service tests

After you record a service test, you can edit the calls and message returns to include variable data (rather than the
data that you recorded). You can add verification points (to confirm that the test runs as expected), transactions,

conditional processing, and custom code.
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Web service test editor overview

With the test editor, you can inspect or customize a test that you recorded.
The test editor lists the web service call elements for a test, in sequential order.

There are two main areas in the test editor window. The area on the left, Test Contents, displays the chronological
sequence of test elements in the test. The area on the right, Test Element Details, displays details about the currently

selected item (test, call, message return, or verification point) in the test hierarchy.

Window events are the primary test elements in a Citrix test and represent graphic objects that are drawn by the Citrix
server, such as actual window, dialog boxes, menus, or tooltips. A Window event is recorded each time a window is
created, destroyed, moved, or resized. The first occurrence of a window, a create window event, is displayed in bold.
Window objects are typically identified by their title. If there is no window title, for example on menus or tooltips, then
the test editor uses the window ID number.

A service request node name can be updated automatically or you can use custom code or dataset to supply different
names. To apply a dataset to a node name, in the test editor, select the node name. In the Request Details area of the

test editor, clear the Update node name automatically, select the name and substitute it with dataset.

Web service calls can contain web service message return elements, which display the results of the web service call.
The XML message content can be displayed either in Form, Tree or Source view. Each of these views displays the

same message content in different forms:

« Form view provides a simplified view of the call elements focused on editing the values of the XML message
content.

- Tree view provides a hierarchical view of the XML structure, including elements, namespaces, and the
associated values. Tree view also allows you to manipulate XML fragments.

« Source view displays the XML contents of a web service or XML call or the plain text contents of a simple text

message.

Message return elements can contain verification point elements that check that the actual return results match

expected criteria.

Some actions contain data that is highlighted. This highlighting indicates that the data can be used as a dataset

candidate or as a reference. See Data correlation overview on page for more information.

In service calls and message returns, you can use datasets and data correlation on values contained in the XML or on
XML fragments. To use data correlation on XML fragments, switch to the Tree view, right-click the XML element and
select Create XML Fragment.

To view or modify the color coding in web service tests, click Window > Preferences > Test > Test Editor, and then
click the Fonts and Colors tab.

Click Add to add elements to the selected test element. Alternatively, you can right-click a test element and select an

action from a menu.
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The choices that you see depend on what you have selected. For example, inside a web service call, you can add
a web service message return. The Insert button works similarly. Use it to insert an element before the selected
element. The Remove button allows you to delete an item.

Verifying application behavior

To check the expected behavior of the application during a service test, you can add verification points after a
message return. During the run, verification points produce a pass, fail, error, or inconclusive status in the Web Service
Verification Point report.

Adding equal verification points

Equal verification points enable you to check that the contents returned by a service match exactly the contents
specified in the verification point.

About this task
When you add verification points, the results from a service response are compared with the expected data specified
in the verification point test element. Equal or contain verification points enable you to directly compare the XML

document that the service returns.

- Contain verification points return a Pass status when the response XML document contains the expected
XML data.

- Equal verification points return a Pass status when the response XML document matches exactly the
expected XML data.

Complex service requests or verification points might have empty XML elements that are not needed in a test script.
When playing back the test, you can skip such empty XML elements. In Window > Preferences > Test > Test editor >
Service test ensure that the Display the 'Skip if empty' column in XML tree viewer check box is selected. This option
displays a Skip if empty column in the tree view of the request. You can then choose the XML elements to skip.

1. Open the test editor, and right click a response element and select Add > Equal Verification Point.
2. Select the verification point, and in the Test Element Details area of the test editor, type a name for the
verification point.
3. Select the verification options:
> Select Test using XML namespaces to perform the verification on the qualified structure of the XML
document, including the namespace tagging, instead of the simple name. Disable this option to check
only the simple name of the element and the final return value.
- Select Text XML text nodes to include the content of text elements in the verification.
> Select Text XML attributes to include the content of attributes in the verification.

4. On the Message page, select the Form, Tree, or Source view to specify the expected XML data.

For an equal verification point, the expected XML data contains the XML document from the response test

element. If necessary, you can edit the expected XML data.
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You can specify standard Java™ regular expressions in the Tree view. To do this, select the Regular
expression column on the line of an attribute or text value and type the regular expression in the Value
column. For example, the following regular expression checks for a correctly formatted email address: /([ a-

ZA-Z0-9_\.\-1) A\ @([a-zA-Z0-9\-1) +\.) +([ a- zA- Z0- 9] { 2, 4} ) +$/

When using regular expressions, the number of XML nodes or XML fragments in the verification point must
match the quantity of expected nodes.

What to do next
You can enable or disable each verification point by right-clicking the verification point in the test editor and clicking
Enable or Disable.

Adding contain verification points

With contain verification points, you can check that one or several elements of the XML content returned by a service
match the XML fragment that is specified in the verification point.

About this task
When you add verification points, the results from a service response are compared with the expected content that is
specified in the verification point test element. Equal or contain verification points enable you to directly compare the

XML contents that the service returns.

« Contain verification points return a Pass status when the response XML contents contain the expected XML
fragment.

- Equal verification points return a Pass status when the response XML contents match exactly the entire
expected XML content.

Complex service requests or verification points might have empty XML elements that are not needed in a test script.
When playing back the test, you can skip such empty XML elements. In Window > Preferences > Test > Test editor >
Service test ensure that the Display the 'Skip if empty' column in XML tree viewer check box is selected. This option

displays a Skip if empty column in the tree view of the request. You can then choose the XML elements to skip.

1. Open the test editor, and select a service response element.

2. In the Test Element Details area, click the Message tab and select the Form or Tree view.

3. Expand the envelope ling, right click the element that you want to check, and then click Create Contain
Verification Point. This action creates a contain verification point that includes the XML element from the
recorded response.

Note: You can also create a contain verification point with the message response by selecting the
message response in the Test Contents pane and clicking Add > Contain Verification Point. However,
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Pw the result is effectively the same as an equal verification point because the verification point contains

the entire XML content of the message response.

4. Select the verification point, and in the Test Element Details pane, type a name for the verification point.
5. Select the verification options:
> Select the Test using XML namespaces check box to perform the verification on the qualified

structure of the XML document, including the namespace tagging, instead of the simple name. Disable

this option to check only the simple name of the element and the final return value.
- Select the Test XML text nodes check box to include the content of text elements in the verification.
o Select the Test XML attributes check box to include the content of attributes in the verification.
6. If necessary, select the Form, Tree, or Source views to edit the expected XML fragment.

For an equal verification point, the expected XML data contains the XML document from the response test

element. If necessary, you can edit the expected XML data.

You can specify standard Java™ regular expressions in the Tree view. Select the Regular expression column
on the line of an attribute or text value and type the regular expression in the Value column. For example, the
following regular expression checks for a correctly formatted email address: /~([a-zA-20-9_\.\-]) N\ @ ([ a- zA-

Z0-9\-1) 4\ . ) +([ a- zA- Z0- 9] { 2, 4} ) +$/

When using regular expressions, the number of XML nodes or XML fragments in the verification point
must match the number of expected nodes. The verification point returns a Pass status when all regular

expressions in the XML fragment are matched.

Exemple

You can use a contain verification point to check that the message response contains only a specific element with a

specific value. For example, consider the following message response:

<s:Envelope
xmlns:a="http://www.w3.0rg/2005/08/addressing"
xmlns:s="http://www.w3.0rg/2003/05/soap-envelope'">
<s:Header>
<a:Action
s:mustUnderstand="1">http://www.w3.0rg/2005/08/addressing/soap/fault</a:Action>
<a:RelatesTo>uuid:ed9bc447-d739-452f-989d-cd48344d494a</a:RelatesTo>
</s:Header>
<s:Body>
<s:Fault>
<s:Code>
<s:Value>s:Sender</s:Value>
<s:Subcode>
<s:Value
xmlns:a="http://schemas.xmlsoap.org/ws/2005/02/sc">a:BadContextToken</s:Value>
</s:Subcode>
</s:Code>
<s:Reason>
<s:Text
xml:lang="en-US">The message could not be processed. This is most likely because the action
&apos;http://Samples.ICalculator/Add&apos; is incorrect or because the message contains an invalid or
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expired security context token or because there is a mismatch between bindings. The security context
token would be dinvalid if the service aborted the channel due to inactivity. To prevent the service
from aborting idle sessions prematurely increase the Receive timeout on the service endpoint&apos;s
binding.</s:Text>
</s:Reason>
<s:Node>http://www.w3.0rg/1999/x1link</s:Node>
<s:Role>http://www.w3.0rg/1999/x1link</s:Role>
<s:Detail
xmlns:tns0="http://schemas.com/2003/10/Serialization/"
xmlns:tns15="http://Samples.Windows"
tnsO@:Id="+d"
tnsO:Ref="+idref">
<tnsl5:GetCallerIdentityResponse>
<tnsl5:GetCallerIdentityResult>str</tnsl5:GetCallerIdentityResult>
</tnsl5:GetCallerIdentityResponse>
</s:Detail>
</s:Fault>
</s:Body>
</s:Envelope>

To check for the subcode element, the expected content of the contain verification point is the following XML
fragment:

<s:Subcode
xmlns:a="http://www.w3.0rg/2005/08/addressing"
xmlns:s="http://www.w3.0rg/2003/05/soap-envelope'">
<s:Value

xmlns:a="http://schemas.xmlsoap.org/ws/2005/02/sc">a:BadContextToken</s:Value>
</s:Subcode>

By default, the contain verification point checks whether an element named Subcode contains one element named

val ue. You can use the following options:

- Test using XML namespaces: With this option, the verification point checks whether an element named
"http: // www. wW3. or g/ 2003/ 05/ soap- envel ope": SubCode contains one element named "ht t p: / / www. w3. or g/
2003/ 05/ soap- envel ope": Val ue.

« Test XML text node: With this option, the verification point also checks whether the element named val ue
contains the text a: BadCont ext Token.

« Test XML attributes: With this option, the verification point also checks that the attributes match the expected
XML fragment. In this example, the Test XML attributes option is not necessary because the subcode element

does not have any attributes.

To check that the Det ai I element properly returns a specific value for Get cal | er I denti t yResul t, the expected content
of the contain verification point is the following XML fragment:

<s:Detail
xmlns:a="http://www.w3.0rg/2005/08/addressing"
xmlns:s="http://www.w3.0rg/2003/05/soap-envelope"
xmlns:tns®@="http://schemas.com/2003/10/Serialization/"
xmlns:tnsl5="http://Samples.Windows"
tns0:Id="regular_expression"
tnsO@:Ref="1idref">
<tnsl15:GetCallerIdentityResponse>
<tnsl5:GetCallerIdentityResult>IdentityValue</tnsl5:GetCallerIdentityResult>
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</tnsl5:GetCallerIdentityResponse>
</s:Detail>

You can use the following options:

« Test XML text node: With this option, the verification point also checks whether the element named
Get Cal | erl dentityResul t contains the text | dentityval ue.

- Test XML attributes: With this option, the verification point also checks that the attribute | d referred to by
tns0: 1 d has the expected value. You can specify a regular expression for this value by using the Regular
expression column in the Tree view of the verification point. For example, t ns0: 1 d="[ a- zA- ] " checks that the
value does not contains numbers.

What to do next

You can enable or disable each verification point by right-clicking the verification point in the test editor and clicking
Enable or Disable.

Adding Xpath query verification points

With service query verification points, you can check that a response matches an Xpath query.
Before you begin

When you add verification points, the results from a service response are compared with the expected data that is
specified in the verification point test element. With query verification points, you can check that the number of nodes

returned by an XML Path language query matches the expected number of nodes specified in the verification point.
Refer to the XPath specification for details on expressing an XPath query: http://www.w3.org/TR/xpath.

You can use the test editor to create or edit verification points.

1. Open the test editor, and select a web service response element.

2. Click Add, and select Query verification point.

3. In the Test Element Details area of the test editor, type a name for the verification point.

4. Type a valid XPath expression or click Build Expression to open the XPath Expression Builder.
The XPath Expression Builder helps you build and evaluate XPath expressions based on the recorded
contents of the response.

5. Specify a Comparison operator (=, >, or <), and the expected number of nodes that the query should return.
Click Evaluate to update the Expected Count with the actual result based on the recorded contents of the
response.

What to do next
You can enable or disable each verification point by right-clicking the verification point in the test editor and clicking
Enable or Disable.
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Note: Because XPath expressions require that the qualified name have a prefix, XPath expressions will return

null for the default namespace declared with xmins.

Adding attachment verification points

Service attachment verification points enable you to check that the attachment of a service response matches the

specified criteria.
Before you begin

When you add verification points, the results from a service response are compared with the expected data that are
specified in the verification point test element. Attachment verification points enable you to verify that an expected

attachment is delivered with the response.

Attachment verification points return a Pass status when all the criteria of an attachment match the expected criteria
specified in the verification point test element. If any of the criteria do not match, the verification point returns a Fail

status.
You can use the test editor to create or edit verification points.

To add attachment verification points to a performance test:

1. Open the test editor and select a service response element.
2. Click Add and select Attachment Verification Point.
3. In the Test Element Details area of the test editor, type a name for the verification point, and specify the
criteria to be verified. All criteria must match in order for the verification point to pass.
a. In the case of multiple attachments, set the Index of attachments to the index number of the
attachment to be checked. Type 1 if there is only one attachment in the response.
b. Specify the expected size in bytes of the attachment.
c. Specify the MIME type and encoding of the attachment.

What to do next
You can enable or disable each verification point by clicking Enable verification point in the test editor.

Adding Text verification points

To check the text content that is returned by the service response, you can add a text verification point in the service
test. When you add the verification point, you can check whether the text matches equally with the response or
whether the response contains the text.

1. Open the Test editor, right-click a response element and select Add > Text Verification Point.

2. In Verification Point Name, specify a name for the verification point.

3. In the Operator field, select the basis of comparison between the text to be verified and the response content.
4. To search between the offset values, select From Offset and To Offset check boxes and specify the offset

values.
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5. To search between two string values, select From String and To String check boxes and specify the strings.

You must also specify the number where the strings occurred.
For example, if there are four occurrences of 'My Text' in the content and you want to verify the text that is
between second and third occurrence, you should specify 2 and 3 in From String and To String respectively.

6. To do a case-sensitive match, select the Case sensitive check box.
7. To ignore carriage return/ line feed in the response, select the Ignore CL/LF when matching check box.

8. Save the test and run it.

Results
The Service Verification Point Report shows the number of Text Verification Points that passed or failed.

Adding properties verification points to a test response

You can add verification points for the properties in a service test so that these properties in the test response are

verified and validated when you play back the test.

Before you begin
You must have recorded or created a service test using the test editor.

About this task

When you add verification points, results from a service response are compared with the expected data specified as
the verification point test element. You can add the verification point for the properties to an existing test response
when the test is manually created or recorded. After you add the verification point for the properties to a test

response, you can verify the selected response properties during the test run.

1. Identify the service test from Test Navigator and double-click the service test to open it in the test editor.
2. Select a service response for a service request from the service test.
3. Right-click the service response, click Add > Properties Verification Point.

Result

The Properties Verification Point is added based on the existing properties of the service response.
Note: You can add multiple verification points for the properties, if required.

4. Perform any of the following on the verification points for the properties in the Properties Verification Point

Details pane.
To Do... Do This...
To add a new property and its value Click Add.
To edit the value of an existing property Click Edit.
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To Do... Do This...

To remove the property that you do not want to verify | Click Remove.

during the test run

Note: You can remove multiple properties in
a group at the same time.

5. Select or clear the Apply And Operator check box based on the requirement as follows:
> To verify all the listed properties, select the Apply And Operator check box.
» To verify one of the listed properties, clear the Apply And Operator check box.
6. Optionally, you can substitute the value of one or more properties in the verification point by using a test
variable, data set, custom java code, or built-in variables.
7. Verify all the verification points for the properties that you entered, and then click Save.

Results

The verification points that you added for the response properties are added to the service test.

What to do next
You can run the test and after the test run, you can view and analyze the properties verification point details from

the following page and reports:

« Verdict List pane in the Test Log page. Click any of the verification point from the list and view the details.

» Response Properties Verification Points tab in the Service Verification Point Report. Click the Response
Properties Verification Points tab and view the verification point details.

- Verification points verdicts pane from the Functional Test report page. Click any of the verdict status to verify
the expected value and actual value of the verification point for the properties.

Related reference

Web Service Verification Points report on page 814

Adding XSD verification points
XSD verification points enable you to check that the XML content of a service response comply with the rules defined
in an XML Schema Definition (XSD) file.

Before you begin

When you add verification points, the results from a service response are compared with the expected data that are
specified in the verification point test element. XSD verification points return a Pass status when the XML contents of
the response are compliant with the associated XSD or a Web Service Description Language (WSDL) file that contains

XSD information.
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If you add multiple XSD files to the verification, then the XML content of the response must comply with all of the XSD
files.

You can use the test editor to create or edit verification points.

To add an XSD verification point to a test:

1. Open the test editor and select a service response element.

2. Click Add and select XSD Verification Point.

3. In the Test Element Details area of the test editor, type a name for the verification point.

4. Click Add XSD to add a an XSD file to the validation list or Add WSDL to add a WSDL that contains XSD
information.
Click Open to display the XSD or WSDL contents.

What to do next
You can enable or disable each verification point by right-clicking the verification point in the test editor and clicking

Enable or Disable.

Working with Server Name Indication (SNI) recordings

If you have recorded against a server that supports Server Name Indication (SNI), an extension of the TLS protocol,
the recording session file displays t r ue for the SNI Extension field. There might be a need for you to access both
SNI and non-SNI applications from the same server. To run the same test without using the SNI extension, you can
manually change the value to f al se.

About this task
Packets }:9 - 'L:k::' Packet Details
Packet StatTime  EndTime  ~| Proxy Open Secured
2 Proxy connection type 0 00:00069  00:00069 5| Recorder ® HTTP Proxy Recorder
IEuaLocal addresses 00:00.308 00:00.308 .
& Proxy starts 00:00.210 00:00.210 Connection Id: z
4 Proxy initiates connection 1 00:06.271 00:06.271 Parent ConnectionId: 1
L?Proxy opens connection 1 00:06.271 00:06.611 Connection Type Id: 0
] = 4 4
< Proxy opens secured connection 2 based on 1 00:06.758 00:07.357 Server Host: tiles.cervices.mozilla.cam
|§Prm<}r close connection 2 00:07.551 00:07.551
= Proxy close connection 1 00:07.551 00:07.551 Server Port: 443
tlg.aprox)r initiates connection 3 00:10.195 00:10.195 Client Host: 127.00.1
9 Proxy opens connection 3 00:10.195 00:10.259 Client Port: 54790
L] i . .
= Proxy opens secured connection 4 based on 3 00:10.268 00:10.408 Cinher Suites: 55L_ECDHE_RSA_WITH_AES 128 GCM_SHAZ56
=P | tion 4 00:10.703 00:10.703 ’
roxy close connection 10, 10,
P Proxy close connection 3 0010703 00:10.703 55L Pratocols: TL5v1.2
Elg.aproxy initiates connection 5 00:10.788 00:10.788 HTTP Version Protocol: |http/1.1
9 Proxy opens connection 5 00:10.788 00:11.066 - | | SMI Extension: true

Overview | Content

The Server Access Configurations resource of the test script also have SSL entries. Each SSL entry displays which
TLS version and Cipher value was used. To edit multiple SSL entries, select them and in the Detail area, right-click the

entries and click Edit multiple SSLs.
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Adding elements to a socket test

A socket test provides the flexibility to add close, send, and receive elements to the test.

Adding a service request

You can use service request elements in tests to send a request to the service.
About this task

Complex service requests or verification points might have empty XML elements that are not needed in a test script.
When playing back the test, you can skip such empty XML elements. In Window > Preferences > Test > Test editor >
Service test ensure that the Display the 'Skip if empty' column in XML tree viewer check box is selected. This option
displays a Skip if empty column in the tree view of the request. You can then choose the XML elements to skip.

1. Open the test in the test editor, and select the first element in the test.

2. Click Add and select a service request.

3. If you selected WSDL service request, select one or several WSDL files in your workspace for the web service
that you want to test and click Next.
If necessary, you can import a WSDL file into the workspace with the Add button.

4. Select either HTTP, JMS, or WebSphere MQ depending on the transport protocol used by the web service, and
provide the correct transport protocol configuration to perform the call.
You can create a New transport configuration or reuse an existing one.

5. Click Finish.
Result
This creates the web service request in the test editor.

6. On the Message page of the request, select the Form, Tree, or Source views to edit the service request
contents.

7. If any resource files are to be attached to the request, select the Attachment tab. Use Add, Remove, or Edit to
specify the resources that are to be attached to the request.

8. If the service uses encryption, signature or other security protocols, select the Security for Request and
Security for Response pages to configure the security for this particular service request or to open the WSDL

security editor.

What to do next
After creating elements, you can use the test editor to edit service requests. You can create a service response
element to test the performance and behavior of the service. You can also replace some content values with dataset

variables or a references.

Updating a service response from the service

While you are developing a service test, you can send a request from the test editor to record or update the response

element.

Before you begin
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Service response elements are children of service request elements. Service tests use response elements to measure
the response time between a call and the corresponding response. Response elements can also contain verification

points.

You can click Update Response in the request element to complete one of the following actions:

« Record a response from the service: This method sends the request and records the actual response from the
service. For services that use the IBM® WebSphere® MQ or JMS transport protocols, multiple responses can
be recorded.

« Update the current response content: If a response exists, its contents are replaced. If multiple responses are
received, the number and order of the responses are updated.

! Important: After updating the response content, data correlation or verification points that referred to

replaced content might no longer work.

You can use the test editor to create or edit response elements in a service test. There are three methods of adding a

service response:

« Generate a response from Web Services Description Language (WSDL): If the service uses WSDL, then the
response is created with the content structure that the WSDL specifies.

» Add a text response: In this response type, you specify free formatted content for the response.

» Record a response from the service: This method sends the request and records the actual response from the

service.

WebSphere® MQ and JMS requests can contain multiple response elements.

To add a response element to a service test:

1. Open the test in the test editor, and select a service request element.
2. On the Test Element Details page, click Update Response.
Alternatively, right-click the service request element, and click Add > Response from Request.
Result
This action performs the service request. If the request is valid, the Update Response window opens and
displays the response data.
3. In the Return Preview window, review the content of the response to ensure that it is correct.
For the WebSphere® MQ and JMS protocols, if multiple responses are received, then click the arrows to view
each response.
a. Click the Message tab to view the contents of the response in the Form, Tree or Source view.
b. Click the Attachment tab to view any resource files that were attached to the response.
c. Click the Response Properties tab to view the properties of the response.
4. To use the received response in the test, click Update Test.
This creates the response elements as a child of the request element or updates the existing response

elements with the new data.
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What to do next
After creating or updating response elements, you can create verification points on the response contents to test the

behavior of the service.

Related information

Manually adding a response element on page 334

Verifying application behavior on page 323

Manually adding a response element

You can add service response elements to specify the received content of a service request. You can use the test

editor to create or edit response elements in an existing service test.

Before you begin

Service response elements are children of service request elements. Service tests use response elements to measure
the response time between a call and the corresponding response. Response elements can also contain verification
points. IBM® WebSphere® MQ and JMS requests can contain multiple response elements.

Depending on the type of request, you can manually create several types of response elements:

« Response from Web Services Description Language (WSDL): For web services, this response type uses the
WSDL file to create the specified XML structure of the response.

« XML response: This response type creates an empty response element in which you must manually create
the expected XML structure. You can use an XML Schema Definition (XSD) document from the XSD catalog to

assist you.
- Text response: This response type creates an empty response element, which can contain freely formatted

text.

Alternatively, you can automatically create and update response content by recording the actual response content

that the service returns. See Updating a service response from the service on page 332 for more information.

To add a response element to a service test:

1. Open the test in the test editor, and select a service request element.
2. Create one of these elements:
Choose from:
> For web service requests, click Add > Response from WSDL.
o If the expected response contains XML content, click Add > XML Response.
o If the expected response contains plain text, click Add > Text Response.

Result
This action creates the corresponding response element in the test. If the request uses the WebSphere® MQ

or JMS format, then you can create multiple responses.
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3. Edit the message content of the response element to reflect to actual content that the service returns.
a. Click the Message tab to view the contents of the response in the Form, Tree or Source view.
b. Click the Attachment tab to view any resource files that were attached to the response.
c. Click the Response Properties tab to view the properties of the response.

What to do next
After creating a message return, you can create verification points on the contents to test the behavior of the service.

Related information

Updating a service response from the service on page 332

Verifying application behavior on page 323

Managing JMS/MQ connections in a service test

When you run a service test that includes JMS or MQ protocol, the socket connections are created and closed in the
background. When you include multiple tests in a compound test or a A schedule, in this context, is used to refer

to both VU Schedule and Rate Schedule., multiple connections are created and closed. Starting from 9.2, when you
run service tests in a schedule, you can select a pooling strategy for these JMS/MQ connections so that when the

connections are created, they do not close and are reused subsequently for the other JMS/MQ calls, if required.

About this task

You can set the scope of JMS/MQ connections to a test, compound test, or schedule. When you set the scope to
test, existing behavior comes into play wherein duplicate connections could be created and closed. When you set the
scope to a compound test or a schedule, the connections are reused for JMS/MQ calls within a compound test or a

schedule.

1. In the Test Navigator, browse to the schedule and double-click it. The schedule is displayed.
2. Select a schedule. In the VU Schedule Details area, click the Advanced tab and under Protocol-specific
options, click Edit Options.
3. In JMS/MQ connections scope, select the scope of the connections.
4. Use the following options to control the underlying MQ Connection Manager to create only the specified
number of connections. These options are generally used by the MQ expert:
a. In Maximum quantity of connections, specify a number to ensure that a certain number of
connections are open at a time only for MQ Java.
b. In Maximum quantity of unused connections, specify the maximum number of connections that
should be unused among the open connections.
c. In Connection timeout (ms), specify a time after which there is no attempt to establish the connection.

Results
When you run a schedule, the JMS/MQ connections are reused.
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Editing WSDL security profiles

To ensure that your service test uses the correct security protocols to access a SOAP-based service, you must specify
a security profile for the (Web Service Description Language) WSDL file. After a security profile is set up, it can be

reused in multiple web service calls.

WSDL security editor overview

With the WSDL security editor you can create the SOAP algorithm stacks that are associated with a web service
operation. Algorithm stacks contain digital certificate information and the security algorithms that are applied to

messages to perform secure communication with a web service.

After you create an algorithm stack, you associate it with an operation that is specified in the Web Services
Description Language (WSDL) file of the web service. Algorithm stacks remain available in the workspace and you
can reuse them with other WSDL files. You can also edit a test to make the same web service call several times with

different security configurations.

You use the WSDL security editor to create and edit security configurations. The WSDL security editor contains two

pages that correspond to the steps of setting up a security configuration:

« Describing a security stack

« Associating a security stack with each WSDL operation

Algorithm stacks

Algorithm stacks contain one or several algorithm blocks that are arranged in a sequence of steps. Each algorithm
block modifies or transforms the message content. Algorithm blocks can add timestamps to, add tokens to, encrypt,

or sign messages.

Use the Algorithm Stacks page of the WSDL security editor to create stacks for service requests and responses.
When a message is sent or received, each algorithm block in the stack is executed in the specified order. For example,
you can define a request stack for outgoing requests that adds a timestamp, signs, and then encrypts the message
content, and you can define a response stack that decrypts incoming responses. You can create as many algorithms

as your application requires.

You can edit algorithm blocks and move them up and down in the stack. Encryption and signature blocks can use
keystores for digital certificates. Some algorithm blocks display messages that help you enter correct information. If
the contents of the algorithm block are invalid, an error icon is displayed.

Raw transaction data view

When a stack is associated with a service request or response, viewing the results of each transformation step that
is applied to the XML message content can be useful. You can use the Raw Transaction Data view to look at the

message content before and after each algorithm in the stack.
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Digital certificate keystores

You can add digital certificate keystores to a security stack to use with encryption or signature algorithms. Keystores
must be declared with their associated passwords before the algorithms that use them. Digital certificates are
contained in Java™ keystore files (KS, JKS, JCEKS, PKCS12, and PEM) that must be located in your workspace.

Associating stacks with WSDL operations

Use the Algorithms by WSDL operations page of the WSDL security editor to associate a security algorithm stack
with each web service call and message return in the WSDL file.

Creating security profiles for WSDL files

You can create SOAP security profiles for the web service calls or message returns that require message encryption,
signature or other advanced security algorithms.

Before you begin
You must have a Web Services Description Language (WSDL) file in your workspace.

If the security profile uses digital certificates for encrypting or signing requests or responses, you must have the
corresponding keystore files (KS, JKS, JKECS, PKCS12, or PEM) in your workspace.

About this task

If the WSDL is simple and you want to check its security, in the Request Stack tab of the test editor, click Override
Stack > Tools > Analyze Security from Pasted Content. Paste the SOAP XML message and click Next. The next page

shows the different security algorithms used in the XML. Click Finish to add the security algorithms to the editor.

Note: When you add a secured SOAP XML message in Message > Source tab of the test editor, certain
security related warnings are displayed in the Error Message view. If you are aware of the secured SOAP
XML message and do not want to view the warnings, click Window > Preferences > Generic Service Client >
Message Edition and select the Analyze pasted SOAP content check box.

If the WSDL uses WS-Policy, you must configure security as follows:

1. In the test navigator or project explorer, right-click the WSDL file and select Edit WSDL Security.
Result
The WSDL security editor is displayed.

2. Click the Security Algorithms tab.
Security profiles are described by adding elements to a stack. When a service request is sent or a response
is received, each element in the stack is applied to the message in a specified order. If necessary, create one
security profile for outgoing requests and one for incoming responses.

3. In the Security Algorithms area, click Add to create a new algorithm stack, and click Rename to change the
default name.

4. In the Algorithm Stack Details area, click Add to add a new algorithm element to the stack.
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You can add time stamps, username tokens, encryption, or signatures.

5. Edit each element in the stack according to the requirements of the web service.

You can apply encryption and signature stack elements to portions of the web service call or message return
document by specifying an Xpath query in User Xpath part selection. For example, you can encrypt one XML
element with one encryption stack element, and another element with another stack element. You can use the
Web Service Protocol Data view to help identify the correct Xpath query for this option.

You can check whether the security stack is valid by clicking Tools > Validate Selected Algorithm.

6. When all the stack elements are complete, ensure that the execution order is correct.
If necessary, use the Up and Down buttons to change the order of elements in the stack.
7. Repeat steps 4 through 7 to create as many algorithms as are required for security profile.
8. Click the Algorithms by WSDL Operations tab.
This page enables you to associate a security profile with each request or response operation in the WSDL.
9. In the WSDL Contents column, select a service request or response.
10. In the Algorithm Stack column, select a security profile from the list.
If necessary, click << to open the stack on the Security Algorithms page.

Results
After saving the security profile, the Web Service Protocol Data view displays the effect of the security profile on the
XML data of the web service.

Related reference

WSDL security editor reference on page 1205

Related information

Using a security policy on page 338

Adding WS-Addressing to a security configuration on page 350

Implementing a custom security algorithm on page 347

Using a security policy

The WS-Policy specification enables web services to use XML to publish their security policies either as part of the
Web Services Description Language (WSDL) file (compliant with the WS-PolicyAttachment specification) or as a
separate XML document. With the WSDL Security Editor, you can create a security profile that uses a policy that
complies with the WS-Policy specification.

Before you begin
Before creating a security configuration, you must have a WSDL file in your workspace.

If the security policy uses digital certificates for encrypting or signing requests or responses, you must have the
corresponding keystore files (KS, JKS, JKECS, PKCS12, or PEM) in your workspace.
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When you import a WSDL that contains a policy (with WS-PolicyAttachment), a security profile is automatically
generated for each operation in the WSDL security editor.

1. In the test navigator or project explorer, right-click the WSDL file, and select Configure WSDL Security.
Result
This opens the WSDL security editor.
2. Click the Security Algorithms tab.
Security profiles are described by adding elements to a stack. When a service request is sent or a response is
received, each element in the stack is applied to the message in the specified order.
3. In the Security Algorithms area, click Add to create a profile, and click Rename to change the default name.
4. In the Algorithm Stack Details area, click Add > WS-Policy to add the WS-Policy element to the stack.
You can also add time stamps, user-name tokens, encryption, or signatures.
5. If the policy is included in the WSDL file, click Use policy included in WSDL (WS-PolicyAttachment), and edit
the WS-Policy settings as required:

Policy

If you are not using the WS-PolicyAttachment specification, specify the XML policy file. Click
Browse to add a policy file from the workspace or to import a policy file.

Signature configuration

Select this option to specify a keystore for any signature that is specified in the policy. Click Edit
Security to add a keystore from the workspace or to import a keystore.

Encryption configuration

Select this option to specify a keystore for any encryption that is specified in the policy. Click

Edit Security to add a keystore from the workspace or to import a keystore.
Decryption configuration

Select this option to specify a keystore for any decryption that is specified in the policy. Click

Edit Security to add a keystore from the workspace or to import a keystore.
Retrieve token from security token server (WS-Trust and WS-SecureConversation)

Select this option, and click Configure to specify a Security Token Server (STS) to use with the
policy.
Additional properties

Use this table to specify settings for the advanced properties or specific implementations of the
WS-Security specification. Click Add to add a property name and to set a value.

6. Check that the security profile is valid by clicking Tools > Validate Selected Algorithm.
7. Click the Algorithms by WSDL Operations tab.
On this page, you can associate a security profile with each request or response operation in the WSDL.
8. In the WSDL Contents column, select a web service request or response operation.
9. In the Algorithm Stack column, select a security profile from the list.

If necessary, click << to open the stack on the Security Algorithms page.
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What to do next
After saving the security profile, the Web Service Protocol Data view displays the result of the security profile on the

XML data of the web service.

Related information

Creating security profiles for WSDL files on page 337
Adding WS-Addressing to a security configuration on page 350

Implementing a custom security algorithm on page 347

Adding security stacks

To provide better WSDL security, you can make use of many security algorithms in the service test.

About this task

1. From the Test Navigator view or from the Request Library section of Generic Service Client, right-click the

WSDL file and select Edit WSDL Security.
2. In the Security Algorithms area of Algorithm Stacks tab, click Add to create a profile.
3. In the Stack Contents area, click Add and add any of the following security algorithms:

Custom Security Algorithm

If you want to use a Java™ class as a custom security algorithm, then use this stack element to

apply the custom algorithm to the service.
Java™ Project

If you have not implemented a custom Java™ class, select Java Project, type a
name for the new project, and click Generate to create a new Java™ class with the

default structure for custom security implementations.
Note: If you are using IBM® Security AppScan®), this field is not available.

Implementation class

Specify the name of the class that implements the custom security algorithm.

Click Browse Class to select an existing Java™ class from the workspace.

Properties

Use this table to send any specific properties and associated values to the custom

security algorithm.
WS-Addressing Algorithm
Use this block if your service uses either WS-Addressing 2004/08 or the WS-Addressing 1.0 Core

standard.
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Namespace

Specify the namespace for either WS-Addressing 2004/08 or WS-Addressing 1.0
Core.

Action if request uses WS-Addressing
Select the action to complete if WS-Addressing is already in the request.
Replace anonymous address in Reply-to with:

Select this option to generate the specified address in the Reply-to header instead

of an anonymous address.
Remove WS-Addressing from response
Select this option to strip any WS-Addressing headers from the response.
Encrypted Key

This block defines an encrypted key that can be used in an XML signature or XML encryption

block. The encrypted key block must be before a block that uses the encrypted key.
Actor / Role name
Specify the name of the recipient of the algorithm header element, if required.
Must understand

Select whether it is mandatory that the algorithm header is processed by the
recipient, if required. The recipient is either the Actor name or the server.

Key name
Specify the name of the encrypted key.
Identifier type

Select the type of key identifier to be used for the key. The following key identifiers
are available, as defined in the the Web Service Security (WSS) specification X509
profile and OASIS WSS 1.1 specification:

> ISSUER_SERIAL

o BST_DIRECT_REFERENCE

> X509_KEY_IDENTIFIER

> THUMBPRINT_IDENTIFIER

> SKI_KEY_IDENTIFIER

Key size
Specify the size of the key in bits.
Key encoding algorithm name

Specify the algorithm to be used for encoding the key.
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Keystore

Select a keystore or click Edit Security to define a new keystore or to manage the
existing keystores.

Name
Select a key contained in the specified keystore.
Password
Type the password for the selected key name.
XML Signature

The XML signature security algorithm specifies how the XML document is signed. For details on

security algorithms, refer to the web service security specification.
Actor / Role name
Specify the name of the recipient of the algorithm header element, if required.
Must understand

Select whether it is mandatory that the algorithm header is processed by the

recipient, if required. The recipient is either the Actor name or the server.

Security token

Select the type of key identifier to be used for the signature. The following
key identifiers are available, as defined in the the Web Service Security (WSS)
specification X509 profile and OASIS WSS 1.1 specification:

> ISSUER_SERIAL

> BST_DIRECT_REFERENCE

> X509_KEY_IDENTIFIER

> SKI_KEY_IDENTIFIER

> KEY_VALUE

o USER_NAME_TOKEN

o CUSTOM_SYMM_SIGNATURE

In addition, the following identifiers are available when the signature is based on a
UsernameToken profile:

> USER_NAME_TOKEN

> CUSTOM_SYMM_SIGNATURE

User XPath part selection

Specify an XPath query that describes parts of the XML document that can be
the subjects of the algorithm. By default, the body is the subject. Click the XPath
Helper button to build the Xpath expression.
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Key

Select the key used for the encryption. The details of each key vary.

> x509 key: This key specifies the name and password of the x509 key and
the keystore where it is located.

- User name token key: This specifies a user name and password for the
signature.

- Encrypted key: This specifies a reference to an encrypted key that was
previously defined in the security stack. Click Insert a new encrypted key to
create a new encrypted key definition block.

Signature algorithm name

Specify the signature method algorithm as described in the XML Signature Syntax
and Processing specification.

Canonicalization

Specify the canonicalization method to be used as described in the XML Signature
Syntax and Processing specification.

Digest algorithm method

Specify which digest method to be used based on the algorithm method used on
the server side.

Inclusive namespaces

Specify whether the canonicalization is exclusive as described in the Exclusive

XML Canonicalization specification.
XML Encryption

The XML encryption security algorithm specifies how the XML document is encrypted. For
details on security algorithms, refer to the web service security specification.

Actor / Role name
Specify the name of the recipient of the algorithm header element, if required.
Must understand

Select whether it is mandatory that the algorithm header is processed by the
recipient, if required. The recipient is either the Actor name or the server.

Identifier type

Select the type of key identifier to be used for the encryption. The following
key identifiers are available, as defined in the Web Services Security (WSS)
specification X509 profile and the OASIS WSS 1.1 specification:

> ISSUER_SERIAL

> BST_DIRECT_REFERENCE

> X509_KEY_IDENTIFIER
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> SKI_KEY_IDENTIFIER

> EMBEDDED_KEYNAME

° THUMBPRINT_IDENTIFIER

o ENCRYPTED_KEY_SHA1_IDENTIFIER

User XPath part selection

This enables you to specify an XPath query that describes parts of the XML

document that can be subjects of the algorithm. By default, the body is the subject.
Key

Select the key used for the encryption. The details of each key vary.

> x509 key: This specifies the name and password of the x509 key and the
keystore where it is located.

> Raw key: This specifies the name and the byte value of your SecretKey in
hexadecimal.

- Encrypted key: This specifies a reference to an encrypted key that was
previously defined in the security stack. Click Insert a new encrypted key to
create a new encrypted key definition block.

Encoding Algorithm Name

Specify the encryption method to be used as defined in the XML Encryption Syntax

and Processing specification.
Key Encoding Algorithm

Specify the standard algorithm for encoding the key as defined in the XML
Encryption Syntax and Processing specification.

User name token

The user name token security algorithm adds a user name token to the XML document in the
message. For details on security algorithms, refer to the web service security specification.

Actor / Role name
Specify the name of the recipient of the algorithm header element, if required.
Must understand

Select whether it is mandatory that the algorithm header is processed by the
recipient, if required. The recipient is either the Actor name or the server.

Name
Type the name of the user.
Password

Type the password of the user.
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Password type

Specify the password type for the security algorithm as defined in the Web
Services Security UsernameToken profile.

Use nonce

Select this check box to add the Nonce element to the User Name Token XML

code. In most cases, the Nonce ID is required.
Use created

Select this check box to add current timestamp to the Created XML element in the
User Name Token XML.

Time Stamp

The time stamp security algorithm adds time stamp information to the XML document in the
response. For details on security algorithms, refer to the web service security specification.

Actor / Role name
Specify the name of the recipient of the algorithm header element, if required.
Must understand

Select whether it is mandatory that the algorithm header is processed by the
recipient, if required. The recipient is either the Actor name or the server.

Expiration delay
Specify the delay after which the time stamp expires.
Millisecond precision

Select this option to produce a time stamp that uses millisecond precision instead
of the default (1/100th second).

SAML Assertion Block

To use the self-signed SAML assertion security algorithm, add the SAML Assertion stack to the
request or WSDL files.

User XPath part selection

Specify an XPath query that describes parts of the XML document that can be the subjects of
the algorithm. By default, the body is the subject. Click the XPath Helper button to build the
Xpath expression.

Key

Select the key used for the encryption. The details of each key vary.
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> x509 key: This key specifies the name and password of the x509 key and the keystore
where it is located.

- User name token key: This specifies a user name and password for the signature.

> Encrypted key: This specifies a reference to an encrypted key that was previously
defined in the security stack. Click Insert a new encrypted key to create a new encrypted

key definition block.
Signature algorithm name

Specify the signature method algorithm as described in the XML Signature Syntax and
Processing specification.

Canonicalization

Specify the canonicalization method to be used as described in the XML Signature Syntax and
Processing specification.

Digest algorithm method
Specify which digest method to be used based on the algorithm method used on the server side.
Inclusive namespaces

Specify whether the canonicalization is exclusive as described in the Exclusive XML

Canonicalization specification.
Signed Assertion

Select this check box to self-sign the SAML Assertion.
Issuer

Specify the description of the issuer of the SAML Assertion or protocol message.
Subject

Specify the principal that is the subject of all of the statements in the assertion. It might contain

an identifier or a series of one or more subject confirmations.
Subject Qualifier

Specify the Name Qualifier of the Subject
Subject Format

Specify the format used for the Subject.
Subject Locality DNS

Specify the DNS domain name for the system from which the assertion subject was
authenticated.

Subject Locality IP

Specify the IP address for the system from which the assertion subject was authenticated.
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Statement Type

Specify the authentication method to use for the assertion.
Authentication: The assertion subject was authenticated
Attribute: The specified subject is associated with the supplied attributes.

Authorization decision: Permission to allow a subject to access the specified resource.
Requested Resource

When Authorization decision option is used, specify the resource for which you need access.
Action

Specify what action to take to access the resource.
Confirmation number

Confirmation methods define the mechanism by which an entity provides evidence (proof) of the

relationship between the subject and the claims of the SAML assertions.

Sender vouches: Select this option when a server needs to share the client identity with SOAP
messages on behalf of the client. This method is similar to identity assertion, but it has the
added flexibility of using SAML assertions to share not only the client identity, but also client
attributes.

Holder of key: Select this option when the proof of the relationship between the subject and
claims is established by signing part of the SOAP message with the key specified in the SAML
assertion. Because there is key material associated with a holder-of-key token, this token can be

used to provide a message-level protection (signing and encryption) of the SOAP message.

Bearers: Select this option when the proof of the relationship between the subject and claims
is implicit. No specific steps are taken to establish the relationship. Because there is no key
material associated with a bearer token, protection of the SOAP message, if required, must be
performed using a transport-level mechanism or another security token, such as an X.509 or
Kerberos token, for message level protection.

Version
Specify the SAML version used.

4. Optional: To verify simple SAML code, use the Analyze Security from Pasted Content option.
For more information about that option, see Creating security for WSDL profiles on page 337.

Implementing a custom security algorithm

You can define your own security algorithms for SOAP security profiles by implementing custom security Java™
interfaces that can be used in the WSDL security editor. With custom security algorithms, you can implement
proprietary security algorithms that transform the XML before sending and after receiving message content.
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Before you begin

The custom security interface and the JAR file that contains it are provided with the product in the
custonsecuritydefinition folderofthecomibmrational.ttt.comon. nodel s. cor e plugin. You need
these interfaces to create your own algorithms. If you are using HCL OneTest™ Performance, see Extending test

execution with custom code on page for more information about extending test capabilities with Java™ code.

1. In the test navigator or project explorer, create a new Java™ class in your web service test project folder.

2. Implement a security algorithm in Java™ using the following interface:

/%%
R T T R R S R S T S S L T S L L L T S L T L S T

* IBM Confidential
(c) Copyright IBM Corporation. 2008. All Rights Reserved.

The source code for this program 1is not published or otherwise
divested of its trade secrets, qirrespective of what has been
deposited with the U.S. Copyright Office.
hhkhkhkhkkhkhkhkhkkhkhkhkhkkhkhkhkhkkhkhkhkhkhkhkhkhkhkhkhkhkkhkhhkhkkhkhhkkkhkhhkkkhkhkkkhkhkkkkhkkkkhkhkkkkhkhkkkkkx

L S R

*

package com.ibm.rational.test.lt.models.wscore.datamodel.security.xmlsec;

import java.util.Properties;
import org.w3c.dom.Document;

public interface ICustomSecurityAlgorithm {

[ **
* The following methods can be used in both case:
* Execution in the workbench and execution of the test.

*/

/**
* Called to process de Document that is sent over a transport.
* @param subject
x/
void process(Document subject);
/**
* Called to un process a document that is received from a server.
* @param subject
*/

void unProcess(Document subject);

[ **

* Properties defined in the UI of the CustomSecurityAlgorithm.
* @param map

x/

void setProperties(Properties map);

/*x
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* The following methods can only be used in terms of cast to test service interface,
* or 1in terms of access to the previous XML <dinformation, when the jar containing

* the custom security algorithm is deployed in the performance test project. In

* this case you cannot use the algorimth directly from the workbench.

*/

* This object corresponds to the ITestExecutionService object.

* This applies only to an algorithm that must link to the execution of the test.

* If you plan to use this object you will need to deploy the jar containing the

* implementation 1into your performance test project and not directly into the JRE.

* In case of a need of the previous xml document received from the execution you can
* obtain the value using:

* IDataArea area =
((ITestExecutionService)executionObject).findDataArea(IDataArea.VIRTUALUSER);

*String previousXML = (String) area.get("PREVIOUS_XML"); //$NON-NLS-1$

*
*/

void setExecutionContext(Object executionObject);
The process method modifies the XML before it is sent to the server.
The unpr ocess method modifies the XML after it is received from the server.

The set Properti es method retrieves any properties that are defined in the security editor for this custom
security interface.

The set Executi onCont ext method is called during test with the object | Test Execut i onSer vi ces that
corresponds to the message using this custom security interface.

3. The custom security interface can be used either in the WSDL security editor for web services or in XML call
elements in the Local XML security tab.
Choose from:

o If you are testing a WSDL-based web service, right-click the WSDL file in the test navigator or project
explorer to open the WSDL security editor, select the Security Algorithms page; then, under Details of
selected security algorithm stack, click Add > Custom Security Algorithm.

o If you are testing an XML call, open the XML call element in the test editor, select the Local XML
Security tab, and then, click Add > Custom Security Algorithm

4. In custom security, click Browse Class to select the class name of the custom security algorithm, for
example : 1 cust onBecuri t yAl gorithm

5. Type an Algorithm name for the custom security algorithm.

6. In the properties list, use Add, Remove, or Edit to specify any properties that are used by the set Properti es
method in your custom security algorithm.

What to do next

After saving the security configuration or the call element, the Web Service Protocol Data view displays the effect of
the security algorithm on the XML data of the web service.
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Related reference

WSDL security editor reference on page 1205

Adding WS-Addressing to a security configuration

The WS-Addressing specification provides transport-neutral mechanisms that enable SOAP-based web services to
communicate addressing information. You can use WSDL security algorithms to add WS-Addressing to your service
tests.

Before you begin

Before adding WS-Addressing to a security configuration, you must have a service test with requests and responses
that are related to a valid WSDL.

To add WS-Addressing to a WSDL security algorithm:

1. Open the test, select a service request, and in the Raw Transaction Data view, select Enable the display of the
XML document after the security processing.

2. On the Request Stack page, click Edit WSDL Security = .

o Tip: If you need to edit separate security or processing algorithms for incoming responses, click Show

Response Stack to add a Response Stack page to the editor.

Result
The WSDL security editor opens.

3. Select the Algorithm Stacks page of the WSDL security editor, and in the Security Algorithm list, select or
create a security algorithm.

4. In the Stack Contents list, click Add > WS-Addressing and specify the settings that are implemented by the

service.
WS-Addressing Algorithm

Use this block if your service uses either WS-Addressing 2004/08 or the WS-Addressing 1.0 Core
standard.

Namespace

Specify the namespace for either WS-Addressing 2004/08 or WS-Addressing 1.0
Core.

Action if request uses WS-Addressing
Select the action to complete if WS-Addressing is already in the request.
Replace anonymous address in Reply-to with:

Select this option to generate the specified address in the Reply-to header instead

of an anonymous address.
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Remove WS-Addressing from response
Select this option to strip any WS-Addressing headers from the response.
5. Save the WSDL security algorithm, and select the test editor.

Result

The WS-Addressing namespace and header XML content is displayed in the Raw Transaction Data view.

Related reference
WSDL security editor reference on page 1205
Related information

Creating security profiles for WSDL files on page 337

Implementing a custom security algorithm on page 347

Testing asynchronous services

Use the asynchronous callback services for inter-object communications in a service test.

Asynchronous service testing overview

Asynchronous services use a callback interaction pattern for inter-object communications. Asynchronous services
can be used, for example, in publish-subscribe systems that are provided by message-oriented middleware vendors or
in system and device management domains.

WS-Notification services

Asynchronous services are standardized in the WS-Notification specifications:

- WS-BaseNotification defines the web services interfaces for NotificationProducers and NotificationConsumers.
This specification includes standard message exchanges that are implemented by service providers that want
to act in these roles, along with the associated operational requirements.

« WS-BrokeredNotification defines the web services interface for a NotificationBroker. A NotificationBroker
is an intermediary which, among other things, enables entities that are not service providers themselves to
publish messages. It includes standard message exchanges that are implemented by NotificationBroker
service providers, along with the associated operational requirements of service providers and requestors that
participate in brokered notifications.

» WS-Topics defines a mechanism to organize and categorize items of interest for subscription known as
topics. These are used in conjunction with the notification mechanisms defined in WS-BaseNotification and
WS-BrokeredNotification.

You can test web services and XML services that implement the WS-Notification specification by creating an
asynchronous request inside a test. The asynchronous request contains the interfaces for the corresponding WS-
Notification specification, along with a callback structure.
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Proprietary asynchronous services

You can test proprietary asynchronous services that do not implement WS-Notification specifications. To test these
services, you manually create a service request that contains the interfaces for the service, and then, you can add the

asynchronous callback structure to the request.

The XML data of the asynchronous request must contain an endpoint that specifies the URL of the callback receiver.

During the test, this endpoint is used to redirect the callback to the tester instead of the real receiver.

Callback structure

To test asynchronous services, you must create an asynchronous request structure in your test as shown in the
following diagram:

o B mesod rest
= up n
+- g getlastMameRequest "Micholas" )
=% subscribe

*L‘ﬁ SubscribeResponse

'ii Callback.
=P Parallel
A Elements here run while waiting For callback
=+ Loop (infinike )
q'lil Anorymous Calll # )
= 'Dlﬂ Receive

A Elements here run after callback is received
= I'f’g:- Timeouk

A Elements here run after trmeout occurs

A web service request or a plain XML request provides the subscription action and contains a callback element, which

describes the behavior of the test in three states:

« Parallel contains test elements that are run after the subscription request and while waiting for the notification
response.

* Receive contains test elements that are run when the notification response has been received from the
service.

- Timeout contains test elements that are run if the notification response is not received after a delay that is

specified in the callback element.

When everything contained in the parallel, receive, and timeout elements have finished running, the run continues with
the next element in the test after the asynchronous request.

The method for generating the asynchronous callback structure in the test depends on whether the asynchronous
service uses the WS-Notification specification:

« WS-Notification services: Create the asynchronous request in the test.
« Proprietary services: Manually create a web service request or XML request in the test, and then add the

asynchronous callback structure to the request.
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Creating an asynchronous request structure

You can create an asynchronous request based on the WS-Notification specification, which contains an callback

structure.

1. In the test editor, select the test, and click Add, and then click Specification-based Structure.
Result
The New Web Service Test wizard opens.

2. On the Web Services Specification Selection page, Select WS-Notification, and click Next.

3. On the WS-Notification Details page, if the service has a Web Services Description Language (WSDL) file, click
Add to associate it with the call.

4. Specify the Subscription identifier.
You can select default identifiers for Websphere Application Server or Apache Muse; or if your service does
not use a standard identifier, you can select Custom, and type the Name and Namespace of the identifier.

5. In the Topic area, replace the default Name and Namespace values with those of topic of your service.

6. Specify the Subscription duration.
Because this is a test environment, the subscription expires after the specified delay to save server resources.

7. If this is a WS-BrokeredNotification service, which implements a notify call when the subscription is received,
you can select Add notify call, and type the message to be sent.

8. Click Next.

9. On the Configure Protocol page, select a Protocol configuration, and specify the options of the configuration.
Select Generate SOAP 1.2 envelope if you are testing a SOAP 1.2 web service.

10. Click Finish.

Result
This action generates in the test editor a web service call or an XML request with a callback structure that

contains a parallel, a receive, and a timeout element.

What to do next

In the callback structure, add test elements to the parallel, receive, and timeout elements to specify the behavior of
the test:

« Parallel contains test elements that are run after the asynchronous call has been sent.
* Receive specifies the message return of the callback and contains test elements that are run after the
callback is received.

- Timeout contains test elements that are run if the callback is not received after a specified delay.

Adding an asynchronous callback to a service request

To test a proprietary asynchronous service that does not implement the WS-Notification specification, you can add an

asynchronous callback to a service request or XML request.

Before you begin

353



HCL OneTest Performance

Manually create a web service call or XML call that invokes the asynchronous service. The call must contain an
endpoint that specifies the URL of the callback receiver. This endpoint is used to redirect the callback to the tester.

If the service implements the WS-Notification specification, create the asynchronous call structure with the Create
New WS-Notification Request and Callback wizard instead. See Creating an asynchronous request structure on

page 353.

1. In the test editor, select a web service or XML request, click Add, and then click Asynchronous Callback.
Result
The Create New Asynchronous Callback wizard opens.

2. On the Select Callback Endpoint page, select the XML element of the request where the endpoint URL of the
callback is located.

3. If you have a web Services Description Language (WSDL) file for the web service, click Next. Otherwise, skip to
step 5.

4. On the Bind Message to WSDL Port page, select a port from the WSDL file. If the WSDL file for the service is
not listed, click Add to add a WSDL file from the workspace or to import a WSDL file.

5. Click Finish.
Result
This generates a callback structure that contains a parallel, a receive, and a timeout element, in the test editor.

What to do next

In the callback structure, you can add test elements to the parallel, receive, and timeout elements to specify the

behavior of the test:

« Parallel contains test elements that are run after the asynchronous request has been sent.

* Receive specifies the message return of the callback and contains test elements that are run after the
callback is received.

- Timeout contains test elements that are run if the callback is not received after a specified delay.

Creating a reliable messaging call structure

You can create a test structure dedicated to testing service calls based on the WS-ReliableMessaging specification.

Before you begin

The WS-ReliableMessaging specification provides for a series of SOAP messages to be delivered reliably between
distributed applications in the presence of software component, system, or network failures. In the context of a
service test, a reliable messaging call structure consists of a series of calls that conform to the specification. The
structure can be created either as a sequential list of unique service calls or a loop that contains a call element and

uses a dataset to identify the unique calls.

1. In the test editor, select the test, and click Add, and then click Specification-based Structure.
Result
The New Web Service Test wizard opens.

354



Chapter 6. Test Author Guide

2. On the Web Service Specification Selection page, Select WS-ReliableMessaging, and click Next.
3. Select one or several Web Services Description Language (WSDL) files in your workspace for the web service
that you want to test, and click Next.
If necessary, you can import a WSDL file into the workspace with the Import push button.
4. On theConfigure Protocol page, select an existing HTTP transport configuration, or click New to create a new
configuration.
a. Specify the URL of the service, the HTTP Method, and Version.
b. In the Header table, click Add to specify any specific headers that need to be added to the call.
c. In the Cookies table, click Add to specify any specific cookies that need to be used by the call.
d. Click Next.
5. On the Sequence Options page, specify how the sequence structure will be created in the test.

a. In Message count, specify the number of calls in the list or the number loop iterations.

b. Select Create service call list to generate a list of calls with the number of messages or Create loop
with dataset to generate a loop with a dataset.
The dataset defines the call number for each call in the loop.

c. Select Shuffle sequence if you want the call numbers to be generated in a random order.

6. Click Finish.
Result
This action generates a reliable messaging service call structure in the test.

Editing Socket tests

Improve the Socket tests by adding test elements.

Socket API test editor overview

You use the test editor to inspect or customize a socket API test that you recorded.
The test editor lists the connections and data exchanges for a test as they occurred during the recording.

The test editor window has two main areas. The area on the left, Test Contents, displays the flow of the socket events
that constitute the test. The area on the right, Test Element Details, displays details about the currently selected test

element in the test hierarchy.

Values can sometimes be highlighted in green. This highlighting indicates that these requests contain one or both of

the following types of information:

« A dataset candidate: This is a value, usually one specified by the tester during recording, that the test
generator determined is likely to be replaced by values in a dataset. An example of a dataset candidate
is a string that you search for in a recorded test. The string is highlighted as a dataset candidate on the
assumption that, before playback, you might want to associate the string with a dataset column that contains

appropriate substitute values.
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- Correlated data: These are values in a test, usually one of them in a response and the other in a subsequent
request. An example is a product price returned to the browser by a test that searches a product database.
You can use these values as references that can be reused later in the test. Suppose that, before running the
test with many virtual users, you replace the product name searched for in the recorded test with names in a
dataset. Because the test correlates the data, each virtual user searches for a different product, and the server

returns an appropriate price.

To see an illustration of color coding in performance tests or to change the color settings, click Window >

Preferences > Test > Fonts and Colors.

Click Add to add elements to the selected test element. Alternatively, you can right-click a test element, and select an
action from a menu. The choices that you see depend on what you have selected. For example, after you select a test,

you can add a new event.
The Insert button works similarly. Use it to insert an element before the selected element.

Use the other buttons (Remove, Up, Down) primarily when you substantially modify a test.
0 Tip: Performing actions with these buttons or choices are likely to break a recorded test.

Sometimes, the area of the editor where you need to work is obscured. To enlarge an area, move your cursor over one
of the blue lines until your cursor changes shape to a vertical line with an up arrow at the top and a down arrow at the

bottom, and drag up or down while holding the left mouse button.
Displaying binary data

With the Socket Details view, you can display the binary data for send and receive elements in the test. The text area
of the Socket Details view supports many international character encoding standards. To open the Socket Details

view, right-click a socket send or receive element, and click Show Socket Details.

In the test log, the Socket Details view also displays actual the actual binary data sent and received during a test run.

Manipulating elements in the socket test editor

Socket tests are often made of a long series of send and receive elements to or from various connections. The
test editor helps you to locate specific elements and to manipulate certain types of elements in the test editor. The

following examples demonstrate how you can select and manipulate large sets of test elements:

« To select all the send or receive elements in the test: Click the Select button and click Socket Send or Socket
Receive.

« To locate all the connections in the test: Click the Select button and click Socket Connection.
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- To disable or remove all send and receive actions to or from a specific connection: Right click a test element,
click Manage Socket Connections, click Only disable them, and select the connections that you want to
disable or remove.

« To reenable all disabled send and receive actions to or from a specific connection: Right click a connection
element, click Select All Related Actions, right-click again, and click Enable.

Related information

Merging socket send and receive elements on page 361

Changing multiple socket send and receive elements on page 362

Adding elements to a socket test

A socket test provides the flexibility to add close, send, and receive elements to the test.

Adding a socket close

You can manually add a socket close element to a socket API performance test.
Before you begin

In a performance test, socket close elements close the connection to a server. A socket close element relates to a
specific socket connection.

Ensure that for each socket connection, there is a corresponding socket close. If not, during the test run, the operating
system can run out of socket handles, causing the test to fail.

1. Open the performance test in the test editor.

2. In the Test Contents area of the test editor, right-click the test node, and click Add > Socket Close.

3. In the Test Element Details section, click Change and select the socket connection that you want to close.
You can specify a Think Time delay before the test establishes the connection.

Results
After you have closed a connection, you can no longer send or receive data from that connection. If any test elements
use a connection after the close element, they are flagged with an error in the test editor.

Adding a socket send
You can manually add a socket send element to a socket API performance test.
Before you begin

In a performance test, socket send elements describe how data is sent over a connection. A socket send element

relates to a specific socket connection.
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to.

. Open the performance test in the test editor.
2. In the Test Contents area of the test editor, right-click the test node, and click Add > Socket Send.
3. In the Test Element Details section, click Change, and select the socket connection that you want to send data

You can specify a Think Time delay before the test establishes the connection.

. In the Data area, type the data that you want to send.

By default, data is sent as 7-bit alphanumeric characters. To specify hexadecimal bytes, prefix the data with \ x,

for example: \ xo0\ xf f

Adding a socket receive element

You can manually add a socket receive element to a socket API performance test.

About this task
In a performance test, socket receive elements describe how data is received over a connection. A socket receive

element relates to a specific socket connection.
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1. Open the performance test in the test editor.
2. In the Test Contents area of the test editor, right-click the test node, and click Add > Socket Receive.
3. In the Test Element Details section, click Change and select the socket connection that you want to receive

data from.

You can specify a Think Time delay before the test establishes the connection.

. Specify the End Policy.

This specifies when the receive element stops receiving data and the test resumes:

o

o

o

o

o

Detects inactivity: The receive action stops when no bytes are received from the connection after

a delay specified in Inactivity threshold (in milliseconds). After this delay, the remote computer has
finished sending the response and is considered inactive. This is the default setting.

Receives exact number of bytes: The receive action stops when the recorded number of bytes is
received. Specify a Timeout (in seconds) after which the receive action produces an error in the test
log, if the correct number of bytes is not received. If Link data size is enabled, the receive action
expects the number of bytes displayed in the Data area. If Link data size is disabled, the receive action
expects the number of bytes displayed in Bytes.

Receives until end of stream: The receive action stops when the connection is closed by the remote
computer. If Accepts empty response is selected, then the reception of a single byte is not required
and the Response Timeout is ignored. Specify a Timeout (in seconds) after which the receive action
produces an error in the test log, if the correct number of bytes is not received.

Matches a string: The receive action stops when a specified sequence of bytes is received. Specify

a Timeout (in seconds) after which the receive action produces an error in the test log, if the correct
number of bytes is not received.

Recognizes a regular expression: The receive action stops when a sequence of bytes that matches a
regular expression is received. Specify a Timeout (in seconds) after which the receive action produces

an error in the test log, if the correct number of bytes is not received.
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5. In the Data area, type the data that you expect to receive.
By default, data is sent as 7-bit alphanumeric characters. To specify hexadecimal bytes, prefix the data with \ x,
for example: \ x00\ xf f .

Verifying application behavior

Add the different verification points to verify the responses in a socket test.

Verifying received content
With content verification points, you can check that actual received data matches the expected data that is specified
in the verification point.

About this task

When you add verification points, the received data is compared with the expected data that is specified in the
verification point test element. With content verification points enable, you can directly compare the content data that
the server returns and return a Pass status when the criteria is met.

To add a content verification point to a socket test:

1. Open the test editor, right click a socket receive element, and select Add > Content Verification Point.
2. Select the verification point, and in the Test Element Details area of the test editor, specify the verification

criteria:
Comparison operator
Specify the criteria to use to perform the verification, among the following operators:
Equals

The verification point returns a Pass status if the received data exactly matches
the text or binary content that is specified in the Data area.

Contains

The verification point returns a Pass status if the text or binary content that is

specified in the Data area occurs at least once in the received data.
Starts with

The verification point returns a Pass status if the text or binary content that is

specified in the Data area occurs at the beginning of the received data.
Ends with

The verification point returns a Pass status if the text or binary content that is

specified in the Data area occurs at the end of the received data.
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Differs from

The verification point returns a Pass status if the received data does not exactly
match the text or binary content that is specified in the Data area.

Does not contain

The verification point returns a Pass status if the text or binary content that is

specified in the Data area does not occur at least once in the received data.
Does not start with

The verification point returns a Pass status if the text or binary content that is

specified in the Data area does not occur at the beginning of the received data.
Data
Specify the data that is expected to be received through the connection.
Binary
In this view, edit the expected content as binary data.
Raw ASCII

In this view, edit the expected content as raw ASCII data. Bytes are expressed as
7-bit alphanumeric characters or two-digit hexadecimal bytes preceded with \ x.
Additionally,\r and\ n stand for carriage-return and line-feed, while \\ represents

the backslash character.

What to do next
You can enable or disable each socket verification point by clicking Enable verification point in the test editor.

Verifying received message size
With size verification points, you can check that actual received data matches the expected data size in bytes as
specified in the verification point.

About this task

When you add verification points, the received data is compared with the expected data that is specified in the
verification point test element. With size verification points, you can check the number of bytes in a socket receive

element and return a Pass status when the criteria is met.

To add a size verification point to a socket test:

1. Open the test editor, right click a socket receive element, and select Add > Size Verification Point.
2. Select the verification point, and in the Test Element Details area of the test editor, specify the verification

criteria:
Comparison operator

Specify the criteria that is used to perform the verification with these operators:
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°ls

o Is less than

o |s less or equals

o Is more than

o s more than or equal to

° |s not
Value (bytes)

Specify the size criteria for the verification point.

What to do next

You can enable or disable each socket verification point by clicking Enable verification point in the test editor.

Verifying received data with custom Java™ code

With custom verification points, you can use Java™ code to verify the data received through a connection.
Before you begin

Using Java™ custom code requires knowledge of the Java™ programming language and of the HCL OneTest™

Performance API. See Executing test execution with custom code on page for more information.
About this task

When you add verification points, the received data is compared with the expected data that is specified in the
verification point test element. Custom verification points return a Pass status when the custom class returns a Pass
status after performing a verification written in Java™ code.

To add a custom verification point to a socket test:

1. Open the test editor, right click a socket receive element, and select Add > Custom Verification Point.

2. Select the verification point, and in the Test Element Details area of the test editor, click Generate Code.
Result
This action generates a Java™ class that is based on the template of the HCL OneTest™ Performance API for
socket custom verification points.

3. Edit the Java™ code to define the specific verification action to perform.

4. Save and close the Java™ class.

What to do next
To modify the custom class, click View Code to open the code in the Java™ editor. You can enable or disable each

socket verification point by clicking Enable verification point in the test editor.

Merging socket send and receive elements

With the Organize wizard, you can merge consecutive send or receive elements that use the same connection to

improve the clarity of your socket test.
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Before you begin

The wizard can perform the following actions when merging socket test elements:

» Merge consecutive socket send elements that use the same connection.
« Merge consecutive socket receive elements that use the same connection.
- Delete all socket receive elements except for the last one, which is necessary to synchronize the test.

To perform a merge, the selected elements must be consecutive and must be to or from the same connection.

To merge send or receive elements in a socket test:

1. Select the socket send or receive elements that you want to merge.
Press the Shift key to select multiple consecutive elements in the test editor.
2. Right-click the selection and click Organize Send and Receive Actions. This opens the Organize wizard.
3. Choose one of the following options:
Choose from:
- Select Merge all selected send or receive actions to merge the selected elements.
> Select Merge all selected send and keep a single receive to delete all socket receive elements except
the last one.
4. Click Next.
5. If your selection contained send elements that could be merged, specify the Custom Code settings that
should be retained for the merged element, and click Next.
6. If your selection contained receive elements that could be merged, specify the Response Timeout and End
Policy settings that should be retained for the merged element, and click Next.

7. Click Finish to perform the merge.

Related information

Socket API test editor overview on page 355

Changing multiple socket send and receive elements on page 362

Changing multiple socket send and receive elements

You can perform global changes to multiple send and receive elements in a socket test.

About this task
With the Organize wizard, you can perform the following global changes on multiple send and receive elements:

« Change the Custom Code data manipulation settings on selected send elements.
« Change the Response Timeout and End Policy settings on selected receive elements

You can also apply a global change strategy that applies to all the selected send and receive elements. A change

strategy can change the settings and merge send and receive elements at the same time.
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To perform global changes on a series of send or receive elements:

1. Select the socket send or receive elements that you want to merge.
Press the Shift key to select multiple consecutive elements in the test editor. Use the Select button to select
a specific type of test element. Right-click a connection and click Select All Related Actions to select all
elements that use a specific connection.

2. Right-click the selection and click Organize Send and Receive Actions. This opens the Organize wizard.

3. Choose one of the following options:
Choose from:

- If you want to modify the selected elements, select Change settings on all selected send and receive
elements.

o If you want to modify all elements that use a specific connection, select Change settings on all
elements related to a specific connection, click Next, and then select the connections for which you
want to change the settings.

4. Click Next.

5. If you want to change send elements, select Globally change, specify the new custom code settings for data
manipulation that you want to apply to all send elements, and then click Next.

6. If you want to change receive elements, select Globally change, specify the new response timeout or end
policy settings that you want to apply to all receive elements, and then click Next.

7. Click Finish to apply the changes.

Related information

Socket API test editor overview on page 355

Merging socket send and receive elements on page 361

Splitting a socket test

After you record a test, you can split it into smaller tests. Splitting tests enables you to create modular building blocks
of smaller tests and combine them to make bigger tests. The original test is unchanged. You can recombine these
building blocks in a schedule, including loops and conditions.

Before you begin

When reusing split tests in a schedule, you must ensure that the general test structure is consistent including
socket connection and close elements. For example, you must ensure that all socket send and receive elements are
preceded with a corresponding socket connection and followed by a socket close element. When the split tests are
recombined in the schedule, you must place them in the correct order.

1. In the Test Navigator, browse to the test and double-click it. The test opens.
2. Right-click a socket send or receive element in the test, and select Split Test. The page that you click is the
first page of the new test.
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3. In the New Test Names window, confirm the location of the split, optionally provide names and descriptions
for the split tests, and click Next.
4. In the Split Test window, examine the changes to be performed as a result of the split, and click Finish.

Exemple

For example, you could record a test that contains the following actions:

» Logging on to a server.
« Creating an entry on the server and removing the entry.
« Editing an entry, validating that the change occurred, and restoring the entry.

- Logging off of the server.

You then split the test into four parts: Logon, Create, Edit, and Logoff. You create a schedule that runs virtual users
selected from a dataset. Each virtual user runs the Logon test, performs various combinations of the Create and Edit

tests, and finally runs the Logoff test.

Using custom code to specify an end policy

You can write a custom Java™ class to specify when a socket receive element stops receiving. This offers the most

flexibility, but requires that you write your own Java™ class using the HCL OneTest™ Performance extension API.

Before you begin

The end policy specifies how the receive element stops receiving and allows the test to resume. There are several
predefined end policies that you can choose from, for example after a certain number of bytes has been received, or
when a specific string is detected. However, in some cases, a complex condition must be defined. This can be done

by delegating the decision to custom code.

To create a new custom code class:

1. In the test editor, select a socket receive element.

2. In the End policy section, select Delegated to custom code and click Generate Code.
Result
This creates a Java™ class template that follows the HCL OneTest™ Performance extension API. The Java™
class in created in the sr ¢ folder of the current project.

3. Write the custom code by extending the generating class. See Extending test execution with custom code on
page for more information about extending HCL OneTest™ Performance with Java™ code.

4. Save the custom code and the test.

You can click View Code to edit the Java™ class later.

Exemple
The following example is a sample custom class that demonstrates how to configure a custom end policy for the

internet time protocol:

package test;

import java.text.DateFormat;
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import java.util.Date;
import java.util.TimeZone;

import com.ibm.rational.test.lt.execution.socket.custom.ISckCustomReceivePolicy;
import com.ibm.rational.test.lt.execution.socket.custom.ISckReceiveAction;
import com.ibm.rational.test.lt.kernel.services.ITestExecutionServices;

[ *x

* Custom receive policy CustomReceive_TimeReceiver.

* For javadoc of ITestExecutionServices, select 'Help Contents' in the Help menu and select

* 'Extending HCL OneTest™ Performance functionality' -> 'Extending test execution with custom code'
x/

public class CustomReceive_TimeReceiver implements ISckCustomReceivePolicy {

// static {
// static blocks are called once on each run and allow for example to bind
// to an external dynamic library

/1}

ISckReceiveAction receiveAction;
ITestExecutionServices testExecutionServices;

public CustomReceive_TimeReceiver() {
// The constructor is called during the test creation, not at the time of the execution of
// the customized receive action

3

public void setup(ITestExecutionServices tesRef,
ISckReceiveAction receiveActionRef) {
testExecutionServices = tesRef;
receiveAction = receiveActionRef};

}

public boolean onRead(int readByte) {
// TIME protocol (RFC 868): a connected server returns 4 bytes and closes the connection
// Those 4 bytes are the number of seconds since 1900/1/1
// The test is simply made of a connection to one TIME server on port 37
// (public servers are listed here: Got time server host name from
http://tf.nist.gov/service/time-servers.html),
// Then a receive delegated to this custom code class,
// Then a close
try {
if (readByte == EndOfStream) {
/* In case of success: *x/
receiveAction.receiveSuccess();
String message = extractAndCheckTime(receiveAction.getConnectionHolder ().getFinallyReceivedBytes());
/* A message is appended in the Test Log just after this receive action: */
testExecutionServices.getTestLogManager () .reportMessage(message);
return true;
}
} catch (Throwable t) {
/* In case of exception: x/
receiveAction.handleException(t);
return true;
}
if (receiveAction.getConnectionHolder ().getCurrentlyReceivedBytesCount() > 4) {
/* Unexpected condition: x/
receiveAction.handleException(new Exception("Time protocol server returned more than 4 bytes"));
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return true;
}

/* We need further bytes to complete this receive */
return false;

}

private String extractAndCheckTime(byte[] bytes) {
// This is network order, i.e. big endian
long remoteTime = ((((long)bytes[0]) & Ox00000000000000ff) << 24) +
((((long)bytes[1]) & OxO000OEEEEOO0OOff) << 16) +
((((long)bytes[2]) & 0x00000000000000ff) << 8) +
(((long)bytes[3]) & 0x00000000000000ff) ;
// 1900 to 1970: a difference of reference, see RFC 868 and java.util.Date javadoc
remoteTime -= 2208988800L;
Date remoteDate = new Date(remoteTimex1000);
Date localDate = new Date();
DateFormat dateFormat = DateFormat.getDateTimeInstance();
dateFormat.setTimeZone(TimeZone.getTimeZone ("GMT"));

String message = "Remote time: " + dateFormat.format(remoteDate) + " GMT (TIME server is " +
receiveAction.getConnectionHolder () .getHostName() + ", port 37)\n" +
"Local time: " + dateFormat.format(localDate) + " GMT\n";

long diff = localDate.getTime()/1000 - remoteTime;
if (diff == 0) {

message += "-> No difference";

} else {

message += "-> Difference (seconds): " + diff;
3

return message;
3

Using custom code to manipulate data

You can write a custom Java™ class to manipulate data in a send element. This offers flexibility for injecting data in

test, but requires that you write your own Java™ class using the HCL OneTest™ Performance extension API.
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Before you begin
In some cases, complex methods of generating data are required to send specific content to the server. This can be

done by manipulating data with custom code.

To create a new custom code class:

1. In the test editor, select a socket send element.

2. Select Manipulate data with custom code and click Generate Code.
Result
This creates a Java™ class template that follows the HCL OneTest™ Performance extension API. The Java™
class in created in the sr ¢ folder of the current project.

3. Write the custom code by extending the generating class. See Extending test execution with custom code on
page for more information about extending HCL OneTest™ Performance with Java™ code.

4. Save the custom code and the test.

You can click View Code to edit the Java™ class later.
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Editing Kerberos tests

You can change the Kerberos realm, user name, and password when editing tests.

1. In the Test Navigator, browse to the test, and double-click the test name. The test opens.

2. Click the Security tab.

3. Expand Kerberos.
To edit the Kerberos information in a test, Enable Kerberos authentication must be selected.

4. Edit the Kerberos client realm name, client key distribution center (KDC), user name, and password as
necessary.
Result
The realm name, user name, and password are used for all Kerberos connections and requests in the test.

5. Select Server is in a different realm than client to edit the server realm name and server KDC if the server is in
a different realm than the client.

6. Optional: Click Edit krb5.ini, and then type a realm name, to edit the Kerberos configuration file.

What to do next
Kerberos user names and passwords can be associated with a dataset. See the related topic on providing tests with
variable data to learn more about datasets.

Related information

Providing tests with variable data (datasets) on page

Adding test elements

You can add a variety of elements to a test, such as transaction blocks, IF-THEN conditions, loops, and comments.

Adding a comment

You can add a comment to document a test.

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.
2. In the test, select the item that you want to comment.
3. Click Add and then click Comment.
Result
The comment icon is placed before the selected item and the Comment text field opens.
4. Add the comment to the Comment text field. The comment is added to the test.

Adding a transaction to a test

A transaction is a specific group of test elements whose performance you are interested in. When viewing the test

results, you can view performance data about any transactions that you have added.
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To put a group of test elements into a transaction:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. In the test, select the test elements to group together. Use Shift+click to select multiple contiguous elements;
use Control+click to select multiple noncontiguous elements.

3. Click Add (to place the transaction after the selected element) or Insert (to place the transaction immediately
before the selected element or block), and click Transaction.

4. You are prompted whether to move the selected objects into the transaction. Click Yes or No.

5. Optional: In the transaction details, you can give the transaction a meaningful name. This is useful in the
Transactions report, which lists transactions by name.

Adding conditional logic

You can add IF-THEN conditional logic around portions of a test/compound test or a A schedule, in this context, is
used to refer to both VU Schedule and Rate Schedule. to make those portions run if a specific condition is met.

Before you begin

A conditional block can run portions of a test depending on the value of a reference or field reference. The reference
or field reference must exist in the test and precede the conditional block. If the reference or field reference that the
conditional block uses for input does not exist, you must create the reference as explained in Creating a reference or

field reference on page 450.
About this task

The test might already contain the test elements that are to be run. If the test does contain the elements to be run,
you must select the requests in step 2 of the procedure, and click Insert. The following instructions explain how to

add a conditional block that contains such requests.

Otherwise, you can create an empty conditional block at the end of the selected item (test or request). Click the
object, and then click Add.

1. In the Test Navigator, browse to the test and double-click it.

Result

The test opens. You can also open a compound test or a schedule.
2. Click a page or page request.

The conditional block is inserted before the selected item. By completing step 5, you can move the selected

items into the block.

3. Press Shift or Ctrl when clicking to select multiple pages or requests to be moved into the block.
In step 6, if you add an Else block, you can select one or more of these items to be moved into the Else
branch.

4. Right-click the item and select Insert > Condition (IF).
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Result
A prompt Would you like to move selected objects into the new IF? is displayed.
5. Click Yes or No.
Result
The If block is inserted into the test. If you click Yes, as shown in the example, the items that you selected are
moved under If in the Test Contents area. The following example shows an If block with an HTTP test.

Test Contents Test Element Details
This section shows the test contents Conditional (IF) Blodk
Enter filter text optons +  Condition

Type the text to compare or select & data source object from the list

E:
= % Browse A Add
(1. Test Variables = First operand: |true |
+- Lt HomeP, -Lnsert
¥ ﬁ LCII'I-'IE 2= Selected data type: Aa text value
B Home [Csekect ]
Select
#-l# . HomePageAfterLogin - Operator: |Equals vl
| ”
-l Coleus Selected data type:  Aa text value
H-Led . Flowers2 ]
Lo opdions
+ Lt Flowers3 [Cmegate the operator (NOT{op))
#-lgl. Fruitsaveg [¥] Case-sensitive comparison
+-Led . Grapes
[z Fruits&Veg2 If the condition above evaluates to "rue” execute:
#-lei. Strawberries H el Coleus
+ Ll Trees H -l Flowers2
+-Led. Crabapple H-Led . Lily
+Lel . Accessories

6. To add an Else block:

a. In the Test Contents area, under If, select the items to be moved to the Else block. Press Shift or Ctrl
when clicking to select multiple items.

b. Right-click and select Insert > Condition (IF) - ELSE Block.
Result

A prompt Would you like to move selected objects into the new ELSE? is displayed.

c. Click Yes or No.

Result
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The Else block is inserted into the test. If you click Yes, as shown in the example, the items that you
selected are moved under Else in the Test Contents area and into the Else field in the Test Element
Details area. The following example shows an If-Then-Else block with an HTTP test.

Test Contents Test Element Details
This section shows the test contents Conditional {IF) Block
Enter filter text Options = Condition

Type the text to compare or select a data source object from the list

E:
-, Test Variables Firstoperand:  [true |
5 L1 Home? [ipsert
- ﬁ Lon.we =ae - Selected data type:  Aa text value
2 v [Cseect ]
Select
+[#1. HomePageAfterLogin - Operator: |ECIUE||5 v|
| e
* Li Ve Second operand: |t'ue |
=== Then Selected data type:  da text value
513 Coleus _
5[ Flowers2 Options
=)-Ee Hle [negate the operator (NOT(op))
-l Lily [¥] Case-sensitive comparison
4L, Flowers3
[ Fruitsaveg If the condition above evaluates to "true” execute:
+-lg. Grapes H- e, Coleus
+-[1. Fruitsfveg? #lg . Flowers2
+-Le. Strawberries
g Trees
4L Crabapple
T A
+-led. Accessories Elea
H-Led . Wheelbarrow 2 . i
#-171. Shopping {3} o
+-Lel. Pot

7. In the Test Element Details area, under Condition, add conditions:

a. Next to the First operand field, click Data Source, and then select a data source to be compared with

the string in the Second operand field, or type a value in the First operand field.

. In the Operator field, indicate the basis of comparison of the two operands.

Note that the two operands are strings.

Starting from 9.1.1.1, you can use the Matches regex operator to match the operands. Click Verify to
verify whether the regular expression finds a match in the data source. If there is a match, the Verify

button is disabled. If there is no match, a message is displayed. If the regular expression is invalid, a

message is displayed for that also.

. Next to the Second operand field, click Data Source, and select a data source to be compared with the

First operand, or type a value in the Second operand field.
When the defaults are used (both operand fields set to t rue and the Operator field set to Equal s), the

block is always processed.

8. In the Test Element Details area, under Options, choose the required comparison type by selecting or clearing
the check boxes.
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Synchronizing users in tests

By inserting a synchronization point, you can coordinate the activities of a number of virtual users by pausing and
resuming activities. You can synchronize all virtual users at the beginning of a test and stagger the release times so
that the users do not overload the system. Synchronization points are also useful in stress testing.

About this task
You can insert a synchronization point into a schedule or a test. You typically insert synchronization points into
schedules, because they are more visible at the schedule level and you can set the Release and Timeout options

within a schedule only, not within a test. However, in the following cases, insert a synchronization point into a test:

« You must control where the synchronization point is encountered. For example, you can insert a
synchronization point just before a test sends a request to a server.

* You have edited a test, and the execution of a synchronization point depends on the logic that you have
added.

Synchronization points within loops are not reset. In other words, after a synchronization point has been released (in
the first iteration of a loop), the synchronization point stays released for all further iterations.

To insert a synchronization point into a test:

1. In the Test Navigator, browse to the test, and double-click it.
Result
The test opens.

2. Click the test element just below the place to add the synchronization point, and then click Insert >
Synchronization point. Depending on the nature of the test element, you can insert a synchronization point at
some points in the test hierarchy but not at others.

3. Type a name for the synchronization point, or select the name of an existing synchronization point.

Result

The synchronization point opens in the test. Note that Release Type and Timeout are not available for
synchronization points in tests. Release Type and Timeout are available only for synchronization points in
schedules.

4. To change the Release Type or Timeout, open the synchronization point within a schedule, and make the

changes. The changes affect all instances of the synchronization point.

Adding a loop to a test

You can define part of a test as a loop that runs a specified number of times. If the loop contains a synchronization
point, the synchronization point is released after the first iteration of the loop and stays released for all further

iterations.

About this task

You can set a loop within a schedule or a test. The following table shows the advantages of both methods:
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Loop
loca-
tion Results

Sched- Loops in schedules are easy to locate and modify.Loops in schedules close the server connection at the end
ule of each iteration and reopen it at the beginning of the next iteration. This action models the behavior of a

user closing and reopening a browser. Use this method to run a test at a set rate.
Test Loops in tests can be more granular, and thus provide a higher level of control.
Loops in tests reuse the server connection during each loop iteration.

Use this method, with loops that have high iteration counts, to stress test a server.

1. In the Test Navigator, browse to the test, and double-click it.
Result
The test opens.
2. Click the page or the request that will be inside the loop.
Press Ctrl when clicking to select multiple pages or requests.
3. Click Insert, and select Loop.
4. You are asked whether you want to move the selected elements into a the loop. Click Yes.
If you click No, an empty loop is inserted into the test.

5. In the Loop Details area, type the number of iterations for the loop to repeat.

Option Description
Count-based Runs for the number of iterations that you select.
Time-based Runs for at least the time that you specify. The loop

always finishes the iteration. For example, if you
select a time of 1 second and a loop takes 10 sec-
onds to run, the loop finishes one iteration, and then
checks the time.

Infinite Runs until the test stops.

6. Optional: Select Control the rate of iterations, and type your preferences for the pacing rate.
In specifying a number of iterations for a unit of time, you set a fixed period for the iterations to complete. If
you select Randomly vary the delay between iterations, the total delay is randomly distributed. If you clear this
check box, the same delay occurs between each iteration.

Note: Statistically, the Randomly vary the delay between iterations option sets delay amounts at
random from a negative exponential distribution with the same mean as the fixed delay value. The
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negative exponential distribution has a long "tail," which means that a very small number of delays
will have very large values. Therefore, make sure that the application you are testing is not negatively
affected by long periods of inactivity (such as a timeout that disconnects the user).

Adding Dataset Mapper

You can include a Dataset Mapper in a compound test or a schedule to assign the dataset values to the variables that
are defined in multiple tests. In previous releases, to apply the dataset values to multiple tests, you had to associate
the dataset to each test. The Dataset Mapper is able to map the dataset columns with the variables.

Before you begin
You must have created at least one dataset. See Creating a dataset in a workspace on page 392.

About this task

For the Dataset Mapper to fetch the test variables, in the Variable Details section of the Test editor, you must set the

Visible In field for the variable to All tests for this user. You can also fetch the variables from the custom code calls.

If the compound test or the schedule includes a Dataset Mapper that retrieves values from one dataset and a test in

the compound test or schedule is also associated with another dataset, the run uses both the datasets.

Note: When you run the schedule or compound test with a Dataset Mapper, by default the test picks up the
dataset values from the first row. For the test to pick up all of the dataset values, you must put the test in a
loop.

1. In the Schedule or Compound test editor, click Add > Dataset Mapper.

2. In the Select Dataset dialog box, select a dataset to use for the tests and click OK.
To change the dataset after it is associated, in Dataset Mapper Details, click Browse and select another
dataset.

3. Select whether the test will make the data in the dataset record permanent for each virtual user.

By default, one row is retrieved from the dataset for each execution of a test, and the data in the dataset row
is available to the test only for the duration of the test. Select Fetch only once per user to specify that every

access of the dataset from any test being run by a particular virtual user will always return the same row.

To illustrate how these options affect the rows that are returned, assume that a test contains a loop which

accesses a dataset. The loop has two iterations. The following table shows the row that is accessed in each

iteration:
Dataset option Iteration 1 Iteration 2
Sequential and Private row 1 row 2
Shared and Shuffled row X row y
Fetch only once per user row X row X
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4. In the Columns mapping table, the Column is automatically filled with the column names from the dataset.

5. To use the variable names from the test, click the cell and click the Ellipsis button I—I and select the variable.
By default, the variable names are also created with the same names as the dataset columns.

6. If the dataset that you selected in step 2 was generated by HCL® OneTest™ Data, you can choose to update
the data by clicking Update dataset or update the data automatically for every run by selecting the Update
dataset during deployment check box.

7. To fetch all the dataset values, put the Dataset Mapper in a loop. Select the Dadtapool Mapper in the schedule
and click Insert > Loop.

8. Save the changes.

Adding data source controller

Use this test element to control how the data is fetched from the data sources to be used by the test. You can use

data from dataset, array variables, built-in data sources, and correlation.
About this task

In the Test editor, the pages/requests succeeding the data source controller makes use of the data source associated
to the controller. So, if there are 3 pages in your test and the first controller is placed before the first page and the
second controller is before the last page, the first two pages use data associated with the first controller. The last

page will use data associated with the second controller.

1. In the Test editor, select the pages for which you want to substitute data and click Insert > Data Source
Controller.

2. Select the data source from where you want the succeeding pages to pick data and click Select.
Result
The data source controller is added to the test.

3. In Data Source Controller Details section, select Increment for the test to automatically pick the next value
from the data source or select Reset to pick the first available value from the data source.

4. Optional: To change the data source, click Data Source and save the test.

Controlling the flow of test

A test is usually run in the order it was recorded. However, you might want to add some conditions to the test that the
users would actually face when interacting with the application under test. For example, if you select a product, you
want to know its manufacturing date. If the date is not available, you want to exit. You can now add such control to
the test.

1. In the Test Navigator view, browse to the test and double-click it.
2. Select the request or page that uses the IF condition and click Insert > Test Flow Control.

3. In the Test Flow Control Details section, specify one of the following actions:
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Action

Description

Continue

Continue running the test.

Exit Transaction

Exit the transaction and continue running the test.
If there are multiple levels of transactions, specify
whether you want to exit the innermost or outermost

transaction.

Exit Loop

Exit the loop and continue running the test. If there
are multiple levels of loops, specify whether you

want to exit the innermost or outermost loop.

Continue to next iteration of loop

Continue to run the next iteration of the loop after the

existing iteration completes.

Exit test

Exit the test.

Exit user

Exit the currently running virtual user and start run-
ning with the next user.

Terminate Run

Stop the A schedule, in this context, is used to refer
to both VU Schedule and Rate Schedule..

Searching within tests

Search request data or response content by right-clicking in the data or content and selecting Find. To search for

specific element types and to display the results in a table, click Select. For a still more powerful search and replace,

use the Test Search function.

About this task

You can use a number of different methods to search within a test.

« Use the Find option to search within the Test Details area and, optionally, to replace text.

« Use the Select button to search within the Test Contents area and display a table of like test elements.

« Use the powerful Test Search function to search within the Test Contents and the Test Details areas. For

example, you can search for a type of verification point and also declare whether the result should include

enabled verification points, disabled verification points, or verification points in both states. The specific data

that you can search for and the search options are protocol-dependent.

Locating specific types of test elements

A test script can include multiple requests and responses with many test elements and attributes. To locate elements

of a specific type in the Test Contents area, click Select. The results are displayed in a table, and you can sort the

table columns. This option is also useful for viewing attributes of test elements that are the same type.
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1.

N o o b

In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

. To restrict the search to specific instances of elements, select them in the test. For example, you might want

to search for text in specific responses, rather than in all responses.

. Click the test editor tree to give it focus, and then click Select.

Result

A list of element types opens. This list is generated dynamically based on the contents of the test. For
example, if a test does not contain verification points, they are not listed.

. Conneckion

. HTTP Page

1
2
3, HTTP Request
4, Respanse
5
f

. Sek Wariable
. Wariable

se Filker Text
Restrict To Highlighted Elements

Collapse all

. To include only the elements that you selected, select Restrict To Highlighted Elements.

. Toinclude only the elements that contain specific text from the Test Contents area, select Use Filter Text.
. Select the type of test element to view from the list.

. If you selected Use Filter Text, enter the filter text in the prompt, and then click OK.

To use regular expressions in the filter text, click the Search Options icon to the right of the prompt, and then
select Regular expression. By default, if Regular expression is not selected, the asterisk (*) and question mark
(?) are interpreted as wildcard characters. To search for a URL that contains an asterisk or question mark, type
a backslash (\) before the asterisk or question mark.

Results

The Test Element Details area displays the results under the heading Multiple Items.

Exemple

The following example shows results for an HTTP request. Other protocols might display less detailed information.

Double-click a table row to locate the element within the test.



Test Element Details

Mulkiple Items

A

=i URL Delay A0 REsponse Size
WGET ween,ibrn, com)f 0 ms. 302 - Found 206 i
GET  www.ibm.com/us, 0 ms. 200 - QF;, 31,455
GET v, ibm.comfcommonyv16/hpfisth... 0 ms, 200 - K 5,742
GET  wwen.ibm.comjfcommon/v16fcssfall.css 0 ms, 200 - OF 138
GET s, ibm, comfcommon)v16/cssfscr,., 0 ms, 200 - QF;, 13,183
GET s, ibm, comfcommonv16/cssfscr,,. 156 ms, 200 - OF 099,371
GET v, ibm.comfcommonfv16fcssfus/,..  0ms, 200 - K 15,847

Searching and replacing text in tests
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With the Test Search function, you can search for text in a test or search within specific test elements and optionally

replace the found text.

1. In the Test Navigator, browse to the test and double-click it.

Result

The test opens.

2. Right-click the test name, and then select Test Search.

3. In Search for text, type the text to locate.

You can leave this field blank, depending on your search strategy. For example, if you know that a string

occurs in elements or element instances that you are not interested in, by using the options described in steps

4, 6, and 8, you can locate the elements or element instances of interest before entering the search text into
this field.

4. If you have selected pages or requests within the test, click More Options, and then select Restrict search to
elements highlighted in Test Contents.
This restricts the search to the selected pages and requests.

5. To perform a case-sensitive search, select Case sensitive. To search with regular expressions, select Regular
expression.
In regular expression mode, press Ctrl and type a space in Search for text for content assistance. Content
assistance lists the regular expression patterns and the content that they match.

6. To highlight found elements in the Test Contents area, click More Options, and then select Highlight found
elements in Test Contents.
You can use this option with the option that is described in step 4 to designate the element instances of
interest before specifying the text of interest.

7. To have the search include children of the selected element, click More Options, and then select Recursive.
This option is selected by default. If Recursive is cleared, then only the selected element is searched.

8. To have the search locate both encoded and decoded versions of the specified text, click More Options, and
then select Match encoded and decoded values.
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10.

11.

12.

13.
14.

This option is selected by default. The type of encoding that the search supports varies depending on the
protocol.

Example

For example, when searching in HTTP data, abc%.23 and abc%25123 match.

. In the Elements to search list, select all test elements to search.

Selecting the check box in step 4 restricts the elements that you can select in this step to the instances that
are selected in the Test Contents area. For example, if you select HTTP Pages here and only one page is
selected in the Test Contents area, only that page is found. If the check box in step 4 is cleared, every test

page is found.

Optional: Click selected elements to define how to search them.
A new area opens, where you can define how to search a selected element.

To locate items, continue to the next step. To replace found strings, click Replace, and go to step 12.

Click Search.
Result
The results of your search are displayed in two views
o The Search view, which lists the objects that contain matches
> The Test Search Match Preview view, which displays the matches that were found
In the Search view, complete any of these search actions:
> To preview a found string in the Test Search Match Preview, click the object.
> To open your test at the location where an instance is found, double-click the object.
- To perform a different search action (such as proceed to the next match or previous match, replace),
right-click the object, and select your choice.
If you clicked Replace in step 9, the Replace window opens. In the With field, type the replacement text.
Select the replacement action by clicking the appropriate push button.
Result
If you are making selective replacements, found instances are displayed in the same order as in the Test
Search Match Preview view. Click Replace or Skip until all found instances have been displayed.

Exporting a test

To share the test scripts with manual testers or reviewers who do not have the workbench, export the test scripts to

text files. You can export one file at a time.
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1,
2.
3.
4,

In the Test Navigator view, double-click a test.

In the test editor, right-click the root node of the test and click Export Contents to File.

Select a project and specify the name of the file to export to.

To add a separator between two steps or lines, select the Add line separators after each step check box and

click Finish.

Results
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The text file opens on another tab in the workbench and is saved in the directory it is exported to.

Copying test assets with dependencies

You can export test assets, and then import them into another project or workspace without losing any dependencies.
Test assets include projects, schedules, and tests. You can export and import test assets to collaborate with other

testers.

Before you begin
If you plan to export assets with dependencies, make sure that you have migrated the test assets to the current
version of the product before you start to export.

About this task

When you copy a test with dependencies, any datasets or custom code referred to by the test are also copied. When
you copy a schedule with dependencies, any locations or tests referred to by the schedule are also copied. When you
copy results, any schedules or tests referred to by the results are copied.

1. In the Test Navigator view, right-click the test assets to export, and then click Export.
You can export projects, schedules, tests, and test results with dependencies.

2. In the Export window, expand the Test folder, and then click Test Assets with Dependencies.
You can export test assets with dependencies if the test assets were created in the current version of the
product. You cannot export test assets with dependencies if the test assets were created in a previous version
of the product and the assets have not been migrated to the current version of the product.

3. Click Next.

4. Specify the path and name of the archive file into which you want to export the selected test assets.

5. Click Finish.
The assets are exported to the archive file. You are prompted if the total size of the test assets is larger than 4
GB, or if any individual test asset file is larger than 4 GB. To copy test asset files that are larger than 4 GB, copy
the files manually.

6. If the target workspace is on a different computer, transfer the archive file to a location that is accessible to
that computer.

7. In the Test Navigator view, select the test project into which you want to import the test assets.
The target project must have the same name as the source project. Optionally, you can import test assets with
dependencies into a workspace where no projects exist. If you import test assets with dependencies into a
workspace where no projects exist, the Import wizard creates projects based on information from the archive
file. To import test assets into a project with a different name, you must first import the test assets into a
project with the same name, and then manually move the assets into the project with the different name.

8. Click File > Import.

9. In the Import window, expand the Test folder, and then click Test Assets with Dependencies.

10. Click Next.
11. In the Import with dependencies window, click Browse, and then select the archive file.

The test assets are displayed in the File contents list.

12. Click Finish to import the test assets with dependencies from the archive file into the target project.
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If a file that you are attempting to import already exists in the target workspace, you will be prompted to
choose whether to overwrite the file. You can also choose to overwrite all files that already exist in the target
workspace, or not to overwrite any files that already exist in the workspace. If you choose to overwrite all
files that already exist in the target workspace, you will be prompted again if the import process encounters a

.cl asspat hor. proj ect file in the source archive file.

Copying projects

You can export a test project from a workspace and import it into another workspace.

About this task

If you export test assets to an archive file and then import them to another project, ensure that both project names

are the same. Otherwise, you might not be able to locate your imported test assets.

380

Note: You can also export the test project with all the dependent assets in to an archive file. See Copying test

assets with dependencies on page 379 for the instructions.

. Start HCL OneTest™ Performance, and select the source workspace.

. Export the test project to an archive file.

For instructions, see Exporting resources to an Archive file. Datasets can be located either in the same project
as the tests that use them or in different projects. Be sure to export all the datasets that the exported tests

require.

. If the target workspace is on a different computer, transfer the archive file to a location that is accessible to

that computer.

. Start HCL OneTest™ Performance, and select the target workspace.
5. Click File > Import. Expand the General folder, and click the Existing Projects into Workspace icon; then click

Next.

. Click Select archive file, and then click Browse to select the archive file. Click Finish to import the source

project from the archive file into the target workspace.

. Optional: If the imported project contains custom code or tests that have been run, you might need to change

the Java™ build path.
The following examples are cases that might require a change to the Java™ build path:
> The Java™ build path was manually changed in the project from which it was exported. In this case,
the same changes need to be made in the imported project. While importing, you are asked whether to
overwrite the class path file, which stores the Java™ build path for project. Answering Yes reduces the
likelihood that the build path will need to be changed.


http://help.eclipse.org/juno/topic/org.eclipse.platform.doc.user/tasks/tasks-59ag.htm
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> The project was imported onto a different computer with a different Java™ installation configuration.
In this case, missing libraries must be removed from the build path.

> The project was imported into a workspace on a different disk drive. When you are asked whether
to replace the class path file, answering No reduces the likelihood that the build path will need to be
changed.

For instructions on changing the build path, see the Java™ Build Path page.

What to do next

If you encounter errors after importing a test project or when using an existing workspace with a new version of the

product, you might need to delete .java files from the sr ¢ folder in the workspace:

1. Click Window > Open Perspective > Resource to open the Resource perspective.

2. In the Navigator window, expand the test project folder, and locate the sr c folder.

3. Delete all .java files in the sr ¢ folder, except for those that contain custom code.

4. Return to your test perspective: Click Window > Open Perspective, and select Performance Test (or Service
Test, if you are using Rational® Service Tester).

Disabling portions of a test

When you disable portions of a test, you can still see the disabled portion, but it is not executed during a run. You can
also disable portions of a schedule by using the following procedure.

About this task

To disable secondary HTTP requests, see Disabling and enabling secondary HTTP requests on page 289.

To disable an element:

1. In the Test Navigator, browse to the test, and double-click it.
Result
The test opens.
2. Right-click the element that you want to disable, and select Disable.
The element and the dependent child elements, which are disabled automatically, are shaded and preceded by

two forward slashes (/ /) to remind you that they are disabled.

Note: To change the color or symbol that represents disabled elements, click Windows > Preferences

> Test > Test Editor, and then click the Colors and Fonts tab.

Result
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Although a disabled test element does not run, you can still work with it. For example, you can insert a test

into a disabled user group for later use.

3. To enable a disabled element, right-click it, and select Enable. Select Enable All to enable all disabled

elements.

Exemple

Disabling an element affects other elements in the following ways:

Disabled element

Result

User group (percentage)

The percentages in the remaining user groups are recal-
culated. When you enable the user group again, remem-
ber to return all of the affected user groups to their origi-
nal percentage.

User group (absolute)

The number of users in the remaining groups might not
match the total number of users specified in the sched-
ule. If so, new virtual users are redistributed among the
remaining user groups so that the numbers will match.
When you enable the user group again, remember to re-

turn all of the affected user groups to their original totals.

Request or step that contains a data correlation refer-

ence

Substitution in the remaining actions that depend on this

request does not work.

Request or step that contains a data correlation substi-

tuter

Substitution does not occur because the entire action
is omitted. The substituter that uses the disabled data
source is also disabled. To re-enable the substituter, se-
lect an enabled data source for substitution.

HTTP request that contains a server connection

No effect. The connection is automatically created in the

next request.

Portion of custom code

Custom code with disabled arguments is flagged. If the
disabling causes an unexpected number of arguments
passed to custom code elements, you receive an error at
runtime. To fix this, modify the custom code to check the

number of arguments.

IF data_source construct

An IF construct is marked as invalid if it contains a dis-

abled data source.

Test element and child are disabled

If you disable a child element and then disable its parent
(for example, a request and then a page), the disabled
child element will have two prefixes: one created manu-

ally and one inherited. In the following example, the first
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Result

request has inherited the disabled state. The second re-
quest has been manually disabled and has also inherited
the disabled state:

//disabled page
//request
////disabled request

Do one of the following to re-enable the second request:

» Re-enable the request, and then re-enable the

page.
« Right-click the page and select Enable All.

A data source or a range of text that will be replaced

Running test elements in random order

The Data table displays this text in gray.

You can record multiple user scenarios in a test and then run each scenario in a random order. To do this, you put

each scenario under a random selector and then select the proportion of time that the scenario should be run.

About this task

For example, you can record a test that includes logging on to a system, browsing through items in the system, buying

various items, and then totaling the order. In this case, you could run the logging in and the totaling scenarios once,

but put the browsing and buying scenarios under a random selector.

1. In the Test Navigator, browse to the test and double-click it.

Result

The test opens.

2. Click the test element that will be controlled by the random selector, and then click Insert > Random Selector.

Use Shift+Click to select multiple elements.

3. You are asked whether you want to move the selected elements into a new random selector. Click Yes.

Click No to insert an empty random selector into the test.

Note: To set whether or not elements are moved automatically, or whether you are prompted, click

Window > Preferences > Test > Test Editor, and click the General tab.

4. Set the weight of the random selector. The weight determines the statistical probability that a specific element

will be selected.
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a. If you have added a number of test elements, the Create weighted blocks window is displayed. You
can select adjacent elements and group them. Each element—whether in a group or by itself—must be
weighted.

b. If you have added only one test element, the weighted block is displayed in the Test Element Details

area with a default of 1.

Exemple
When a selector contains many different weights, you can mathematically determine the likelihood that a block will be
executed. To do this, add the weights together and divide the weight for each block by that total.

For example, assume a selector contains six blocks set to the following weight:

- two blocks set to a weight of 1
- one block set to a weight of 2
« two blocks set to a weight of 5
« one block set to a weight of 9

The total of the weightsis: 1+ 1+ 2+ 5+ 5+ 9 = 23. Therefore, the statistical likelihood of selection is:

Weight of block Likelihood of block being selected
1 (two blocks) 1/23. = 0.0435, or about 4.35% (for each block)
2 2/23 =0.0870, or about 8.70%
5 (two blocks) 5/23 = 0.2174, or about 21.74% (for each block)
9 9/23 =0.3913, or about 39.13%

Note that a higher weight increases the likelihood, but does not guarantee, that a block will be executed. Some
variation might occur. For example, if you run a test 23 times, you cannot predict that the first and second blocks will
execute exactly once, the third block exactly twice, the fourth and fifth blocks exactly five times, and the sixth block

exactly nine times. However, the more times that the blocks are executed, the more accurate this prediction is.

Renaming test assets

As your test assets increase and become more complex, you might want to rename them. Use the Eclipse Rename

function or save the assets under a different name.

Use either of the following steps to rename a test asset:

1. When you use the Eclipse Rename function, the new name is visible in the Test Navigator, but the underlying
file system name is not changed. To use the Eclipse Rename function:

a. In the Test Navigator, right-click the test asset, and then select Rename

b. Type the new name, and then click Enter

Be sure to click Enter, or the file will not be renamed.
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2. When you rename a test asset by saving it under another name, the underlying file system name is changed,
but you must perform manual cleanup. To save a test asset under another name:
a. In the Test Navigator, browse to the test and double-click it. The test asset opens.
b. Click File > Save As, and save the asset under a different name.

c. Delete the original asset.

Exemple
The following table summarizes how renaming an asset affects the other assets in your workspace.

Renamed asset Effect on other assets

Project Do not rename a project. Renaming a project might result

in lost or corrupted project assets.

Schedule Renaming a schedule has no affect on other assets, but

note that results cannot be renamed.

Test When you use Rename, schedules that contain the old
test name will still run correctly. To avoid confusion,

manually update the schedule to use the new test name.

After you use Save As, manually update each schedule

that uses the renamed test.

Custom code If you rename the custom code class (java file), then
the reference to the class in the custom code action of
the test will not work. Typically rename the custom code
class in the Resource perspective or the Java™ perspec-

tive.

If you change the name of the custom code class in the
test editor that implements the custom code action, the
modification does not change the corresponding .java
file; instead the modification causes the custom code
action to refer to a different (and possibly new) custom

code class.

Dataset When you use Rename and open a test that contains the
dataset, you are prompted to save the changes (in this

case, the renamed dataset that the test now uses).

After you use Save As, manually update each test that

uses the dataset.

Location When you use Rename, locations (agent computers) are

automatically updated in the schedules that use them.
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Renamed asset

Effect on other assets

When you use Save As, manually update each schedule

that uses the test.

Results

You cannot rename results.

Weighted block

Deleting test assets

Renaming a weighted block has no affect on other as-
sets. To rename a weighted block, click the block in the

test, and type the new name in the Name field.

As your test assets grow and become more complicated, you might want to delete the assets that you no longer use.

In the Test Navigator, right-click the test asset, and then select Delete.

Result

The following table summarizes how deleting an asset affects the other assets in your workspace.

Note: If you are deleting a test asset, you can choose to delete it from other test assets that refer it and you

can choose to delete other test assets that are referenced only by the test asset that you are deleting.

For example, if you delete a dataset, the Remove references to test asset name in other test assets option

lets you delete the dataset from all the test assets that uses it.

If you delete a test, the Delete files that are referenced only by test asset name option lets you delete all the

test assets such as recsession and dataset that are referenced only by the test that you are deleting. If the

dataset is used by another test too, it will not be deleted. The Preview button lets you see the assets that are

referenced by the test.

Deleted asset

Effect on other assets

Project

You are prompted whether to delete the project contents.
If you click Yes, the contents are physically deleted. If you
click No, you will not see the contents in the Test Navi-
gator, but the project remains in your workspace, which
is, by default, C: \ Docunent s and Settings\user-
nane\ __VENDOR NAME__\  SDP_FULL_SHORT-
NAME__n. n/ wor kspace).

Schedule

Deleting a schedule has no effect on other assets.

Test

If you delete the test in the Test Navigator, the test is
physically deleted.
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Deleted asset Effect on other assets

If you open a schedule and delete a test, the test is delet-
ed from the schedule, but the test remains available as a
test asset.

Custom code If you delete the custom code class (.java file), then the
reference to the class in the custom code action of the
test will not work. Typically you delete the custom code
class from the Resource perspective or the Java™ per-
spective.

If you delete the name of the custom code class that im-
plements the custom code action, the deletion does not
change the corresponding .java file.

Dataset If you delete a dataset in the Test Navigator, the dataset
is physically deleted. When you open a test that uses the

dataset, you are prompted to take one of these actions:

« Locate the dataset
- Remove the dataset reference from the test

« Leave the invalid reference in

You must correct or delete the reference to run the test
successfully.

If you open a test and delete the dataset from the Com-
mon Options tab, only the reference to the dataset is
deleted.

Location You are not asked to confirm the deletion, nor are you
warned if a user group uses the location. The user group
is marked with a red x when you open the schedule that

contains it.

Results You are asked to confirm the deletion, and the results are

physically deleted.

Debugging custom code for tests and compound tests

If you have custom code added to a test or a compound test, you can debug the custom code for any errors by

clicking the Debug button.

Before you begin
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This procedure can only be done when custom code is part of a test or compound test. If there are multiple custom

code classes added to a test or compound test, the debug action debugs all the custom code classes.

You can use the debug option only in full Eclipse mode of the product. You cannot debug in the streamline mode.

1. Open a test or a compound test from the Test Navigator view.
2. Click the Debug button.
Result
The Debug view opens. If there are any breakpoints in the custom code, the test run pauses at the breakpoint.

Press F8 to resume the test run.

Providing tests with variable data (datasets)

You can produce more realistic tests by changing them to use datasets. During execution, a test that uses a dataset
replaces a value in the recorded test with variable test data that is stored in the dataset. This substitution allows each
virtual user to generate a different request to the server.

Dataset overview

Datasets provide tests with variable data during a run. When you record a test, you perform a sequence of steps that
you expect a typical user to perform. After the recording, a test is generated that captures these interactions. When
you run this test, it uses the same data that you used during recording. To vary the data in the test, you use a dataset,

that contains variable data. At run time, this variable data is substituted for the data in the recorded test.

If you need to create a dataset with many records, you can initialize the dataset quickly by importing data from a
comma-separated-value (CSV) file. Also, you can export test data from your dataset into a CSV file to enable you
to maintain large volumes of test data as a spreadsheet for reuse. Earlier to 9.5, the dataset (formerly known as
datapool) was in .datapool format and starting from the 9.5 release, the dataset is in the csv format.

You can copy the CSV file and paste into your project to import the data from a CSV file and create a dataset.
Similarly, to export the dataset values as a CSV file, you must copy the dataset from your project and paste it into your

local machine.

Note: Alternatively, you can use the Import option available in the CSV editor to import the data from a CSV
file. For more information, see Editing datasets on page 402.

Perform the following steps should you plan to create a test that searches the HCL® website for three items: HCL
OneTest™ Performance, HCL OneTest™ Ul, and IBM® Rational® Manual Tester:

1. Record a test that searches for one item. For more information, see Recording an HTTP test on page 156.
2. Create a dataset and associate it with the test. For more information, see Creating a dataset associated with a
test on page 389.
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3. Associate a request in the test with a column in the dataset. For more information, see Associating a test
value with a dataset column on page 400.

4. Add a loop in the test to fetch the values from different rows of a dataset. A test without a loop fetches the
value only from the first row of the dataset. For more information, see Adding a loop to a test on page 371.

Creating a dataset associated with a test

You can create a dataset that contains variable data for tests to use when they run. This is the preferred way to
create a dataset because the dataset is automatically associated with a test. You can create anything from an empty

dataset that contains one column, which you can edit later, to a fully functioning dataset.

1. In the Test Navigator, browse to the test and double-click it.

Result
The test opens.
2. In the Test Contents area, click the name of the test.

3. In the Common Options tab, click Add Dataset.

The options listed in the following table, enable you to create anything from a simple dataset that you can edit

later to a complete dataset.

To create

Do this in the Test Editor - Add Dataset window

A one-column dataset with a default access mode.

In Existing datasets in workspace, select New
Dataset<testname>.csv, and click Finish. You can op-
tionally name the dataset column in this session, and
you can add other columns and data later.

A one-column dataset and choose the access mode.

In Existing datasets in workspace, select New
Dataset<testname>.csv, and click Next. You can op-
tionally name the dataset column in this session and
you are prompted for the access mode. You can add

other columns and data later.

An association between the test and an existing

dataset.

Select the dataset. The dataset is associated with the
test, and you can optionally set the access mode in
this session.

A new, fully functioning dataset.

Select a project and click Use wizard to create new

dataset.

4. Select Open mode for the dataset. This mode determines the view that virtual users have of the dataset.

Different tests can open the same dataset differently, and you can change the open mode later by opening the

test and double-clicking the dataset title.
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Option

Description

Shared (per test execution) (default)

When you choose the Shared (per test execution) op-
tion, the virtual users running in the test share the

dataset values in sequential order.

For example, if your dataset has 10 rows, the dataset
values are taken from row 1, row 2, row 3, and so on
when you select this option.

Private

Virtual users draw from a private view of the dataset,
with dataset rows apportioned to each user in se-
quential order.

This option ensures that each virtual user gets the
same data from the dataset in the same order. How-
ever, because each user starts with the first row of
the dataset and accesses the rows in order, different
virtual users will use the same row. The next row of
the dataset is used only if you add the test that is us-
ing the dataset in a loop with more than one iteration.

Shared (for all test executions)

When you choose the Shared (for all test executions)
option, the virtual users running in multiple tests
share the dataset values from the current row.

For example, if your dataset has 10 rows and when
you set the current row as row 5, the dataset values
are taken from row 5 instead of row 1 when you se-
lect this option. If you had set the current row as row
1 and used the dataset values until row 5, the dataset
values are retrieved from row 6 when you run the test

next time.

5. If you are setting how the test accesses the dataset during this session, select one of the following options:
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- Sequential: The rows in the dataset are accessed in the order in which they are physically stored in the
dataset file, beginning with the first row and ending with the last.

- Random: The rows in the dataset are accessed in any order, and any given row can be accessed
multiple times or not at all. Each row has an equal chance of being selected each time.

- Shuffled: Before each dataset access, the order of the rows is changed, and a different sequence
results. Rows are accessed randomly but all rows must be selected once before a row is selected
again.

6. Select one of the following options.

Option Description

Wrap when the last row is reached
By default, when a test reaches the end of a dataset

or dataset segment, it reuses the data from the
beginning. To force a test to stop at the end of a
dataset or segment, clear the check box Wrap when
the last row is reached. Forcing a stop might be use-
ful if, for example, a dataset contains 15 records, you
run a test with 20 virtual users, and you do not want
the last five users to reuse information. Although the
test is marked as “Fail” because of the forced stop,
the performance data in the test is still valid. Howev-
er, if it does not matter to your application if data is
reused, the default of wrapping is more convenient.
With wrapping, you need not ensure that your dataset
is large enough when you change the workload by
adding more users or increasing the iteration count in

a loop.

Note:

> With Random access order, Wrap
when the last row is reached option is
unavailable because you never reach
the end of the row.

» With Shuffled access order, if you
select Wrap when the last row is
reached option, you resume select-
ing from the beginning of the row with

the same access order after each row

has been selected once. No more se-
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Option Description

lections are required if you clear the
/
Wrap when the last row is reached

option.

Fetch only once per user
By default, one row is retrieved from the dataset for

each execution of a test, and the data in the dataset
row is available to the test only for the duration of
the test. Select Fetch only once per user to specify
that every access of the dataset from any test being
run by a particular virtual user will always return the

same row.

Example

To illustrate how these options affect the rows that are returned, assume that a test contains a loop which

accesses a dataset. The loop has two iterations. The following table shows the row that is accessed in each

iteration:
Dataset option Iteration 1 Iteration 2
Sequential and Private row 1 row 2
Shared and Shuffled row X rowy
Fetch only once per user row X row X

7. If you are creating a fully functioning dataset, you can optionally import the data from a CSV file during this

session by copying the CSV file and pasting into your project. For more information on importing dataset, see
Editing datasets on page 402.

What to do next

After you have created a dataset and added data to it, the next step is to associate a value in the test with a column in
the dataset, as discussed in Associating a test value with a dataset column on page 400.

Creating a dataset in a workspace

You can create datasets in a workspace containing variable data that tests use when they run. You can use this
method to create a dataset if you have not yet created the test that will use it.

1. Click File > New > Dataset.

2. In the New Dataset window, click the project that contains the dataset. The project is displayed in the Enter,
create, or select the parent folder field.

3. In the Name field, type the name of the dataset, and then click Next.
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4. In the window for describing the dataset, add a description.
5. In the Dimensions field, specify the number of rows and columns for the dataset that you want to create.
6. Click Finish.

Results

The new dataset opens in a browser. For instructions on how to add data to or edit the dataset, see Editing a dataset

on page 402.

What to do next
After you have created a dataset and added data to it, you must associate a value in the test with a column in the

dataset.

Converting an existing datapool to a dataset

Starting from 9.5 the dataset formerly known as datapool is in the CSV format. You can convert any existing datapool

to a dataset.
About this task

When you open the workspace earlier to 9.5 in HCL OneTest™ Performance 9.5, the existing datapools in the

workspace are stored in the Datapools (Legacy-Unsupported) folder as shown in the following figure.

Ex, Test Navigator &2 S (gEE ¥ = 0
~ e Sample2
& Compound Tests
~ (@@ Datapools (Legacy - Unsupported)
~ [ Datasets
B sampledp1
Z Datasets
& IMeter Tests
2 Locations
(& Results
& Schedules
& Tests
=2 TestProject

To convert the existing datapool to a dataset:

1. In the Test Navigator, browse and select the existing datapool.
2. Right-click and select Convert to Dataset.... Verify that the name of the dataset is the name of the existing
datapool and format is .csv.

3. Click Finish. The converted datapool opens in a CSV editor.

What to do next
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After you have created a dataset and added data to it, you must associate a value in the test with a column in the

dataset.

Creating datasets with multiple substitutions

Earlier to 9.2, you could substitute one dataset value at a time. Starting from 9.2, after the test is generated, you
can view all the dataset candidates, add multiple candidates as dataset values, substitute values, and create a new
dataset out of it. You can also substitute multiple dataset candidates for an existing dataset.

About this task

When you substitute multiple dataset candidates to create a new dataset, the same number of columns are created
in the dataset. The names of the candidates become the names of columns and values in the dataset. When you
substitute multiple dataset candidates in an existing dataset, the column names in the dataset are retained. If

the number of substitutions chosen was greater than the number of columns in the dataset, the extra number of
substitutions are added as columns in the dataset. For instance, if a dataset has three columns and you substitute

five dataset candidates, two new columns are created by using the names of the dataset candidates.

To create a dataset from multiple dataset candidates:

1. In the Test Editor, select the name of the test and from the Test Details section, select Common Options and
click Show Dataset Candidates.
Alternative: After the test generation when you open the test, you are prompted that “Some test data may need
to be correlated or substituted”. If you click Yes, you can see the list of dataset candidates.

2. Select the dataset candidates that you want to add as values to the dataset and click Substitute multiple
candidates.
The Add Dataset dialog box shows the list of datasets that are in the project but not associated with the test.

3. To associate an existing dataset with the test and assign the selected dataset candidates as values and
substitutions, select a dataset and click Next. To associate a new dataset with the test, click the Use wizard to
create new Dataset and click Next.

4. Select Open mode for the dataset. This mode determines the view that virtual users have of the dataset.
Different tests can open the same dataset differently, and you can change the open mode later by opening the

test and double-clicking the dataset title.

Option Description

Shared (per test execution) (default)
When you choose the Shared (per test execution) op-

tion, the virtual users running in the test share the
dataset values in sequential order.

For example, if your dataset has 10 rows, the dataset
values are taken from row 1, row 2, row 3, and so on

when you select this option.
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Option Description

Private
Virtual users draw from a private view of the dataset,

with dataset rows apportioned to each user in se-
quential order.

This option ensures that each virtual user gets the
same data from the dataset in the same order. How-
ever, because each user starts with the first row of
the dataset and accesses the rows in order, different
virtual users will use the same row. The next row of
the dataset is used only if you add the test that is us-
ing the dataset in a loop with more than one iteration.

Shared (for all test executions)
When you choose the Shared (for all test executions)

option, the virtual users running in multiple tests
share the dataset values from the current row.

For example, if your dataset has 10 rows and when
you set the current row as row 5, the dataset values
are taken from row 5 instead of row 1 when you se-
lect this option. If you had set the current row as row
1 and used the dataset values until row 5, the dataset
values are retrieved from row 6 when you run the test

next time.

5. If you are setting how the test accesses the dataset during this session, select one of the following options:

> Sequential: The rows in the dataset are accessed in the order in which they are physically stored in the
dataset file, beginning with the first row and ending with the last.

- Random: The rows in the dataset are accessed in any order, and any given row can be accessed
multiple times or not at all. Each row has an equal chance of being selected each time.

- Shuffled: Before each dataset access, the order of the rows is changed, and a different sequence
results. Rows are accessed randomly but all rows must be selected once before a row is selected
again.

6. Select one of the following options.

Option Description

Wrap when the last row is reached
By default, when a test reaches the end of a dataset

or dataset segment, it reuses the data from the
beginning. To force a test to stop at the end of a

dataset or segment, clear the check box Wrap when

395



396

HCL OneTest Performance

Option

Description

the last row is reached. Forcing a stop might be use-
ful if, for example, a dataset contains 15 records, you
run a test with 20 virtual users, and you do not want
the last five users to reuse information. Although the
test is marked as “Fail” because of the forced stop,
the performance data in the test is still valid. Howev-
er, if it does not matter to your application if data is
reused, the default of wrapping is more convenient.
With wrapping, you need not ensure that your dataset
is large enough when you change the workload by
adding more users or increasing the iteration count in
aloop.

Note:

> With Random access order, Wrap
when the last row is reached option is
unavailable because you never reach

the end of the row.

o

With Shuffled access order, if you
select Wrap when the last row is
reached option, you resume select-
ing from the beginning of the row with
the same access order after each row
has been selected once. No more se-
lections are required if you clear the
Wrap when the last row is reached

option.

Example

Fetch only once per user

By default, one row is retrieved from the dataset for
each execution of a test, and the data in the dataset
row is available to the test only for the duration of
the test. Select Fetch only once per user to specify
that every access of the dataset from any test being
run by a particular virtual user will always return the

same row.
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To illustrate how these options affect the rows that are returned, assume that a test contains a loop which

accesses a dataset. The loop has two iterations. The following table shows the row that is accessed in each

iteration:
Dataset option Iteration 1 Iteration 2
Sequential and Private row 1 row 2
Shared and Shuffled row X row y
Fetch only once per user row X row X

7. Click Finish.

How dataset options affect values that a virtual user retrieves

The Open, Access, and Wrap modes that you select for a dataset affect the values that a virtual user retrieves.

The following table lists the most common types of datasets and the options that you select to create them.

Dataset purpose

The virtual user retrieves the value from the current row of the dataset in a ran-
dom order for every attempted transaction. Note that before accessing each row

of the dataset the order of the rows is rearranged.

The virtual user retrieves the value from the current row of the dataset in sequen-
tial order for every attempted transaction.

The virtual user retrieves the value from the beginning of the row of a dataset in a

random order for every attempted transaction.

The virtual user retrieves the value from the current row of a dataset in sequential
order for every attempted transaction. When a test reaches the end of a dataset, it

reuses the data from the current row selection of the dataset.

Enabling a test to use a dataset

Open
mode se-

lection

Shared
(forall
test exe-
cutions)

Shared
(for all
test exe-

cutions)

Shared
(per test
execu-
tion)
Shared
(for all
test exe-

cutions)

Access

mode
selec-

tion

Shuf-
fled

Se-
quen-
tial

Ran-

dom

quen-
tial

Wrap mode

selection

Fetch on-
ly once per

user

Fetch on-
ly once per
user

Wrap when
the last row

is reached

Wrap when
the last row

is reached

Before a test can use variable data from a dataset, you must update the test to include a reference to that dataset.
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1. In the Test Navigator, browse to the test and double-click it. The test opens.
2. Right-click the test name, and click Add > Dataset.
Result
The Select Dataset File window is displayed listing the datasets available to the test. If a test is already using
a dataset, it does not appear in the list.
3. In the Existing Dataset in workspace list, click the name of the dataset that your test will use and click Next.
4. Select the Open mode for the dataset. This mode determines the view that virtual users have of the dataset.
This option is useful when you do a parallel test run.

Option Description

Shared (per test execution) (default)
When you choose the Shared (per test execution) op-

tion, the virtual users running in the test share the

dataset values in sequential order.

For example, if your dataset has 10 rows, the dataset
values are taken from row 1, row 2, row 3, and so on

when you select this option.

Private
Virtual users draw from a private view of the dataset,

with dataset rows apportioned to each user in se-

quential order.

This option ensures that each virtual user gets the
same data from the dataset in the same order. How-
ever, because each user starts with the first row of
the dataset and accesses the rows in order, different
virtual users will use the same row. The next row of
the dataset is used only if you add the test that is us-

ing the dataset in a loop with more than one iteration.

Shared (for all test executions)
When you choose the Shared (for all test executions)

option, the virtual users running in multiple tests

share the dataset values from the current row.

For example, if your dataset has 10 rows and when
you set the current row as row 5, the dataset values
are taken from row 5 instead of row 1 when you se-
lect this option. If you had set the current row as row
1 and used the dataset values until row 5, the dataset
values are retrieved from row 6 when you run the test

next time.
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5. Select the Access mode for the dataset:

- Sequential: The rows in the dataset are accessed in the order in which they are physically stored in the
dataset file, beginning with the first row and ending with the last.

- Random: The rows in the dataset are accessed in any order, and any given row can be accessed
multiple times or not at all. Each row has an equal chance of being selected each time.

- Shuffled: Before each dataset access, the order of the rows is changed, and a different sequence
results. Rows are accessed randomly but all rows must be selected once before a row is selected
again.

6. Select whether the test will reuse data when it reaches the end of the dataset.

By default, when a test reaches the end of a dataset or dataset segment, it reuses the data from the
beginning. To force a test to stop at the end of a dataset or segment, clear the check box Wrap when the

last row is reached. Forcing a stop might be useful if, for example, a dataset contains 15 records, you run a
test with 20 virtual users, and you do not want the last five users to reuse information. Although the test is
marked as “Fail” because of the forced stop, the performance data in the test is still valid. However, if it does
not matter to your application if data is reused, the default of wrapping is more convenient. With wrapping,
you need not ensure that your dataset is large enough when you change the workload by adding more users or
increasing the iteration count in a loop.

7. Select whether the test will make the data in the dataset record permanent for each virtual user.
By default, one row is retrieved from the dataset for each execution of a test, and the data in the dataset row

is available to the test only for the duration of the test. Select Fetch only once per user to specify that every

access of the dataset from any test being run by a particular virtual user will always return the same row.

To illustrate how these options affect the rows that are returned, assume that a test contains a loop which

accesses a dataset. The loop has two iterations. The following table shows the row that is accessed in each

iteration:
Dataset option Iteration 1 Iteration 2
Sequential and Private row 1 row 2
Shared and Shuffled row X row y
Fetch only once per user row X row X
8. Click Finish.
Result

A reference to the dataset is added to the test, and the Test Details area is updated with the dataset
information.
9. Save the test.

What to do next
Now that you have created a reference between the test and the dataset, the next step is to associate a value in the
test with a column in the dataset.
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Associating a test value with a dataset column

After you have created a dataset and have enabled your test to use the dataset, you can associate a specific value in

the test with a specific dataset column.

400

1. In the Test Navigator, browse to the test and double-click it. The test opens.

2. Locate and click a request that contains a value to replace with variable data.

Clicking a test page displays a table that lists dataset candidates and correlated data on that page. (If
correlated data is not displayed, right-click the table and verify that Show References is selected.) References
are color coded in blue and dataset candidates are color coded in black.

Test Data

MNarme Yalue | Substituted with

If the contents of the Value column corresponds exactly with column data in your dataset, click the row, and
then click Substitute. The Select Data Source window is displayed. Skip to step 6. You can ignore step 8

because the URL encoding is preselected.

Otherwise, double-click the row to navigate to the page request that contains the value to replace from a

dataset, and continue to the next step.

The value to replace from a dataset might not be listed in any page table. In this case, manually locate the

request string that includes the value.

. If the value to replace from a dataset is part of a string that has been designated a dataset candidate, you

must remove the light green highlight: right-click and select Remove Substitution.

For example, if you searched for doe, john in your test, the dataset candidate in your test is displayed as
doe%2C+john. Suppose that you do not want to associate this candidate with a single dataset column that
contains data in the format doe, john. Instead, you want to associate doe and john with separate dataset

columns. In this case, you must first remove the substitution.

. Highlight the value: With the left button pressed, drag your mouse over the value.

. Right-click the highlighted value, and select Substitute > Select Data Source.

Result

The Select Data Source window is displayed.

Note: To use a dataset that is not listed, click Dataset: the Select dataset column window is displayed.

6. Click the name of the dataset variable, or column, to associate with the test value.
7. Click Select.
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Result

To indicate that the association has been set, the highlighting for the selected test value turns dark green, and

the dataset table for this page is updated as shown in the example.

Test Data
Marme | Yalue | Substitted with
doe %2C+ johin F "firsthame" variabl...

searchFor "lasthame" variabl...

8. Optional: Encode variable data when it is substituted from a dataset.

If a test value contains special characters such as spaces or commas, click the row and select URL Encode.
With this option, special characters are encoded when variable data is substituted from a dataset. For
example, data that is space-separated in a dataset column might need to be encoded. When the URL encoding
is enabled, John Doe is substituted as John%20Doe. If the URL encoding is not selected, the variable data that

is substituted is literal. Do not enable URL encoding for datasets that contain data that is already encoded.

9. Optional: If you substitute an element of a page with a dataset column, to view the substitutions in the
Page Elements report, in the Test Elements Details area of the request click the Use the substituted URL in
performance reports check box.

10. Save the test.

Related information

Adding data source controller on page 374

Viewing dataset candidates when you open a test

Dataset candidates are displayed automatically when you open a test for the first time. From the dataset candidates
window you can view the dataset candidates in the test, bookmark locations of interest, and add or remove dataset

references.

1. Record a test.
Result
When the test opens for the first time in the Test Navigator, the Show Dataset Candidates window is
displayed. The Show Dataset Candidates window is displayed only if there are dataset candidates and if
Always display this dialog when a test is first opened is selected. To prevent the Show Dataset Candidates
from being displayed when a test opens, clear the Always display this dialog when a test is first opened
check box in the Show Dataset Candidates window.

2. Do one of the following:
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Option Description
To view details about the Navigate through the Dataset Candidates field to see
dataset candidates in a test them previewed in the Preview pane. Click the Next

and Previous icons to move the selection down or up
in the list of dataset candidates. Click the Show as
Tree icon to toggle between tree format and list for-
mat. Click the Sort icon to sort the list of dataset can-
didates. Click the Bookmark icon to bookmark a loca-

tion for later review.

To select a data source for a dataset candidate Select the dataset candidate in the Dataset Candi-
dates field, and then click Substitute. The Select Data

Source window opens.

To find more values in the test that have the Click Find More and Substitute. These values can be
same value as the selected dataset candidate reviewed and substituted interactively as needed.
To remove a substitution Select a substitution site, and then click Remove
Substitution.

3. Click Close to close the Show Dataset Candidates window and proceed to the test in the test editor.
To display the Show Dataset Candidates window again while in the test editor, click the root node of the test.

Then click the Common Options tab under Test Element Details, and then click Show Dataset Candidates.

Editing datasets

You can add, modify, or remove data from a dataset by using the CSV Editor. The working principle of the CSV Editor
is similar to that of a spreadsheet.

Before you begin

You must have created a dataset. See Creating a dataset in a workspace on page 392.
About this task
In HCL OneTest™ Performance 9.5.0 or later, you can use the CSV Editor to view and edit data in the dataset.

To have seamless access to a dataset CSV editor use any one of the following web browsers on Windows or Linux or
Mac operating systems:

» Mozilla Firefox
» Google Chrome

« Microsoft Edge based on Chromium

You can also view the datasets in other editors by right-clicking the dataset and selecting the Open With option.
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When you want to run a test asset with different dataset values, you can either edit the existing dataset or create a
new dataset to use it during the test asset run. When the number of edits is minimal, it is easier to edit the dataset
within the CSV Editor.

You can perform basic tasks in the CSV Editor by right-clicking any row, column, or cell of the dataset to organize your
data in a better way. For example, updating the data in a cell, inserting or deleting rows and columns, or renaming

column names.

When you edit the dataset in a CSV Editor, you can use the following keyboard shortcuts to control the cursor
selection in the CSV Editor:

« Tab - To move the cursor control to the next available option.
« Shift-Tab — To move the cursor control to the previous option.

« Shift+F10 — To open the context menu from the dataset cell.

Note:

You cannot resize the width of rows in the CSV Editor. When you have a large amount of data in a cell, you
can right-click the cell and select Copy (or Ctrl+C), and then paste it into a text-editing program to view the

content. Alternatively, you can hover the mouse over the cell to view the content.

1. Double-click the dataset that you want to edit in the Test Navigator.
Result
The dataset opens in the CSV Editor in a bowser.
2. Perform the following actions to use the options available in the CSV Editor:

Option Description

Set as current row Right-click any cell in a row and select Set as current

row.
When rows are deleted:

If you delete any row between row 1 to current row,
the current row data is taken from the next row.

For example, when you set the current row as 6, and
then you delete any row between row 1 to row 6, the
current row remains at row 6, but the content of row

7 is moved to row 6.

When rows are inserted:
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Option

Description

If you insert any new row between row 1 to the cur-
rent row, the current row data is taken from the previ-

ous row.

For example, when you set the current row as 6, and
then you insert any row between row 1 to row 6, the
current row remains at row 6, but the content of row
5is moved to row 6.

Find and Replace

To find:

a. Click the Find and Replace icon
b. Enter the content that you want to search in
the Find field.
c. Select any or all the following options to find
the search content more effectively:
= Select the Case sensitive check box
to search the content that is the exact
letter case of the content entered in
the Find field.
= Select the Match entire cell contents
check box to search for cells that con-
tain only the characters that you have
entered in the Find field.
= Select the Search using regular ex-
pression check box to search the pat-

tern that matches strings.

For example, to search a cell that con-
tains any number between 0 to 9, do
the following:
i. Enter \d in the Find filed.
ii. Select the Search using regu-
lar expression check box.
iii. Click Find.
d. Click Find. If the text is found, the cell contain-
ing that text is selected.
e. Click Find again to find further instances of

the search text.
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Description

Find and Replace

To find and replace:

a. Click the Find and Replace icon
b. Enter the content that you want to search in
the Find field.
c. Enter the content that you want to replace in
the Replace field.
d. Select any or all the following options to find
and replace the content more effectively:
= Select the Case sensitive check box
to find the content that is the exact let-
ter case of the content entered in the
Find field.
= Select the Match entire cell contents
check box to find and replace for cells
that contain only the characters that
you have entered in the Find and Re-
place fields.
= Select the Search using regular
expression check box to find and
replace the pattern that matches
strings.
e. Click Replace to replace the individual in-
stances.
f. Click Replace All to replace every instance of
the content throughout the dataset.

Undo lSl

a. Click the Undo icon D.
b. Select the recent changes from the list that

you want to undo, and then click the list.

The Undo option undoes anything you do in the
dataset. The CSV Editor saves the unlimited un-
do-able action. You can perform the undo action even

after you save your changes made to the dataset.

Redo el

a. Click the Redo icon c ]
b. Select the recent changes from the list that
you want to redo, and then click the list.
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Option

Description

The CSV Editor saves the unlimited redo action.

5

Import

a. Click the Import icon b 3

b. Click Choose File and select the CSV file that
you want to import in the Import File dialog
box.

c. Optional. Click Overwrite to add the rows and
columns from the selected CSV file from the
beginning of the dataset.

d. Optional. Click Append to add rows and
columns from the selected CSV file to the end
of the dataset.

e. Optional. Select the First row contains head-
ers check box if your CSV file contains the
header.

Export

Click the Export icon to download the dataset
as a CSV file.

Dataset configuration settings

L

In the Configure Dataset window, you can change
the row and column settings and configure the string
values in the dataset that contains variable data for
tests to use when they run.

a. Click the Menu icon and select Configure
option.
b. Configure the following options in the Config-
ure Dataset window:
= Column header - To change the col-
umn header, use an up-down control
button to increment or decrement the
value.
= Data start point - To change the data
starting pointer, use an up-down con-
trol button to increment or decrement
the value.
= Current row - To set the current row,
use an up-down control button to in-

crement or decrement the value. You
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Option Description

can also see the Current row number
on the upper-right side.

= Treat empty text as null -If a dataset
contains any blank cells, the value of
those blank cells is interpreted as null
when you select this field.

= Treat as null - Enter a string value that
is to be treated as null when running
test.

= Treat as empty - Enter a string value
that is to be treated as empty when

running test.

Discard ) . H . .
Click the Menu icon and select Discard to dis-
card the changes made to the dataset.
3. Click the Save icon to save the changes made to the dataset and close the CSV editor.

Encrypted datasets overview

You can encrypt one or more columns in a dataset. If you want to encrypt confidential information such as a set of

passwords or account numbers that are used during a test, you can use an encrypted dataset.

Dataset columns are encrypted using the RC4 private-key algorithm. You can use only one password to encrypt
columns in any given dataset. Encrypted datasets are not supported on agent computers that are running the z/0S®

or AIX® operating systems.

! Important: If you forget the password to a dataset, there is no way to recover the password.
When you run a test that uses a dataset that contains encrypted variables, you are prompted for the dataset
password. If the test uses multiple encrypted datasets, you must enter the password for every encrypted dataset that

the test uses.

When you run a test that uses a dataset with an encrypted column, the value of the column is decrypted at a run time.
The column value is sent as a cleartext string in the requests to the server. The actual values of the encrypted dataset
variables are not displayed in the test log. The test log displays asterisks for the encrypted dataset variables.

To see the actual values of variables that are sent to the server at run time, you must use custom code. You can send
the dataset column value to custom code that writes the value to a file other than the test log. If the custom code
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writes to the test log using t es. get Test LogManager () . repor t Message( ), then asterisks are displayed instead of the

decrypted variables.

Encrypting a dataset column

To secure test data, you must encrypt datasets. You can encrypt data in the columns of a dataset by using an
encryption key. When you run a test that utilizes a dataset with encrypted variables, you must enter the encryption key

for the encrypted column that the test uses.
Before you begin

You must have created a dataset. See Creating a dataset in a workspace on page 392.

1. Double-click the dataset in the Test Navigator.
Result
The dataset is displayed in a browser.
2. Right-click any cell in a column that you want to encrypt and select Encrypt column data.
Result
The Encrypt Column window is displayed.
3. Enter an encryption key in the Encryption Key field to encrypt the data in the column.

n Remember: When you have already encrypted other columns in the dataset, you must enter the same
encryption key that you used previously. You can use only one encryption key to encrypt columns in a

dataset.

Important: The encryption keys you use to encrypt data in a dataset are not stored on the server nor
can be retrieved from the server. Therefore, you must remember to store the encryption keys in a
secure location. You must use the same encryption keys to view the encrypted values, to decrypt data,

or enable the use of the encrypted dataset during test runs.

4. Click Encrypt Column.
Result
Asterisks are displayed instead of actual data for the encrypted column.

Results
The dataset column is encrypted.

Decrypting a dataset column

To view the content of an encrypted dataset, you can decrypt the dataset. Removing encryption from a dataset
revokes the protection offered to the test data.

Before you begin
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You must have created a dataset with at least one encrypted column. See Creating a dataset in a workspace on

page 392 and Encrypting a dataset column on page 408.

1.

2.

3.
4.

Double-click the dataset in the Test Navigator.

Result

The dataset is displayed in a browser.

Right-click encrypted cells that display the contents with asterisks, and then select Decrypt column data.
Result

The Decrypt Column window is displayed.

Enter the encryption key that you used to encrypt the data in the column in the Encryption Key field.
Click Decrypt Column.

Result

Asterisks are replaced with the actual data in the decrypted column.

Results

The encryption is now removed from the selected column in the dataset. When you run a test that uses a dataset that

contains decrypted data, the variable data is substituted for the data in the recorded test without prompting for the

encryption key.

Using a digital certificate store with a dataset

You can associate the certificates in one or more certificate stores with a dataset to use multiple digital certificates

during testing.

1. Open a test for editing. On the Common Options page, click Add Dataset.

O© 00 N o0 01 b~ W

10.

. Create a dataset with two columns that contains a list of the certificates in the certificate store and a list of

passphrases for the certificates. To learn more about adding datasets, see Creating a dataset in a workspace
on page 392. You can use the supplied KeyTool program to generate a list of names of certificates in a

certificate store. To learn more about KeyTool, see Creating a digital certificate store on page

. Select Fetch only once per user.

. Save the dataset.

. On the Security page, under Digital Certificates, click Add.

. Select a certificate from the certificate store that you created previously.
. Type the passphrase for the selected certificate.

. When prompted to dataset the digital certificate, click Yes.

. In the Select dataset column wizard, choose the dataset that you added previously, and substitute the

appropriate columns for the certificate name and passphrase.
Save the test, and then add the test to a schedule.

Results

When you run this schedule, the certificates from the certificate store are submitted to the server.
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Navigating between a dataset and a test

After you have created a dataset or imported a comma-separate values (CSV) file into a dataset, you can navigate

between the dataset and associated tests in the test editor. You can enlarge the test and the dataset, list the datasets

that a test uses, navigate from a row in a dataset to the corresponding element in the test, see the data for a page or

request, and add or remove dataset references.

1. In the Test Navigator, browse to the test and double-click it. The test opens.

2. Do one of the following actions:

Option

Description

Maximize the test window

Double-click the test tab (for example,

). Do not click the x, or you will
close the test. To return to the default perspective,

click Window > Reset Perspective.

View the datasets that a test uses

In the Test Contents area, click the first line of the

test, which is the test name.

Navigate from a row in a dataset

to its corresponding element

a. In the Test Contents area, click the test name,
which displays the dataset.

b. Expand the dataset to display the rows.

c. Double-click the row.

View the data for a page or request

In the Test Contents area, click the page or request.

To add a reference to a dataset

In the Test Element Details area, drag your cursor
over the candidate, right-click, and select Substitute >
Select Data Source. The Select Data Source window
opens. If you have not already added the dataset to
the test, click Dataset, and then add the new dataset.

Remove a reference to a dataset

3. Save the test, if you have made any changes.

Test variables

In the Test Element Details area, drag your cursor
over the reference, right-click, and select Remove

Substitution.

A test variable is a user-defined, name-value pair that stores and refers to information throughout a test and between

tests.
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A variable is declared in the test variables section of the test. You can use it throughout the test as a reference for any
field that can be substituted. Substituting data from a test variable is achieved using the Test Variables page of the
Test Data Source view. You can do the following actions to a test variable:

« Provide a default value to the variable during declaration.

« Change the value of the variable using Set Variable statement. You can use the Add and Insert menus of the
Test Editor to create Set Variable statements.

« Set hard-coded value or value retried from a data source, such as dataset or reference that appears before the
Set statement to the variable.

If a variable is initialized at various places such as test, compound test, schedule, or user group, the product uses the
following order to initialize the value of the variable when running the test. The variable set in the variable table of the

compound test editor takes the highest precedence followed by others:

. Compound test setting in the variable table Ul

. Compound test specified in a var file

. User group setting in the variable table Ul

. User group specified in a var file

. Schedule specified setting in the variable table Ul
. Schedule specified in a var file

N o o0 b WON =

. Command line

Note: You must select All tests for this user from the Visible in drop-down list to take the precedence of
variable initialization.

Sharing variables among tests

In order to share variables between tests, all the tests must contain the variables with the same name. The variables
must also have Visible in set to All tests for this user. When these conditions are met and multiple tests have been

placed in a schedule, then variable in the dataset of one test can be used in the other test.

A common reason to share data between tests is to perform data correlation. With data correlation, a variable is set
to a response that comes from a request in one test and is used in requests performed in a different test. Assume
that you are testing an employee database. The Create Employee test creates an employee record and the Modify
Employee test modifies an employee record. When a new record is created, it is assigned a record ID. Variables can
be used to pass the record ID from a response in the Create Employee test to the Modify Employee test. A user-
defined variable is not shared among different virtual users. The variable is shared only among the different tests of
the same virtual user. If you set Visible in to This test only, then dataset from a test is not available to another even if

both tests contain variables with the same name.

If you want to share variables between the different types of test scripts in your product, consider the following
points:
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- Declare the test variables with the same name across all the test scripts for the variables to communicate

with each other. Set Visible in to All tests for this user.
« Include the required test scripts into a compound test.

Using test steps, you can share the default values of the variables to another test script. You can also assign new

values to the variables and use the latest values in another test script.

If you want to share variables between the test scripts of different testing products such as HCL OneTest™ Ul, HCL
OneTest™ Performance, or HCL OneTest™ API, you must consider the following points:

- If you are using Installation Manager, you must shell-share or install the products in the same package group.

« If you are using InstallAnywhere, you must use the installer that installs both HCL OneTest™ Ul and HCL
OneTest™ Performance together.

Note: By using InstallAnywhere, you cannot shell-share your product with HCL OneTest™ API.

» Declare the test variables with the same name across the HCL OneTest™ Ul and HCL OneTest™ Performance

test scripts. Set Visible in to All tests for this user.
« Include the required test scripts into a compound test.

« If you are using HCL OneTest™ API test scripts, you must map your tags with the test variables of HCL

OneTest™ Ul or HCL OneTest™ Performance.

Using variables to access datasets

You can define variables so that they share data from a dataset throughout tests. This is achieved by having the value
field of a Set Variable statement substituted from a dataset. By doing so, the first test which appears in the schedule
can set the variable from a dataset and share it with the other test in a schedule.

Assume that you have two tests that log in to an application using a user ID from a dataset. The first test can set the
value of a variable from the dataset, and both tests can use the variable, instead of directly using the dataset. In this
case both use the same record from the dataset. This is similar to the fetch-only-once-per-user behavior of a dataset.
However, fetching once means that during playback, a virtual user gets only one record from the dataset. The one-
record limit holds even if the tests are in a loop, and are run several times by the virtual user. By using the user-defined
variables, the virtual user retrieves a new record each time through the loop, and both tests can use the same record.
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Note: Assignment (set) operators can not only have a variable value substituted from a dataset, but also in
the declaration of a variable. You can substitute the assignment operator and variable value from any data

source, and thus that value can be shared between tests as well.

Array variables

You create an array variable to add multiple values to a variable. If you create a secondary HTTP request, add
complete paths of the requests in the array variable that can be used a custom code during playback.

Declaring and assigning test variables

When you declare a variable, you can create a container for it, initialize it to a string or a dataset value, and set its
scope. Then, within the test, you can reassign another value to the variable.

About this task

If the data that you want to assign to a variable is only available after a specific test step, instead of initializing the
variable, you need to add a variable assignment further down in the test, so that when the assignment occurs, the
data that you need to use is available. Otherwise, when you try to initialize the variable (or do the assignment), the

value that you want to use will not be available and will not show up as an option to select.

If a variable is initialized at various places such as test, compound test, schedule, or user group, the product uses the
following order to initialize the value of the variable when running the test. The variable set in the variable table of the

compound test editor takes the highest precedence followed by others:

. Compound test setting in the variable table Ul

. Compound test specified in a var file

. User group setting in the variable table Ul

. User group specified in a var file

. Schedule specified setting in the variable table Ul
. Schedule specified in a var file

N o o0 A ON =

. Command line

Note: You must select All tests for this user from the Visible in drop-down list to take the precedence of
variable initialization.

To create, initialize, and assign a value to a test variable:

1. In the Test Navigator, browse to the test and double-click it.
Result
The test opens.

2. To create a container for the test variables that you create in a test:
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. Open the test, and in theTest Contents area, click Test Variables.

. Select Add > Test Variable Container.

Result

A container named Test Variables is created for the user-defined variables.

. Select the container to rename it.

Result
The Test Element Details area opens for you to type a new name in the Name field.

3. To declare or define a test variable:

a. Open the test, and in the Test Contents section, click the user-defined container to contain the

variable.

. To create a variable, select Add > Variable Declaration. To create an array variable, select Add > Array

Variable Declaration.

. Type the name of the variable, and click OK.

Result
The variable is added as the last element in the container and the Test Element Details area opens.

. In the Test Element Details area, set the scope and initial value for the variable.

Visible in: Select This test only to restrict data to the current test only. Even if another test has a
variable with the same name, that variable will not change. Select All tests for this user to share the
value of this variable when the test runs in a schedule. For the variable to be shared, both tests must
have a variable with the same name and must have this option enabled.

Check Value: Select When first used to check whether or not a variable is initialized only after the test
execution reaches the first request that uses a variable. Select At test start to check whether or not
a variable is initialized when starting the execution of the test. If the variable is not initialized, then an

error message is displayed, depending on the behavior set.

If not initialized, set to: Select Text to initialize the variable to a specific value whenever the test runs
in the schedule. Select Dataset value and, in the Select Data Source window, select the dataset that

will initialize the variable.

Run-time error if variable not initialized: Select the action for the run when it encounters an
uninitialized test variable. If you select Issue test log warning or Issue test log error, verify that the
Test log page in the schedule sets errors, failures, and warnings to All, which is the default setting.
If you select Exit the test, the schedule continues to run although the virtual users that have the

uninitialized variable stop. If you select Do nothing, the test continues to run.

4. To assign or initial a value to a test variable:
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a. Open the test, and in the Test Contents area, select a test element.

b. Select Insert > Variable Assignment, which inserts the assignment before the selected element.
Result

The Test Editor window opens and lists the variables available to the test.

c. Select the variable that you are assigning a value to and, in the Set to box in the Test Element Details
area, set the value for the variable.
You can set the value to a text string, to any data source that exists in the test before the assignment
statement, or to Not initialized.
Result

A set statement is added to the test, with the value you chose.

Initializing variables from the command line

To initialize test variables from an XML file, you can run the test from the command-line interface using the varfile
option.

Before you begin

« Declare the variables using HCL OneTest™ Performance.

» You must have set the Web Reports preferences in the desktop client to view the status of the test run from

the command line. For more information, see Accessing reports remotely on page 772.

» Create an XML file that contains the variables with values. The XML file would have a structure similar to the
following image
<?xml version="1.0" encoding="UTF-8"?=
<initsz
<variable_init value="9.999.99.999" nams="hostname"/=
< finitsz

About this task

If a variable is initialized at various places such as test, compound test, schedule, or user group, the product uses the
following order to initialize the value of the variable when running the test. The variable set in the variable table of the
compound test editor takes the highest precedence followed by others:

. Compound test setting in the variable table Ul

. Compound test specified in a var file

. User group setting in the variable table Ul

. User group specified in a var file

. Schedule specified setting in the variable table Ul

. Schedule specified in a var file

N o g ODN =

. Command line
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Note: You must select All tests for this user from the Visible in drop-down list to take the precedence of

variable initialization.

1. Navigate to the directory that contains the cndl i ne. bat and cndl i ne. sh files. On Windows™ operating

systems, this directory is typically found as pr oduct I nst al | ati onDi rect ory/ cndl i ne. For example, C:
\ Program Fi | es\ HCL\ HCLOneTest \ crdl i ne.

. Issue the following command:

Example

crdl i ne -workspace workspace_full _path -project proj_rel _path -eclipsehone eclipse_full_path

-plugins plugin_full_path -schedul e sched_rel _path -suite suite_rel_path -inportzip file_nane.zip
-varfile variable_file_full_path -servicename service -serviceargs service_args -configfile

file_full _path -results result_file -overwite {"true" | "false"} -quiet -users nn -vnargs

JVM args -rate RateRunner GroupNane=iterati onNunber/duration, iterationNunber/duration -duration

St agel=dur ati onCf St age; Stage2=durationCf Stage - publish server URL#proj ect . nane=pr oj ect Name - publish_for
{ ALL, PASS, FAI L, ERROR, | NCONCLUSI VE} -exportlog |og_full_path -exportstats |local _dir_path -timerange
"all, 5 Users, 10 Users" -exportstatshtml |ocal _dir_path -conpare "result_pathl, result_path2"
-exportstatreportlist stats_list -execsummary |ocal _dir_path -execsunmmaryreport reportlD -usercomments
"any user comment” -publishreports "FUNCTI ONAL, MOBI LE_WEBUI, STATS, TESTLOG' -stdout -swapdatsets

exi sting_dataset _file_path: new dataset _file-path -history jaeger,testlog,null -overridermn abels "Il abe

nane 1,|abel nane 2"

Note:

> The workspace is locked after you issue the command. To check the progress of the test
or schedule during the run, invoke another workspace and open the project through that
workspace.

> On Linux operating system, the command must start with crdl i ne. sh.

> The command line does not provide a way to specify the secure storage password for
resource monitoring. You must provide the password in the workbench and ensure that it is

stored and persisted in the schedule before you execute the schedule from the command line.

If a value contains spaces, enclose the value in quotation marks. To see the online help for this command

while you are in the directory that contains the .bat file, type cndl i ne - hel p.

The following table explains each option:

Option Description
-workspace Required. The complete path to the Eclipse work-
space.
-project Required. The path, including the file name of the
project relative to the workspace.
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Option Description
-eclipsehome Optional. The complete path to the directory that con-
tains ecl i pse. exe.
-plugins Optional. The complete path to the folder that con-
tains the plugins. Typically, on Windows operat-
ing systems, this folder is located at C: \ Pr ogr am
Fi | es\ HCL\ HCLI Mshar ed\ pl ugi ns.
Required. This option is required only if the folder is
at a different location.
-schedule Optional. However, in a command, it is mandatory to
use one of the following options:
o -suite
> -schedule
o -servicename
You must not use the -schedule option along with the
other options. The path includes the file name of the
schedule to run relative to the project.
Starting from V9.2.1.1, you can execute multiple
schedules simultaneously. For example, - schedul e
sch1:sch2:sch3.
-suite Optional. However, in a command, it is mandatory to
use one of the following options:
o -suite
> -schedule
o -servicename
You must not use the -suite option along with the
other options. The path includes the file name of the
suite to run relative to the project.
Starting from V9.2.1.1, you can execute multi-
ple tests simultaneously. For example, -sui te
test1:test2:test3.
-importzip Optional. To import the project as test assets with de-

pendencies into your workspace, use the -importzip
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Option

Description

option. This command is available from 9.2.1.1 and
later.

Optional. You can execute test assets from the im-
ported zip file, but you must specify the -importzip
option along with the -schedule option or -suite op-

tion. For example, - i nport zi p script.zip

-varfile

Optional. You can use this option to specify the com-
plete path to the XML file that contains the variable

name and value pairs.

-servicename

Optional. However, in a command, it is mandatory to
use one of the following options:

o -suite
» -schedule
o -aftsuite

° -servicename

You must not use the -servicename option along with
the other options. The path includes the file name of
the service to run relative to the project. Instead of
running a performance test, the specified service is

run when it is available.

-serviceargs

Optional. You can use this option to specify a series
of arguments to pass to the service specified. For ex-
ample, - ser vi cear gs -myserviceparm1 myservicepar-
m1value”. The values are in quotation marks as they
contain spaces.

-configfile

Optional. You can use this option to specify the com-
plete path to a file that contains the parameters for

a test or schedule run. Each parameter must be on

a single line. To create a configuration file, you must
use an editor that does not wrap lines. Any parame-
ters, whether required or optional, can be set in the
configuration file. Command line parameters override

the values in this file.

Notes:
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Description

o If you are creating a config file man-
ually, the file must be in the UTF-8
format. You must not use quotation
marks in this file even for values that
contain spaces.

o

Starting from V10.0.2, you can create
command line config file from HCL
OneTest™ Performance, which you
can use while running tests or sched-
ules from the command-line interface
and Maven. For more informaiton
about how to create a command line
config file from the product, see relat-

ed links.

-results

Optional. You can use this option to specify the name
of the results file. The default result file name is the
test or schedule name with a time stamp appended.
Specify a folder name that is relative to the project

to store the test results. For example, -resul ts fol d-

er/resul t nane.

-overwrite

Optional. Determines whether a results file with the
same name is overwritten. The default value, f al se,
indicates that the new results file is created. If the
value is t r ue, the file is overwritten and retains the
same file name. You must use double quotes for val-

ues “true” or “false”.

-quiet

Optional. Turns off any message output from the
launcher and returns to the command shell when the

run or the attempt is complete.

-users

Optional. Overrides the default number of virtual
users in the run. For a schedule, the default is the
number of users specified in the schedule editor. For
a test, the default is one user. This option creates a
new copy of the schedule that contains the specified

number of users.
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Option

Description

-vmargs

Optional. To specify the Java™ maximum heap

size for the Java™ process that controls the com-
mand line playback, use the -vmargs option with the
-xnmx argument. For example, when you use-vmargs
-Xmx4096m, specify a maximum heap size of 4096m.
This method is similar to specifying -Xmx4096m in
the eclipse.ini file for the workbench when playing

back the test from the user interface.

-rate

Optional. You can use this argument to specify a rate
that you want to achieve for a workload in the Rate
Runner group. For example, - r at e “Rate Runner Group
1=1/s, 3/m; Rate Runner Group 2=5/s, 10/s".

Here, Rate Runner Group 1 is the name of the Rate
Runner group that has two stages. The desired rate
for the first state is one iteration per second and
the rate for the second stage is three iterations per

minute.

Note: The Rate Runner group name must

match with the name in the Rate Schedule.

-duration

Optional. You can use this argument to specify the
duration of the stages in the Rate Schedule. For ex-

ample, - durati on“Stage1=10s; Stage2=3m”

Note: The stage number specified must exist
in the Rate Schedule.

-publish

Optional. You can use this parameter to publish test
results to the HCL OneTest™ Server. You can use the
following options along with the - publ i sh parameter:
o server URL#pr oj ect . nane=pr oj ect -
Nane: You can use this option if to specify the
project name. If the project name is not speci-
fied, the name of the current project is used.

Note: If you provide the server
and the project details under Win-
dow > Preferences > Test > Ratio-
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Description

nal Test Automation Server in the
2 product, and if you use ser ver -
URL#pr oj ect . nane=pr oj ect -
Nane along with the - publ i sh para-
meter, the server details in the com-
mand-line interface takes precedence

over the product preferences.

> no: You can use this option if you do not want
to publish test results after the run. This op-
tion is useful if the workbench preferences
are set to publish the results, but you do not
want to publish them.

Important: You must provide the offline

user token for the server by using the HCL _-
ONETEST_OFFLINE_TOKEN environment
variable before you use the -publish parame-

ter in the command-line interface.

-publish_for

Optional. You can use this option to publish the test
results based on the completion status of the tests:
o ALL - This is the default option. You can use
this option to publish test results for any text
execution verdict.
> PASS - You can use this option to publish test
results for the tests that have passed.
o FAIL - You can use this option to publish test
results for the tests that have failed.
> ERROR - You can use this option to publish
test results for the tests that included errors.
o INCONCLUSIVE - You can use this option to
publish test results for the tests that were in-
conclusive.
You can add multiple parameters separated by a

comma.

-exportlog

Optional. You can use this parameter to specify the
file directory path to store the exported HTTP test
log.
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Description

Starting from HCL OneTest™ Performance V10.0.1,
by using the -exportlog parameter, you can provide
multiple parameter entries when running multiple
tests. You must use a colon to separate the parame-

ter entries.

For example: -exportlog c:/logexport.txt:c:/secondlog-

export.txt

If there are multiple -suite parameter entries with a
single -exportlog parameter entry, the -exportlog pa-
rameter generates the appropriate number of test
logs by appending 0, 1, 2, and so on to the -exportlog

parameter entry name.

For example: -suite “sampletest1:sampletest2:sam-
pletest3” -exportlog c:/logexport.txt The command

generates the following test logs:

> logexport_0.txt
o logexport_1.txt
o logexport.txt

The last test log generated has the same name as

that of the initial -exportlog entry.

Note: If there are multiple -suite and -export-
log parameter entries, the number of suite
entries must match with the number of -ex-
portlog entries. Otherwise, the following error

message is displayed:

Error, nunber of -suite and -exportlog en-

tries do not match.

-exportstats

Optional. You can use this option to export reports
in comma-separated values (CSV) format, with the
file name derived from the report name. This directo-
ry can be relative to the project or a directory on your
file system. If the -exportstatreportlist option is not
specified, the reports specified on the Export Reports
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Description

page of the Performance Test Report preferences

are exported.

-timerange

Optional. You can use this option along with -export-
stats, -exportstatshtml, and -execsummary to export
test results within one or more time ranges. The val-
ue is the time range that you specify in the schedule.
For example, “all, 5 Users,10 Users”. You must sepa-
rate time ranges with a comma and use double quo-

tation marks when there is space in a time range.

-exportstatshtml

Optional. You can use this option if you want to ex-
port web analytic results only. The results are export-
ed in the specified directory. You can then analyze
the results on a web browser without using the test
workbench.

-compare

You can use this argument along with -exportstat-
shtml and -execsummary to export the result in com-
pare mode. The value can be paths to the runs and
are relative to the workspace. You must separate the

paths by a comma.

-exportstatreportlist

Optional. You can use option to specify a com-
ma-separated list of report IDs along with exportstats
or exportstatshtml to list the reports that you want to
export in place of the default reports, or the reports
selected under Preferences. To view this setting, nav-
igate to Window > Preferences > Test > Performance

Test Reports > Export Reports.

To copy the report IDs list into your command line,
navigate to Window > Preferences > Test > Perfor-
mance Test Reports > Export Reports. UnderSelect
reports to export, select the required reports, and
click Copy ID to clipboard. You can then paste the
clipboard content on to your command line editor

-execsummary

Optional. You can use this option to export all of the
reports for the test run in a printable format, also
known as an executive summary, to the local com-
puter. You must specify the path to store the execu-

tive summary.
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Option

Description

-execsummaryreport

Optional. You can use this option to export a specif-
ic report as an executive summary for the test run to
the local computer. You must specify the ID of the re-
port to export. For example, to export an HTTP per-
formance report, specify ht t p. You must use this op-

tion along with -execsummary.

To copy the report IDs list into your command line,
navigate to Window > Preferences > Test > Perfor-
mance Test Reports > Export Reports. Under Select
reports to export, select the required reports, and
click Copy ID to clipboard. You can then paste the
clipboard content on to your command line editor

-usercomments

Optional. You can add text within double quotation
mark to display it in the User Comments row of the

report.

Note: You can use the file Command-
Li ne. exe to run the command to add com-
ments in a language that might not support
Unicode characters on Windows operating
system.

-publishreports

Optional. You can use this option to publish test re-
sults in HCL OneTest™ Server. The parameters that
you can use with it are the following:

o FUNCTIONAL

> MOBILE_WEBUI

o STATS

o TESTLOG
For example, - publ i shreports "STATS, TESTLOG".

Prefix with “I” to publish all the reports except the

specified one.
For example, - publ i shreports "l TESTLOG".

All the reports except the TESTLOG report is pub-
lished to HCL OneTest™ Server after executing the

command.
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Description

-stdout

Optional. You can use this option to display the infor-
mation about the test or schedule on the command

line.

After you run a test or schedule from the command
line, the following outputs are displayed to give you

the overall information of the test or schedule:

o ~VERDICT: The verdict of the test or sched-
ule.

> -REMOTE_RESULT: The URL of the result
published to HCL OneTest™ Server.

o -REMOTE_RESULT_UI: The URL of the result
published to HCL OneTest™ Server and can be
opened in a browser to analyze the result.

o --LOCAL_RESULT: The path of the result
saved locally.

For example, -workspace workspace_full_path
-project proj_rel_path -schedule sched_rel_path -pub-
lish publish_url -stdout

-swapdatasets

Optional. Use this option to replace dataset values
during a test or schedule run. If a test or schedule
is associated with a dataset, you can replace the
dataset at run time while initiating the run from the

command line.

You must ensure that both original and new datasets
are in the same workspace and have the same col-
umn names. You must also include the path to the
dataset when you run the -swapdatasets command.
For example, -swapdatsets /project_name/ds._-
path/ds_filename.csv:/project_name/ds_path/new_d-

s_filename.csv

You can swap multiple datasets that are saved
in a different project by adding multiple paths to
the dataset separated by a semicolon. For exam-
ple, -swapdatsets /project_name1/ds_path/ds_-
filename.csv:/project_name1/ds_path/new_ds_-

filename.csv;/project_name2/ds_path/ds_file-
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Option Description
name.csv./project_name2/ds_path/new_ds_file-
name.csv

-history Use this command when you want to view a record of

all events that occurred during a test or schedule run.
However, you must use the command suffixed with
any of the following options:

o jaeger: To send test logs to the Jaeger Ul dur-
ing the test or schedule run.

o testlog: To send test logs as traditional test
logs in HCL OneTest™ Performance during the
test or schedule run.

o null: To send no test logs either to the Jaeger
Ul or HCL OneTest™ Performance during the
test or schedule run.

For example:

workspace workspace_full_path -project proj_rel_path
-suite suite_rel_path -stdout -history comma
delimited list of modes

-workspace
C:/Users/HCL/hclonetest/test ws —project Projectl -s
uite testl.testsuite —stdout -history jaeger

Note: You can add multiple options separat-
ed by a comma to send test logs during the
test or schedule run to HCL OneTest™ Perfor-

mance and the Jaeger Ul.

For example:

-workspace

C:/Users/HCL/hclonetest/test ws —-project Pro
jectl -suite testl.testsuite -stdout -history
jaeger,testlog

For more information about how to view test logs in
the Jaeger Ul and HCL OneTest™ Performance, see

related links.

- overridermlabels

Optional.
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Description

By using the overri der ni abel s command, you can
control the Resource Monitoring sources that are re-
quired to collect in a performance schedule during

the schedule run.

You can use this command if you want to perform
any of the following actions:
> To enable the Resource Monitoring from Ser-
vice option for a performance schedule if the
Resource Monitoring from Service option is
not enabled from the schedule editor in HCL
OneTest™ Performance.
> To ignore Resource Monitoring sources that
were set in the performance schedule and to
change for a label matching mode.
> To replace an existing set of Resource Moni-
toring labels that were set in the performance
schedule and run the schedule with a new set

of Resource Monitoring labels.

Note: You must add the Resource
Monitoring labels to the Resource
Monitoring sources on the Re-
source Monitoring page in your HCL
OneTest™ Server project. You can use
these labels for adding the Resource
Monitoring sources to run the perfor-
mance schedule through the com-
mand line interface.

The command accepts a comma-separated list of la-
bels.

For example, if you have added a label in HCL
OneTest™ Server for a Resource Monitoring source
as r i, then run the following command to collect da-

ta from the source as follows:

workspace workspace_full_path —project proj_rel_path
-suite suite_rel_path -overridermlabels "rml"
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Option Description

Note: You can add multiple labels to a perfor-
mance schedule separated by a conma to col-
lect data from the multiple sources during the

schedule run. For example:

workspace workspace_full_path —-project proj_
rel_path -suite suite_rel_path -overridermla
bels "rml,rm2,rm3"

If your label contains a comma (, ), then when running
the - overri der m abel s command, you must replace
the single comma with the double comma in the la-
bel.

For example, if you have added a label to a Resource
Monitoring source as (r n, t est ), then you must run
the following command to collect data from source

as follows:

workspace workspace_full_path -project proj_rel_path
-suite suite_rel_path -overridermlabels "rmil,test"

To stop the test run, you can open another command prompt window and use one of the following options

with the cmdline option:

Command Description

-stoprun Optional. Stops the test run after the specified num-
ber of seconds. The block is executed, and the test

log is transferred before stopping the run. You must
use the -workspace command and specify the loca-

tion of the workspace.

-abandonrun Optional. Stops the test run immediately. You must

use the -workspace command and specify the loca-

tion of the workspace.

Note: Messages are displayed to indicate when the test or schedule is launched and when it is

completed unless you include the -quiet option.

Exemple
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cmdl i ne -workspace C:/RPTWrkspace -project testProj -eclipsehome C\Program Files\__BRAND NAVE__\__SDP_PATH _

\eclipse. exe -schedul e MySchedul e -varfile C:./Assets/testProjVar.xn

Initializing variables from Rational® Quality Manager

If you want to run an HCL OneTest™ Performance test from IBM® Rational® Quality Manager, you can pass the

execution variables defined in Rational® Quality Manager to the HCL OneTest™ Performance test.

Before you begin

« Configure the Rational® Quality Manager adapter in HCL OneTest™ Performance. For more information, see
the Configuration on page 112 topic.

« Variable names must be the same in Rational® Quality Manager and HCL OneTest™ Performance.

- The Visible in value for the variable in the HCL OneTest™ Performance test must be set to All tests for this

user.

About this task

When you pass an execution variable to a HCL OneTest™ Performance test, the value initialized in the test is replaced
by the value in the execution variable. If you modify the value that is initialized in the test, after the test is executed,
the modified value is passed back to the execution variable in Rational® Quality Manager.

To initialize an execution variable value to a test, run the test from Rational® Quality Manager. For information about

execution variables, see Using execution variables in manual test.

Correlating response and request data

For a test to run correctly, a request that is sent to a server might need to use a value that was returned by a previous
request. By ensuring that this data is correlated accurately, you can produce better performance tests.

Data correlation overview

A request can include data that was returned in the response to a previous request. Associating data in this manner is
called data correlation.

Interactions with an application are typically related to each other. For example, consider the following interactions
with a web-based application, in which each request depends on information returned from a previous response:

1. A payroll clerk types the web address for an application, which sends a login prompt. When the clerk logs in,
the web server returns a page that indicates that login has succeeded and a unique session ID to the web
browser that the clerk is using.

2. The clerk clicks a link on the returned page, which requests that the web server open the page for searching
the employee database. The web browser includes the session ID when sending the request. Based on the
session ID, the web server knows that the request comes from someone who is already logged on, and so
opens the search form for the employee database. The clerk then searches for a specific employee. The web
server returns a photograph of that employee and the employee's unique ID.
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3. The clerk clicks a link that requests the web server to return the payroll record for the employee. With this
request, the web browser sends two IDs:
> The session ID, so that the web server knows that the request comes from some who is logged on
> The employee ID, so that the web server can locate and return the correct information

In this example, request 2 depends on request 1, and request 3 depends on requests 1 and 2.

If you record these interactions in a test, before running the test with multiple users, you would vary the test data. For
example, you would replace the user name and password values, the employee name search values, or both, with
values that datasets contain. When you run the test, each virtual user returns a different employee payroll record,
based on the contents of the datasets.

In a generated test, where data in a request depends on data that is contained in the response to a previous request,
the request data is substituted from the response data on which it depends. The term for this internal linking
of response and request data is data correlation. When you run a test with multiple users and varied data, data

correlation is required to ensure that the test runs correctly.

A reference is a value in a test (typically in a response) that can be used by a subsequent value in the test (typically
in a request). When the test generator detects that a request value must be substituted from a previous value, it
designates the earlier value as a reference and correlates the subsequent request value with the reference. This
process is called automated data correlation. You can also manually correlate any two values in a test or unlink

existing correlations.

Note: You can change or disable automated data correlation. To do so, click Window > Preferences, expand
Test, and then click Test Generation.

By default, the empty strings are not correlated because it might increase the time taken to generate a test. However,
sometimes empty strings such as spouse name or middle initial become important to correlate. To correlate the
empty strings, click Window > Preferences > Test > Test Generation > HTTP Test Generation > Data Correlation and

select the Create substitutions for empty strings check box.

Generally, the HTML response content after the recording appears as <input type="username" name="User" id="aaa"
value="John'/>. Some applications dynamically update the name attribute. Therefore, when you play back the test,

the HTML response content appears as <input type="username" name="idt020" id="aaa" value="John'/>. Because the
name attribute changes dynamically, data correlation does not occur and the playback fails. For data correlation to
correlate the response content based on the ID attribute, ensure that you have selected ON in the Priortize correlation

based on ID option at Window > Preferences > Test > Test Generation > HTTP Test Generation > Data correlation.

To help you work with correlated data, the test editor uses color coding and provides navigational aids:
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» When you click a page, you see a Test Data table for that page. By default, related dataset candidates are
shown in green text on a light green background, values that are already associated with a dataset are shown
in white text on a green background, and references are shown in blue text.

Test Data Cptions =
Mame Value Substituted with -
faction shopping i
category 1
action getimage E} “action2” ("getimage " - Content)
inventoryID Yooo1 E} “inventoryID7" (V0001 - Content)
action getimage @) “action2” ("getimage " - Content)
inventoryID YOo0s E “inventoryID&”™ (V0005 - Content)
action aetimage ?} “action2” ("getimage” - Content)
inventoryID Yooo3 = “inventoryID5® ("W0003" - Content) w

« If correlated data is not displayed, right-click the table and verify that Show References is selected. To
navigate directly to a page request containing correlated data, double-click a table row. To associate
correlated data from this table with a dataset, click the row, click Substitute, and then click Select Data Source
to open the Select Data Source window. You can also use the Test Data Sources view to make substitutions.
In the test editor, right-click the Test Data table, and then select Link with Test Data Sources View. When
you click a row in the Test Data table, the Test Data Sources view displays information about the selected
substitution site.

« When you expand a page, green text indicates page requests that contain dataset data or candidates. Blue
text indicates page requests that contain references.

=I-Lgt . IBM Search Results: performance tester
+ /ﬁ www.ibm.com/Search/?g=performance testerfv=16&en=uti&lang=en&cc=us
+ /l,’% wwww.ibm. comfcommon fv 16/css fsearch. css
+ /ﬁ www.ibm,com/searchfaddons search. js

/ﬁ wwwe, ibm. comjifv 16/buttonsshort-bin. gif

“ﬁ wwwe,ibm. comjfifv 11/thumbnails /sdamer_sparts_car.jpg

“ﬁ wwwe,ibm. com/fifv 14ficons ffw. gif

“ﬁ www,ibm. comjfifv 11/thumbnails /stgsmb_app_perf.aqif

“ﬁ www,ibrn. comjfife 11/thumbniails jJu842 131002456y 75, gif

< www.ibm. com/fifv 16/tfcontainer-gradient. gif

TR T3 B T B ry B iy

+

/ﬁ wwwy.ibm. com fifv 16 ficonsffw. gif

» When you click a highlighted request, dataset candidates are highlighted in light green, data that is associated
with a dataset is highlighted in dark green, and correlated data is highlighted in red. If you right-click a value

for correlated data, as shown in the example, you can then click Go To to see its reference:
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URL:  [fSearch/?q=performance +esterfy =fton—lthtlona—bunoe i
Paste Cirl+v
Data: Delete Delete
Select all Cirl+4
Data Chunk Add
Text data: ™ Add Bookmark...
3
W Wrap Long Lines
Find *
Qs Remaove All Data-correlation from "URI™...
Request Headers Substitute »
Go To 3
Header Mame Value ¢ Add

« References are highlighted in dark blue.

Viewing data correlation

You can switch between viewing all test elements in the test editor and viewing only elements related to data
correlation in the test editor. Viewing only data correlation elements makes it easier to add and remove substitutions.

1. In the Test Navigator, browse to the test, and double-click it. The test opens.

2. In the Test Contents area, click Options.

3. Click Show > Data Correlation.

Result
The test editor window displays only elements that are related to data correlation. Alternately, click View under
Test Contents to switch between Display all Test Contents and Show Substitutions.

4. Select a single test element in the Test Contents area to see the current data source and to remove or change
the substitution in the Test Element Details area. Select multiple elements in the Test Contents area to see
the data in tabular form in the Test Element Details area. Different controls are available depending on the
type and number of elements that you select in the Test Contents area.

5. Optional: In the Test Elements Details area, click Substitute > Select Data Source to open the Select Data
Source window, where you can specify the data source for the selected substitution site.

What to do next
To view all test elements, click Options > Show > Data Correlation again.

Note: If you select a test element while viewing all test contents, and then switch to viewing only data

correlation elements, then the corresponding substituters and dataset candidates are selected. For example,
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if you select an HTTP page in the test editor, and then switch to viewing only data correlation elements, then

all substituters and dataset candidates for all requests from the HTTP page are selected.

Data correlation rules overview

You can use the data correlation rules editor to customize how data is correlated. You can control how references and
substitutions are generated in tests, and store these rules so that you do not have to manually correlate data in every

test that you record against a particular application.

You create data correlation rule sets in the rules editor. Data correlation rule sets are also known as rules files. Each
rule set can contain multiple rule passes, and each rule pass can contain multiple rules. When you re-correlate test
data with data correlation rules, each rule set is applied in the order that you specify. Within each rule set, each rule
pass is applied in order. Within each rule pass, each rule is applied in order.

You can use data correlation rules to do these tasks:

« Create a reference, substitution, variable, or dataset column
- Link a substitution to a reference

» Rename a reference or substitution

 Encode a substitution

- Unlink a substitution from a reference

« Remove a specific reference, substitution, or variable

» Remove all references or substitutions

Typically, you create a substitution and then link a reference to the substitution. References are located in the data
that the server under test returns, while substitutions are in the data that is sent to the server. To create a substitution
and then link a reference to the substitution in the rules editor, see Example: Linking references to substitutions with
rules on page 438.

Rule sets are hierarchical trees. You can insert child rules, which accept values generated by parent rules as input. To
find a particular reference by name, first add a Fi nd a reference rule, and then add a child Ref erence nane rule. In the
rules editor, you can also combine rules by using And and o and Not rules.

Creating data correlation rule sets

To use rules-based data correlation, you must create a data correlation rule set. Data correlation rule sets are also
known as rules files.

1. Click File > New > Data Correlation Rule Set.

Result

The New Data Correlation Rule Set wizard opens.
2. Select a parent folder, and then in File name provide a name.
3. Click Finish.

Result

The data correlation rules editor opens.
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Results
An empty rule set is created. Data correlation rule sets are XML files with the .dcr ul es file extension. Typically, you
use the rules editor to edit data correlation rule sets. You can also use any XML editor to edit a data correlation rule

Creating a reference using data correlation rules

You can create a data correlation rule that creates a reference from a regular expression when the rule is applied to

test data.
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1. Open a data correlation rule set in the rules editor.

A new rule set contains one empty rule pass.

. Click Insert, and then select Create a reference.

Result

An empty Create a reference rule is inserted in the rule pass.

. Under Details, supply information for all fields that are marked with asterisks and shaded in red. For

Reference field, click the down arrow to select the field in which to create the reference. Use the push buttons
at the top of the window to select a protocol, and then select a field.

Example

For example, to create a reference in the content field of an HTTP response, click the down arrow, and then
click HTTP > Content. To create references in multiple fields, click the Add field push button to add another

Reference field.

. In Regular expression, type an expression to use to locate the reference. If only a part of the regular

expression is required for a reference, enclose that part in parentheses.
a. Open the test, and locate the response to create the reference in.
b. Copy the text from the response to the clipboard.

c. In the rules editor, click the Toggle regular expression assistant push button to open the regular

expression assistant.

d. Paste the text from the clipboard to the Test regular expression page of the regular expression
assistant window.

If the Test regular expression page is empty, the contents of the clipboard is automatically pasted in.

e. Click the Captured group tab in the regular expression assistant.
Result
The overall group is displayed, and the captured groups are displayed. If no groups are displayed, edit
the regular expression accordingly.

Example
To create more than one reference using the same regular expression, enclose each part in parentheses. For

example, two references can be created from this regular expression: nane=(\ S+)\ sval ue=(. +?).

5. In Reference names, provide names for the references.
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The names that you specify are available to child rules. To use the references as arguments in child rules,
enclose the reference name in percent signs.
Example

For example, if you specify a reference name of nane, you can use wmarme%as an argument in a child rule.

. If an attribute contains multiple matches for the regular expression, in Occurrence, type or select the

occurrence to use to create the reference.

. Under Create reference only if used, select true to create a reference only if a substitution site uses the

reference. Select false to create the reference regardless of whether a corresponding substitution site is

found.

. Under Overlapping site action, select the action to take when a new reference overlaps with existing

references.

Option Description

Always remove existing If the new reference overlaps with other references,

the other references are removed.

Keep existing If the new reference overlaps with other references,
the other references are not removed.

Keep existing only if used If the new reference overlaps with other references,
the other references are removed only if the refer-

ences are unused.

. Under Create reference even if overlapping, select true to create a reference even if the new reference

overlaps with existing references.

In Log level, select the level of error data to be written to the error log. With logs, you can see which rules
worked and which did not. When you are debugging data correlation rules, use the Action log level. If the
Action log level does not provide enough data for troubleshooting, use the Detail log level. The Detail log level
products a significantly higher number of log entries. Typically, when you are sure that the data correlation
rules that you have written work correctly, use the None or Summary log levels to reduce memory and disk-

space consumption and unrequired entries in the error log.

Option Description
None Nothing is logged.
Warning A message is logged when there are potential prob-

lems that are detected when the rule is applied.

Summary One message is logged for the rule, no matter how

many times the rule is applied.

Important A message is logged every time the rule is applied
in a manner that is not typical. This is the default log

level.
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Option Description

Action A message is logged every time the rule is applied.

Detail A detailed message is logged every time the rule is
applied.

11. In Label, type a label for the rule. If you do not type a label name, the rule is given a default name. The default
name is the base name with the regular expression appended.

12. In Description, describe the rule. Descriptions can be useful if you share rule set files with other testers.

Creating a substitution with data correlation rules

You can create a data correlation rule that creates a substitution from a regular expression that is applied to test data.

1. Open a data correlation rule set in the rules editor.
A new rule set contains one empty rule pass.
2. Click Insert, and then select Create a substitution.
Result
An empty Create a substitution ruleisinserted in the rule pass.

3. Under Details, supply information for all fields that are marked with asterisks and shaded in red. For Field,
click the down arrow to select the field for which to create a substitution. Use the push buttons at the top of
the window to select a protocol, and then select a field. To create a substitution in the data field of an HTTP
request, click the down arrow, and then select HTTP > Data.

4. In Regular expression, type a regular expression to use to locate the substitution. If only a part of the regular

expression is required for a substitution, enclose that part in parentheses.

o]

. Open the test, and locate the request to create the substitution in.
b. Copy the text from the request to the clipboard.

c. In the rules editor, click the Toggle regular expression assistant push button to open the regular

expression assistant.

d. Paste the text from the clipboard to the Test regular expression page of the regular expression
assistant window.

If the Test regular expression page is empty, the contents of the clipboard is automatically pasted in.

e. Click the Captured group tab in the regular expression assistant.
Result
The overall group is displayed, and the captured groups are displayed. If no groups are displayed, edit

the regular expression accordingly.

To create more than one substitution site using the same regular expression, enclose each part in
parentheses. For example, two substitution sites can be created from this regular expression: (. +?)=(. *?).
Example
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To use values that were created in a parent create a ref erence rule as arguments in the regular expression,
enclose the reference names in percent signs. For example, if a parent rule created a name reference and a
val ue reference, you could use them in this regular expression: \ : \ { %mane% %al ue% } . When the rule is run,
umame%and wal uevare substituted with the values extracted by the parent rule, and then the resulting regular

expression is evaluated. Two substitutions are created, each linked to the corresponding reference.

5. In Substitution names, type names for the substitutions.

. Under Decode the field, select true to decode the specified attribute before searching for a matching
reference. Select false to search for a matching reference without decoding the attribute. The type of
encoding depends on the selected protocol and attribute. For example, HTTP data can be URL-encoded.

. Under Create substitution only if used, select true to create a substitution only when a matching data source
is found. Select false to create the substitution regardless of whether a matching data source is found.

. Under Conflict action, select the action to take when a new substitution overlaps with existing substitutions.

Option Description

Always replace existing If the new substitution overlaps with other substitu-

tions, the other substitutions are removed.

Replace existing if dataset candidate If the new substitution overlaps with other substitu-
tions, and all the other substitutions are dataset can-
didates, other substitutions are removed. If at least
one current substitution site that overlaps with the
new substitution site is associated with a reference,
then no current substitution is changed, and the new

substitution is not created.

Replace existing if enclosed in the new site If the new substitution overlaps with other substitu-
tions that are all completely enclosed in the new sub-
stitution, other substitutions are removed. If at least
one current substitution overlaps with the new substi-
tution without being completely enclosed by the new
substitution, then no current substitution is changed,

and the new substitution is not created.

Replace existing if dataset candidate or enclosed | If the new substitution overlaps with other substitu-
tions, and each of the other substitutions is either a
dataset candidate or is completely enclosed in the
new substitutions, other substitutions are removed.
If at least one current substitution overlaps with the
new substitution without being completely enclosed
by the new substitution, or if at least one current sub-
stitution site that overlaps with the new substitution

site is actually associated with a reference, then no
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Option Description

current substitution is changed, and the new substitu-
tion is not created.

Keep existing If the new substitution overlaps with other substitu-
tions, the other substitutions are not removed. The

new substitution is not created.

9. In Log level, select the level of error data to be written to the error log. With logs, you can see which rules
worked and which did not. When you are debugging data correlation rules, use the Action log level. If the
Action log level does not provide enough data for troubleshooting, use the Detail log level. The Detail log level
produces a significantly higher number of log entries. Typically, when you are sure that the data correlation
rules that you have written work correctly, use the None or Summary log levels to reduce memory and disk-

space consumption and unrequired entries in the error log.

Option Description
None Nothing is logged.
Warning A message is logged when potential problems are

detected when the rule is applied.

Summary One message is logged for the rule, no matter how
many times the rule is applied.

Important A message is logged every time that the rule is ap-
plied in a manner that is not typical. This is the de-

fault log level.
Action A message is logged every time the rule is applied.
Detail A detailed message is logged every time the rule is
applied.

10. In Label, type a label for the rule. If you do not type a label name, the rule is given a default name. The default
name is the base name with the regular expression appended.

11. In Description, describe the rule. Descriptions can be useful if you share rule set files with other testers.

Example: Linking references to substitutions with rules

You can create data correlation rules to link references to substitutions.

About this task
If you know which field in a request or in POST data must be correlated, write a Create a substi tuti on rule for that

field, and then insert a create a reference rule as a child of the create a substitution rule.
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1. Open a data correlation rule set in the rules editor.
A new rule set contains one empty rule pass.

2. Create aCreate a substitution rule. See Creating a substitution with data correlation rules on page 436 to
learn more about creating a Create a substitution rule.

3. Right-click the Create a substitution rule, and then click Insert Item > Find data source for substitution.

4. Right-click the Find data source for substitution rule, and then click Insert Item > Create a reference. If the
reference exists, select Find a reference instead of Create a reference.
ACreate a reference Or Find a reference rule is inserted as a child of the Fi nd data source for
substi tution rule. To use the value of the substitution extracted by the parent rule, type %subnanewfor the
Regul ar expr essi on, where subname is the name of the substitution that is created by the parent rule. See
Creating a reference using data correlation rules on page 434 to learn more about creating a Create a

ref erence rule.

Results
When you recorrelate test data using this rule set, the references and substitutions that you defined are created and
linked.

Exemple

Assume that a URI in your test is http://host:port/RPThelp/index.jsp?topic=datacorrelation.html. Assume

that some of the response data from a previous request includes . . . <i d=2 docHel pNanme=r ecor dt est > <i d=23

docHel pNane=dat acorr el ati on> <i d=24 docHel pName=r ul es>. . .. Write a rule that creates a substitution site in the URI
for dat acorrel ati on and sets the substitution name to hel pnane. Then, add rules that create a reference as a child

of the substitution rule. The regular expression for the reference rule is docHel pName=9%hel pnane%. Thus, the regular
expression in the reference rule evaluates to docHel pName=dat acorr el at i on>. This regular expression ensures that the

correct reference is linked to the substitution site.

Example: Linking substitutions to references with rules

You can create data correlation rules to link substitutions to references.
About this task

If you are familiar with the application under test and know the exact location of the reference in the response data,
write a Create a ref erence rule that uses a regular expression to locate the reference data, and then inserta create a

substitution rule as a child of the create a reference rule.

1. Open a data correlation rule set in the rules editor.
A new rule set contains one empty rule pass.

2. Create aCreate a reference rule. See Creating a reference using data correlation rules on page 434 to learn
more about creating a Create a reference rule.

3. Right-click the Create a reference rule, and then click Insert Item > Link with substitutions.

4. Right-click the Link with substitutions rule, and then click Insert ltem > Create a substitution. To use the
value of the reference that is extracted by the parent rule, type % ef nanewfor the Regular expression, where
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refname is the name of the reference that is created by the parent rule. See Creating a substitution with data
correlation rules on page 436 to learn more about creating a Create substitution rule.

ACreate a substitution ruleisinserted as a child of the Li nk with substitutions rule.

Results
When you recorrelate test data with this rule set, the references and substitutions that you defined are created and
linked.

Exemple

Assume that a response in your test data contains an ID that is present in URIs and in POST data throughout the test.
For example, the response includes . . . <Needed! D=I D123 docHel pName=r ul es>. . . . Assume that a URI in the test is http://
host:port/RPTHelpID123/index.jsp?topic=datacorrelation.html and the POST data includes . . . namel D123=1 D123. . . .
Because you know the exact location of the ID in the response, you can write a rule that creates a reference for the

ID. Specify the Reference name as |1 b. Then, add rules for two substitutions as children of the reference rule. Add one
substitution with a URI attribute and one with a data attribute. Specify % dwin Regular expression for both substitution
rules. Thus, the regular expression in the substitution rule becomes the | D123 value when the rules run. This regular
expression creates substitution sites in every location where the | D123 value is found in URIs and in POST data. In this
example, three substitution sites would be created: RPThelplD123, namelD123, and namelD123=ID123.

Example: Linking substitutions to built-in data sources with rules

You can create data correlation rules to link substitutions to built-in data sources. Built-in data sources include the

dynamically calculated variables such as Current Date, Random Number, and Timestamp.

1. Open a data correlation rule set in the rules editor.
A new rule set contains one empty rule pass.

2. CreateaCreate a built in data source rule.

3. Right-click the create a built in data source rule, and then click Insert Item > Link with substitutions.

4. Right-click the Link with substitutions rule, and then click Insert Item > Create a substitution. See Creating
a substitution with data correlation rules on page 436 to learn more about creating a Create substitution
rule.

AcCreate a substitution ruleisinserted as a child of the Li nk with substitutions rule.

Results
When you recorrelate test data with this rule set, the built-in data sources and substitutions that you defined are
created and linked.

Recorrelating data with rules

After you have created a data correlation rule set, you can recorrelate data in tests.

Before you begin

Record a test, and create a data correlation rule set.
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. Open a test for editing. To recorrelate data in tests that are not open in the editor, select multiple tests in the
Test Navigator window.

. To recorrelate a test that is open in the test editor, click Edit > Re-correlate test and transform data. To
recorrelate multiple tests, right-click the selected tests in the Test Navigator window, and then select Apply
data correlation rules.

Result

The Data Correlation and Transformation window opens.

3. Select Do rule-based data correlation.

4. Optional: To remove data correlation from the test data, select Clear existing data correlation. Select Do

automatic data correlation to recorrelate the test data by using the automatic data correlation.
You can control automatic data correlation in the preferences. Click Window > Preferences > Test > Test
Generation. Click HTTP Test Generation, and then click the Data Correlation tab for additional controls over
automatic HTTP data correlation.

. Click Add.
Result
The Rules File Selection window opens.

6. Expand the list of resources to locate the data correlation rules file to add.

. Select the data correlation rules file to add, and then click OK.
Data correlation rules files have the . dcr ul es extension by default.
Result
The rules file is added to the list under Rules Files.
. Optional: Click Add to add more rules files. Use the Up and Down push buttons to move rules files in the list.
The data correlation rules are applied in the order in which the files are listed.
. Click Finish.
Result

The test data is recorrelated.

Results
If you recorrelate test data in multiple tests that are not open in the test editor, the original tests are backed up. The
backup copies are displayed in the list in the Test Navigator window. To restore the original version of the test, right-

click the backup copy in the Test Navigator window, and then select Restore test.

Recording tests with data correlation rules

After you have created a data correlation rule set, you can record a test that uses those rules.

Before you begin

Create a data correlation rule set.

1. In the Performance Test perspective, click the New Test From Recording toolbar button or click File > New >

Test From Recording.

2. In the New Test From Recording wizard, click Create a test from a new recording, select the type of test to

create, and click Next.
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. On the Select Location page, select the project and folder to create the test in, type a name for the test, select

Customize automatic data correlation, and click Next.

. Continue recording a test.

Result

After you have recorded the test, the Data Correlation window opens.

5. Select Do rule-based data correlation.

. Optional: Select Do automatic data correlation to correlate the test data using the automatic data correlation.

You can control automatic data correlation in the preferences. Click Window > Preferences > Test > Test
Generation. Click HTTP Test Generation, and then click the Data Correlation tab for additional controls over
automatic HTTP data correlation. For example, when recording an HTTP test with data correlation rules, you
might select Automatically correlate host and port data, Automatically correlate URL pathname if redirected
by response, and Automatically correlate Referers, and then clear Enable all other data correlation.

. Click Add.

Result
The Rules File Selection window opens.

8. Expand the list of resources to locate the data correlation rules file to add.

9. Select the data correlation rules file to add, and then click OK.

10.

11.

Data correlation rules files have the . dcr ul es extension by default.

Result

The rules file is added to the list under Rules Files.

Optional: Click Add to add more rules files. Use the Up and Down push buttons to move rules files in the list.
The data correlation rules are applied in the order in which the files are listed.

Click Finish.

Result

The recorded test data is correlated.

Generate data correlation rules in the test editor

Instead of writing rules in the rules editor, you can generate rules automatically based on data correlation

adjustments that you make while editing tests.

To see what data correlation looks like in rule form, generate rules while you edit tests, and then examine the rules

in the rules editor. To generate a rule set file that you can use to correlate data on multiple tests that run against the

same application, save all manual correlations in a rule set file.

Generating rules while you edit

You can generate rules automatically as you make changes to data correlation in the test editor. With this feature, you

can see what a typical data correlation action looks like in rule form.

Before you begin

Record a test.
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1. Rules accumulation is enabled by default. To enable rules accumulation, right-click in the Test Contents
window, and then select Data Correlation > Allow rules accumulation.

2. Adjust data correlation as you typically would in the test editor. For example, create or delete references,
substitution sites, datasets, or variables.
To learn more about adjusting data correlation, see Guidelines for adjusting data correlation on page 455.

3. Right-click in the Test Contents window, and then select Data Correlation > Show accumulated rules.
Result
The Save Data Correlation Rule Set wizard opens. The data correlation rules that are generated while you
manually edited the test are displayed.

4. Clear the check boxes of any rules that you do not want to save, and then click Next.

5. Type a file name, and then click Save.

What to do next
Examine the data correlation rules in the rules editor. To learn more about the types of data correlation rules available,

see Data correlation rules on page 1140.

Saving manual data correlation in a rule set file

You can generate data correlation rules based on the data correlation changes made to a performance test. This
feature analyzes the data correlation adjustments that you have made to a test and saves those adjustments as a
data correlation rule set file. You can use the rule set file to automatically correlate the data for other tests that run

against the same application.

Before you begin
Create a performance test. Adjust the data correlation so that the test runs correctly. To learn more about adjusting

data correlation, see Guidelines for adjusting data correlation on page 455.

1. Open a performance test for editing.

2. Adjust data correlation as you typically would in the test editor. For example, create or delete references,
substitution sites, datasets, or variables.

3. Right-click in the Test Contents window, and then select Data Correlation > Save All Manual Correlation in
Ruleset file.
Result
The test is analyzed to determine the set of data correlation rules that represents the adjustments that you
have made to data correlation. The Save Data Correlation Rule Set wizard opens. The data correlation rules
are displayed.

4. Clear the check boxes of any rules that you do not want to save, and then click Next.
Typically, when saving manual data correlation, you save all the generated rules, because the generated rules
represent the data correlation required for the test to run correctly.

5. Type a file name, and then click Save.

What to do next
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You can use the generated rules file to perform data correlation on other tests that run against the same application.

To learn more about applying data correlation rules to existing tests, see Recorrelating data with rules on page 440.

Viewing data correlation rule usage

To see a record of all the elements that changed when data correlation rules are applied, open the data correlation

rules log. You can use the data correlation rules log to determine which rules worked and which did not.

About this task
The Data Correlation Rules Log view opens automatically when you apply data correlation rules to a test.

1. In the Data Correlation Rules Log view, consider the following options:
Choose from:

> You can apply data correlation rules when you record a test, or you can recorrelate existing test data.
To learn more about recorrelating test data, see Recorrelating data with rules on page 440.

> You can specify the logging level in the data correlation rules file, or on the Data Correlation and
Transformation wizard page.

= You can use the Action log level to debug data correlation rules. If the Action log level does not
provide enough data for troubleshooting, use the Detail log level.

> You can view the data correlation actions in the chronological order. Click the Chronological log view

icon %' 7 to view test elements that are created or removed by the data correlation rules.
> When you are sure that the data correlation rules that you wrote work correctly, use the None or
Summary log levels to reduce memory, disk-space consumption, and unnecessary entries in the error
log.
2. Expand the first element of the log, and navigate to the detail that you want to see. Use the icons in the upper-
right corner of the view to navigate through the log. For example, to navigate to the corresponding element in
the test editor, select a log entry, and then click Go to test element.

Test data sources overview

Use the Test Data Sources window to add or change data correlation for any supported test element.

The test generator attempts to perform automated data correlation. You can also manually correlate request values
with other test data. The Test Data Sources window displays the following types of test data that you can substitute

from:

 References

» Datasets

« Custom code
« Test variables

« Built-in datasources

You can right-click references, custom code, and built-in data sources to display a menu that contains commonly
used commands. In addition, you can use the toolbar and menu at the top of the Test Data Sources window to
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complete common operations, such as creating a dataset or switching from tree view to list view. The Substitute
From push button is enabled when you select a substitution site in the test editor and a data source from one of
the five categories in the Test Data Sources window. Click Substitute From to correlate the data source and the

substitution site.

B Test Mavigator L) Test Data Sources 53 = 0O
[

BIREIEE

Selected Substitution Site
Type: = TextRange (0 characters at offset 0)

Column name: req_uri
Value:
Data source:

’ E’;‘, Substitute From ] % “domain” (™ - Content)

Fﬁ Datapools | (8 Custom Code | [._ Test Variables ﬂ'_j Built-in Variables

type filter text |
References Offset
e "avid® (™ - Content) 7705

#. “domain” (™ - Content) 12511
%: "domain2” (™ - Response header) 95

Matching References Only [ ] Include Potential Matches

E=c1(B,C,"; " J;if(1A| NEJMIf( ERRD! =null)freturn D ”
rreturn EXE=c1(A,E,"&");if (| E&&D! =null}{return D}return unescape(E)}function CLOvar —
D, A,B,C,E=0;A=cGa.cookie ;if(A){D=A.split(";");E=D.length; for(C=0;C <D.length; C++){

References

The data sources that have been created in the test and the potential matches that are available for

a selected substitution site. For example, text that is found in a response and used in a subsequent
request is automatically created as a reference. Clear the Matching References Only check box to see
all the references that occur before the substitution site in the test. Select Include Potential Matches
to see a list of locations that might match the substitution site. Replace the type filter text string
with keywords to filter the list of references. Select a reference in the References table to display the
reference in the pane at the bottom of the window. Use the controls to the left of the preview pane to

switch between inline view and tree view.

Datasets

The datasets that have been added to the test. To add a new dataset, click the Add new Dataset icon

( Fﬁ)_
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Custom Code

The custom code that is available as data sources for this substitution site, if you have written Test
Execution Services (TES) custom code.

Test Variables

The test variables and their types that are available as data sources for this substitution site. Replace

thetype filter text string with keywords to filter the list of test variables.
Built-in Datasources

The dynamically calculated data sources, such as Current Date, Random Number, Sequential
Numberand Timestamp, that are available as data sources for this substitution site. To create a built-
in data source, right-click inside the Built-in Datasources page, and select New, or click the New push
button at the top of the window.

To assign a unique value for every substitution, when creating the built-in data sources, select the Get
New Value Each Time Used check box.

Detaching the Test Data Sources window

The Test Data Sources window is detachable. To detach the Test Data Sources window, right-click the Test Data
Sources tab, and then select Detached. When detached, the Test Data Sources window is always displayed in front of

the other windows that make up the workbench.

Correlating a request value with test data

If a test runs without error but does not generate the results that you expect, you might need to correlate a value in a
request with other test data.

About this task
You can correlate a request value with the following types of test data:

 References

» Datasets

» Custom code

« Test variables

« Built-in datasources

For example, if you recorded a test and searched on a date, you might want to substitute the built-in data source
Current Date so that the test will search on the playback date, not on the recorded date. For information on the
different types of test data, see Test data sources overview on page 444,

1. In the Test Navigator, browse to the test, and double-click it. The test opens in the test editor.
2. Locate the value that the other test data will replace.
3. Highlight the value: Press and hold the left mouse button and drag your mouse over the value.
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4. In the Test Data Sources window, click the appropriate tab: References, Datasets, Custom Code, Test
Variables, or Built-in Datasources. To see all references, clear the Matching Only check box.

5. In the Test Data Sources window, select the test data to use. For references and custom code, you can
double-click the entry in the Test Data Sources window to find the data source in the test editor.

6. Click Substitute From.
Result
The value is shown in purple text to indicate that it has been correlated and the correlation is added to the
Test Data table, which contains the substitution sites for the page.

Substituting request content with file contents

You can substitute the content portion of a protocol request with the contents of a file. This feature is only supported
in certain sections of a test, depending on the protocol. For example, HTTP tests support file content substitution only
in the POST data section of a request. SOA tests support file content substitution for MIME and DIME attachments,
XML node values and fragments, and text content. File content substitution works in the same manner as other
substitutions. All standard test data sources such as test variables, datasets, and references can be used. The data
from the source is treated as a full path to a file. The file is opened, its contents are read, and then those contents are

used in the substitution.

Before you begin

You must copy the files that contain the substitution content to the agent computers. You must record a test with
locations for substitution from a file. For example, record an HTTP test that contains multipart MIME data in a POST
request.

1. Create a data source that contains the full path to the file from which you want to substitute content.
Specify an absolute path to the file. Use path separator characters appropriate to the operating system of the
agent computer running the test. Optionally, specify a character set to use in reading the file. The existence of
the file is not validated. If the file cannot be opened when the test runs, a message is written to the test log.
If you use path separator characters that are not appropriate for the operating system of the agent computer,
the substitution cannot be completed. For example, if you use a path of D: \ Dat aFi | es\fi | el on an agent
computer running Linux™, the substitution cannot be completed, because Linux™ uses forward slashes as
path separator characters.

2. In the test editor, navigate to the request where you want to substitute content, and then select the request
data that you want to substitute.

3. Right-click, and then select Substitute > Select Data Source.

4. Select the data source that contains the path to the file from which you want to substitute.

5. Right-click the substitution site, and then select File Contents Substituter.

Results
When the test runs, the content in the protocol request is substituted with the specified file contents.

HTTP POST data is displayed in the test editor in chunks. You can create a file contents substitution in the POST
data of an HTTP POST request by selecting the data chunk that you want to correlate, and then clicking Substitute.
The test data source that you select is automatically treated as a file contents substituter. The entire data chunk

447



HCL OneTest Performance

is replaced with the contents of the file when the test runs, even if only a portion of the text in a text data chunk is

selected by the substituter.

Built-in Datasources

You can use built-in data sources instead of creating custom data sources to substitute the recorded values. The
Built-in Datasources section in the Test editor displays the data sources that have been used and unused. You can

modify their properties from a location.

The built-in data sources are Current Date, Random Number, Sequential Number, and Timestamp. The values of these

data sources are dynamically calculated and submitted to the test.

Assigning random numbers to users or clients

To assign unique random numbers to all the virtual users in a test, you can create a random number data source in
the workbench. This data source will generate unique integers or floating point numbers for the users or clients. You
can choose to distribute the numbers of the virtual users or clients in a uniform, normal, or negative exponential way.

1. In the Test editor, select the root node (name of the test) and from the Test Details area, select Built-in
Datasources.
2. Select the Random Number data source and click Add Built-in Datasource.
3. Type a name for the data source.
4. Select how do you want to generate the numbers:
> Uniform: Click this option to generate random numbers with a uniform distribution. Specify the
minimum and maximum values for the generated numbers.
> Normal: Click this option to generate random numbers with a normal or Gaussian distribution. Specify
the average and the standard deviation for the generated numbers.
- Negative Exponential: Click this option to generate random numbers with an exponential distribution.
Specify the average for the generated numbers.
5. Select how do you want to format the numbers. You can select Common to format the numbers in decimal or
scientific notations.
You can choose Custom to specify a Format mask by using the standard Java formatting syntax. The
changes that you specify can be previewed in Formatted output.
6. To substitute the built-in data source every time with a new value for the requests, select the Get new value

each time used check box.

Assigning sequential numbers to users

To assign unique sequential numbers to all the virtual users in a test, you can create a sequential number data source

in the workbench. This data source will generate unique integers or floating point numbers for the users.

Before you begin
You can use the sequential built-in data source option wherever data correlation substitutions are permitted, such as

Transactions or Delays.
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About this task

You define an initial value that should be assigned to the first virtual user and a step value that is a number by which
the current value increments after each retrieval by a virtual user. If initial value is 1 and step value is 5, the workbench
generates numbers in the sequence of 1, 5, 10, 15, and so on and each number is mapped to a virtual user. If a test is

run on multiple agent machines, the workbench assigns a sequential value to all the users in all the agent machines.

You can also assign a full sequence of numbers of one virtual user. The sequence number increments in the request

for each time the request in the multi-request generator is executed.

1. In the Test Contents area of the test, click an element in the test where data correlation substitution is
permitted, such as a transaction name or delays.

2. In the Test Element Details area, right-click the name of the element and click Substitue > Built-in
Datasources.

. In Built-in Datasource Selection Wizard, click Sequential Number and click Next.

. Assign a name for the data source.

. In Initial Value, type a number to be assigned to the first virtual user.

. In Step Value, type a number.

. In Formatting Options, you can format the number in the manner you want to use.

0 N o o b~ W

. Optional: To assign a full sequence of numbers to one virtual user, select the Execute for individual user
check box.
9. Optional: To substitute the built-in data source every time with a new value for the requests, select the Get
new value each time used check box.
10. Click Finish.

11. Save and run the test.

Results
After you add the test to a schedule and run the schedule, the test log displays each element name where the data
source is applied with the unique sequential number assigned to the virtual user.

Selecting a reference in a response

When a response contains multiple matches for the regular expression that defines a reference, you can select which
match is used subsequently as the data source. You can specify a particular occurrence, or you can specify a random

occurrence.
About this task

An application under test might return responses that contain multiple matches for a regular expression that defines
a reference. For example, a response might contain multiple links to rows of data, where each row represents a
different user. You can control which occurrence of the regular expression is used as the data source in subsequent

data correlation.

449



450

HCL OneTest Performance

If you edit the Regular Expression that is associated with a reference, and then click Verify or OK, and the new regular
expression still connects to the highlighted string in the preview window, then the Specific occurrence number is
updated automatically, overwriting any changes.

1. In the Test Navigator, browse to the test, and double-click it. The test opens.

2. Locate the response that contains the reference that you want to specify.

3. In the Content field under Test Element Details, right-click the reference, and then select Properties.

4. Optional: To edit the regular expression that is used to locate the reference, click the Toggle regular
expression assistant push button on the Properties window. The regular expression assistant displays the
response content that is matched by the regular expression and the groups that are captured by the regular
expression.

5. On the Properties page for the reference, select which Occurrence to use as the data source. By default, the
first occurrence of a match for the Regular Expression is used as the data source.

Choose from:
o To specify a particular occurrence, select Specific occurrence number, and then type the number of
the match. For example, type 4 to specify the fourth match of the regular expression in the response.
> To specify a random occurrence, select Random occurrence.
- To specify the last occurrence, select Last occurrence.
6. Click OK.
Result

The occurrence that you specified is used as the data source for data correlation when you run the test.

Creating a reference or field reference

When you designate a test value as a reference or designate a set of test data as a field reference, you can use the

data elsewhere in the test.
About this task

A reference, which is typically located in response data, points to a specific value that you want to use in a subsequent
test location, typically a request. You can substitute a request value with a reference. This substitution is called data
correlation. You can also use a reference as input to an IF-THEN condition in a test or as input to custom Java™ code

that your test calls.

A field reference points to an entire block of test data. For example, an entire HTTP response can be designated as a

field reference. You can use a field reference as input to custom Java™ code that your test calls.

1. In the Test Navigator, browse to the test, and double-click it. The test opens.
2. Locate the value or set of data to designate as a reference or field reference.

Different protocols support different references. For HTTP tests, you can create references and field
references in these fields:
> A response header value, the Value column of a Response Headers table

> Response content, the Content field
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For HTTP responses, you can create field references in these fields:
o The Status field
> The Reason field
3. Create the reference:

a. For response contents, highlight the value. For response header contents, click the row in the
Response Headers table, and then click Modify.

b. Right-click, and then click Create Reference.
Result
The value is highlighted in light blue to indicate that it is an unused reference. When you use it, the
highlight changes to dark blue. The reference is given a name automatically. To see the name of the
reference, right-click the value, and then select Properties. To edit the regular expression that is used
to locate the reference, click the Toggle regular expression assistant push button on the Properties
window. The regular expression assistant displays the response content matched by the regular
expression and the groups captured by the regular expression. To ensure that the details about the
reference is always logged, select a reference and click Properties, and then click the Always log
details checkbox. To create a reference that will be used by the HTTP secondary request, you must

select All occurrences. You can also match the reference within a given range of all the occurrences.

Note:

A reference that is created to be used by the HTTP secondary request cannot be used by custom code
or other data sources.

If you select the Always log details checkbox, the details will be logged irrespective of the logging
level set for a schedule. You must use this option only for debugging purpose.

You can always log the details of Substituters, Data Sources, and Requests.

4. To create a field reference, do not highlight the value. Instead, right-click the value, and then click Create Field
Reference.
a. Field references are not automatically given names. To name a field reference, right-click the field
reference, and then select Properties. Type a name in the Name field, and then click OK.
Result
The entire field is highlighted in yellow to indicate that it is a field reference.

Correlating multiple fields in a test

Some tests are structured in such a way that you must correlate data for multiple fields.For example, assume that
you plan to dataset an item that a virtual user is buying. For the test flow to be correct, you must also dataset all
occurrences of that item in the test. You can find and correlate all instances of that item in one procedure. Typically,

you use Find More and Substitute in the Show Dataset Candidates window to correlate data for multiple fields. See
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Viewing dataset candidates when you open a test on page 401. Alternatively, you can use the Test Search page to
correlate data for multiple fields.

To find all instances of a field in a test and correlate some or all of the instances with a data source, such as a
dataset:

1. In the Test Navigator, browse to the test, and double-click the test. The test opens.

2. Locate the item or the substitution site to change or create a reference for. If the item is plain text, select the
item. If the item is an existing reference, click the highlighted area.

3. Right-click, and then click Find > More Substitution Sites.

4. Click OK.

5. On the Test Search page, select Case sensitive to perform a case-sensitive search or Regular expression to
perform a search using regular expressions. In regular expression mode, press Ctrl+spacebar key in Search
for text for content assistance. Content assistance lists the regular expression patterns and the content that
they match.

6. Click More Options, and then select the appropriate options:

Restrict to elements highlighted in Test Contents

Search only in elements that are selected in the Test Contents area.
Highlight found elements in Test Contents

Highlight found elements in the Test Contents area.
Recursive

Searches the child test elements in addition to the element. For example, if you search an HTTP
page, select this option to search the requests and responses within the page.

Match encoded and decoded values (protocol-specific)

When selected, searches for matches of the unencoded and URL-encoded versions of the

specified text. For example, when searching in HTTP data, abc%d23 and abc9®5123 match.
Include matches with overlapping data correlation

Include sites that are contained in, or overlap with, an existing substitution site. If you decide to

substitute, the conflicting substitutions are automatically removed.
Include matching substituters

Click to return elements that originally matched the search string but have since been

substituted. Clear to skip existing substitution sites when results are returned.

7. Click Close.
8. Click Search. The search results are displayed in the Search view.
9. In the Search view, select the matches to substitute, and then right-click the selection.
10. Optional: To select all matches, right-click the test name.
11. Click Substitute in DataSource View.
Result
This action sends the selected matches to the Test Data Sources window.
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12. In the Test Data Sources window, click the tab that corresponds to the type of data source to use:

Option Description

References The data sources that have already been created in
the test and the possible matches that are available
as data sources for the selected substitution site. For
example, text that is found in a response and used in
a subsequent request is automatically created as a
reference. Clear the Matching References Only check
box to see all the references that occur before the

substitution site in the test.

Datasets The datasets that have been added to the test. To
add a new dataset, click the Add new Dataset icon

( :EI)'

Custom Code If you have written test execution services (TES) cus-
tom code, the custom code that is available as data
sources for this substitution site.

Test Variables The test variables and their types that are available
as data sources for this substitution site.

Built-in Datasources The dynamically calculated data sources (Current
Date, Random Number, Sequential Number, and
Timestamp) that are available for this substitution
site. To create a new built-in data source, right-click

inside the Built-in Datasources page, and select New.

13. Select the data source, and click Substitute From.
Result
The Substitute Multiple Items window is displayed, showing information about the data source and
substitutions sites that you selected.

14. For each site with a selected check box, click Substitute Checked to substitute the data source or clear the
check box to skip the site.
Click Always Prompt to examine every substitution site one at a time. Click Prompt on overlapping data
correlations to examine a site only if the site you are substituting into is contained in, or overlaps with, an
another substitution site. If you decide to substitute, the conflicting substitutions are automatically removed.

Results

The selected instances of the field are correlated with the data from the data source.
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Viewing references

You can use the Test References window to view, modify, or verify references in a test.

. In the Test Contents area, click Options.

. Select Display References.

Result

. In the Test Navigator, browse to the test, and double-click the test name. The test opens.
. Optional: To view references in only part of a test, select test elements in Test Contents before continuing.

The Test References window opens. All references in the test or the selected test elements are displayed in

tabular format.

. Do one of these tasks:

Option

Description

To view details about the references in a test

Navigate through the References table to preview the
references in the Preview area. Click the Next and
Previous icons to move the selection down or up in
the list of references. Click the Show as Tree icon to
toggle between tree format and list format. Click the
Show Usage icon to view the substitution sites that
are associated with each reference. Click the Book-

mark icon to bookmark a location for later review.

To verify regular expressions that

are associated with references

Select the check box next to each reference to verify,
and then click Verify Checked. The verification proce-
dure completes this procedure:

a. Checks that the regular expression finds the
correct content. Regular expressions can stop
working if you modify a test.

b. Checks that there are no references with du-
plicate names. Troubleshooting data corre-
lation problems is easier if references have
unigue names.

c. Checks that there are no overlapping correla-

tions.

To find more locations in the test that have

the same value as the selected reference

Select a reference, and then click Find and Substi-
tute. These locations can be reviewed and substitut-
ed interactively as needed.

To modify a reference

Select a reference, and then click Properties.

To use the regular expression assistant to edit

the regular expression used to locate a reference

a. Select a reference, and then click Properties.
b. Click the Toggle regular expression assistant

push button on the Properties window. The
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Option Description

regular expression assistant opens. The re-
sponse data that is matched by the current
reference is automatically copied into the
Test regular expression window.

c. Click the Captured group tab in the regular ex-
pression assistant. The regular expression as-
sistant displays the response content that is
matched by the regular expression and the
groups that are captured by the regular ex-
pression. If no groups are displayed, edit the

regular expression accordingly.

To remove a reference Select a reference, and then click the Clear Reference
icon. The reference is removed from the test when

you close the Test References window.

6. Click Close to close the Test References window and return to the test in the test editor.
When you close or save a test, you are prompted if any changes that you made to the test might affect the

integrity of references in the test.

Guidelines for adjusting data correlation

When you run a test, you might notice that the server is not under the expected load or that your database is not being

updated as expected. Incomplete or incorrect data correlation can cause these problems.

To identify data correlation problems:

1. Use the Potential Correlation Errors view to find missing or incorrect data correlations. See Finding data
correlation errors on page 458 for more information.
2. Run a test individually or in a schedule with the Log Level for errors, failures, and warnings set to All.

3. After the run, open the test log as explained in Viewing the test logs on page 770.

The data correlation algorithms that are used during test generation are based on well known best practices.
However, because these practices continually evolve, various types of errors can occur during automated data

correlation:

- Insufficient correlation: Test values that must be correlated are not. Some possible causes follow:
o Two parameters that must be correlated have different names.
> A value must be correlated with a previous value that does not occur in the expected location.
o A parameter or value must be correlated with a previous parameter or value that does not occur in the
test because it is a computed value.
- Superfluous correlation: Unrelated test values are correlated.

« Incorrect correlation: Test values that must be correlated are correlated incorrectly.
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Insufficient correlation: Parameters have different names or occur in unexpected locations

When two parameters that must be correlated have different names, automated data correlation does not recognize
that the two parameters are related. For example, consider this request: http://www.example.com?id=12345. Suppose
that this request must be correlated with the server response that contains cust omer _I D=12345, not | b=12345. In this

case, the | b parameter must be correlated with cust omer _I D.

Data correlation typically links a response value that was returned from the server with a subsequent request value.
The automated correlation algorithms search in the URL and the POST data for potential matches; however, other
schemes for returning parameters are possible. For example, consider this request: http://www.example.com?
id=12345. Suppose that this request must be correlated with the server response that contains the name and entity
pair href name="custoner_I D' entity="12345", not | p=12345. In this case, the | D parameter must be correlated with

nanme="cust oner _| D' and value 12345 must be correlated with entity="12345".

Here are some additional causes of insufficient correlation:

- Siebel uses the star array format. Standard correlation algorithms can neither retrieve from this format nor
substitute into this format.
- SOAP designates correlation parameters in external XML files. The correlation algorithms cannot correlate

parameters in the external file with parameters in the test.
To manually correlate data in these cases:

1. In the test editor, use search or browse to locate the two parameters for correlation.
2. Navigate to the parameter that occurs later in the test, and select the parameter. This is the substitution site.
3. In the Test Data Sources window, click the References tab.

4. Select the data source to use as a reference, and then click Substitute From.

Insufficient correlation: One parameter is unnamed

Sometimes a parameter or value must be correlated with a previous parameter or value that is not named in the test,
because it is computed, for example, by a JavaScript™ program. In this case, in order to correctly correlate the data,
you must understand how and where the parameter or value is computed, and then use a custom code block. See

Extending test execution with custom code on page 631 for more information about custom code.

For example, consider the web address http://www.example.com?login_stamp=12345_Apr_11_07, where the value
for 1 ogi n_ti mest anp is the concatenation of the login ID and the current date. In this case, you must generate a custom

code that concatenates the login ID and the date.

For another example, suppose that the server returned the login ID and date as separate entities: hr ef
"customer _i d=12345" Dat e="Apr _11_07". In this case, you can put these parameters in separate references and, in

subsequent requests that use customer ID and date, substitute them separately.
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Superfluous correlation

Automated data correlation is based on pattern matching: A parameter or parameter value is correlated with a
subsequent parameter or parameter value with an exact or similar name. But sometimes parameters with exact or
similar names are in fact unrelated. In the best case, unneeded correlation is either harmless or adds a slight load
that is inappropriate. In the worst case, the application does not expect a correlation and fails during playback.

To remove a superfluous data correlation:

1. In the test editor, search or browse to locate the substitution site that must not be correlated. By default,
purple letters indicate correlated data.

2. Right-click the substitution site.

3. Click Remove Substitution.

Incorrect correlation

A parameter that requires data correlation might occur many times throughout a test. For example, a session ID
parameter that is used initially when a user logs in might also be used in every subsequent request. If multiple

instances of a parameter in a test are not same, the correlation algorithms might use the wrong instance.

With the HTTP Test Generation preferences, you can optimize automatic data correlation for accuracy or for

efficiency.

« Accuracy: Each occurrence of a parameter is correlated with the nearest previous occurrence. This is the
default setting.
« Efficiency: Each occurrence of a parameter is correlated with a single previous occurrence.

Note: If you do not manually apply a correlation in the Referer field in an HTTP request header, then the
Referer field is automatically correlated as needed. If you manually apply a correlation in the Referer field in an
HTTP request header, then no automatic correlation is performed.

Incorrect correlations are more likely to happen when Optimize automatic data correlation for execution is set to
Efficiency. To fix an incorrect correlation:

1. In the test editor, search or browse to locate the value that is incorrectly correlated.
2. Right-click the substitution site.

3. Click Remove Substitution.

4. Right-click the substitution site again.

5. Click Substitute, and select the correct parameter.

Generally, the HTML respon